System Will not Boot After Latest Update

Hello,

I updated yesterday. All went well, however, the system will not boot.

Booting into Manjaro Linux. I see:
Starting Version 239
/dev/sda1: Clean 28.../147... files and blocks.
I see a flashing cursor, which will not respond on a black screen
__________________________________________-

Advaced Optionjs for Manjaro Linux
Fallback initramfs
Same result


Next kernel: 4,14,65-1
I see the message: Failed to Start Load Kernel Modules


Next kernel: 4.14.65-1, Fallback initramfs
I see: failed to Start Load Kernel Modules


Using F12 Hard Drive Diagnostics
Drive 0: Fail: Return Code: 7


Boot to Utlity Partition
F1 does not function
F2 Takes me to setup


Can anyone help me to return my system to health?

Thnaks

1 Like

The update was a big one and might break some systems. We are sorry for that. Please use a live-session from one of our install medias and use chroot to fix your local installation. Most likely your update was not fully finished:

sudo pacman -Syyu
sudo mkinitcpio -P
sudo grub-update

Also check if you can login to a TTY via CTRL+ALT-F3

1 Like

Hello,

I am using a live Manjaro pendrive at the moment.
how do I use chroot to fix my installation?
I belive that the update was completed. The command prompt appeared.

Do I type those sudo commands in the Terminal from the live pendrive.

Regards

UPDATE:

I rebooted into Manjaro on the hard drive
I can login using CTRL+ALT-F3

sudo pacman -Syyu gave an error. Failed to retrieve file (many lines).
I don't believe that I am connected to the internet.

sudo mkinitcpio -P was successful

sudo grub-update gave a message that the command was no found.

Regards

Still not sure how to use CHROOT to repair the system using the pendrive.

sudo update-grub

Hello,

Yes, I discovered that command.

I followed the chkroot link and implemented the instructions.

The pacman -Syyu had nothing to do.

mkinitcpio -P completed successfully/

The update-grub was also successful.

However, on restarting the machine I am still left with the same black screen. On shutting down the pc and restarting, again the black screen remains.

Any suggestions.

Regards

Yes anon, I do have several suggestions.

The first one is exactly the same suggestion I made to you the last time we chatted. As you are still rather new to Manjaro I suggested you get a backup regimen in place for exactly these kinds of situations. You complained that was too much for you to do, and now here we are again.

Second suggestion. I'm not sure if you read the release notices but that's a habit you need to get in to. This being a rather large and potentially troublesome update, it would have been best done from the tty. For that you press CTL+ALT+F2 and do your update from the terminal from a non graphical session.

Best of luck with your current situation.

Hopefully a kind soul will stop by to help you out.

3 Likes

Post /var/log/Xorg.0.log from your installed system, but use a pastebin service, please.
I guess, that your Nvidia card might not be supported anymore. Find that out with your own research, because I don't know anything about Nvidia. See

Learn how to provide useful information. Hint: See #technical-issues-and-assistance:tutorials

Please check if you have internet connection in a TTY. You may ping google or any other homepage: ping www.google.de. A way to use chroot is given in the wiki.

I don't think that I do have an internet connection

Then it might be harder to fix it. You may try the new 17.1.12 ISOs to see if Manjaro still boots for you with a fresh base on Xorg-120 stack.

Hello,

I know that it boots using 17.1.7 x86-64.

I could install this version and use the free drivers, then update. But it would mean many updates.

I could buy another pendrive and create a live thumbdrive. If it boots install; if not, I could select another flavour of manjaro and test that version.

Regards

Hello,

I have created a pastebin account, but can't get the data to save. I have asked the people at pastebin for help, but they have not yet responded.

I can see why you asked me to use pastebin looking at the length of the output.

Regards

I can recommend hastebin.com, it is enough for Xorg.0.log, but sometjimes not for journalctl.

I'll get back to you once the people at pastebin have advised me. I'll send them another message.

Regards

Ps. Just realised that you recommended hastebin. I read this as pastebin. Just goes to show how expectations influence our reading

Let me know if you can see these data. This is the first time that I have used hastebin

https://www.hastebin.com/examerunar.bash

Regards

Good! But I don't know how to fix Nvidia issues, I'll let others help you.
For further reading: https://wiki.archlinux.org/index.php/Nouveau
But remember Manjaro unlike Arch uses MHWD.

1 Like

Hello,

Glad you could see the data.

I have changed the proprietry video driver to Noveau.

I also repeated the full update.

and updated grub.

But the system is still not booting into the GUI properly.

I used MHWD to communicate with the hard drive from the pendrive, hence keeping my internet connection

Best wishes

Could you please elaborate your advice for me? Is there some guide how to update the system? I have read the release notes and have not found recommendation to update via TTY2. Considering backup I have found several options, including rsync and others. What option would you recommend?

EDIT: I have found this tutorial - Applying manjaro update from TTY. Is it necessary to apply all these steps during update?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by