Systemd boot time very long

Hi all,
Newbie with Manjaro, I've concerns because it seems that I spend too much time for the start-up sequence....

[irena@irena-pc ~]$ systemd-analyze blame
         11.653s systemd-journal-flush.service
          8.428s lvm2-monitor.service
          8.068s polkit.service
          7.113s dev-sda3.device
          5.619s snapd.service
          3.918s org.cups.cupsd.service
          3.789s avahi-daemon.service
          3.782s systemd-logind.service
          3.779s bluetooth.service
          3.770s NetworkManager.service
          2.720s ufw.service
          2.454s systemd-modules-load.service
          2.440s systemd-udevd.service
          2.128s apparmor.service
          2.113s udisks2.service
          1.918s ldconfig.service
          1.602s systemd-fsck@dev-disk-by\x2duuid-aa1d0d14\x2d4ab6\x2d4670\x2db58b\x2d2fe2adb>
          1.074s ModemManager.service
          1.028s systemd-fsck@dev-disk-by\x2duuid-65a8f3de\x2df60b\x2d4d9b\x2dbb9f\x2de0bfcc5>
           

I would need some advises from specialist(s) trying to win on this first step
Then, I was thinking to win something on the first thirty seconds if possible

Many thanks for your help,

well journal should settle on its own .. otherwise you can disable what you dont need - like lvm2 or snaps or bluetooth

moved from #general-discussion to #newbies

As Allllllllwayyyyysss :wink:

inxi -Fxxxrza --no-host

(OT: the -z give me the host although it should not do so anymore ??? :man_shrugging::man_shrugging::man_shrugging:
or my translation/deepl is bad/missunderstanding.

)

The inxi version needs to be 3.0.37-33 or higher for that, it's currently not even in unstable or testing (still 3.0.37-1).

1 Like

Hi SGS,
Sorry, you're right, I did know this, "But" forgot it.
Below the returning of this :

[irena@irena-pc ~]$ inxi -Fxxxrza --no-host
System:    Kernel: 5.4.13-3-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: BOOT_IMAGE=/vmlinuz-5.4-x86_64 
           root=UUID=0ea536f1-7320-4128-b5d4-13f3f059d1b7 rw quiet apparmor=1 
           security=apparmor resume=UUID=f34d1638-649d-4e61-a0e2-db349538ed66 
           udev.log_priority=3 
           Desktop: KDE Plasma 5.17.5 tk: Qt 5.14.0 wm: kwin_x11 dm: SDDM 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Micro-Star product: GP62 6QE v: REV:1.0 serial: <filter> 
           Chassis: type: 10 serial: <filter> 
           Mobo: Micro-Star model: MS-16J5 v: REV:0.A serial: <filter> 
           UEFI [Legacy]: American Megatrends v: E16J5IMS.11D date: 01/19/2018 
Battery:   ID-1: BAT1 charge: 35.5 Wh condition: 39.1/42.4 Wh (92%) volts: 11.9/10.8 
           model: MSI BIF0_9 type: Li-ion serial: N/A status: Unknown 
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter> 
           charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i5-6300HQ bits: 64 type: MCP 
           arch: Skylake-S family: 6 model-id: 5E (94) stepping: 3 microcode: D6 
           L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18406 
           Speed: 840 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 800 2: 804 3: 804 
           4: 806 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf 
           mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 
           mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
           IBRS_FW, STIBP: disabled, RSB filling 
           Type: tsx_async_abort mitigation: Clear CPU buffers; SMT disabled 
Graphics:  Device-1: Intel HD Graphics 530 vendor: Micro-Star MSI driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:191b 
           Device-2: NVIDIA GM107M [GeForce GTX 950M] vendor: Micro-Star MSI 
           driver: nvidia v: 440.44 bus ID: 01:00.0 chip ID: 10de:139a 
           Display: x11 server: X.Org 1.20.7 driver: modesetting,nvidia 
           unloaded: intel,nouveau alternate: fbdev,nv,vesa compositor: kwin_x11 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) 
           v: 4.6 Mesa 19.3.2 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Micro-Star MSI 
           driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a170 
           Sound Server: ALSA v: k5.4.13-3-MANJARO 
Network:   Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: e000 
           bus ID: 02:00.0 chip ID: 8086:3165 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Micro-Star MSI 
           driver: alx v: kernel port: d000 bus ID: 03:00.0 chip ID: 1969:e0a1 
           IF: enp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 430.83 GiB (46.3%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10JPVX-22JC3T0 size: 931.51 GiB 
           block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: 1A01 scheme: MBR 
Partition: ID-1: / raw size: 244.14 GiB size: 239.31 GiB (98.02%) used: 11.43 GiB (4.8%) 
           fs: ext4 dev: /dev/sda3 
           ID-2: /boot raw size: 1000.0 MiB size: 968.3 MiB (96.83%) used: 56.6 MiB (5.8%) 
           fs: ext4 dev: /dev/sda1 
           ID-3: /home raw size: 682.49 GiB size: 670.78 GiB (98.28%) 
           used: 419.34 GiB (62.5%) fs: ext4 dev: /dev/sda4 
           ID-4: swap-1 size: 3.91 GiB used: 0 KiB (0.0%) fs: swap 
           swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 52.0 C mobo: 27.8 C 
           Fan Speeds (RPM): N/A 
Repos:     Active pacman repo servers in: /etc/pacman.d/mirrorlist 
           1: https://manjaro.moson.eu/stable/$repo/$arch
           2: https://mirror.alpix.eu/manjaro/stable/$repo/$arch
           3: https://repo.ialab.dsu.edu/manjaro/stable/$repo/$arch
Info:      Processes: 222 Uptime: 2h 12m Memory: 7.66 GiB used: 1.36 GiB (17.7%) 
           Init: systemd v: 242 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
           running in: konsole inxi: 3.0.37
2 Likes

Mh, 5400 HDD is not so fast then SSD drives, so it need some time.
But I do not know the boot times for HDD's on notebooks/laptops.
KDE is feeling a little bit more slow then Xfce too :wink:

@freggel.doe

Unstable

~ >>> inxi -V                                                                                                                                              
inxi 3.0.37-00 (2019-11-19)

~ >>> pacman -Qi inxi | grep Packer                                                                                                                     [1]
Packer                   : Stefano Capitani <stefano@manjaro.org>
Erstellt am              : So 24 Nov 2019 17:41:15 CET

Hope @Ste74 may be able to change that :slight_smile: ?

systemd-analyze critical-chain tells you what really holds up the boot process

2 Likes

Hello, here below the output :

graphical.target @28.350s
└─multi-user.target @28.350s
  └─ModemManager.service @27.274s +1.074s
    └─polkit.service @19.203s +8.068s
      └─basic.target @19.172s
        └─sockets.target @19.172s
          └─snapd.socket @19.169s +2ms
            └─sysinit.target @19.143s
              └─systemd-update-done.service @19.090s +52ms
                └─systemd-journal-catalog-update.service @18.490s +597ms
                  └─systemd-tmpfiles-setup.service @17.951s +536ms
                    └─systemd-journal-flush.service @6.295s +11.653s
                      └─systemd-journald.service @5.879s +415ms
                        └─haveged.service @5.878s
                          └─systemd-tmpfiles-setup-dev.service @5.140s +736ms
                            └─systemd-sysusers.service @4.164s +974ms
                              └─systemd-remount-fs.service @3.934s +38ms
                                └─systemd-journald.socket @3.895s
                                  └─system.slice @3.729s
                                    └─-.slice @3.729s

1 Like

Unless you are actually using LVM2, you can stop, disable, and mask that service.

Your inxi and systemd-analyze information give you the following options in speeding up your computer: (higher numbers mean less speed can be gained, but are also less expensive)

  1. Upgrade your HDD to an SSD
  2. If you can add a drive, add a small SSD (128 GB will suffice) where you keep your EFI, BOOT, OS, SWAP, home config files on and symlink your /home/$USER/Documents, ..., Music, Videos to your HDD)
  3. Upgrade your 5400 RPM HDD to a 10000 RPM HDD
  4. Upgrade your 5400 RPM HDD to a 7200 RPM HDD
  5. Disable systemd services that you don't need.
    Some candidates are:
    • ModemManager: If you don't use your phone's Internet, USB Internet dongles (not WiFi dongles!), ...
    • lvm2: if you don't use Logical Volume Manager
    • snapd: if you don't use snap packages.
    • cups: if you don't print
    • ...

We can't tell you exactly what to disable as it depends on your use case. E.G. I don't mind keeping the ModemManager service and loosing a few milliseconds in my boot time, but you might not.

1 Like

Thanks to take time on this.
Question :
What about the below service ? can be faster by changing parameters ?

systemd-journal-flush.service

That depends on the amount of work you want to do manually: the systemd-journal-flush.service is part of the journal service and that would make your hard disk run out of space rapidly if you just disable the service and don't perform the work manually as the systemd log files would not be:

  • compressed
  • deleted

any more...

Like I said before: we cannot tell you what you can or cannot do: you might well like to keep all log files forever until you manually delete them once in a while before you run out of disk space instead of letting the service compress the old ones and delete the really old ones automatically.

:innocent: :wink:

Yes sure, well I'll glance through all comments.
Thanks all
Have a good time

Yup: you'll need to read the manuals of all services and then decide for yourself which ones you will perform yourself manually after disabling them.

Please note that you're looking at #5 which will save you the least time, is the cheapest solution, but which comes with a lot of work to be done by you, yourself and Chris!

:grin: :smiley:

I change the solution to post #8 because reading all the comments is no solution :slight_smile: .

What you mean? pinxi is the development branch for inxi if i m correct and inxi are at the last release... :thinking:

That dos not work from now on.

But there's no hurry :slight_smile:

I think @chris57 meant that he will read through all the posts and then make up his mind...

:stuck_out_tongue_winking_eye: :grin:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by