Temporary Artix support thread

That's the way it works. But consider to back up your system. You can easily make mistakes during the lengthy and CLI intensive migration process.
Edit: /etc/pacman-mirrors.conf is a Manjaro thing. In Arch you manage the /etc/pacman.d/mirrorlist file directly. Therefore for the first step you are right, but after that do it the Arch / artix way.

1 Like

Okay, but as long as I'm using the extra and community repos of Manjaro, I have to retain /etc/pacman-mirrors.conf. Is that right?

You technically don't need that on Manjaro neither. Just set unstable in the URL of Manjaro mirrors in /etc/pacman.d/mirrorlist

Nothing wrong with Firefox on KDE using Arch I use it fine with no problems, I think you will find its a Manjaro problem.
But I would advise a clean install any way for other reasons as a lot of config files etc are not the same in Manjaro.

The #artix and #artix-dev are both up now though the latter is said to be "regulated" whatever that means, but does not appear to be at the moment.


I mean the firefox-kde package, which Manjaro includes in the community repo. It is in the AUR.

What I was saying I just use the basic firefox with no problems what so ever so why compile from AUR. Artix uses arch packages Manjaro plays with those packages as its not 100% arch complaint that is why I stopped using Manjaro to many Manjaro made problems not arch related Manjaro is not arch

Because I use KDE, and I like whatever little integration the firefox-kde package provides.

Just remember that openrc support is being dropped here, artix is migrating everything in arch to its own repros to totally strip any traces of systemd, so keeping manjaro repros is a limited. that being said the firefox-KDE AUR package should be fine,at present if you think it makes you happy.

There is this firefox-kde-opensuse in artix aur no idea if its the same?

1 Like

It is ulikely that firefox-kde will break anything. It simply takes a bit longer get updated, because first some KDE updates must be available. I don't know what the problem with it exactly is, but on Manjaro firefox updates take longer to get to the stable branch. I remember that philm wrote in such cases of delays that firefox-kde works, but it is not completely compatible with everithing else.

An alternative to try from AUR is waterfox-kde-bin. No need to compile.
But if you invest 2-4 hours for compiling a browser you could compile it with march=native flag and it will be optimized for your CPU model.

Nope, except you got plenty of time to compile FF. Will take about 2h+ on your box.
Go with default FF and be done with it instead of making yourself life difficult.


I am having issues with the volume control on the xfce panel. It will open but when I try to use it does nothing. I can control sound form my laptop and pavucontrol just not the plugin

IS this the xfce-plugin as its depreciated the pulse tray icon works as does volumeicon. but you need to start them from
the startup menu

It is I will have to try that thanks
Edit: That worked

Calamares crashed.

I tried to install Artix with this configuration: Plasma, Btrfs, LUKS, xorg and nouveau gui driver.

Immediately after the download of the file I've this error (I repeat the installation 2 times and the error is always present):

Installation failed

Boost.Python error in job "machineid"

<class 'subprocess.CalledProcessError'>

Command "dbus-uuidgen --ensure" returned non zero exit status 127


File "/usr/lib/calamares/modules/machineid/main.py", line 54 in run check_target_env_call (["dbus-uuidgen", "--ensure"])

File "<string", line 2, in <module>.

To remark also that this version of Calamares, do not permit me to install Artix on an external HD connected via usb, but ONLY on the internal HD (sda). This functionality was present and running in a previous version. Don't ask me which iso version, I deleted the older iso images.


I tried to install artix before it was announced and in btrfs as well and got the same vor a similar failure. It worked with ext4 then.

@eugen-b; I did a previous installation with btrfs without LUKS and without any problems. I'm using it now, for testing and it work perfectly.

The fact is that I need a crypted HD for my work and I don't like the idea to restart to use ext4. I spent so much time to learn btrfs... :smile:

PS: shall be great to have something like manjaro-architect...

Then it is probably unrelated.

I think so and I agree with you, but who can tell? I download the last iso and tomorrow I'll repeat the installation.

Now, to avoid to be killed, I must take the girl and go to see a movie that she want to see :wink:

1 Like

Forum kindly sponsored by