Terminal (alacritty) transparency not working

After update, the transparency feature of my terminal, alacritty, is no longer working.
If I set the background_opacity to 0 in alacritty.ym, which is supposed to completely transparent, the terminal turned out to be wholly black.
image

Any ideas?

I see from your user description you are on Gnome but the screenshot looks like i3. Are you on X11 or Wayland session?

use
background_opacity: 0.5
and try on both X11 and Wayland session or see the issue here:


and an older one

Typo?

I am currently playing with gnome - it is working here.

image

I'm not sure if it is still useful, but i had a similar problem.
My composer (picom) was not loading properly... try changing starup config...

I am having the same issue with picom and alacritty. I am running herbstluftwm and while not focused
the picom setting I have does work, but the focused window seems to be ignoring the alacritty setting
and is either non-see through grey on any setting except 0.0 which then turns it black

So I am not sure if I need to be changing a setting in picom or alcaritty??

I had the same issue.
I eventually found this post picom fails to start
Simply put , I comment out paint-on-overlay = true; from ~./.config/compton.conf and it worked!

the compton.conf is deprecated - it is now picom.conf in ~/config/picom

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by