Testers needed for the Plasma5 20.0 release

Oh, i always build myself with makepkg -s to review changes manually and all that...
As i don't really trust AUR that much and like to prep my packages for doomsday. :upside_down_face:

I thought it's exactly same for pamac, but if it's conflicting then it's fine..

This morning, I installed a kde-based system using architect using test repositories to test the RC branch. At the moment, everything is fine, if there are problems, I will let you know, thanks.

1 Like

I have no idea why the kde profile has this file. It has been there for years and none of the others has it. I will just remove it.

4 Likes

Clean install to VirtualBox. I can try on real HW, if a new ISO is not imminent.

1 Like

Absolutely nothing to report.
Everything works after multiple attempts at perfection.
Really great work.

1 Like

VM was fine, but on real HW, I could not get the ISO to boot to a graphical environment.

  • With Free Drivers, I saw SDDM start, I saw a cursor, and the Enjoy the Simplicity splash screen, and it hung there, and I had to hard power-off. I could not get to a TTY.
  • With Non-free Drivers, it seemed as if I got less far. I saw [ OK ] Started TLP System Startup/Shutdown and it appeared to hang, but from there I was able to Ctrl Alt F4 to a TTY where I could systemctl poweroff.
$ inxi -Fxxxz
System:    Host: marco-T61 Kernel: 5.4.34-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           Desktop: KDE Plasma 5.18.4 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 64574UU v: ThinkPad T61 serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: LENOVO model: 64574UU serial: <filter> BIOS: LENOVO v: 7LETC1WW (2.21 ) date: 07/01/2008 
Battery:   ID-1: BAT0 charge: 0 Wh condition: 62.9/84.2 Wh (75%) volts: 4.8/10.8 model: Panasonic 42T4620 
           type: Li-ion serial: <filter> status: Unknown 
CPU:       Topology: Dual Core model: Intel Core2 Duo T7300 bits: 64 type: MCP arch: Core Merom rev: B 
           L2 cache: 4096 KiB 
           flags: lm nx pae sse sse2 sse3 ssse3 vmx bogomips: 7982 
           Speed: 1401 MHz min/max: 800/2001 MHz boost: enabled Core speeds (MHz): 1: 798 2: 798 
Graphics:  Device-1: NVIDIA G86M [Quadro NVS 140M] vendor: Lenovo ThinkPad T61 driver: nvidia v: 340.108 
           bus ID: 01:00.0 chip ID: 10de:0429 
           Display: x11 server: X.Org 1.20.8 driver: nvidia compositor: kwin_x11 resolution: 1680x1050~60Hz 
           OpenGL: renderer: Quadro NVS 140M/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108 direct render: Yes 
Audio:     Device-1: Intel 82801H HD Audio vendor: Lenovo ThinkPad T61/R61 driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:284b 
           Sound Server: ALSA v: k5.4.34-1-MANJARO 
Network:   Device-1: Intel 82566MM Gigabit Network vendor: Lenovo ThinkPad T61/R61 driver: e1000e v: 3.2.6-k 
           port: 1840 bus ID: 00:19.0 chip ID: 8086:1049 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Intel PRO/Wireless 4965 AG or AGN [Kedron] Network driver: iwl4965 v: in-tree:d port: 2000 
           bus ID: 03:00.0 chip ID: 8086:4230 
           IF: wls3 state: up mac: <filter> 
Drives:    Local Storage: total: 111.79 GiB used: 54.42 GiB (48.7%) 
           ID-1: /dev/sda vendor: PNY model: CS1311 120GB SSD size: 111.79 GiB speed: 1.5 Gb/s serial: <filter> 
           rev: 1122 scheme: MBR 
Partition: ID-1: / size: 101.32 GiB used: 54.42 GiB (53.7%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 8.34 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 61.0 C mobo: 55.0 C gpu: nvidia temp: 67 C 
           Fan Speeds (RPM): fan-1: 3007 
Info:      Processes: 180 Uptime: 2m Memory: 3.78 GiB used: 1.37 GiB (36.2%) Init: systemd v: 245 Compilers: 
           gcc: 9.3.0 Shell: bash v: 5.0.16 running in: yakuake inxi: 3.0.37 

https://linux.die.net/man/7/inotify

/proc/sys/fs/inotify/max_user_watches
This specifies an upper limit on the number of watches that can be created per real user ID

Listen uses inotify by default on Linux to monitor directories for changes. It's not uncommon to encounter a system limit on the number of files you can monitor. For example, Ubuntu Lucid's (64bit) inotify limit is set to 8192.

The issue

When dropbox or guard says like:

  • Unable to monitor filesystem Please run: echo 100000 | sudo tee /proc/sys/fs/inotify/max_user_watches and restart Dropbox to correct the problem.
  • No space left on device - Failed to watch "…": The user limit on the total number of inotify watches was reached or the kernel failed to allocate a needed resource. (Errno::ENOSPC)

Is it safe to raise that value and what would be the consequences of a too high value?

Yes, it's safe to raise that value and below are the possible costs [source]:

  • Each used inotify watch takes up 540 bytes (32-bit system), or 1 kB (double - on 64-bit) [sources: 1, 2]
  • This comes out of kernel memory , which is unswappable.
  • Assuming you set the max at 524288 and all were used (improbable), you'd be using approximately 256MB/512MB of 32-bit/64-bit kernel memory.
    • Note that your application will also use additional memory to keep track of the inotify handles, file/directory paths, etc. -- how much depends on its design

To see current value do

cat /proc/sys/fs/inotify/max_user_watches

But we probably want it highish. I see recommends at ex: 524288
From my limited research I might be comfortable with either 1/2 (262114) or 1/4 (131072) as well.
Based on some bug reports - 128k seems to be ceiling .. or floor.. for some. Though I guess it all depends on amount of stored data. If the above is to believed though, maybe setting a maximum of 128/256mb for kernel to monitor files is enough until proven otherwise.

(and yes though - whatever decided, this shouldnt be a DE-specific consideration.)

5 Likes

This lot of course was on the 19.0 ISO, so nothing has changed in that regard. It did exactly the same thing in Live environment but once installed, all Breath2 Konsole themes are available. EDIT - you can actually try them in live environment too. right click in the konsole terminal window and edit the profile.

@oberon & @bogdancovaciu I am not overly impressed with the latest iteration of the Breath2 Konsole themes. Feel free to carry on butchering them as I said all along you can do what you like with them but it would have been nice to have been involved in the discussions if there were any about such changes.

I'll keep my own going forward stored in my local folder for use with whichever distribution I see fit. I know there were compromises with it but on balance the new version has introduced far worse issues instead. You can deal with the mess yourselves because I won't be contributing anything further since you failed to ask for my input over the changes to my work.

2 Likes

just run it in live ISO or VM and see for yourself.

I found this, too, and tried to reproduce thre problem.
For me auto-updateb in dolphin works fine also without the file...

1 Like

I am sorry for the bad procedure. My fault, I should have contacted you first.
Yesterday someone in the team noticed that alsamixer was completely unusable with breath2 terminal colours and @bogdancovaciu kindly offered to take a look at the schemes. He didn't even know it was your contribution - my fault again that I didn't communicate that.
In any case apparently he found a few more issues with the way the colours where defined and uploaded his fix to the repo which I just quickly checked and packaged. To me the result looked great and more or less like before in general...
Sorry again for the bad miscommunication!
I'd hope that there could still be an exchange between the two of you about the problems of thre color-scheme and what was - or apparently still is - broken...
Thank you

6 Likes

I am testing the 20.0 release in a vm, so i don't know how this is of relevance?

No, not here.

Did you test RC2 or RC3? The first shipped with a broken kernel ...

Look mate, you can comment, opinate, critique, add better code, but please take your remarks about butchering remarks elsewhere. I'm not amused by such remarks.

Name them please! Put them here so we can check. Just asserting is wrong or bad is not actually an argument, and calling us butchers here is quite pretentious and not quite friendly.

Oh wow, so now we come to this? Actually i did not used your work but i started from scratch, with a well color balance scheme, and adjusted it for breath to follow the general color-scheme, so when you go into alsamixer the background remains the same, and not switch to that intense yellow background. If you prefer that, fine, but i'm quite sure i followed the KDE Plasma guidelines in that regard.
I don't understand the visceral attitude when is quite easy to edit, present and justify each change, argument why is visually better and so on, instead on going to adhominem us with a rant that actually doesn't help anybody, but flames the egos.

I'm open to discussions, no hard feelings, but if is to use bare hands instead of boxing gloves, i can't guaranty the outcome. :wink:

2 Likes

@antikythera @bogdancovaciu
Jeez, chill out guys...

I can fully understand @antikythera reaction, because we all hold dear our collective achievements as this is our daily OS drivers in question and we supposed to be open with each other as source of our code and all that...So it's only natural to address some process issues and flaws of communication.

For example, i can only double more than valid and worrying questions of silent changes - @oberon why Balena Etcher is in use again?

  • It was a very long time since one of our forum members have found out and addressed that it's not safe and privacy leaks was established with this software.

  • Then i have addressed this issue to you guys, since then all Manjaro editions came out with imagewriter (SUSE Studio Imagewriter) as far as i remember, which should be fine until proven otherwise.

  • So why this change come? What rationalization? Can we trust someone who was already compromised before (i personally believe answer should be always no), instead of using any software that do same functionality without being compromised as pre-installed defaults?

Whatever it is with a process of changes going on, i think it should be addressed and improved in order not to ever step on a same rake again...
Otherwise what's the point of improving anything and wasting time of checking that previously solved stuff is still intact? :slight_smile:

2 Likes

I'm quite chill, but when someone on the forum randomly thinks i need to be told to chill, it actually makes me wonder ... should i send some payment for this psychological intervention, or you do it for free? :slight_smile:

2 Likes

I've let quite a few things slide of late from a couple of the manjaro team including yourself because I knew if I didn't I'd just get banned from here for causing trouble, plus I have been trying to give benefit of doubt given what's going on in the wider world.

However, the simple fact is I am actually disillusioned with the direction manjaro and also KDE project are headed at present anyway. This is not based on what happened here but in general so forgive me if I don't take oberon and yourself up on the offer of further discussions to improve on something I have lost all passion to give the time of day at present. I firmly believe it would be in both our interests not to go there and I walk away.

All the best for the future and I do mean that, I'm not being sarcastic. Stay safe and well.

@keybreak Neither of us believe we require a shrink but if we knew we did then we probably wouldn't need one :crazy_face:

No idea if it is helpful, but the first thing I (as only sporadically using VBox user) failed with was

Auswahl_23-04-2020_11:13:56

When I do this, VBox reports that the setting is invalid, also if I still keep it, nothing changes, that is, I am stuck with a 800x600 resolution, no matter the VBox window size and the resolution I set in the guest Manjaro KDE settings.

Edit: Now I also installed a virtual Manjaro Xfce, there the display resolution set in the guest is being used. So the second problem is KDE specific.

Weird, i tested it with:
virtualbox 6.1.6-1
virtualbox-guest-iso 6.1.6-1

This .iso on new machine with VBoxSVGA without Enable 3D acceleration ticked - window resizing works and without that warning from mhwd...

Do you have your user added to vboxusers group on host machine though?

1 Like

Thanks! It was indeed the 3D acceleration thingy which I unconsciously activated.

edit: But the KDE desktop feels really slow. If I hover some entries in any list, the green "hovered" color is following the cursor with a delay: https://www.dropbox.com/s/qbler1rbr8hwq9y/simplescreenrecorder-2020-04-23_12.47.44.mkv?dl=0

1 Like

Forum kindly sponsored by