(testing branch) Octopi 0.9.0-9/10 and its notifier problems - broken versions

With the update to octopi and octopi-notifier-frameworks 0.9.0-9 I have been having more and more issues. In result, from fully functional application it transformed to beta, buggy, broken software, completely NOT READY TO SHIP TO STABLE

Here is the list already found problems:

  • Broken localization: before Octopi was fully localized in my language (polish), now it's partially translated, first tier menu is English only, the second tier menu is English or Polish. Localization is showed to be 100% ready and yet it's just not working with this version.
  • Notifier icons won't disappear after the update: when we update through pamac or terminal, the red icon is staying in tray forever and there is no way to get rid of it unless we reboot the session (refreshing octopi doesn't help). Previously this wasn't the problem and notifier reacted correctly.
  • Broken terminal function: Previously Octopi opened a new terminal window. Now it opens own terminal tab and when I tried manually update a package from ignore list (I use thunderbird AUR version and its versions are usually belayed toward the repo version so I put localization package to ignore so it wouldn't block the update). However, it showed me some error and aborted the transaction:
    Screenshot-2019-07-03-06-21-30
    It also turned out that I CAN'T GET OUT OF THAT TERMINAL and ALL MY OPTIONS WERE GRAYED OUT so I was in the middle of the transaction locked up. CLOSING OCTOPI NEEDED ME TO GIVE SUDO PASSWORD... Another issue, especially that there was no obvious way to end the transaction.

The thing is: Pamac can't update a package that is on ignore list, Octopi could, now it can't, so it became useless and I had to do that operation in the terminal.

So from one issue, it goes to the next and next and next. Octopi turned to be completely useless at this point. This version should never go to the stable branch. I'll keep trying to use it and maybe I'll find more problems.

EDIT: Just updated Octopi to 0.9.0-10. After the update the red icon was gone so this may start behaving normally. Still, no localization and packages on ignore list can't be installed (no usuall terminal the confirmation), still locked up, etc.

4 Likes

same behaviour here, plasma stable, 0.9.0-10 after last update
downgraded to 0.9.0-8 to have it fully functional again

CTL+C or CTRL+Z could not exit the update process?

Yeah my Testing's Octopi Notifier also is misbehaving, eg, it remains in a permanent state of "Checking for updates".

EDIT.
...or maybe not. Killing its process then relaunching O/N from Application Menu seems to have made it happy again. Silly me.

1 Like

Seems we have to revert to the older git commit? Just let me know.

Octopi devs aren't known from quick responses or fixes (some past bugs lasted for months before they were fixed) and this version is just trash and not ready to use by anyone, so yeah, the version should be rolled back. But you said "revert commit" as you could do that? So who is the octopi developer now? Has something changed?

The thing is, after the error you get a normal prompt to enter another command. So there is no indication or any suggestion to use those shortcuts. However, when I tried ctrl+c, there is NO VISIBLE REACTION but closing octopi doesn't require sudo password so this seemed to work. This is unacceptable since this is not obvious and not behaving in a standard way (both for terminal or GUI).

This is messed up and not thought out.

Yes, I agree.

Octopi was always 3rd party. Our focus lays in Pamac. Therefore we are working on a QT UI. I tried with the latest git-version to see if all issues we had with Octopi are solved. Seems not. The commit we used for revision 8 seems to work kinda, but not fully.

Anyway, I'm rolling back to -8 version, since Octopi -9 don't do things I mostly used it for (updating ignored packages, reinstalling - those things suck or are impossible in Pamac).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by