Testing for bspwm edition

I wonder if I should get crazy and actually include a display manager too...? I included some configurations for slick greeter and lightdm.

I see. And this is the reason I can't automatically login? I didn't know.
In /etc/group the "users" group is this: users:x:985:
I suppose that it's not so simple like manually editing the file...

Sure that some users should like it. I like how it is. Just my opinion.

Why do we have 2 sxhkdrc configuration file (sxhkdrc and sxhkdrc-minimal) in the folder? It's a little bit confusing.

A (temporary?) workaround, because a different set of applications is used in full and minimal profiles?

1 Like

Ok, I understand. This was not a criticism of course, but only the possible point of view of a new user who see this in the beginnings of his manjaro bspwm experence.

I didn't find any way to get the automatic login. So today I started some tests reinstalling again for several times, both the minimal and the full installation, in different media (the internal SSD and an external USB flashdrive.
At the final what I've got is that every installation on the flash drive (full and minimal) works perfectly but every installation on the SSD drive (full and minimal) ended up again with no automatic login. The full install comes with Lightdm now, but same issue.
The error I found out is :

~ >>> systemctl --failed                                                                                                                                 
[127]
  UNIT                     LOAD   ACTIVE SUB    DESCRIPTION
  ● x@vt7.service            loaded failed failed X on vt7
  ● xlogin@graphical.service loaded failed failed Direct X login for user graphical

I tried then to reload and enable the services on boot, but nothing happend, same problem.
Any idea guys?

Xlogin issue, did not happen in my test installations to ssd. Strange.

I switched the full version to use lightdm instead of xlogin, you might want to give it another go? Unstable repos as usual.

I also created a test iso that I found satisfactory, now I just need to upload it...

Xlogin, yes, but I had the same issue with lightdm. I've installed from stable repos; maybe this could be the problem?
Anyway the problem as I wrote in the previous post, was only on SSD drive. Another difference was that in the usb installations the automatic logins were running on TTY7, while in the failed installations on SSD, they were on TTY1... I realy don't understand it.

17 posts were split to a new topic: Mounting android devices with pcmanfm

Now switched to Firefox. I'm considering adding timeshift.

1 Like

Added this to alt+enter

Mate polkit was accidentally missing from the packages, need to add that.

Now considering moving to pcmanfm-gtk3 instead of spacefm. I'll do some digging and comparison in regards to them.

1 Like

Screenshot%20from%202018-09-05%2002-06-00

Should I move to using the same themes as i3 edition?

They are very similar... I like them both! Maybe you could just add a few more themes, icon and font sets, and then the end user will decide what to use or remove. It depends of the size of the next ISO you wish to offer.
In the screenshot some text it's a little bit cutted in pcmanfm (in the icon of the Bspwm-beginners-guide), I have the same.

testing iso is out

2 Likes

Wonderfull, I'm going to test it!

Ok, at the moment I'm running from usb live, not any installation.

  1. The pcmanfm issue with the android connection is gone, now it's perfectly working. Well done!
  2. I had some problems on boot, in 2 machines: black screen on X, so I had to login with tty2, and edit compton.conf: my 2 laptops with AMD don't like the backend=glx option. Setting it to xrender let me startx normally. This is my hardware currently problem (I still fight against that in the last 3 months), but maybe other users might end in the same problem, so imho, the default installation with xrender should be more prudent for a bigger range of hardware.
  3. Sterminal does not start from menus, or keybinding. Starting it with st terminal gives this message:
~ >>> sterminal
child finished with error '256'
tmux: invalid LC_ALL, LC_CTYPE or LANG

and 4. Mygtkmenu, the right click on the desktop: some apps don't start when click: file manager, run, find, terminal.

This happens if you haven't set locale in the installation.

Thank you for the data!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by