[Testing Update] 2018-02-08 - Kernels, Browsers, Plasma, GCC, Nvidia, Systemd

Great job getting 5.12 so fast in Testing. Only 1.5G of RAM when booting. This is caused by Kontact and millions of e-mails. But things run great, no problems so far.
Just noticed, also a new Nvidia driver, very nice.

At the begin of boot process I get since the kernel 4.15.2-1 the screen message:

EDAC pnd2: failed to register device with error -22

With kernel 4.14 there is no error message and first release version of 4.15 was fine too.

Found on research, that it seems related to non ECC capable RAM and could be avoided with kernel option oder BIOS setting. But found no more (for me) understandable information and no setting possibility in BIOS. And why no problems in 4.14 and initial 4.15?

The system makes no problems after booting and login, as I can see in the first minutes.

Annoying window/theming changeup for breeze after update on KDE :frowning:

image

But luckily it is just a new setting in breeze.

System Settings>Application Style>Window Decorations>Breeze>Settings Icon

image

Untick "Draw seperator between Title Bar and Window"

Yay
image

Also, I must say how stoked I am that they finally got rid of the down-and-off-to-the-left shadows in breeze and centered them. Sheesh.

3 Likes

It's:
System Settings>Application Style>Window Decorations>Breeze>Settings Icon

1 Like

Oops skipped one, thanks. :wink:

Firefox 58 wouldn't start on me, but I was able to resolve it from following through with the suggestions from the very helpful thread: Firefox 58 won't start

Edited to add link, thanks for pointing that out, @cscs

Please point a link or something to what thread you are referring.
(no issues here, but for info purposes)

1 Like

Which kernels were rebuilt with GCC?

About my error I went back to unstable but this time I compiled f2fs from AUR and it said that I was missing some dependencies so I install them as well and also I was getting an error about:

libtool: warning: '../lib/libf2fs.la' has not been installed in '/usr/lib'

Anyway after installing the missing dependencies I shutdown the pc and started again and everything seems to work ok. I have also installed manjaro f2fs-tools and is working fine now as well.

At the end I dont know if Manjaro fix it or is fixed by installing the missing dependencies that have been installed from Aur?

nice to see plasma update already here. Wayland on kde still sucks though.

Everything great here on KDE. Update with no issues.

I also had the line added between the window border and top toolbar, but this is a KDE item and not a Manjaro item. Several people are also posting about it on the KDE subreddit and KDE Neon forums. May be something Manjaro wants to change the default for the Manjaro theme so it retains the original look-and-feel, but some people like the line. :slight_smile:

Yeah, its just a new setting, not locked :wink:
I wonder how much anyone thinks that is more desirable than without .. but what do I know?

1 Like

Plasma Discover is broken.

http://storage5.static.itmages.ru/i/18/0209/h_1518151455_8143670_5830eaccce.png

http://storage6.static.itmages.ru/i/18/0209/h_1518151470_1947211_40faa16726.png

After update not working fn+F1..12 combinations.
Notebook asus. Kernel 4.14, 4.15 last (both)

Packagekit ist broken on Arch distros.

1 Like

Anyone having conflicts with nvidia utilities?

EDIT: I think I found the problem...I had the 4.13 kernel installed...

I haven't, but now Chrome with hardware accelerate and new nvidia driver (390.25) works with horrible freezes, on youtube particularly :slightly_frowning_face:

Yesterday I had an issue that the wget backend for pacman got stuck during doenloads of community.db and also during downloads of some packages.

Terminating the wget process in htop made wget resume the download and it completed successfully.

I cannot reproduce it and there is nothing special in the journal. It happened on different machines three times.

2 Likes

I think there will be some that will ask about these errors at shutdown

shutdown[1]: Failed to wait for process: Protocol error

seems related to systemd 237, but I did not found more detail now. just that someone also have it on arch.
https://bbs.archlinux.org/viewtopic.php?id=234329

I have them on my VM and latptop installation. (both on unstable)
doesn't look armfull until now

3 Likes

I also have this, and while i tried to look them up in journal another problem came up: they are not shown due to rate limit:

kernel: systemd-shutdow: 42 output lines suppressed due to ratelimiting

When i tried to remove rate limiting from /etc/systemd/journald.conf by setting RateLimitInterval=0
RateLimitBurst=0 the behavior does not change.

Forum kindly sponsored by