[Testing Update] 2018-03-14 - Kernels, Browsers, Nvidia, Xorg, KDE Frameworks, Deepin

Hi community,

welcome to another testing update of Manjaro. Mostly we worked on our Kernels, Deepin, Xorg and added regular upstream updates as usual.

Here is the list of changes in more details:

  • We updated some of our browsers
  • We updated some of our kernels
  • We added the latest KDE Frameworks
  • We worked again on the systemd issue
  • We added the latest Deepin packages
  • We upgraded our Nvidia driver
  • We upgraded some parts of our Xorg-Stack
  • We added regular upstream updates like Foomatic-DB, Haskell and Python

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.55
  • linux318 3.18.99 [EOL]
  • linux41 4.1.50
  • linux44 4.4.121
  • linux49 4.9.87
  • linux414 4.14.26
  • linux415 4.15.9
  • linux416 4.16-rc5
  • linux-RT-LTS 4.14.24_rt19
  • linux-RT 4.14.24_rt19

Package Updates (Wed Mar 14 07:49:25 CET 2018)

  • testing community x86_64: 373 new and 373 removed package(s)
  • testing core x86_64: 29 new and 29 removed package(s)
  • testing extra x86_64: 332 new and 432 removed package(s)
  • testing multilib x86_64: 9 new and 11 removed package(s)

A detailed list of all changes can be found here.


  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


https://youtu.be/xha6DJ_v1E4

5 Likes

wiki post

I had to:
sudo rm /usr/lib/firefox/distribution/distribution.ini
to not get the update process interrupted, not a big deal, and on reboot/shutdown i only get one line (for a very short time = a blink)
watchdog0: watchdog did not stop!
something like that.
Cool update! Everything else seems to be working just fine.

5 Likes

@Ste74: does manjaro-browser-settings still not work as expected and we still have to repack firefox in regard of distribution.ini?

@bogdancovaciu: was manjaro-browser-settings installed on your system?

Yes, on this particular system it was installed. It didn't bother me. I had the same on one unstable install, but on other 2 unstable installs was not the case. I thought the inconsistency was because of me, something i previously installed/uninstalled ...

removed "usr shutdown" bevore update and messeges while shutdown are gone.
Kernel 44, 4.14, 4.15 all fine.

This is the first report after my changes and adjustments.. Theorically it work as expected..

@bogdancovaciu are this system not updated recently? I. E. Is a big update for you?

On Plasma is always a big update :slight_smile:
On Gnome not so much and i didn't had any issue with distribution.ini. On another (but unstable) i use a mix of DE's and i had the distribution.ini issue, solved quick by removing it.

Really strange..
https://github.com/manjaro/manjaro-browser-settings/blob/master/manjaro-browser-settings-pre.hook
Hook content
https://github.com/manjaro/manjaro-browser-settings/blob/master/manjaro-browser-settings-pre.script
Script to remove .ini

I had to do the same as @bogdancovaciu.

I also had to downgrade bluez (and utils, etc.) to retrieve bluetooth functionality in gnome with kernel 4.14.
Cheers,

This evening try to repeat the issue in vbox in a fresh installation.. Since for me work..

The Chromium browser update to build 65 from extra repo works fine, it's the only package I've installed from Testing but no problems running it on Stable.

Also had to remove the .ini file from firefox, but no more error messages at reboot or shutdown.

I think we don't support firefox-kde yet. However, this is now a community project.

Aha.. Good Point.. You are right not include the -kde version in the trigger..

I too. But Firefox not run in german.

Edit:
See here and Firefox run in german.
Klick

I can't cleanly shutdown my system with the new systemd 238.0-3. I went back to 238.0-2.

more info's can be found here:

I can confirm this. On fresh install it works. On fresh install moved to testing works too. Cheers!!!
I think on older installs from testing makes to misbehave ... I have to test.

Edit: Made a new fresh install of XFCE and switched it to testing and the distribution.ini was displayed ... I did a clone of it and now i will see how is on unstable and report back.

Edit2: Same deal with a fresh install XFCE to unstable ... distribution.ini appears and prevents the update process.
Now i have to investigate what was different on those 2 unstable older installs that didn't manifest, but even so, on another unstable that was even older install, it did. On Gnome unstable install didn;t happened ... I'm confused and i hope i didn't transmitted that confusion further :smiley:

1 Like

I had problems with /usr/lib/firefox/distribution/distribution.ini too.
I'm using Plasma

1 Like

My only thing is it : the remove script fail? If you want before update open the scitpts ( pre and post ) placed into
/usr/share/libalpm/scripts folder and add set -x at the first line ( but after #!bin/bash ) to debug the scripts..

Forum kindly sponsored by