[Testing Update] 2018-06-13 - Kernels, Nvidia, Deepin, Browsers, KDE Framework

Hi community,

Welcome to another testing update. So what do we have with this one?

  • Palemoon Browser got updated
  • A new set of Deepin package updates
  • Another Firefox Development Update
  • Some kernels got updated
  • Latest Nvidia legacy drivers
  • KDE Frameworks are now at v5.47
  • Usual upstream rebuilds

We hope with all these changes Manjaro to be more efficient for you all.

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts:

Latest information about the intel-cpu-bug risk and our efforts can be found here.

Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.112 [EOL]
  • linux41 4.1.52 [EOL]
  • linux44 4.4.136
  • linux49 4.9.107
  • linux414 4.14.49
  • linux415 4.15.18 [EOL]
  • linux416 4.16.15
  • linux417 4.17.1
  • linux418 4.18-rc0 (early preview)
  • linux414-rt 4.14.40_rt30
  • linux416-rt 4.16.12_rt5

Package Updates (Wed Jun 13 08:08:14 CEST 2018)

Sync Packages

  • testing core x86_64: 10 new and 10 removed package(s)
  • testing multilib x86_64: 3 new and 3 removed package(s)
  • testing extra x86_64: 132 new and 130 removed package(s)
  • testing community x86_64: 332 new and 328 removed package(s)

Overlay Packages

  • testing core x86_64: 10 new and 8 removed package(s)
  • testing multilib x86_64: 6 new and 5 removed package(s)
  • testing extra x86_64: 29 new and 25 removed package(s)
  • testing community x86_64: 44 new and 43 removed package(s)

A detailed list of all package changes may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

File conflict with engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the upgrade.

Items from previous update sets

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

1 Like

Before i make the update, i want to be sure. It seems that is the same as was mentioned here for the unstable

EDIT: so, in 30 minutes we had also the plasma-framework 5.47 , rendering the update absolutely flawless, 111 packages. Awesomeness at superlative !!! Thanks @philm !!! :slight_smile:
Now, looking forward for plasma 5.13 :smiley:


Everything fine under deepin.

Thx a lot :slight_smile:
Ups, only me???
Dos not start deepin-image-viewer Fixed with update 20180616

➜  ~ deepin-image-viewer
deepin-image-viewer: symbol lookup error: /usr/lib/libfreeimage.so.3: undefined symbol: _ZTIN7Iex_2_27BaseExcE

➜  ~ nm -D libfreeimage.so.3
nm: 'libfreeimage.so.3': No such file



pamac did stop updating with this message

at my:

OS: Manjaro 17.1.10 Hakoila
Kernel: x86_64 Linux 4.17.0-2-MANJARO
Uptime: 53m
Packages: 1310
Shell: bash 4.4.19
Resolution: 1920x1080
DE: Xfce4
WM: Xfwm4
WM Theme: Vertex-Maia
GTK Theme: Vertex-Maia [GTK2]
Icon Theme: Vertex-Maia
Font: Cantarell 10
CPU: Intel Pentium 4 3.60GHz @ 2x 2.81GHz
RAM: 1526MiB / 3003MiB

Hi, Same problem...


remove DeepinBildschirmfoto_Bereich%20ausw%C3%A4hlen_20180613104733


Thanks, pamac updates did take place. It seems ok.

1 Like

Thank you for your quick reply, That was the answer, super....

1 Like

Also had to remove thunar-plugin engrampa, then everything ran without problems. :wink:


I updated in the terminal and noticed updating grub failed nothing was done. After all updates installed a "sudo update-grub" worked fine and so a reboot succeeded.

It looks like VLC 3.0.3 has finally solved my issues. :tada::tada::tada:

I was curious about the new archive plugin for Thunar -- it's been a while since I ran any gui compression apps (always used p7zip terminal for heavy-duty compression.) Nice to see Engrampa is now using all available cpu cores on the 7z option but I still don't see advanced options like specifying lzma2 and other method switches...w/e, fits the casual user I guess.

Plasma System Tray widget broke on multiple bare metal and VM systems.

To re-create add a system tray widget, bring up System Tray Settings, select Entries, tweak which items are shown/hidden, click OK.

Now click on the system tray widget to toggle the display and it is broken.

Go back into System Tray Entries and now there is nothing there, which is most likely the source of the breakage.


To get a usable system tray again I remove the widget, re-add it, and when configuring the system tray completely avoid the Entries tab.

Anyone else able to reproduce this, or is it just me?


Had that issue prior to getting the

After that all was ok ... Still investigating.

Is there a KDE Illyria beta on the way too?

I had this issue as well thanks for the help

1 Like

still have it on unstable..

Did the plasma-framework package got updated to 5.47 ? On one of my installs i had to delete ~/.config/plasma-org.kde.plasma.desktop-appletsrc to be able to get back some functionalities and settings ... but on other installs was no issue ... still not sure what was going on :thinking:
But in the end all looks fine on all my installs.

You can also keep engrampa and remove thunar-archive-plugin. I did so.
You have the embarrassment of choice :grin:

1 Like

Xfce, 4.17.

After the update the exo entries (exo-terminal-emulator.desktop and exo-file-manager.desktop provided by exo 0.12.0-1 ) are no longer registered/present in the top level of the right-click on the desktop menu. They are still in the application sub-menu and the desktop entries themselves at /usr/share/applications/ did not change; they still have the X-Xfce-Toplevel category specified.

Did not make any progress on this. I find these entries in the top level very handy for my workflow. (Aka - help needed.) :fearful:

Edit: presumably this is a problem with xfdesktop 4.12.4-2 but I was unable to confirm as downgrading this package leaves a broken desktop. I tried reinstalling exo but this made no difference.

Forum kindly sponsored by