[Testing Update] 2018-07-14 - Kernels, KDE (Plasma, Apps), Firefox, Thunderbird, Mesa, Haskell

Hi community,

Welcome to another testing update. So what do we have with this one?

  • latest kernels
  • Firefox updated in Development edition
  • Mesa got updated to v18.1.4 which brings fixes for radeon and intel
  • KDE got updated with Plasma and Apps
  • Stefano managed to add our new plasma5-theme-adaptabreath theme for KDE
  • python and haskell updates/rebuilds.

We hope with all these changes Manjaro to be more efficient for you all.

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts:


Our KDE fans may try our beta-build with the latest KDE v5.13 instead.

Latest information about the intel-cpu-bug risk and our efforts can be found here.

Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.115 [EOL]
  • linux41 4.1.52 [EOL]
  • linux44 4.4.140
  • linux49 4.9.112
  • linux414 4.14.55
  • linux415 4.15.18 [EOL]
  • linux416 4.16.18 [EOL]
  • linux417 4.17.6
  • linux418 4.18-rc3
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt9

Package Updates (Sat Jul 14 07:48:21 CEST 2018)

Overlay Packages

  • testing core x86_64: 10 new and 10 removed package(s)
  • testing multilib x86_64: 7 new and 0 removed package(s)
  • testing extra x86_64: 45 new and 100 removed package(s)
  • testing community x86_64: 9 new and 2 removed package(s)

Sync Packages

  • testing multilib x86_64: 12 new and 12 removed package(s)
  • testing core x86_64: 6 new and 7 removed package(s)
  • testing extra x86_64: 419 new and 416 removed package(s)
  • testing community x86_64: 552 new and 552 removed package(s)

A detailed list of all package changes may be reviewed here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Ready for Stable ?!?

  • We are ready to move this to our stable branch
  • I still see some issues (post about them)

0 voters


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Items from previous update sets

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

The update process went smooth, but after the reboot i got black screen with the pointer (KDE Plasma). I got Yakuake by pressing F12 and rebooted. This time i got black screen with latte-dock running, no right click, not able to switch Activities by any shortcuts. Did the same as previously, rebooted. Third reboot got the entire plasma working, but no internet connection even tho the notification popup said "Connection established". Accessing the router configuration page shows that i do have internet, i could ping and trace any site i tested, but from the browser i couldn't access any site. Disconnected and connected again made the forum load, but very slow. Long story short, i remade the connections from Network Configuration, rebooted but now the internet connection is slower.


Used to be 92Mbps
The status bar when accessing the router shows this:


So i was wondering what is that _gateway doing there ... A stripped down netstat shows this:

$ netstat
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State      
tcp        0      0 AuroraALX.local:47920   _gateway:www-http       ESTABLISHED
tcp        0      1 AuroraALX.local:47914   _gateway:www-http       SYN_SENT 

Yes, i have two LAN cards, one is connected at boot and one is as a backup and for VBox Bridge Connection ... The funny part is that the VBox Speed Test shows this:


The difference is that on that VBox i have Networkmanager 1.12.0-0 while on the main tower i have now the 1.12.0-1 (i will install it on VBox too and compare results). My guess is that something in the new package got a glitch ... I will downgrade networkmanager on my main tower after i do more tests.

If some moderators think this post needs to be split, please do so ... Cheers!


A small issue with the KDE edition update: I could not update the "spectacle" package. Got a message saying something as it was not the expected size and the update process was aborted. So I just uninstalled "spectacle" (anyway never used it) and run again the update, this time without issue.
After reboot I try to install again the new version of spectacle (18.04.3-1)with pamac, and this time I could install it without issue.
Seems to have been a sync issue with the servers.... (even if I have try at least 8 different servers with the same result).

I'm not sure what the update to networkmanager (1.12.0-0 -> 1.12.0-1) was about...(latest commit was on 29-Jun?:confused:), but it looks as though the openvpn connection bug in the networkmanager applet is still present...but, using the nmcli workaround still works as previously mentioned. It looks like there's an arch bug filed just yesterday about this as well.


After rebooting:

You are in emergency mode.


After CTRL+D the GUI was there and system working normal as i so far.



networkmanager 1.12 working without problems.

please check if it got resolved with the current update of networkmanager ...

with the nm change to 1.12.0-1, right-clicking the icon, internet speed says "unknown", but it works. Before it detected the speed. Xfce, intel.

Even with the last 3 packages update, i can access/load sites (whatever browser), or ping domains from terminal only 1 minute after the Desktop loaded. Changed the default network interface from the two, changed priority, auto-negotiation on or off and the speed with no effect. Nothing in journalctl nor the kernel log ... After that minute all seems to work normal, but previously i could access any site right after boot ...

with the original testing update, I got the "maybe no internet connection present" - warning by octopi at startup and the networkmanager - icon had a connection error label, although the connection was up and running without issues.

The new networkmanager packages don't trigger the "maybe no internet connection present" anymore. But the icon still shows the connection error warning.
Logging out and in again solves the icon problem.

Everything works flawlessly on a Manjaro with Mate-Desktop... Nothing to report.

I've got nothing to report as well. Update went fine. Plasma desktop.

Got same problem (starting into emergency mode).

File System Check failed:

Jul 14 14:31:51 username systemd[1]: Started Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling.
Jul 14 14:31:51 username systemd[1]: Reached target Local File Systems (Pre).
Jul 14 14:31:51 username systemd[1]: systemd-fsck@dev-disk-by\x2duuid-d3e0fa2e\x2d0474\x2d4821\x2d980b\x2d7d926f6996dc.service: Bound to unit dev-disk-by\x2duuid-d3e0fa2e\x2d0474\x2d4821\x2d980b\x2d7d926f6996dc.device, but unit isn't active.
Jul 14 14:31:51 username systemd[1]: Dependency failed for File System Check on /dev/disk/by-uuid/d3e0fa2e-0474-4821-980b-7d926f6996dc.
Jul 14 14:31:51 username systemd[1]: Dependency failed for /home/systemname/Games/Steam_SSD.
Jul 14 14:31:51 username systemd[1]: home-systemname-Games-Steam_SSD.mount: Job home-systemname-Games-Steam_SSD.mount/start failed with result 'dependency'.
Jul 14 14:31:51 username systemd[1]: systemd-fsck@dev-disk-by\x2duuid-d3e0fa2e\x2d0474\x2d4821\x2d980b\x2d7d926f6996dc.service: Job systemd-fsck@dev-disk-by\x2duuid-d3e0fa2e\x2d0474\x2d4821\x2d980b\x2d7d926f6996dc.service/start failed with result 'dependency'.
Jul 14 14:31:51 username systemd[1]: tmp.mount: Directory /tmp to mount over is not empty, mounting anyway.
Jul 14 14:31:51 username systemd[1]: Mounting /tmp...
Jul 14 14:31:51 username systemd[1]: Mounting /boot/efi...
Jul 14 14:31:51 username systemd[1]: Starting File System Check on /dev/disk/by-uuid/8ecee5ff-16f1-4045-a364-8bc8c244eaee...
Jul 14 14:31:51 username systemd[1]: systemd-fsck@dev-disk-by\x2duuid-6b76ac5b\x2d1174\x2d4998\x2dbd53\x2d2a80432bab61.service: Bound to unit dev-disk-by\x2duuid-6b76ac5b\x2d1174\x2d4998\x2dbd53\x2d2a80432bab61.device, but unit isn't active.
Jul 14 14:31:51 username systemd[1]: Dependency failed for File System Check on /dev/disk/by-uuid/6b76ac5b-1174-4998-bd53-2a80432bab61.
Jul 14 14:31:51 username systemd[1]: Dependency failed for /home.
Jul 14 14:31:51 username systemd[1]: Dependency failed for Local File Systems.
Jul 14 14:31:51 username systemd[1]: local-fs.target: Job local-fs.target/start failed with result 'dependency'.
Jul 14 14:31:51 username systemd[1]: local-fs.target: Triggering OnFailure= dependencies.
Jul 14 14:31:51 username systemd[1]: Dependency failed for /home/systemname/fast.
Jul 14 14:31:51 username systemd[1]: home-systemname-fast.mount: Job home-systemname-fast.mount/start failed with result 'dependency'.
Jul 14 14:31:51 username systemd[1]: home.mount: Job home.mount/start failed with result 'dependency'.
Jul 14 14:31:51 username systemd[1]: systemd-fsck@dev-disk-by\x2duuid-6b76ac5b\x2d1174\x2d4998\x2dbd53\x2d2a80432bab61.service: Job systemd-fsck@dev-disk-by\x2duuid-6b76ac5b\x2d1174\x2d4998\x2dbd53\x2d2a80432bab61.service/start failed with result 'dependency'.


Me too, Deepin. Fine after reboot. Thx. :slight_smile:


no problems on either machine, the network manager update flagged a new optional called iwd which can be used in place of wpa_supplicant. However, after reading the arch wiki about this new package I think I'll leave a working notebook setup well alone and ignore it for now.

1 Like

The last update of networkmanager seems to fix the issue with VPN and the networkmanager applet, at least for me.

1 Like

I got the same behaviour. journalctl -b0 -p4 reports:

systemd[1]: Dependency failed for File System Check on /dev/disk/by-uuid/[snip].
systemd[1]: Dependency failed for /hdd.
systemd[1]: Dependency failed for Local File Systems.

System seemed perfectly operational. Rebooted and process was normal although somewhat slower to desktop after login. Now journalctl -b0 -p4 reports:

systemd[1]: systemd-fsck@dev-disk-by\x2duuid-[snip].service: Main process exited, code=killed, status=15/TERM
systemd[1]: systemd-fsck@dev-disk-by\x2duuid-[snip].service: Failed with result 'signal'.

where the snipped strings match. A third reboot brings the same errors in journal (not present before this update) but nothing else new. System seems to function fine on brief usage.


Everything went fine on my KDE Plasma system except that network manager shows the wrong connection speed now (0 Bit/s). I tested connection speed with speedtest and it is slower from this morning (by about 20 Mbit/s slower) but that could simply be due to the time. I'll continue to check.

I too ran into booting issues.
Trying to boot into 4.17, would stop at booting emergency mode. CTRL-D did nothing.
Booted 4.14, would stop at the same thing, rebooted.
Attempted 4.4, same. Shut the computer down and attempted after a bit, 4.17 would not boot,
started 4.14, emergency mode, CTRL-D worked, and now I have a usable desktop/system at the moment.


A little more information. The disk which is failing its system check is a hard disk mounted as secondary (data) storage. It seems notable that it is also a hard disk second drive for @LAZA too - if I read it right. My secondary SDD does not suffer this problem.

I have been returned to the emergency mode on reboot (separately) after the following operations:

  1. Reinstalling sip and python-sip (and after removing again)
  2. Running mkinitcpio -P && update-grub
  3. Removing an address from my /etc/resolv.conf.

(I'm guessing this list might continue to grow, if so I'll try to edit it to reflect.)

In other words these are the things I have bumped into while stumbling around in the dark. :stuck_out_tongue_winking_eye:

1 Like

Forum kindly sponsored by