[Testing Update] 2018-07-27 - Pacman, Adapta-Themes, Deepin, XFCE, Wine, Firmware

Hi community,

Welcome to another testing update. So what do we have with this one?

  • we updated pacman to 5.1.1
  • we fixed issues with our adapta themes, especially with XFCE
  • deepin and xfce-gtk3 got new package updates
  • wine got updated to 3.13
  • pushed out a new linux-firmware to support more AMD-GPUs
  • the usual python/haskell rebuilds/updates

We hope with all these changes Manjaro to be more efficient for you all.

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts:


Our KDE fans may try our beta-build with the latest KDE v5.13 instead.

Latest information about the intel-cpu-bug risk and our efforts can be found here.

Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.116 [EOL]
  • linux41 4.1.52 [EOL]
  • linux44 4.4.144
  • linux49 4.9.114
  • linux414 4.14.58
  • linux415 4.15.18 [EOL]
  • linux416 4.16.18 [EOL]
  • linux417 4.17.10
  • linux418 4.18-rc6
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt9

Package Updates (Fri Jul 27 06:36:24 CEST 2018)

Sync Packages

  • testing multilib x86_64: 1 new and 1 removed package(s)
  • testing extra x86_64: 1 new and 1 removed package(s)
  • testing community x86_64: 57 new and 57 removed package(s)

Overlay Packages

  • testing core x86_64: 3 new and 2 removed package(s)
  • testing extra x86_64: 2 new and 4 removed package(s)
  • testing community x86_64: 4 new and 4 removed package(s)
:: Different overlay package(s) in repository community x86_64

                             PACKAGE           2018-07-26           2018-07-27

:: Different sync package(s) in repository community x86_64

                             PACKAGE           2018-07-26           2018-07-27
                                atom             1.28.0-1             1.28.2-1
                           bettercap                2.6-1                2.7-1
                          cozy-stack           2018M2S6-1           2018M3S2-1
                               darcs            2.14.1-28            2.14.1-29
                         debootstrap            1.0.106-1            1.0.107-1
                     deepin-anything              0.0.2-1              0.0.2-2
                 deepin-file-manager          1:            1:4.6.1-1
                              facter             3.11.2-1             3.11.3-1
                             fractal             3.29.1-1             3.29.4-1
                               gammu             1.39.0-1             1.39.0-2
                           git-annex         6.20180719-1         6.20180719-2
                haskell-authenticate            1.3.4-145            1.3.4-146
                         haskell-aws              0.20-53              0.20-54
                 haskell-hjsonschema             1.9.0-55             1.9.0-56
                        haskell-http         4000.3.12-30         4000.3.12-31
                haskell-http-conduit             2.3.2-19             2.3.2-20
                   haskell-http-date              0.0.7-7              0.0.8-1
                   haskell-js-jquery            3.3.1-100            3.3.1-101
                       haskell-shake            0.16.4-64            0.16.4-65
                        haskell-warp             3.2.23-5             3.2.23-6
                       haskell-yesod             1.6.0-69             1.6.0-70
                  haskell-yesod-auth             1.6.3-66             1.6.3-67
                  haskell-yesod-core              1.6.6-3              1.6.6-4
               haskell-yesod-default            1.2.0-358            1.2.0-359
                  haskell-yesod-form              1.6.2-3              1.6.2-4
            haskell-yesod-persistent             1.6.0-62             1.6.0-63
                haskell-yesod-static             1.6.0-57             1.6.0-58
                  haskell-yesod-test              1.6.5-1              1.6.5-2
                         hledger-api              1.10-15              1.10-16
                         hledger-web              1.10-19              1.10-20
                                 iwd                0.3-1                0.4-1
                              kstars            1:2.9.6-1            1:2.9.7-1
                           playerctl              0.6.0-1              0.6.1-1
           pycharm-community-edition           2018.1.4-1             2018.2-1
                           python-fs             2.0.25-1             2.0.26-1
                   python-pynormaliz               1.17-1               1.19-1
                        python2-caja             1.20.0-1             1.20.1-1
                          python2-fs             2.0.25-1             2.0.26-1
                  python2-pynormaliz               1.17-1               1.19-1
                          shellcheck             0.5.0-59             0.5.0-60
                               stack             1.7.1-85             1.7.1-86
                      tamarin-prover             1.4.0-67             1.4.0-68
                               vault             0.10.2-1             0.10.3-1
                              xmobar              0.26-62              0.26-63

:: Different overlay package(s) in repository core x86_64

                             PACKAGE           2018-07-26           2018-07-27
                              pacman              5.1.0-2              5.1.1-1
                      pacman-mirrors             4.11.5-1             4.11.5-2
                      linux-firmware                    -   20180717.8d69bab-0

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE           2018-07-26           2018-07-27
                            chromium       68.0.3440.75-0                    -
        libnautilus-extension-legacy                     -
                         thunar-gtk3              1.8.1-5              1.8.1-6
                          xfwm4-gtk3            4.13.0-12            4.13.0-13

:: Different sync package(s) in repository extra x86_64

                             PACKAGE           2018-07-26           2018-07-27
                           libdazzle             3.28.2-1             3.28.4-1

:: Different sync package(s) in repository multilib x86_64

                             PACKAGE           2018-07-26           2018-07-27
                                wine               3.12-1               3.13-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Ready for Stable ?!?

  • We are ready to move this to our stable branch
  • I still see some issues (post about them)

0 voters


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Items from previous update sets

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

I noticed yesterday that gnome system monitor, audacious and boinc manager all have memory leaks.
Don't know after which update, but just to know.

No issues here on my system (hybrid laptop intel-nvidia, xfce-gtk3 session).

Cosmetic effect in Deepin (only?)



About the

Theme parsing error: gtk.css:3601:22: 'none' is not a valid color name

Here, at the update of the pacman-mirrors.
A small script to fix . Solution found on

https://bugs.archlinux.org/task/57058 [Reason for closing: Not a bug]

# - 18.06.2018 -

  echo "${0##*/} Fixed (gnome-clocks:22881): Gtk-WARNING **: timestamp : Theme parsing error: gtk.css:3601:22: 'none' is not a valid color name.
  From https://bugs.archlinux.org/task/57058"
  echo "No Syntax for ${0##*/}"

test "${1}" = "-h" -o "${1}" = "-help" -o "${1}" = "--help" && Hilfe

# Check if the current user is "root" otherwise restart the script with "sudo"...
[ "$(whoami)" != "root" ] && exec sudo -- "$0" "$@"

# Instruct the Script to Abort for any command error...
set -e

sed -i 's/border-color: none/border-color: transparent/g' "/usr/share/themes/deepin-dark/gtk-3.0/gtk.css"

echo "Done."

exit 0

Please post your issue and solution, so we may fix it in one of our next releases of pacman-mirrors. @linux-aarhus: fyi

Did you run pacman-mirrors with the --interactive argument?


sudo pacman-mirrors -ic Germany
sudo pacman-mirrors -f 2
sudo pacman -Syyu

It is a bug in the css used.

The css syntax for border-color property is

border-color: color|transparent|initial|inherit;

The used css property none is invalid in the context.

I cannot code anything to get by that warning message.

1 Like

You know better than I do. Issue #141 closed.
Gtk "Warning" but "Theme parsing error".

Same with gnome-clocks, probably all gnome apps you start from the terminal (in Deepin)?
I haven't tried that yet (I'd have to restore it to its original state first).

I'll just keep changing the one line and have no more visual (Warning) problems. :slight_smile:

If the gtk3.CSS is from Deepin, nobody does anything :wink:

1 Like

After the update to Catfish (1.4.6-1) using the right-click context menu to 'open folder' from Firefox downloads menu (61.0.1-1) and from Transmission-gtk (2.94-1) instead triggers a Catfish search window to open for the respective location.

Downgrading to Catfish 1.4.5-1 gets the 'open folder' right click action to correctly open the locations again.

I had the same problem. The following command sets the default application back to Thunar:

xdg-mime default Thunar-folder-handler.desktop inode/directory

Thanks. I suspected something to do with mimetypes but I did not know where to look. :blush:

After searching a little more it seems

xdg-mime default exo-file-manager.desktop inode/directory

is the more general fix. (Both worked for me.)
See: https://forum.xfce.org/viewtopic.php?id=12340 for above.

[Btw the actual commit causing this change is https://git.xfce.org/apps/catfish/commit?id=b6a30dd88dbf6c97774330327d9ab186b8a7e6cb if someone who knows more thinks it is problematic behaviour.]


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by