[Testing Update] 2018-08-09 - Kernels, Python 3.7, Perl 5.28, LibreOffice, Nvidia, Xorg-Server, Deepin

Hi community,

Welcome to another testing update. So what do we have with this one?

  • we updated our Xorg-Server to 1.20.1
  • Nvidia 304xx driver is dropped now.
  • we pushed our rebuilds for python 3.7 and perl 5.28. There might be still packages needed to be rebuilt. Please report any issues with this.
  • LibreOffice got updated to 6.0.6
  • added some new Deepin packages
  • Stefano updated our Adapta Themes
  • the usual haskell rebuilds/updates

We hope with all these changes Manjaro to be more efficient for you all.


Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis either silver or gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.

Latest information about the intel-cpu-bug risk and our efforts can be found here.

Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.117 [EOL]
  • linux41 4.1.52 [EOL]
  • linux44 4.4.146
  • linux49 4.9.118
  • linux414 4.14.61
  • linux415 4.15.18 [EOL]
  • linux416 4.16.18 [EOL]
  • linux417 4.17.13
  • linux418 4.18-rc7
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt11

Package Updates (Wed Aug 8 17:28:05 CEST 2018)

  • testing community x86_64: 2412 new and 2400 removed package(s)
  • testing core x86_64: 39 new and 40 removed package(s)
  • testing extra x86_64: 648 new and 655 removed package(s)
  • testing multilib x86_64: 6 new and 8 removed package(s)

A detailed list of all changes may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Ready for Stable ?!?

  • We are ready to move this to our stable branch
  • I still see some issues (post about them)

0 voters


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Something using Perl/Python/glibc broke

Rebuilds needed! If it's an AUR package, rebuild it. If it's a repo package, please report and check back regularly for rebuilds.

Items from previous update sets

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

Lists of Python packages

Python packages in Community

phil@development ~/dev/git/manjaro/repositories/stable-repos/community $ grep python */PKGBUILD | grep -v python2 | cut -d/ -f1 | uniq
compiz-manjaro - done
gimp-devel - not in repos
gimp-gtk3 - works
jade-dashboard-git - done
lightdm-settings - works
menulibre - done
ms-office-online - done
mugshot - done
pkgbrowser - done
pulseaudio-equalizer-ladspa - works
python-jade-application-kit - done
snapd-git - done
snapd - done
phil@development ~/dev/git/manjaro/repositories/stable-repos/community $ grep python */*/PKGBUILD | grep -v python2 | cut -d/ -f2 | uniq

Python packages Extra

phil@development ~/dev/git/manjaro/repositories/stable-repos/extra $ grep python */*/PKGBUILD | grep -v python2 | cut -d/ -f2 | uniq
phil@development ~/dev/git/manjaro/repositories/stable-repos/extra $ grep python */PKGBUILD | grep -v python2 | cut -d/ -f1 | uniq
calamares-git - done
calamares - done
gst-plugins-good - using upstream
kpmcore-dev - not in repo
kpmcore - using upstream
libglvnd - using upstream
libinput-git - not in repos
manjaro-features-dev - not in repos
manjaro-features-pre - not in repos
manjaro-hello - works also without rebuild
partitionmanager-dev - not in repos
python-pykwalify - dropped
python-pyparted - dropped
pythonqt - done
samba - using upstream
thus-dev - not in repos
thus - not in repos

Menulibre doesn't launch after the update.
@oberon Could you rebuilt it?

─ menulibre
Traceback (most recent call last):
  File "/usr/bin/menulibre", line 44, in <module>
    import menulibre
ModuleNotFoundError: No module named 'menulibre'

Woaw!! Big one. Just need to restart NetworkManager, but it seems everythings is Ok

Edit: I confirme the same error with menulibre

Do the kernels feature a fix for the below mentioned CVE? I didn’t see you make note of it, but I may well be blind...:grin:


400 Mb of updates here. It restarted well. I will have to test python based software but so far so good :slight_smile:

Testing update Deepin

Gesamtgröße des Downloads:            854,75 MiB
Gesamtgröße der installierten Pakete:  3062,83 MiB
Größendifferenz der Aktualisierung:    18,01 MiB

Smooth, thanks :slight_smile:

1,400 Mb of updates here.
So far so good ![:slight_smile:](https://archived.forum.manjaro.org/images/emoji/emoji_one/slight_smile.png?v=5)

Paket (1)            Alte Version  Neue Version  Netto-Veränderung

community/menulibre  2.2.0-1       2.2.0-2                0,00 MiB

Gesamtgröße der installierten Pakete:  1,98 MiB
Größendifferenz der Aktualisierung:  0,00 MiB

You may check these lists to find potential issues.

1 Like

I "only" had about 300 mb here, on KDE edition :innocent:
All seems OK apart the below message I had during the update :

(256/269) upgrading recoll 
error: command failed to execute correctly

EDIT: Recoll works after reboot, and it appears to be the last version, so.....

(1/2) Warn about old perl modules
WARNING: '/usr/lib/perl5/5.26' contains data from at least 1 packages which will NOT be used by the installed perl interpreter.
 -> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/5.26'
(2/2) Arming ConditionNeedsUpdate...
~ >>> sudo pacman -Qqo '/usr/lib/perl5/5.26'                                                                        

I received this message during install so I ran again. I reinstalled perl and xfconf-gtk3, same conflicting message.

~ >>> sudo pacman -S xfconf-gtk3                                                                                    
warning: xfconf-gtk3-4.13.5-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

600+ MB this time for me - so will take some time to see everything is running =D
Wayland and gnome-shell play nicely from the beginning though <3

Menulibre does work - it ran befor and after the update fine no errors for me on this one

German language pack missing,

Works with Thunderbird 52.0 - 52.*
Na toll :wink: :slight_smile:

Ich kann mich mit dem Datumsformat nicht anfreunden :slight_smile:

Thanks. Rebuilding.

1 Like

Already did.


A bit of erratic behavior with NetworkManager and USB device notifications on 4.14 and 4.17 kernel. For instance there is no notification if i connect my tablet, and sometimes the Tablet Mapping is off with an internal error. Works after powering off and on the tablet. USB stick sometimes is shown to mount, sometimes there is no option.
On 4.18 kernel just the NetworkManager has a delay to connect. In fact is reported connected but browsers and weather widget have no internet connection till after 30 seconds or more. I'll investigate more.

We only updated Thunderbird to v60 in our unstable branch so far. And yes, the language packages are not updated yet.


Should not be accused, went towards to Mozilla, that this is missing.

August 9, 2018 8:11 AM
OMG, wrong thread. Testing, I am so sorry :slight_smile:

Well, the package thunderbird-i18n has no maintainer. Might take a while or they will be dropped at some point. Also Mozilla had not yet updated the languages at all. We might therefore hold back that series on our end.

( 5/19) Warn about old perl modules
WARNING: '/usr/lib/perl5/5.26' contains data from at least 1 packages which will NOT be used by the installed perl interpreter.
 -> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/5.26'
[fh@abook ~]$ pacman -Qqo '/usr/lib/perl5/5.26'

Forum kindly sponsored by