[Testing Update] 2018-08-13 - Kernel 4.18, Grub-Themes, Deepin, Kscreenlocker, Systemd

Hi community,

Welcome to another testing update. So what do we have with this one?

  • we updated some of our Grub themes
  • Kernel v4.18 got released
  • some more Deepin packages got updated
  • we backported a fix for kscreenlocker reducing the 100% CPU usage
  • we reverted commit 6f130e8 in systemd, which improves network speed

We hope with all these changes Manjaro to be more efficient for you all.


Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis either silver or gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.

Latest information about the intel-cpu-bug risk and our efforts can be found here.

Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.118 [EOL]
  • linux41 4.1.52 [EOL]
  • linux44 4.4.147
  • linux49 4.9.119
  • linux414 4.14.62
  • linux415 4.15.18 [EOL]
  • linux416 4.16.18 [EOL]
  • linux417 4.17.14
  • linux418 4.18.0
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt11

Package Updates (Mon Aug 13 06:10:48 CEST 2018)

  • testing community x86_64: 24 new and 24 removed package(s)
  • testing core x86_64: 10 new and 10 removed package(s)
  • testing extra x86_64: 16 new and 13 removed package(s)
:: Different overlay package(s) in repository community x86_64

                             PACKAGE           2018-08-12           2018-08-13
                   grub-theme-adapta                1.3-2                1.4-1
                     grub-theme-blue                1.0-2                1.4-1
               grub-theme-glassfield                1.0-3                1.4-1
              grub-theme-manjaro-dog                1.0-7                1.4-1
                           mintstick       r181.cba7e9c-1              1.3.8-1

:: Different sync package(s) in repository community x86_64

                             PACKAGE           2018-08-12           2018-08-13
                   deepin-calculator              1.0.5-1              1.0.6-1
               deepin-control-center              4.6.3-1              4.6.4-1
                         deepin-dock                4.7.2-1
                     deepin-launcher              4.4.4-1              4.4.5-1
                   deepin-session-ui                4.5.0-1
               deepin-system-monitor              1.4.5-1              1.4.6-1
                              hgview             1.10.2-1             1.10.2-2
                                 m2r             0.1.15-2              0.2.0-1
                           python-fs             2.0.27-1              2.1.0-1
                 python-pycryptodome              3.6.4-2              3.6.5-1
                  python-ruamel-yaml            0.15.52-1            0.15.53-1
                     python-selenium             3.13.0-2             3.14.0-1
                         python-yara              3.7.0-2              3.8.0-1
                          python2-fs             2.0.27-1              2.1.0-1
                         python2-m2r             0.1.15-2              0.2.0-1
                python2-pycryptodome              3.6.4-2              3.6.5-1
                    python2-selenium             3.13.0-2             3.14.0-1
                        python2-yara              3.7.0-2              3.8.0-1
                           sniffglue              0.7.0-1              0.8.0-1

:: Different overlay package(s) in repository core x86_64

                             PACKAGE           2018-08-12           2018-08-13
                          libsystemd              239.0-1              239.0-3
                            linux418 4.18rc8.0811.gec0c967-1          4.18.0-1
                    linux418-headers 4.18rc8.0811.gec0c967-1          4.18.0-1
                             systemd              239.0-1              239.0-3
                  systemd-resolvconf              239.0-2              239.0-3
                  systemd-sysvcompat              239.0-1              239.0-3

:: Different sync package(s) in repository core x86_64

                             PACKAGE           2018-08-12           2018-08-13
                            binutils             2.31.1-1             2.31.1-3
                                gdbm               1.16-1               1.17-1
                             libpcap              1.8.1-2              1.9.0-1
                  mkinitcpio-busybox             1.28.4-1             1.29.2-1

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE           2018-08-12           2018-08-13
                       kscreenlocker                    -           5.13.4-1.1

:: Different sync package(s) in repository extra x86_64

                             PACKAGE           2018-08-12           2018-08-13
                             libmbim             1.16.0-1             1.16.2-1
                          libmm-glib              1.8.0-1              1.8.0-2
                              libqmi             1.20.0-1             1.20.2-1
                          libxnvctrl             396.45-1             396.51-1
                                llvm              6.0.1-2              6.0.1-3
                           llvm-libs              6.0.1-2              6.0.1-3
                          llvm-ocaml              6.0.1-2              6.0.1-3
                        modemmanager              1.8.0-1              1.8.0-2
                          postgresql               10.4-6               10.5-1
                     postgresql-docs               10.4-6               10.5-1
                     postgresql-libs               10.4-6               10.5-1
              postgresql-old-upgrade              9.6.9-2             9.6.10-1
                          webkit2gtk             2.20.3-2             2.20.4-1
                                  gn                    -    0.1458.f9dbfd12-1
                       libnumbertext                    -                1.0-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Ready for Stable ?!?

  • We are ready to move this to our stable branch
  • I still see some issues (post about them)

0 voters


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Something using Perl/Python/glibc broke

Rebuilds needed! If it's an AUR package, rebuild it. If it's a repo package, please report and check back regularly for rebuilds.

Items from previous update sets

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

When I rebooted immediately after the update, I got a message that a Stop job was waiting for my swap to unmount with no time limit. After waiting 7 minutes for it, I hard rebooted. After logging in, I issued the systemctl reboot command again, and the system didn't hang this time.

So far so good. XFCE kernel 4.14.x :grin:

All good for me. Switched to linux418:


1 Like

No problems so far on my linux418+kde manjaro on Ryzen 5 2400G system. (well boot problems and sometimes hang on shutdown is still there but less frequent but thats not a Manjaro problem IMHO. At least it is now stable once i got the system booting into KDE).

Deepin , Kernel 4.18, perfect. :slight_smile:

KDE, Kernel 4.18 - all good - no problem what so ever

just for info hplip plugin from AUR is broken.

Report it to the AUR package maintainer. Reporting here won’t get it fixed unfortunately.

1 Like

All good for me, switched to linux418. Everything is fine. Thank you team.

It seems that even the maintainer is having problems wit the hplip plugin https://bugs.archlinux.org/task/59548?string=hplip&project=1&type[0]=&sev[0]=&pri[0]=&due[0]=&reported[0]=&cat[0]=&status[0]=open&percent[0]=&opened=&dev=&closed=&duedatefrom=&duedateto=&changedfrom=&changedto=&openedfrom=&openedto=&closedfrom=&closedto=

Why are kernel 3.18, 4.1 and 4.15 still offered as options in Manjaro Settings Manager? They are all EOL. Can they not be tagged in MSM as EOL like they are in the announcement threads?

LTS kernels supported upstream as of 2018-08-13:

Version Maintainer Released Projected EOL
4.14 Greg Kroah-Hartman 2017-11-12 Jan, 2020
4.9 Greg Kroah-Hartman 2016-12-11 Jan, 2019
4.4 Greg Kroah-Hartman 2016-01-10 Feb, 2022
3.16 Ben Hutchings 2014-08-03 Apr, 2020

To install the plugin and make my scanner work (MFD printer), I usually run


During the installation I can download and install the plugin. Once done, I cancel the set-up as my printer is already installed and working.

The thing is that printing a test page works fine, but trying to print e.g. a libreoffice document returns a filter failed error.

Smooth update to Linux 4.18 with XFCE.

I haven't update my Manjaro machine for a while but now I have major issue with the radeon graphics driver. The problem can be seen during the transition from SDDM to KDE where intermittent graphical glitches and horrible slowdowns and sometimes loss of display.
When I can get into the desktop I must suspend composition immediately in order to stop the glitch and slow down from locking up the system and losing the display. Resuming composition fixes the problem temporarily but slow downs and smaller scale corruption are still likely to happen.

This is the important part that are taken from kernel logs during the glitch.

[   52.068459] radeon 0000:00:01.0: evergreen_cs_track_validate_texture:855 texture bo too small (layer size 4325376, offset 0, max layer 1, depth 1, bo size 4096) (1408 768)
[   52.068528] [drm:radeon_cs_ioctl [radeon]] *ERROR* Invalid command stream !
[   72.733848] [drm:radeon_cs_parser_relocs [radeon]] *ERROR* gem object lookup failed 0xf
[   72.733912] [drm:radeon_cs_ioctl [radeon]] *ERROR* Failed to parse relocation -2!
[   95.789529] radeon 0000:00:01.0: evergreen_cs_track_validate_texture:855 texture bo too small (layer size 4325376, offset 0, max layer 1, depth 1, bo size 4096) (1408 768)
[   95.789578] [drm:radeon_cs_ioctl [radeon]] *ERROR* Invalid command stream !
[   97.758782] [drm:radeon_cs_parser_relocs [radeon]] *ERROR* gem object lookup failed 0xf
[   97.758844] [drm:radeon_cs_ioctl [radeon]] *ERROR* Failed to parse relocation -2!

Looks like I have to downgrade everything and back to stable branch for now. I can't deal with this kind of problem now.

No problem, KDE edition and kernel 4.18

Yeah, that seems like a known problem with xorg 1.20 and radeon. Use that pkgbuild I linked in this post to compile an updated xf86-video-ati-git and problem solved untill upstream catches away.

1 Like

GNOME, Kernel 4.18 - all good - no problems. Thanks a lot.

Forum kindly sponsored by