[Testing Update] 2018-08-21 - Linux419, Flatpak 1.0, Adapta, LibreOffice

Hi community,

Welcome to another testing update. So what do we have with this one?

  • we updated our Adapta-Themes
  • flatpak is now at 1.0
  • some rebuilds of LibreOffice
  • latest snapshot of linux419
  • the usual python rebuilds/updates

We hope with all these changes Manjaro to be more efficient for you all.

For more info about L1TF please watch this video:


Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis either silver or gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.


If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.

Latest information about the intel-cpu-bug risk and our efforts can be found here.

Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.119 [EOL]
  • linux41 4.1.52 [EOL]
  • linux44 4.4.150
  • linux49 4.9.122
  • linux414 4.14.65
  • linux415 4.15.18 [EOL]
  • linux416 4.16.18 [EOL]
  • linux417 4.17.17
  • linux418 4.18.3
  • linux419 4.19-rc0
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt11

Package Updates (Tue Aug 21 08:26:12 CEST 2018)

  • testing community x86_64: 88 new and 69 removed package(s)
  • testing core x86_64: 5 new and 5 removed package(s)
  • testing extra x86_64: 37 new and 36 removed package(s)
  • testing multilib x86_64: 2 new and 2 removed package(s)
:: Different overlay package(s) in repository community x86_64

                             PACKAGE           2018-08-19           2018-08-21
            manjaro-awesome-settings           20180602-1           20180820-1
                manjaro-gdm-branding           20180625-1           20180820-1
            manjaro-gnome-assets-dev           20180621-1           20180820-1
manjaro-gnome-extension-settings-17.0          20180425-2           20180820-1
manjaro-gnome-extension-settings-18.0          20180625-1           20180820-1
         manjaro-gnome-settings-17.0           20180425-2           20180820-1
         manjaro-gnome-settings-18.0           20180625-1           20180820-1
                               tlpui        r88.ab1183a-1        r89.d6363f0-1
                                 yay              8.922-1              8.998-2

:: Different sync package(s) in repository community x86_64

                             PACKAGE           2018-08-19           2018-08-21
                      acpi_call-dkms            1.1.0-153            1.1.0-155
                                 bat              0.4.1-2              0.5.0-1
                             esptool              2.4.1-1              2.5.0-1
                                  fd              7.0.0-1              7.1.0-1
                             grafana              5.1.3-1              5.2.2-1
                           grunt-cli              1.3.1-1              1.3.1-2
                                gtkd              3.8.3-2              3.8.3-3
                              hackrf          2017.02.1-1          2018.01.1-1
                   haskell-cmark-gfm              0.1.3-6              0.1.4-2
               haskell-microlens-ghc              0.4.9-4  
          haskell-microlens-platform            0.3.10-13            0.3.10-14
                            hasktags             0.70.1-8             0.70.1-9
                         hledger-api              1.10-28              1.10-29
                          hledger-ui              1.10-22              1.10-23
                               iperf             2.0.11-1             2.0.12-1
                               jack2             1.9.12-2             1.9.12-5
                          jack2-dbus             1.9.12-2             1.9.12-5
                               julia            2:0.6.4-1            2:1.0.0-1
                          julia-docs            2:0.6.4-1            2:1.0.0-1
                              jxrlib              0.2.1-1              0.2.1-3
                          keepalived              2.0.2-1              2.0.6-1
                                 ldc           1:1.10.0-2           1:1.11.0-1
                          liblphobos           1:1.10.0-2           1:1.11.0-1
                              lsscsi               0.29-1               0.30-1
                      pidgin-kwallet              1.1.0-4              1.1.0-5
                     python-cherrypy             17.0.0-2             17.3.0-1
                  python-entrypoints              0.2.3-2              0.2.3-3
                   python-hypothesis             3.68.2-1             3.69.0-1
                      python-keyring             13.2.1-2             13.2.1-3
                 python-keyrings-alt              1:3.1-2              1:3.1-3
               python-more-itertools              4.2.0-2              4.3.0-1
                  python-ruamel-yaml            0.15.59-1            0.15.60-1
                python-secretstorage              3.0.1-2              3.0.1-4
                         python-tqdm             4.24.0-1             4.25.0-1
             python-websocket-client             0.50.0-1             0.51.0-1
                    python2-cherrypy             17.0.0-2             17.3.0-1
                  python2-hypothesis             3.68.2-1             3.69.0-1
              python2-more-itertools              4.2.0-2              4.3.0-1
                        python2-tqdm             4.24.0-1             4.25.0-1
            python2-websocket-client             0.50.0-1             0.51.0-1
                          qtkeychain              0.9.0-1              0.9.1-1
                        ruby-bundler             1.16.3-1             1.16.4-1
                          ruby-cairo            1.15.13-1            1.15.14-1
                     ruby-mime-types                3.1-3              3.2.2-1
                       ruby-net-ping              2.0.4-1              2.0.5-1
                          shellcheck             0.5.0-73             0.5.0-74
                              sysdig             0.23.0-1             0.23.1-1
                               tilix              1.8.1-3              1.8.3-1
                        tt-rss 1:17.4.r484.g6e6c3a87-1 1:17.4.r518.g02bb26a9-1
                           wordpress              4.9.7-1              4.9.8-1
                            xcircuit             3.9.72-1             3.9.73-1
                               zcash              1.1.2-1              2.0.0-1
                            argtable                    -               2.13-3
                                japa                    -              0.8.4-3
                              kresus                    -             0.13.2-1
                             lv2file                    -               0.84-2
                       python-datrie                    -              0.7.1-2
                  python-zc.lockfile                    -              1.3.0-1
                 python-zope.testing                    -              4.6.2-1
                      python2-datrie                    -              0.7.1-2
                 python2-entrypoints                    -              0.2.3-3
                     python2-keyring                    -             13.2.1-3
                python2-keyrings-alt                    -              1:3.1-3
                      python2-meliae                    -              0.4.0-1
               python2-secretstorage                    -              3.0.1-4
                 python2-zc.lockfile                    -              1.3.0-1
                python2-zope.testing                    -              4.6.2-1
                 realtime-privileges                    -                  2-1
                            setbfree                    -              0.8.8-1
                             tribler                    -         7.1.0_beta-1
                     weboob-headless                    -                1.3-1

:: Different overlay package(s) in repository core x86_64

                             PACKAGE           2018-08-19           2018-08-21
                      linux419 4.19rc0.0819.g08b5fa8-1 4.19rc0.0821.g778a339-1
              linux419-headers 4.19rc0.0819.g08b5fa8-1 4.19rc0.0821.g778a339-1

:: Different sync package(s) in repository core x86_64

                             PACKAGE           2018-08-19           2018-08-21
                             openssl            1.1.0.h-1            1.1.0.i-1
                              shadow                4.5-4                4.6-1
                      wpa_supplicant             1:2.6-11             1:2.6-12

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE           2018-08-19           2018-08-21
                 calamares-git 3.2.2.r4882.271a1ffa8-1 3.2.2.r4890.46e53997a-1
                  linux419-acpi_call            1.1.0-0.4            1.1.0-0.6
                   linux419-bbswitch              0.8-0.4              0.8-0.6
                   linux419-catalyst    1:15.201.1151-0.4    1:15.201.1151-0.6
                linux419-ndiswrapper             1.61-0.4             1.61-0.6
                     linux419-nvidia         1:396.51-0.4         1:396.51-0.6
               linux419-nvidia-340xx          340.107-0.4          340.107-0.6
               linux419-nvidia-390xx           390.77-0.4           390.77-0.6
                   linux419-nvidiabl             0.88-0.4             0.88-0.6
                      linux419-r8168         8.045.08-0.4         8.045.08-0.6
                        linux419-spl            0.7.9-0.4            0.7.9-0.6
                   linux419-tp_smapi             0.41-0.4             0.41-0.6
                linux419-vhba-module         20161009-0.4         20161009-0.6
   linux419-virtualbox-guest-modules           5.2.18-0.4           5.2.18-0.6
    linux419-virtualbox-host-modules           5.2.18-0.4           5.2.18-0.6
                        linux419-zfs            0.7.9-0.4            0.7.9-0.6
       manjaro-software-install-tool                0.2-2                    -
                         thunar-gtk3             1.8.1-10             1.8.1-11
                                 gdm                    -3.29.91+2+g21867afd-2
                              libgdm                    -3.29.91+2+g21867afd-2

:: Different sync package(s) in repository extra x86_64

                             PACKAGE           2018-08-19           2018-08-21
                              cantor            18.08.0-2            18.08.0-5
                             flatpak             0.99.3-1              1.0.0-1
                     flatpak-builder             0.99.3-1              1.0.0-1
                       gnome-builder           3.28.4-1 3.28.4+24+gb86f10bfc-1
                            kdevelop              5.2.3-1              5.2.4-1
                        kdevelop-php              5.2.3-1              5.2.4-1
                     kdevelop-python              5.2.3-2              5.2.4-1
                   libreoffice-fresh              6.1.0-1              6.1.0-2
               libreoffice-fresh-sdk              6.1.0-1              6.1.0-2
                   libreoffice-still              6.0.6-2              6.0.6-3
               libreoffice-still-sdk              6.0.6-2              6.0.6-3
                              ostree             2018.6-1             2018.7-1
                               pango             1.42.3-1             1.42.4-1
                         thunderbird               60.0-3               60.0-4
                                vala             0.40.8-1             0.40.9-1
                  xdg-desktop-portal               0.99-2                1.0-1
              xdg-desktop-portal-gtk               0.99-1                1.0-1

:: Different sync package(s) in repository multilib x86_64

                             PACKAGE           2018-08-19           2018-08-21
                         lib32-jack2             1.9.12-1             1.9.12-2
                         lib32-pango             1.42.3-1             1.42.4-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Ready for Stable ?!?

  • We are ready to move this to our stable branch
  • I still see some issues (post about them)

0 voters


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.

Something using Perl/Python/glibc broke

Rebuilds needed! If it's an AUR package, rebuild it. If it's a repo package, please report and check back regularly for rebuilds.

Items from previous update sets

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

I got to bring this back again since I've found the fix.
Downgrading networkmanagerto the last stable version 1.12.2-1 from 1.12.3dev+1+g0a3755c17-1 fixes the Wi-Fi connectivity problem after going back from suspend or sometimes the lock screen.
No more No agents were availiable for the request warnings from NetworkManager and it will connect to my network automatically like it used to be.

I got

error: failed to commit transaction (conflicting files)
cmark-gfm: /usr/include/cmark.h exists in filesystem (owned by cmark)
cmark-gfm: /usr/include/cmark_export.h exists in filesystem (owned by cmark)
cmark-gfm: /usr/include/cmark_version.h exists in filesystem (owned by cmark)
Errors occurred, no packages were upgraded.
  Updates from system repositories have failed probably because of file conflicts. 

Just did plain

sudo pacman -Syu haskell-cmark-gfm --overwrite=/usr/include/*

And I am fine.

yes is a old archlinux bug

1 Like

On KDE, libreoffice applications have lost their window decorations (hence shadows, etc.)

check your GTK Application Style settings then LibreOffice looks fine on my system.

kernel 4.19 is working again properly now on both my systems

1 Like

I think I saw that in unstable KDE this morning (though it might have been a couple of weeks between updates on that laptop). For me, I deleted my old entry, and created a new one, and it seemed to connect quickly after a re-boot (and I re-booted again, just to make sure: Again, a quick connection).

Deleting and recreating the connection profile is not necessary since it's still be able to connect to saved network automatically after reboot like it should. But it will stop connecting to any saved network right after waking up from sleep and NetworkManager will emit the "No agents were availiable for the request" warning to system log every time it tries to connect to any saved network.
It seems like it is related to race condition issue between NetworkManager and KWallet.

You mean the GTK settings in the KCM? They haven't changed, which explained why no other GTK app has lost its decoration, only Libreoffice ones.

After latest update running Hakoila 17.1.12 (Originally xfce-18-Beta-5) I get two rather odd notices after booting up:
Screenshot_2018-08-21_13-52-26 Screenshot_2018-08-21_13-55-52

Remove Blueman from your autostart or add a polkit rule.


@philm Could you give the user some kind of script solving the blueman and polkit issue? I'm thinking especially of those on stable.

I use Blueman for my bluetooth hearing aids Phonac ComPiilot II so I tried your fix and it seems to work, thanks. Added rule to 50-default.rules

The problem is not on stable yet, I am using testing too.

Yes, I wanted to pitch him in time so that we have a solution when it's going to stable.

1 Like

can you post screenshots to show what is missing? I have two installs of Manjaro KDE testing and neither have broken libreoffice appearance that I am aware of. Which KDE Theme are you using? I use Breeze.


EDIT - this may need splitting to a separate topic to be resolved properly rather than cluttering up this thread so consider starting one please @nortexoid

Will be fixed via a polkit rule in manjaro-hotfixes package with todays update.

1 Like

My update went fine for...

$ uname -a
Linux Manjaro_KDE_VM 4.17.17-1-MANJARO #1 SMP PREEMPT Sat Aug 18 14:38:10 UTC 2018 x86_64 GNU/Linux

...& for bonus-points i was happy to discover that this subtle LO update created a pacnew file, whose new line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh, fixes a moderately longterm grumble i've had for LO in Plasma since coming to Manjaro last year from openSUSE Tumbleweed [which already had fixed the problem].

Now at last, with this new option present & enabled, once more i have ALL of: scrollbars, scrollbar arrows, ongoing Toolbars, ongoing Menu. The LO Devs' earlier attempt was flawed [export SAL_USE_VCLPLUGIN=kde4], coz though enabling it did give me my scrollbar arrows, the price paid was too high... it destroyed the Menu Bar. Now though: cake & eat it. :hugs:


It looks like this

EDIT: Perhaps it's relevant: I'm running a wayland session.

Forum kindly sponsored by