[Testing Update] 2018-08-23 - Kernels, Nvidia, LibSSH

Hi community,

Welcome to another testing update. So what do we have with this one?

  • we updated most of our Kernels
  • Ńvidia drivers got fixed in regard of an issue with libglvnd
  • latest version of libssh
  • the usual upstream rebuilds/updates

We hope with all these changes Manjaro to be more efficient for you all.

For more info about L1TF please watch this video:


Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis either silver or gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.


If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.

Latest information about the intel-cpu-bug risk and our efforts can be found here.

Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.119 [EOL]
  • linux44 4.4.151
  • linux49 4.9.123
  • linux414 4.14.66
  • linux417 4.17.18
  • linux418 4.18.4
  • linux419 4.19-rc0
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt11

Package Updates (Thu Aug 23 09:30:12 CEST 2018)

  • testing community x86_64: 45 new and 43 removed package(s)
  • testing core x86_64: 14 new and 14 removed package(s)
  • testing extra x86_64: 96 new and 95 removed package(s)
  • testing multilib x86_64: 4 new and 4 removed package(s)
:: Different overlay package(s) in repository community x86_64

                             PACKAGE           2018-08-22           2018-08-23
                                inxi             3.0.20-1             3.0.21-1
                           pacui-git       r911.111c87f-1       r915.27627f7-1

:: Different sync package(s) in repository community x86_64

                             PACKAGE           2018-08-22           2018-08-23
                               aliki              0.3.0-1              0.3.0-2
                                anki           2.1.0rc1-1              2.1.2-1
                             ansible              2.6.2-2              2.6.3-1
                      aspnet-runtime          2.1.2+302-1          2.1.3+401-1
                             cm256cc              1.0.0-2              1.0.0-3
                         dotnet-host          2.1.2+302-1          2.1.3+401-1
                      dotnet-runtime          2.1.2+302-1          2.1.3+401-1
                          dotnet-sdk          2.1.2+302-1          2.1.3+401-1
                             freeciv              2.6.0-1              2.6.0-2
                              gitlab             11.1.4-2             11.2.0-1
                       gitlab-runner             11.1.0-2             11.2.0-1
                    gitlab-workhorse              5.2.0-1              6.0.0-1
     intellij-idea-community-edition         2:2018.2.1-1         2:2018.2.2-1
                    jupyter-notebook              5.3.0-4              5.5.0-1
          jupyter-widgetsnbextension            1:3.2.1-2            1:3.4.0-1
                           mosquitto                1.5-1              1.5.1-1
                             mysql++              3.2.3-1              3.2.4-1
                     mysql-workbench             8.0.12-3             8.0.12-4
                         paulstretch              2.2.2-1              2.2.2-2
                         pidgin-sipe             1.23.2-1             1.23.3-1
                          python-irc               16.1-2               16.4-1
               python-jupyter_client              5.2.2-2              5.2.3-1
                    python-reportlab              3.5.1-2              3.5.6-1
                python-secretstorage              3.0.1-4              3.0.1-6
                         python2-irc               16.1-2               16.4-1
              python2-jupyter_client              5.2.2-2              5.2.3-1
                   python2-reportlab              3.5.1-2              3.5.6-1
               python2-secretstorage              3.0.1-4            1:2.3.1-1
                               qt5ct               0.35-2               0.36-1
                              ranger              1.9.1-2              1.9.1-3
                             remmina         1:         1:
                        riot-desktop             0.16.0-1             0.16.1-1
                            riot-web             0.16.0-1             0.16.1-1
                            sdrangel              4.0.5-2              4.0.5-3
                                yass              0.0.2-2              0.0.2-3
                       zita-ajbridge              0.7.0-4              0.7.0-5
                            zita-at1              0.6.0-6              0.6.0-7
                           zita-dpl1              0.1.0-5              0.1.0-6
                            zita-mu1              0.2.2-5              0.2.2-6
                           zita-rev1              0.2.1-4              0.2.1-5
                               clazy                    -                1.3-2
                            soapyuhd                    -              0.3.4-2

:: Different overlay package(s) in repository core x86_64

                             PACKAGE           2018-08-22           2018-08-23
                            linux414            4.14.65-1            4.14.66-1
                    linux414-headers            4.14.65-1            4.14.66-1
                            linux417            4.17.17-1            4.17.18-1
                    linux417-headers            4.17.17-1            4.17.18-1
                            linux418             4.18.3-1             4.18.4-1
                    linux418-headers             4.18.3-1             4.18.4-1
                      linux419 4.19rc0.0822.gad1d697-1 4.19rc0.0823.g815f0dd-1
              linux419-headers 4.19rc0.0822.gad1d697-1 4.19rc0.0823.g815f0dd-1
                             linux44            4.4.150-1            4.4.151-1
                     linux44-headers            4.4.150-1            4.4.151-1
                             linux49            4.9.122-1            4.9.123-1
                     linux49-headers            4.9.122-1            4.9.123-1

:: Different sync package(s) in repository core x86_64

                             PACKAGE           2018-08-22           2018-08-23
                              cronie              1.5.1-1              1.5.2-1
                           e2fsprogs             1.44.3-1             1.44.4-1

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE           2018-08-22           2018-08-23
                  linux414-acpi_call             1.1.0-54             1.1.0-55
                   linux414-bbswitch               0.8-54               0.8-55
                   linux414-catalyst     1:15.201.1151-54     1:15.201.1151-55
                linux414-ndiswrapper              1.61-54              1.61-55
                     linux414-nvidia           1:396.54-1           1:396.54-2
               linux414-nvidia-340xx           340.107-13           340.107-14
               linux414-nvidia-390xx             390.77-6             390.77-7
                   linux414-nvidiabl              0.88-54              0.88-55
                      linux414-r8168          8.045.08-42          8.045.08-43
                        linux414-spl             0.7.9-18             0.7.9-19
                   linux414-tp_smapi              0.41-54              0.41-55
                linux414-vhba-module          20161009-54          20161009-55
   linux414-virtualbox-guest-modules             5.2.18-2             5.2.18-3
    linux414-virtualbox-host-modules             5.2.18-2             5.2.18-3
                        linux414-zfs             0.7.9-18             0.7.9-19
                  linux417-acpi_call             1.1.0-12             1.1.0-13
                   linux417-bbswitch               0.8-12               0.8-13
                   linux417-catalyst     1:15.201.1151-12     1:15.201.1151-13
                linux417-ndiswrapper              1.61-12              1.61-13
                     linux417-nvidia           1:396.54-1           1:396.54-2
               linux417-nvidia-340xx           340.107-12           340.107-13
               linux417-nvidia-390xx             390.77-7             390.77-8
                   linux417-nvidiabl              0.88-12              0.88-13
                      linux417-r8168          8.045.08-12          8.045.08-13
                        linux417-spl             0.7.9-12             0.7.9-13
                   linux417-tp_smapi              0.41-12              0.41-13
                linux417-vhba-module          20161009-12          20161009-13
   linux417-virtualbox-guest-modules             5.2.18-2             5.2.18-3
    linux417-virtualbox-host-modules             5.2.18-2             5.2.18-3
                        linux417-zfs             0.7.9-12             0.7.9-13
                  linux419-acpi_call            1.1.0-0.7            1.1.0-0.8
                   linux419-bbswitch              0.8-0.7              0.8-0.8
                   linux419-catalyst    1:15.201.1151-0.7    1:15.201.1151-0.8
                linux419-ndiswrapper             1.61-0.7             1.61-0.8
                     linux419-nvidia         1:396.54-0.7         1:396.54-0.8
               linux419-nvidia-340xx          340.107-0.7          340.107-0.8
               linux419-nvidia-390xx           390.77-0.7           390.77-0.8
                   linux419-nvidiabl             0.88-0.7             0.88-0.8
                      linux419-r8168         8.045.08-0.7         8.045.08-0.8
                        linux419-spl            0.7.9-0.7            0.7.9-0.8
                   linux419-tp_smapi             0.41-0.7             0.41-0.8
                linux419-vhba-module         20161009-0.7         20161009-0.8
   linux419-virtualbox-guest-modules           5.2.18-0.7           5.2.18-0.8
    linux419-virtualbox-host-modules           5.2.18-0.7           5.2.18-0.8
                        linux419-zfs            0.7.9-0.7            0.7.9-0.8
                   linux44-acpi_call            1.1.0-105            1.1.0-106
                    linux44-bbswitch              0.8-105              0.8-106
                    linux44-catalyst    1:15.201.1151-105    1:15.201.1151-106
                 linux44-ndiswrapper              1.61-73              1.61-74
                      linux44-nvidia           1:396.54-1           1:396.54-2
                linux44-nvidia-340xx           340.107-10           340.107-11
                linux44-nvidia-390xx             390.77-6             390.77-7
                    linux44-nvidiabl             0.88-105             0.88-106
                       linux44-r8168          8.045.08-27          8.045.08-28
                         linux44-spl             0.7.9-13             0.7.9-14
                    linux44-tp_smapi             0.41-105             0.41-106
                 linux44-vhba-module          20161009-73          20161009-74
    linux44-virtualbox-guest-modules             5.2.18-2             5.2.18-3
     linux44-virtualbox-host-modules             5.2.18-2             5.2.18-3
                         linux44-zfs             0.7.9-13             0.7.9-14
                   linux49-acpi_call             1.1.0-91             1.1.0-92
                    linux49-bbswitch               0.8-91               0.8-92
                    linux49-catalyst     1:15.201.1151-91     1:15.201.1151-92
                 linux49-ndiswrapper              1.61-89              1.61-90
                      linux49-nvidia           1:396.54-1           1:396.54-2
                linux49-nvidia-340xx           340.107-10           340.107-11
                linux49-nvidia-390xx             390.77-6             390.77-7
                    linux49-nvidiabl              0.88-91              0.88-92
                       linux49-r8168          8.045.08-31          8.045.08-32
                         linux49-spl             0.7.9-15             0.7.9-16
                    linux49-tp_smapi              0.41-91              0.41-92
                 linux49-vhba-module          20161009-89          20161009-90
    linux49-virtualbox-guest-modules             5.2.18-2             5.2.18-3
     linux49-virtualbox-host-modules             5.2.18-2             5.2.18-3
                         linux49-zfs             0.7.9-15             0.7.9-16
                  nvidia-390xx-utils             390.77-1             390.77-2
                        nvidia-utils           1:396.54-1           1:396.54-2

:: Different sync package(s) in repository extra x86_64

                             PACKAGE           2018-08-22           2018-08-23
                              amarok  2.9.0.git20180816-1  2.9.0.git20180816-3
                        avogadrolibs             1.90.0-7             1.91.0-1
                        cups-filters             1.20.4-2             1.21.0-1
                             kalzium            18.08.0-1            18.08.0-2
                              libssh              0.7.5-2              0.8.1-2
                         libssh-docs              0.7.5-2              0.8.1-2
                              libx11              1.6.5-1              1.6.6-1
                              libxss              1.2.2-3              1.2.3-1
                    perl-archive-zip               1.62-1               1.63-1
                             libmsym                    -              0.2.3-1

:: Different overlay package(s) in repository multilib x86_64

                             PACKAGE           2018-08-22           2018-08-23
            lib32-nvidia-390xx-utils             390.77-1             390.77-2
                  lib32-nvidia-utils           1:396.54-1           1:396.54-2

:: Different sync package(s) in repository multilib x86_64

                             PACKAGE           2018-08-22           2018-08-23
                     lib32-e2fsprogs             1.44.3-1             1.44.4-1
                        lib32-libx11              1.6.5-1              1.6.6-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Ready for Stable ?!?

  • We are ready to move this to our stable branch
  • I still see some issues (post about them)

0 voters


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.

Something using Perl/Python/glibc broke

Rebuilds needed! If it's an AUR package, rebuild it. If it's a repo package, please report and check back regularly for rebuilds.

Items from previous update sets

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

Smooth update on my end with kernel 4.18.4 on XFCE.

No issues with 4.18.4 on Xfce. :smiley:

Beware, confused and confusing newb report follows:
I reverted from 4.19 because it had problems (only) with booting, and since yesterday shutting down. Problems only occur with a 'cold' boot. Can do a power-off reboot once the initial boot (after being left off overnight) fails. Makes tracing the issue hard.

First problem showed several days ago with a boot that succeeded but with a partially non-operational system - gvfs-udisks2-vo[814]: monitor says it's not supported - where my secondary disks did not mount (and were not mountable from clicking from the gui, at least) and other oddities occurred like the background wallpaper remaining as the login wallpaper rather than the DE wallpaper. Firefox was fully functional but neither transmission nor geany would open. Shrugged it off as a 'glitch' after reboot fixed everything.

Then the next couple of days initial boots after being off overnight would not succeed. Just blinking cursor in top left corner after grub then loading systemd version message. First day I powered off (yeah yuck...) and waited 30 seconds or a minute then rebooted without problems. Next day on getting similar behaviour I tried ctrl-alt-f2 for the terminal (which worked) but then again was stuck before login with cursor blinking. Could not get back with ctrl-alt-f7. This time I REISUB'd and it rebooted perfectly.

Then last night when attempting to shutdown I got a succession of timeout messages. Initially 'modem manager' took 3 minutes to quit, then 'network manager' took another 3, 'IPv6 packet filtering framework' took about 6 minutes to shutdown and on it went. Unfortunately I was exhausted and ready to fall into bed so I just forced a reboot to 4.18 and then quickly shutdown normally. There were also messages displayed about 'jbd2' 'systemd-journal' and 'kworker'.

Throughout this, once 4.19 booted it functioned perfectly well, as far as I could tell, all day (for several days). There was little if any information contained in the journal. Sorry for the poor quality report. If there is anything I could test further (or useful commands/operations to try, logs to report, etc.) just ask. As mentioned above 'beware the newb'.

I have not tried (yet) the most recent version of the 4.19 kernel.


After the update, Latte Dock showed only an invisible icon where previously was IntelliJ. Clicking on the icon lead to an error message. Starting the application from the applications menu lead to the same error message. It seems that the installation path has changed from




Changing the path solved the issue.

Yeah, libglvnd issue with bumblebee went away. Steam can launch correctly on bumblebee now, without any additional libraries commands, or at least with steam-native on board.
I'm curious and I may uninstall steam-native to see if the long-lasting (at least 2 years old) launch issue was fixed with it as well. It should be.

Before this update, the 4.18 kernel was quiet for me during boot and now I noticed some warnings, but I'll have to check it out more closely later. Most probably again some new kernel bugs revealing non-meaningful messages.

Other then that all seems to work fine.

1 Like

I have a weird issue with bumblebee primusrun glxspheres64 returns

primus: fatal: failed to load any of the libraries: /usr/lib/nvidia/libGL.so.1:/usr/lib32/nvidia/libGL.so.1
/usr/lib/nvidia/libGL.so.1: cannot open shared object file: No such file or directory
/usr/lib32/nvidia/libGL.so.1: cannot open shared object file: No such file or directory

While optirun runs fine. Obviously, bumblebeed.service is active (before you ask, I did check it).

Edit: it seems that primusrun does not look for libGL.so.1 libraries in the right place. They are in /usr/liband /usr/lib32/ respectively instead of /usr/lib/nvidia and /usr/lib32/nvidia/a symlink may solve the problem.

Answering to myself, but hey… Found the answer on the arch forums, but I can't find where exactly, so I apologize to the author. Anyway, here's what I did:

sudo cp /etc/bumblebee/bumblebee.conf /etc/bumblebee/bumblebee.conf.bak

and then

sudo cp /etc/bumblebee/bumblebee.conf.pacnew /etc/bumblebee/bumblebee.conf

And now, everything works, without any symlink.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by