[Testing Update] 2018-08-24 - Gimp 2.10.6, Jade Desktop 0.6.6, QT4 cleanup

Hi community,

Welcome to another testing update. So what do we have with this one?

  • we updated our Jade Desktop
  • more qt4 packages got ditched
  • Gimp is now at 2.10.6
  • the usual upstream rebuilds/updates

We hope with all these changes Manjaro to be more efficient for you all.

For more info about L1TF please watch this video:


Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis either silver or gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.


If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.

Latest information about the intel-cpu-bug risk and our efforts can be found here.

Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.119 [EOL]
  • linux44 4.4.151
  • linux49 4.9.123
  • linux414 4.14.66
  • linux417 4.17.18
  • linux418 4.18.4
  • linux419 4.19-rc0
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt11

Package Updates (Fri Aug 24 16:48:16 CEST 2018)

  • testing community x86_64: 64 new and 69 removed package(s)
  • testing core x86_64: 1 new and 1 removed package(s)
  • testing extra x86_64: 39 new and 55 removed package(s)
  • testing multilib x86_64: 3 new and 3 removed package(s)
:: Different overlay package(s) in repository community x86_64

                             PACKAGE           2018-08-23           2018-08-24
                      jade-dashboard              0.6.5-2              0.6.6-1
                      jade-menu-data              1.0.2-1              1.0.4-1
             manjaro-webdad-settings              0.7.4-1              0.7.5-1

:: Different sync package(s) in repository community x86_64

                             PACKAGE           2018-08-23           2018-08-24
                               acorn              5.7.1-1              5.7.2-1
                             alembic              1.7.8-1              1.7.8-2
                    autoconf-archive       1:2018.03.13-1       1:2018.03.13-2
                   blender 17:2.79.b.git3.32432d91-4 17:2.79.b.git3.32432d91-5
                             calibre             3.29.0-1             3.30.0-1
                               cgrep            6.6.25-64            6.6.25-65
                        cinelerra-cv              1:2.3-5              1:2.3-6
                             cryptol              2.6.0-7              2.6.0-8
                           darktable            2:2.4.4-1            2:2.4.4-2
            deepin-wallpapers-plasma             5.11.2-1             5.13.4-1
                          fingerterm              1.3.6-1              1.3.7-1
                           freeimage             3.17.0-7             3.17.0-8
                    gimp-plugin-gmic              2.3.4-1              2.3.5-1
                           git-annex         6.20180807-9        6.20180807-10
                                gmic              2.3.4-1              2.3.5-1
                       haskell-hpack             0.29.7-1             0.29.7-2
                    haskell-mustache             2.3.0-66             2.3.0-67
                         haskell-sbv              7.10-10              7.10-11
                        haskell-yaml             0.9.0-12             0.10.0-1
                       haskell-yesod             1.6.0-87             1.6.0-88
                              hgview             1.10.2-2             1.10.2-3
                             hindent              5.2.7-9             5.2.7-10
                         hledger-web              1.10-38              1.10-39
                               hlint             2.1.10-1             2.1.10-2
                      hopenpgp-tools            0.21.2-10            0.21.2-11
                               hugin           2018.0.0-3           2018.0.0-4
                            krecipes              2.1.0-5                    -
                   krita-plugin-gmic              2.3.4-1              2.3.5-1
                        luminancehdr             2.5.1-11             2.5.1-12
                         mate-themes            3.22.17-1            3.22.18-1
                           ninja-ide                2.3-4                    -
                                ogre             1.11.1-2             1.11.1-3
                           ogre-docs             1.11.1-2             1.11.1-3
                         openimageio             1.8.13-1             1.8.13-2
                 openshadinglanguage              1.9.9-5              1.9.9-6
                             openvdb              5.1.0-3              5.1.0-4
                              povray          2:          2:
                           puddletag              1.2.0-1                    -
           pycharm-community-edition           2018.2.1-2           2018.2.2-1
                 python-cinderclient              3.6.1-2              4.0.1-1
                      python-dropbox              8.9.0-2              9.0.0-1
                   python-hypothesis             3.69.1-1             3.69.2-1
                         python-praw              5.4.0-2              6.0.0-1
                     python-prawcore             0.14.0-2              1.0.0-1
                       python-pytest              3.6.4-1              3.7.2-1
                 python-pytest-xdist             1.22.2-2             1.22.5-1
                python2-cinderclient              3.6.1-2              4.0.1-1
                     python2-dropbox              8.9.0-2              9.0.0-1
                  python2-hypothesis             3.69.1-1             3.69.2-1
                        python2-praw              5.4.0-2              6.0.0-1
                    python2-prawcore             0.14.0-2              1.0.0-1
                       python2-pyqwt              5.2.0-3                    -
                      python2-pytest              3.6.4-1              3.7.2-1
                python2-pytest-xdist             1.22.2-2             1.22.5-1
                         recorditnow             0.8.1-10                    -
                               stack            1.7.1-105            1.7.1-106
                           uglify-js              3.4.7-1              3.4.8-1
                               v2ray               3.35-1               3.36-1
                               vigra            1.11.1-10            1.11.1-11
                           vigra-doc            1.11.1-10            1.11.1-11
                                zart              2.3.4-1              2.3.5-1

:: Different sync package(s) in repository core x86_64

                             PACKAGE           2018-08-23           2018-08-24
                              s-nail            14.9.10-1            14.9.11-1

:: Different sync package(s) in repository extra x86_64

                             PACKAGE           2018-08-23           2018-08-24
                              amarok  2.9.0.git20180816-3  2.9.0.git20180816-4
                          attica-qt4              0.4.2-4                    -
                            automoc4             0.9.88-9                    -
                            calligra              3.1.0-8              3.1.0-9
                               eigen              3.3.5-2              3.3.5-3
                        fontconfig 2.13.0+17+gc78afa9-1 1:2.13.0+15+gc60ed9e-1
                                gegl              0.4.4-2              0.4.8-1
                                gimp             2.10.4-2             2.10.6-1
                             gparted             0.31.0-1             0.32.0-1
                     gst-plugins-bad             1.14.2-1             1.14.2-2
                             haveged              1.9.4-2              1.9.4-3
                                ibus             1.5.18-2             1.5.19-1
                             ilmbase              2.2.1-4              2.3.0-1
                     kdebase-runtime            17.08.3-3                    -
                             kdelibs            4.14.38-4                    -
                       kimageformats             5.49.0-1             5.49.0-2
                          kio-extras            18.08.0-1            18.08.0-2
                               krita              4.1.1-3              4.1.1-4
                             libibus             1.5.18-2             1.5.19-1
                      liblightdm-qt4           1:1.26.0-1           1:1.26.0-2
                      liblightdm-qt5           1:1.26.0-1           1:1.26.0-2
                             librsvg           2:2.42.6-1           2:2.44.0-1
                               libuv             1.22.0-1             1.23.0-1
                             lightdm           1:1.26.0-1           1:1.26.0-2
                 lightdm-kde-greeter                      -
                              opencv              3.4.2-2              3.4.2-3
                      opencv-samples              3.4.2-2              3.4.2-3
                             openexr              2.2.1-1              2.3.0-1
                          phonon-qt4             4.10.1-1                    -
                phonon-qt4-gstreamer              4.9.0-4                    -
                      phonon-qt4-vlc             0.10.1-2                    -
                          phonon-qt5             4.10.1-1             4.10.1-2
                phonon-qt5-gstreamer              4.9.0-4              4.9.0-5
                      phonon-qt5-vlc             0.10.1-2             0.10.1-3
                          polkit-qt4 0.112.0+git20180107-1                   -
                        polkit-qt5 0.112.0+git20180107-1 0.112.0+git20180107-2
                        pyqt4-common             4.12.1-2                    -
                        python-pyqt4             4.12.1-2                    -
               python-qscintilla-qt4             2.10.7-2                    -
        python-qscintilla-qt4-common             2.10.7-2                    -
               python-qscintilla-qt5             2.10.7-2             2.10.7-3
        python-qscintilla-qt5-common             2.10.7-2             2.10.7-3
                       python2-pyqt4             4.12.1-2                    -
              python2-qscintilla-qt4             2.10.7-2                    -
              python2-qscintilla-qt5             2.10.7-2             2.10.7-3
                      qscintilla-qt4             2.10.7-2                    -
                      qscintilla-qt5             2.10.7-2             2.10.7-3
                        schroedinger             1.0.11-4             1.0.11-5
                            valgrind            3.13.0-7 3.13.0+290+2b0aa0a5-1
                                zvbi             0.2.35-2             0.2.35-3

:: Different sync package(s) in repository multilib x86_64

                             PACKAGE           2018-08-23           2018-08-24
                  lib32-fontconfig 2.13.0+17+gc78afa9-1 1:2.13.0+15+gc60ed9e-1
                          lib32-jack            0.125.0-1            0.125.0-2
                       lib32-librsvg             2.42.6-1             2.44.0-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Ready for Stable ?!?

  • We are ready to move this to our stable branch
  • I still see some issues (post about them)

0 voters


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.

Something using Perl/Python/glibc broke

Rebuilds needed! If it's an AUR package, rebuild it. If it's a repo package, please report and check back regularly for rebuilds.

Items from previous update sets

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

Nothing to say besides this: it simply works.

Added also a new set of our adapta-manjaro-themes

Everything is running, Manjaro Xfce, Kernel 4.18.4-1.

Same here. I was waiting for stable update. Looks like I'll have to wait another day or two. Sigh...

No, I'll cook some and watch a movie after doing today's development. Will find some time later to do the stable snap.

Well... Have a good movie so :slight_smile:

There are still some qt4 packages that should be removed from repos:



$ sudo pacman -Qi kdelibs4support
Name: kdelibs4support
Version: 5.49.0-1
Description: Porting aid from KDELibs4
Architecture: x86_64
URL: https://community.kde.org/Frameworks
Licenses: LGPL
Groups: kf5-aids
Provides: None
Depends on: kunitconversion kitemmodels kemoticons kded kparts
Depend. optional: None
Needed for: dolphin-plugins kfind knetattach konqueror plasma-workspace soundkonverter
Optional for: None
Conflicts with: None
Replaces: None
Installed Size: 17.34 MiB
Packer: Antonio Rojas <arojas@archlinux.org>
Date compiled: Fri 17 Aug 2018 17:46:31 -03
Installation date: Sun 19 Aug 2018 13:45:22 -03
Reason for installation: Installed as dependency of another package
Installation script: No
Validated by: Signature

The others I don't have instaled

I think they may all be gone. I noticed the KDE4 breeze and oxygen packages were removed yesterday, and today:

$ pacman -Qm
phonon-qt4 4.10.1-1
phonon-qt4-gstreamer 4.9.0-4

Should we remove them manually? Because AUR phonon-qt4 can't update.

Awesome, I’m itching to test the performance of the “fixed” nvidia drivers on my sons gaming system (stable branch). See if it really is as big of a deal that people are claiming.

Also, no issues noticed again on my system, XFCE linux414.

What got fixed?

I removed KDE4 breeze and oxygen and the two python-qt4 packages, and nothing immediately broke.

My rules:

  • I sudo pacman -Rsn Anything in pacman -Qm that I did not install from the AUR (basically chrome, dropbox, and my print driver)
  • I sudo pacman -Rsn $(pacman -Qqdt) after every major upgrade.

I have heard others get into trouble with that, but I have not so far.

I would prefer to just run the pacman -Qqdt and -Rns from that list as I see fit.
But if you never have anything that impedes that, then go right ahead.


the 396.54 was released to fix a resource leak that had been existent going back to the 390 series driver. This resource leak could lead to lower performance after several OpenGL or Vulkan applications have started/stopped on the system...

1 Like

I think it could be solution. Just remove phonon-qt4-gstreamer (aur), and problem solved. Thanks.

No apparent issues on 4 machines including a KDE installtion.

Wow, when Nvidia says resource leak, they're not kidding around. Those driver benchmarks are like upgrading to a new video card.

I wonder if there's any difference on 1080p resolution. :thinking:

Forum kindly sponsored by