[Testing Update] 2018-08-28 - Kernel v4.19-rc1, Adapta, Haskell

Hi community,

Welcome to another testing update. So what do we have with this one?

  • we updated our adpata-themes
  • kernel got updated to v4.19-rc1
  • the usual haskell rebuilds/updates

We hope with all these changes Manjaro to be more efficient for you all.

For more info about L1TF please watch this video:


Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis either silver or gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.


If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.

Latest information about the intel-cpu-bug risk and our efforts can be found here.

Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.119 [EOL]
  • linux44 4.4.152
  • linux49 4.9.124
  • linux414 4.14.67
  • linux417 4.17.19 [EOL]
  • linux418 4.18.5
  • linux419 4.19-rc1
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt11

Package Updates (Tue Aug 28 07:22:52 CEST 2018)

  • testing community x86_64: 164 new and 163 removed package(s)
  • testing core x86_64: 5 new and 5 removed package(s)
  • testing extra x86_64: 22 new and 22 removed package(s)
  • testing multilib x86_64: 5 new and 5 removed package(s)
:: Different overlay package(s) in repository community x86_64

                             PACKAGE           2018-08-26           2018-08-28
                           limepanel 0.43.r126.gbd57eb7-2 0.44.r127.g29569dd-1
              manjaro-bspwm-settings           20180825-1           20180827-1
                           timeshift             18.6.1-1               18.8-1

:: Different sync package(s) in repository community x86_64

                             PACKAGE           2018-08-26           2018-08-28
                      acpi_call-dkms            1.1.0-156            1.1.0-157
                                c2hs            0.28.5-16            0.28.5-17
                               cgrep            6.6.25-66            6.6.25-68
                        cmake-fedora              2.9.2-4              2.9.2-5
                           cmark-gfm      0.28.3.gfm.14-1      0.28.3.gfm.15-1
                             cryptol              2.6.0-9             2.6.0-10
                               darcs            2.14.1-39            2.14.1-40
                       elasticsearch              6.4.0-1              6.4.0-2
                                eric              18.06-2              18.08-1
                         eric-common              18.06-2              18.08-1
                        eric-i18n-de              18.06-1              18.08-1
                        eric-i18n-en              18.06-1              18.08-1
                        eric-i18n-es              18.06-1              18.08-1
                        eric-i18n-ru              18.06-1              18.08-1
                          feedreader                2.2-1              2.2.1-1
                           filezilla             3.35.2-1             3.36.0-1
                           firewalld              0.6.1-2              0.6.1-3
                            geogebra          6.0.472.0-1          6.0.487.0-1
                           git-annex        6.20180807-12        6.20180807-14
                          git-repair        1.20170626-42        1.20170626-43
                              gpxsee               5.16-1               5.17-1
                haskell-aeson-compat             0.3.8-14             0.3.8-15
                haskell-aeson-pretty             0.8.7-29             0.8.7-30
                    haskell-aeson-qq             0.8.2-65             0.8.2-66
                haskell-authenticate            1.3.4-157            1.3.4-159
                         haskell-aws              0.20-65              0.20-67
               haskell-binary-tagged             0.1.5-20             0.1.5-21
                  haskell-cheapskate            0.1.1-115            0.1.1-117
                   haskell-cmark-gfm              0.1.4-2              0.1.5-1
                         haskell-dav            1.3.2-112            1.3.2-113
                 haskell-descriptive            0.9.4-130            0.9.4-131
                      haskell-gnuidn             0.2.2-60             0.2.2-61
             haskell-haddock-library              1.6.0-6              1.6.0-7
                       haskell-hasql            1.1.1-112  
                  haskell-hasql-pool            0.4.3-112                0.5-2
           haskell-hasql-transaction            0.5.2-115                0.7-2
                haskell-hjsonpointer             1.4.0-28             1.4.0-29
                 haskell-hjsonschema             1.9.0-71             1.9.0-73
                    haskell-hopenpgp              2.7.2-8              2.7.2-9
                       haskell-hpack             0.29.7-4             0.29.7-5
                   haskell-hspec-wai             0.9.0-96             0.9.0-98
              haskell-hspec-wai-json            0.9.0-112            0.9.0-114
                        haskell-http         4000.3.12-40         4000.3.12-41
                haskell-http-conduit             2.3.2-31             2.3.2-33
                   haskell-js-jquery            3.3.1-110            3.3.1-111
                  haskell-lens-aeson             1.0.2-92             1.0.2-93
             haskell-microlens-aeson             2.3.0-33             2.3.0-34
                    haskell-mustache             2.3.0-69             2.3.0-71
       haskell-network-protocol-xmpp             0.4.8-71             0.4.8-72
                        haskell-path             0.6.1-58             0.6.1-59
                     haskell-path-io              1.4.0-3              1.4.0-5
                  haskell-persistent             2.8.2-59             2.8.2-60
           haskell-persistent-sqlite              2.8.2-2              2.8.2-3
         haskell-persistent-template             2.5.4-84             2.5.4-85
                         haskell-sbv              7.10-12              7.10-13
             haskell-servant-swagger             1.1.5-50             1.1.5-51
                       haskell-shake            0.16.4-74            0.16.4-75
                 haskell-shakespeare            2.0.15-49            2.0.15-50
                      haskell-shelly             1.8.1-18             1.8.1-19
                 haskell-skylighting             0.7.2-18             0.7.2-19
            haskell-skylighting-core             0.7.2-18             0.7.2-19
                   haskell-sourcemap             0.1.6-85             0.1.6-86
                    haskell-swagger2             2.2.2-47             2.2.2-48
       haskell-tamarin-prover-theory             1.4.0-31             1.4.0-32
                   haskell-tree-diff             0.0.1-38             0.0.1-39
                      haskell-turtle            1.5.10-18            1.5.10-19
                 haskell-unix-compat                0.5.1-1
                  haskell-wai-logger            2.3.2-104            2.3.2-108
                        haskell-warp            3.2.23-14            3.2.23-15
                      haskell-xcffib             0.6.0-59             0.6.0-60
                  haskell-xml-hamlet             0.5.0-43             0.5.0-44
                        haskell-yaml             0.10.0-2             0.10.0-3
                       haskell-yesod             1.6.0-89             1.6.0-91
                  haskell-yesod-auth             1.6.3-87             1.6.3-89
                  haskell-yesod-core             1.6.6-19             1.6.6-21
               haskell-yesod-default            1.2.0-374            1.2.0-376
                  haskell-yesod-form             1.6.2-22             1.6.2-24
            haskell-yesod-persistent             1.6.0-81             1.6.0-83
                haskell-yesod-static             1.6.0-74             1.6.0-76
                  haskell-yesod-test             1.6.5-20             1.6.5-22
                             hindent             5.2.7-11             5.2.7-13
                             hledger              1.10-13              1.10-14
                         hledger-api              1.10-32              1.10-34
                          hledger-ui              1.10-24              1.10-26
                         hledger-web              1.10-41              1.10-43
                               hlint             2.1.10-3             2.1.10-4
                      hopenpgp-tools            0.21.2-13            0.21.2-14
                               idris             1.3.0-48             1.3.0-50
                                 iwd                0.6-1                0.7-1
                             jenkins              2.138-1              2.140-1
             nextcloud-app-bookmarks           1:0.11.0-1           1:0.12.1-1
                              pdfsam              3.3.5-1              3.3.7-1
                            pgadmin4                3.0-3                3.2-1
                    python-biopython               1.71-2               1.72-1
            python-django-extensions              2.1.0-2              2.1.2-1
                     python-django-q              0.9.4-3              1.0.0-1
              python-mysql-connector             8.0.11-2             8.0.12-1
                       python-pyodbc             4.0.23-2             4.0.24-1
                       python-pytest              3.7.2-1              3.7.3-1
                   python2-biopython               1.71-2               1.72-1
                        python2-eric              18.06-2              18.08-1
             python2-mysql-connector             8.0.11-2             8.0.12-1
                      python2-pyodbc             4.0.23-2             4.0.24-1
                      python2-pytest              3.7.2-1              3.7.3-1
                             remmina         1:         1:
                          shellcheck             0.5.0-76             0.5.0-79
                              sratom              0.6.2-1              0.6.2-2
                               stack            1.7.1-108            1.7.1-110
                          streamlink             0.14.2-2             0.14.2-3
                      tamarin-prover             1.4.0-84             1.4.0-86
                               tilix              1.8.3-1              1.8.5-1
                               tokei              7.0.3-1              8.0.0-1
                             uranium              3.4.1-2              3.4.1-3
                            whowatch              1.8.5-3              1.8.6-1
                              xmobar               0.27-3               0.27-4
                     zsh-completions             0.27.0-1             0.28.0-1
                haskell-text-builder                    -  

:: Different overlay package(s) in repository core x86_64

                             PACKAGE           2018-08-26           2018-08-28
                      linux419 4.19rc0.0826.g2923b27-3 4.19rc1.0826.g5b394b2-1
              linux419-headers 4.19rc0.0826.g2923b27-3 4.19rc1.0826.g5b394b2-1

:: Different sync package(s) in repository core x86_64

                             PACKAGE           2018-08-26           2018-08-28
                           amd-ucode   20180821.1d17c18-3   20180825.fea76a0-1
                      linux-firmware   20180821.1d17c18-3   20180825.fea76a0-1
                             openssh              7.7p1-2              7.8p1-1

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE           2018-08-26           2018-08-28
                  linux419-acpi_call           1.1.0-0.10           1.1.0-0.11
                   linux419-bbswitch             0.8-0.10             0.8-0.11
                   linux419-catalyst   1:15.201.1151-0.10   1:15.201.1151-0.11
                linux419-ndiswrapper            1.61-0.10            1.61-0.11
                     linux419-nvidia        1:396.54-0.10        1:396.54-0.11
               linux419-nvidia-340xx         340.107-0.10         340.107-0.11
               linux419-nvidia-390xx          390.77-0.10          390.77-0.11
                   linux419-nvidiabl            0.88-0.10            0.88-0.11
                      linux419-r8168        8.045.08-0.10        8.045.08-0.11
                        linux419-spl           0.7.9-0.10           0.7.9-0.11
                   linux419-tp_smapi            0.41-0.10            0.41-0.11
                linux419-vhba-module        20161009-0.10        20161009-0.11
   linux419-virtualbox-guest-modules          5.2.18-0.10          5.2.18-0.11
    linux419-virtualbox-host-modules          5.2.18-0.10          5.2.18-0.11
                        linux419-zfs           0.7.9-0.10           0.7.9-0.11

:: Different sync package(s) in repository extra x86_64

                             PACKAGE           2018-08-26           2018-08-28
                               cmake             3.11.4-2             3.12.1-1
                        cups-filters             1.21.0-2             1.21.1-1
                             digikam              5.9.0-1              5.9.0-2
                     gst-plugins-bad             1.14.2-2             1.14.2-3
                        kipi-plugins              5.9.0-1              5.9.0-2

:: Different sync package(s) in repository multilib x86_64

                             PACKAGE           2018-08-26           2018-08-28
                       lib32-libmbim             1.16.0-1             1.16.2-1
                        lib32-libqmi             1.20.0-1             1.20.2-1
                  lib32-libxkbcommon              0.8.0-1              0.8.2-1
              lib32-libxkbcommon-x11              0.8.0-1              0.8.2-1
                       lib32-wayland             1.15.0-1             1.16.0-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Ready for Stable ?!?

  • We are ready to move this to our stable branch
  • I still see some issues (post about them)

0 voters


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

AMD-Ucode introduction

All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.

LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.

Something using Perl/Python/glibc broke

Rebuilds needed! If it's an AUR package, rebuild it. If it's a repo package, please report and check back regularly for rebuilds.

Items from previous update sets

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

Update, reboot, everything is running.

Manjaro Xfce 17.1.12
Kernel 4.18.5-1

Will this get worked into iso-profiles soon, just like the intel-ucode is?

EDIT: Yes it is. Found the commit.

slight variation of the question, could it be made possible to use just one or other ucode package when building an ISO? at present intel-ucode has to be selected even if you don't actually need it. I'd like to build a pure AMD one if possible stripped of all the firmware modules and GPU related stuff my system doesn't actually need.

1 Like

Good update!

Host: xxx-pc Kernel: 4.19.0-1-MANJARO x86_64 bits: 64
Desktop: LXQt 0.13.0 Distro: Manjaro Linux

PC used for porn?? :wink:

1 Like

No, I prefer to do porn myself.:sunglasses:

Sorry, I am not sure if it is the right place to post. Anyway I am using Manjaro xfce 18 with that kernel and looks ok. One of the problem is that if I tried to get icons packages from the AUR, it says "unprepared transactions" (crude translation from French). Those packages work fine in 17. Most of the regular programs goes through ok though. Any idea ?

The other slight problem is that the system sometimes get unresponsive for a few seconds. It is a very old AMD motherboard. Ok it's only a beta release though.

This is pretty similar to the problem I posted here:

It happened to me on all updates. In the meantime it seems to be fixed for me. At least todays testing update went fine with pamac-manager. I dont know why it is fixed. But I executed "pamac update" on the console yesterday. May be that helped.

I have 3 orphaned packages after the last update:


Will remove the packages now and report in case something goes wrong.

Didn't go as smoothly as i'd have liked.

$ uname -a
Linux Manjaro_KDE_VM 4.17.19-1-MANJARO #1 SMP PREEMPT Fri Aug 24 17:46:14 UTC 2018 x86_64 GNU/Linux
  1. Yet another kernel 4.18 variant [4.18.5 this time] that still breaks my VM's Shared Folders, ie, still cannot use this kernel in VMs.

  2. Rebooting back to 4.17 [then re-running the usual sudo ./VBoxLinuxAdditions.run & rebooting VM] gives me my SF back again, but obviously this message seen during the update means i'm about to lose this kernel...

(28/28) upgrading linux417
>>> NOTE, 4.17.19 is the last release of the 4.17.y kernel.
It is now end-of-life.
It is recommend to move on to linux416-series.
Use followed cmd to do that: 'sudo mhwd-kernel -i linux418'

...so i suppose i'll soon need to revert to 4.14. Btw, note the typo [linux416] in that message?

  1. After my initial post-update VM reboot i was shocked to see that my Activity2 desktop wallpaper had been reset to become same as Activity1's wallpaper. Digging deeper i then found, astonishingly, that this update had entirely deleted that previous wallpaper, not merely deselected it from Settings... weird!

I can not confirm that. I have manjaro stable as virtualbox running on a manjaro testing PC. Both have linux418: 4.18.4 and 4.18.5 and shared folders are working fine. Manually mounted:
mount -t vboxsf share-name /mnt/sharefolder

Well, i just saw, & have now also done, the new Testing Update 2018-08-29 in my VM. I then rebooted it back into 4.18.5, re-ran the sudo ./VBoxLinuxAdditions.run, observed that yet again it failed:

Verifying archive integrity... All good.
Uncompressing VirtualBox 5.2.18 Guest Additions for Linux........
VirtualBox Guest Additions installer
Removing installed version 5.2.18 of VirtualBox Guest Additions...
Copying additional installer modules ...
Installing additional modules ...
VirtualBox Guest Additions: Building the VirtualBox Guest Additions kernel modules. This may take a while.
VirtualBox Guest Additions: Look at /var/log/vboxadd-setup.log to find out what went wrong
VirtualBox Guest Additions: Running kernel modules will not be replaced until the system is restarted
VirtualBox Guest Additions: Starting.
Press Return to close this window...

...& so examined /var/log/vboxadd-setup.log again. It's nasty:

Building the main Guest Additions module.
Building the shared folder support module.
Error building the module:
make V=1 CONFIG_MODULE_SIG= -C /lib/modules/4.18.5-1-MANJARO/build SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 -j2 modules
make[1]: warning: -jN forced in submake: disabling jobserver mode.
mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*
make -f ./scripts/Makefile.build obj=/tmp/vbox.0
(cat /dev/null;   echo kernel//tmp/vbox.0/vboxsf.ko;) > /tmp/vbox.0/modules.order
  gcc -Wp,-MD,/tmp/vbox.0/.vfsmod.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/include -I./arch/x86/include -I./arch/x86/include/generated  -I./include -I./arch/x86/include/uapi -I./arch/x86/include/generated/uapi -I./include/uapi -I./include/generated/uapi -include ./include/linux/kconfig.h -include ./include/linux/compiler_types.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -fshort-wchar -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -fno-PIE -DCC_HAVE_ASM_GOTO -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -m64 -falign-jumps=1 -falign-loops=1 -mno-80387 -mno-fp-ret-in-387 -mpreferred-stack-boundary=3 -mskip-rax-setup -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -DCONFIG_X86_X32_ABI -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_SSSE3=1 -DCONFIG_AS_CRC32=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -DCONFIG_AS_AVX512=1 -DCONFIG_AS_SHA1_NI=1 -DCONFIG_AS_SHA256_NI=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mindirect-branch=thunk-extern -mindirect-branch-register -DRETPOLINE -fno-delete-null-pointer-checks -Wno-frame-address -Wno-format-truncation -Wno-format-overflow -Wno-int-in-bool-context -O2 --param=allow-store-data-races=0 -Wframe-larger-than=2048 -fstack-protector-strong -Wno-unused-but-set-variable -Wno-unused-const-variable -fno-var-tracking-assignments -pg -mfentry -DCC_USING_FENTRY -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fno-merge-all-constants -fmerge-constants -fno-stack-check -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -Werror=date-time -Werror=incompatible-pointer-types -Werror=designated-init -fmacro-prefix-map=./= -Wno-packed-not-aligned -mrecord-mcount -Wno-declaration-after-statement -fshort-wchar -include /tmp/vbox.0/include/VBox/VBoxGuestMangling.h -fno-pie -I/lib/modules/4.18.5-1-MANJARO/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxsf/ -I/tmp/vbox.0/vboxsf/include -I/tmp/vbox.0/vboxsf/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DVBOX_WITH_HGCM -DIN_MODULE -DIN_GUEST_R0 -DRT_NO_EXPORT_SYMBOL -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS  -DMODULE  -DKBUILD_BASENAME='"vfsmod"' -DKBUILD_MODNAME='"vboxsf"' -c -o /tmp/vbox.0/.tmp_vfsmod.o /tmp/vbox.0/vfsmod.c
  gcc -Wp,-MD,/tmp/vbox.0/.dirops.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/include -I./arch/x86/include -I./arch/x86/include/generated  -I./include -I./arch/x86/include/uapi -I./arch/x86/include/generated/uapi -I./include/uapi -I./include/generated/uapi -include ./include/linux/kconfig.h -include ./include/linux/compiler_types.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -fshort-wchar -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -fno-PIE -DCC_HAVE_ASM_GOTO -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -m64 -falign-jumps=1 -falign-loops=1 -mno-80387 -mno-fp-ret-in-387 -mpreferred-stack-boundary=3 -mskip-rax-setup -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -DCONFIG_X86_X32_ABI -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_SSSE3=1 -DCONFIG_AS_CRC32=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -DCONFIG_AS_AVX512=1 -DCONFIG_AS_SHA1_NI=1 -DCONFIG_AS_SHA256_NI=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mindirect-branch=thunk-extern -mindirect-branch-register -DRETPOLINE -fno-delete-null-pointer-checks -Wno-frame-address -Wno-format-truncation -Wno-format-overflow -Wno-int-in-bool-context -O2 --param=allow-store-data-races=0 -Wframe-larger-than=2048 -fstack-protector-strong -Wno-unused-but-set-variable -Wno-unused-const-variable -fno-var-tracking-assignments -pg -mfentry -DCC_USING_FENTRY -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fno-merge-all-constants -fmerge-constants -fno-stack-check -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -Werror=date-time -Werror=incompatible-pointer-types -Werror=designated-init -fmacro-prefix-map=./= -Wno-packed-not-aligned -mrecord-mcount -Wno-declaration-after-statement -fshort-wchar -include /tmp/vbox.0/include/VBox/VBoxGuestMangling.h -fno-pie -I/lib/modules/4.18.5-1-MANJARO/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxsf/ -I/tmp/vbox.0/vboxsf/include -I/tmp/vbox.0/vboxsf/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DVBOX_WITH_HGCM -DIN_MODULE -DIN_GUEST_R0 -DRT_NO_EXPORT_SYMBOL -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS  -DMODULE  -DKBUILD_BASENAME='"dirops"' -DKBUILD_MODNAME='"vboxsf"' -c -o /tmp/vbox.0/.tmp_dirops.o /tmp/vbox.0/dirops.c
   ./tools/objtool/objtool orc generate  --module --no-fp  --retpoline "/tmp/vbox.0/.tmp_vfsmod.o";
  gcc -Wp,-MD,/tmp/vbox.0/.lnkops.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/include -I./arch/x86/include -I./arch/x86/include/generated  -I./include -I./arch/x86/include/uapi -I./arch/x86/include/generated/uapi -I./include/uapi -I./include/generated/uapi -include ./include/linux/kconfig.h -include ./include/linux/compiler_types.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -fshort-wchar -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -fno-PIE -DCC_HAVE_ASM_GOTO -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -m64 -falign-jumps=1 -falign-loops=1 -mno-80387 -mno-fp-ret-in-387 -mpreferred-stack-boundary=3 -mskip-rax-setup -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -DCONFIG_X86_X32_ABI -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_SSSE3=1 -DCONFIG_AS_CRC32=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -DCONFIG_AS_AVX512=1 -DCONFIG_AS_SHA1_NI=1 -DCONFIG_AS_SHA256_NI=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mindirect-branch=thunk-extern -mindirect-branch-register -DRETPOLINE -fno-delete-null-pointer-checks -Wno-frame-address -Wno-format-truncation -Wno-format-overflow -Wno-int-in-bool-context -O2 --param=allow-store-data-races=0 -Wframe-larger-than=2048 -fstack-protector-strong -Wno-unused-but-set-variable -Wno-unused-const-variable -fno-var-tracking-assignments -pg -mfentry -DCC_USING_FENTRY -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fno-merge-all-constants -fmerge-constants -fno-stack-check -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -Werror=date-time -Werror=incompatible-pointer-types -Werror=designated-init -fmacro-prefix-map=./= -Wno-packed-not-aligned -mrecord-mcount -Wno-declaration-after-statement -fshort-wchar -include /tmp/vbox.0/include/VBox/VBoxGuestMangling.h -fno-pie -I/lib/modules/4.18.5-1-MANJARO/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxsf/ -I/tmp/vbox.0/vboxsf/include -I/tmp/vbox.0/vboxsf/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DVBOX_WITH_HGCM -DIN_MODULE -DIN_GUEST_R0 -DRT_NO_EXPORT_SYMBOL -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS  -DMODULE  -DKBUILD_BASENAME='"lnkops"' -DKBUILD_MODNAME='"vboxsf"' -c -o /tmp/vbox.0/.tmp_lnkops.o /tmp/vbox.0/lnkops.c
   ./tools/objtool/objtool orc generate  --module --no-fp  --retpoline "/tmp/vbox.0/.tmp_dirops.o";
  gcc -Wp,-MD,/tmp/vbox.0/.regops.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/include -I./arch/x86/include -I./arch/x86/include/generated  -I./include -I./arch/x86/include/uapi -I./arch/x86/include/generated/uapi -I./include/uapi -I./include/generated/uapi -include ./include/linux/kconfig.h -include ./include/linux/compiler_types.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -fshort-wchar -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -fno-PIE -DCC_HAVE_ASM_GOTO -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -m64 -falign-jumps=1 -falign-loops=1 -mno-80387 -mno-fp-ret-in-387 -mpreferred-stack-boundary=3 -mskip-rax-setup -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -DCONFIG_X86_X32_ABI -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_SSSE3=1 -DCONFIG_AS_CRC32=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -DCONFIG_AS_AVX512=1 -DCONFIG_AS_SHA1_NI=1 -DCONFIG_AS_SHA256_NI=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mindirect-branch=thunk-extern -mindirect-branch-register -DRETPOLINE -fno-delete-null-pointer-checks -Wno-frame-address -Wno-format-truncation -Wno-format-overflow -Wno-int-in-bool-context -O2 --param=allow-store-data-races=0 -Wframe-larger-than=2048 -fstack-protector-strong -Wno-unused-but-set-variable -Wno-unused-const-variable -fno-var-tracking-assignments -pg -mfentry -DCC_USING_FENTRY -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fno-merge-all-constants -fmerge-constants -fno-stack-check -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -Werror=date-time -Werror=incompatible-pointer-types -Werror=designated-init -fmacro-prefix-map=./= -Wno-packed-not-aligned -mrecord-mcount -Wno-declaration-after-statement -fshort-wchar -include /tmp/vbox.0/include/VBox/VBoxGuestMangling.h -fno-pie -I/lib/modules/4.18.5-1-MANJARO/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxsf/ -I/tmp/vbox.0/vboxsf/include -I/tmp/vbox.0/vboxsf/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DVBOX_WITH_HGCM -DIN_MODULE -DIN_GUEST_R0 -DRT_NO_EXPORT_SYMBOL -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS  -DMODULE  -DKBUILD_BASENAME='"regops"' -DKBUILD_MODNAME='"vboxsf"' -c -o /tmp/vbox.0/.tmp_regops.o /tmp/vbox.0/regops.c
   ./tools/objtool/objtool orc generate  --module --no-fp  --retpoline "/tmp/vbox.0/.tmp_lnkops.o";
  gcc -Wp,-MD,/tmp/vbox.0/.utils.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/include -I./arch/x86/include -I./arch/x86/include/generated  -I./include -I./arch/x86/include/uapi -I./arch/x86/include/generated/uapi -I./include/uapi -I./include/generated/uapi -include ./include/linux/kconfig.h -include ./include/linux/compiler_types.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -fshort-wchar -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -fno-PIE -DCC_HAVE_ASM_GOTO -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -m64 -falign-jumps=1 -falign-loops=1 -mno-80387 -mno-fp-ret-in-387 -mpreferred-stack-boundary=3 -mskip-rax-setup -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -DCONFIG_X86_X32_ABI -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_SSSE3=1 -DCONFIG_AS_CRC32=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -DCONFIG_AS_AVX512=1 -DCONFIG_AS_SHA1_NI=1 -DCONFIG_AS_SHA256_NI=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mindirect-branch=thunk-extern -mindirect-branch-register -DRETPOLINE -fno-delete-null-pointer-checks -Wno-frame-address -Wno-format-truncation -Wno-format-overflow -Wno-int-in-bool-context -O2 --param=allow-store-data-races=0 -Wframe-larger-than=2048 -fstack-protector-strong -Wno-unused-but-set-variable -Wno-unused-const-variable -fno-var-tracking-assignments -pg -mfentry -DCC_USING_FENTRY -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fno-merge-all-constants -fmerge-constants -fno-stack-check -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -Werror=date-time -Werror=incompatible-pointer-types -Werror=designated-init -fmacro-prefix-map=./= -Wno-packed-not-aligned -mrecord-mcount -Wno-declaration-after-statement -fshort-wchar -include /tmp/vbox.0/include/VBox/VBoxGuestMangling.h -fno-pie -I/lib/modules/4.18.5-1-MANJARO/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxsf/ -I/tmp/vbox.0/vboxsf/include -I/tmp/vbox.0/vboxsf/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DVBOX_WITH_HGCM -DIN_MODULE -DIN_GUEST_R0 -DRT_NO_EXPORT_SYMBOL -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS  -DMODULE  -DKBUILD_BASENAME='"utils"' -DKBUILD_MODNAME='"vboxsf"' -c -o /tmp/vbox.0/.tmp_utils.o /tmp/vbox.0/utils.c
   ./tools/objtool/objtool orc generate  --module --no-fp  --retpoline "/tmp/vbox.0/.tmp_regops.o";
  gcc -Wp,-MD,/tmp/vbox.0/.VBoxGuestR0LibHGCM.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/include -I./arch/x86/include -I./arch/x86/include/generated  -I./include -I./arch/x86/include/uapi -I./arch/x86/include/generated/uapi -I./include/uapi -I./include/generated/uapi -include ./include/linux/kconfig.h -include ./include/linux/compiler_types.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -fshort-wchar -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -fno-PIE -DCC_HAVE_ASM_GOTO -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -m64 -falign-jumps=1 -falign-loops=1 -mno-80387 -mno-fp-ret-in-387 -mpreferred-stack-boundary=3 -mskip-rax-setup -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -DCONFIG_X86_X32_ABI -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_SSSE3=1 -DCONFIG_AS_CRC32=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -DCONFIG_AS_AVX512=1 -DCONFIG_AS_SHA1_NI=1 -DCONFIG_AS_SHA256_NI=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mindirect-branch=thunk-extern -mindirect-branch-register -DRETPOLINE -fno-delete-null-pointer-checks -Wno-frame-address -Wno-format-truncation -Wno-format-overflow -Wno-int-in-bool-context -O2 --param=allow-store-data-races=0 -Wframe-larger-than=2048 -fstack-protector-strong -Wno-unused-but-set-variable -Wno-unused-const-variable -fno-var-tracking-assignments -pg -mfentry -DCC_USING_FENTRY -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fno-merge-all-constants -fmerge-constants -fno-stack-check -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -Werror=date-time -Werror=incompatible-pointer-types -Werror=designated-init -fmacro-prefix-map=./= -Wno-packed-not-aligned -mrecord-mcount -Wno-declaration-after-statement -fshort-wchar -include /tmp/vbox.0/include/VBox/VBoxGuestMangling.h -fno-pie -I/lib/modules/4.18.5-1-MANJARO/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxsf/ -I/tmp/vbox.0/vboxsf/include -I/tmp/vbox.0/vboxsf/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DVBOX_WITH_HGCM -DIN_MODULE -DIN_GUEST_R0 -DRT_NO_EXPORT_SYMBOL -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS  -DMODULE  -DKBUILD_BASENAME='"VBoxGuestR0LibHGCM"' -DKBUILD_MODNAME='"vboxsf"' -c -o /tmp/vbox.0/.tmp_VBoxGuestR0LibHGCM.o /tmp/vbox.0/VBoxGuestR0LibHGCM.c
   ./tools/objtool/objtool orc generate  --module --no-fp  --retpoline "/tmp/vbox.0/.tmp_VBoxGuestR0LibHGCM.o";
  gcc -Wp,-MD,/tmp/vbox.0/.VBoxGuestR0LibIdc.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/include -I./arch/x86/include -I./arch/x86/include/generated  -I./include -I./arch/x86/include/uapi -I./arch/x86/include/generated/uapi -I./include/uapi -I./include/generated/uapi -include ./include/linux/kconfig.h -include ./include/linux/compiler_types.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -fshort-wchar -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -fno-PIE -DCC_HAVE_ASM_GOTO -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -m64 -falign-jumps=1 -falign-loops=1 -mno-80387 -mno-fp-ret-in-387 -mpreferred-stack-boundary=3 -mskip-rax-setup -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -DCONFIG_X86_X32_ABI -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_SSSE3=1 -DCONFIG_AS_CRC32=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -DCONFIG_AS_AVX512=1 -DCONFIG_AS_SHA1_NI=1 -DCONFIG_AS_SHA256_NI=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mindirect-branch=thunk-extern -mindirect-branch-register -DRETPOLINE -fno-delete-null-pointer-checks -Wno-frame-address -Wno-format-truncation -Wno-format-overflow -Wno-int-in-bool-context -O2 --param=allow-store-data-races=0 -Wframe-larger-than=2048 -fstack-protector-strong -Wno-unused-but-set-variable -Wno-unused-const-variable -fno-var-tracking-assignments -pg -mfentry -DCC_USING_FENTRY -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fno-merge-all-constants -fmerge-constants -fno-stack-check -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -Werror=date-time -Werror=incompatible-pointer-types -Werror=designated-init -fmacro-prefix-map=./= -Wno-packed-not-aligned -mrecord-mcount -Wno-declaration-after-statement -fshort-wchar -include /tmp/vbox.0/include/VBox/VBoxGuestMangling.h -fno-pie -I/lib/modules/4.18.5-1-MANJARO/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxsf/ -I/tmp/vbox.0/vboxsf/include -I/tmp/vbox.0/vboxsf/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DVBOX_WITH_HGCM -DIN_MODULE -DIN_GUEST_R0 -DRT_NO_EXPORT_SYMBOL -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS  -DMODULE  -DKBUILD_BASENAME='"VBoxGuestR0LibIdc"' -DKBUILD_MODNAME='"vboxsf"' -c -o /tmp/vbox.0/.tmp_VBoxGuestR0LibIdc.o /tmp/vbox.0/VBoxGuestR0LibIdc.c
   ./tools/objtool/objtool orc generate  --module --no-fp  --retpoline "/tmp/vbox.0/.tmp_VBoxGuestR0LibIdc.o";
  gcc -Wp,-MD,/tmp/vbox.0/.VBoxGuestR0LibIdc-unix.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/include -I./arch/x86/include -I./arch/x86/include/generated  -I./include -I./arch/x86/include/uapi -I./arch/x86/include/generated/uapi -I./include/uapi -I./include/generated/uapi -include ./include/linux/kconfig.h -include ./include/linux/compiler_types.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -fshort-wchar -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -fno-PIE -DCC_HAVE_ASM_GOTO -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -m64 -falign-jumps=1 -falign-loops=1 -mno-80387 -mno-fp-ret-in-387 -mpreferred-stack-boundary=3 -mskip-rax-setup -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -DCONFIG_X86_X32_ABI -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_SSSE3=1 -DCONFIG_AS_CRC32=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -DCONFIG_AS_AVX512=1 -DCONFIG_AS_SHA1_NI=1 -DCONFIG_AS_SHA256_NI=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mindirect-branch=thunk-extern -mindirect-branch-register -DRETPOLINE -fno-delete-null-pointer-checks -Wno-frame-address -Wno-format-truncation -Wno-format-overflow -Wno-int-in-bool-context -O2 --param=allow-store-data-races=0 -Wframe-larger-than=2048 -fstack-protector-strong -Wno-unused-but-set-variable -Wno-unused-const-variable -fno-var-tracking-assignments -pg -mfentry -DCC_USING_FENTRY -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fno-merge-all-constants -fmerge-constants -fno-stack-check -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -Werror=date-time -Werror=incompatible-pointer-types -Werror=designated-init -fmacro-prefix-map=./= -Wno-packed-not-aligned -mrecord-mcount -Wno-declaration-after-statement -fshort-wchar -include /tmp/vbox.0/include/VBox/VBoxGuestMangling.h -fno-pie -I/lib/modules/4.18.5-1-MANJARO/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxsf/ -I/tmp/vbox.0/vboxsf/include -I/tmp/vbox.0/vboxsf/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DVBOX_WITH_HGCM -DIN_MODULE -DIN_GUEST_R0 -DRT_NO_EXPORT_SYMBOL -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS  -DMODULE  -DKBUILD_BASENAME='"VBoxGuestR0LibIdc_unix"' -DKBUILD_MODNAME='"vboxsf"' -c -o /tmp/vbox.0/.tmp_VBoxGuestR0LibIdc-unix.o /tmp/vbox.0/VBoxGuestR0LibIdc-unix.c
   ./tools/objtool/objtool orc generate  --module --no-fp  --retpoline "/tmp/vbox.0/.tmp_VBoxGuestR0LibIdc-unix.o";
  gcc -Wp,-MD,/tmp/vbox.0/.VBoxGuestR0LibSharedFolders.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/include -I./arch/x86/include -I./arch/x86/include/generated  -I./include -I./arch/x86/include/uapi -I./arch/x86/include/generated/uapi -I./include/uapi -I./include/generated/uapi -include ./include/linux/kconfig.h -include ./include/linux/compiler_types.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -fshort-wchar -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -fno-PIE -DCC_HAVE_ASM_GOTO -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -m64 -falign-jumps=1 -falign-loops=1 -mno-80387 -mno-fp-ret-in-387 -mpreferred-stack-boundary=3 -mskip-rax-setup -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -DCONFIG_X86_X32_ABI -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_SSSE3=1 -DCONFIG_AS_CRC32=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -DCONFIG_AS_AVX512=1 -DCONFIG_AS_SHA1_NI=1 -DCONFIG_AS_SHA256_NI=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mindirect-branch=thunk-extern -mindirect-branch-register -DRETPOLINE -fno-delete-null-pointer-checks -Wno-frame-address -Wno-format-truncation -Wno-format-overflow -Wno-int-in-bool-context -O2 --param=allow-store-data-races=0 -Wframe-larger-than=2048 -fstack-protector-strong -Wno-unused-but-set-variable -Wno-unused-const-variable -fno-var-tracking-assignments -pg -mfentry -DCC_USING_FENTRY -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fno-merge-all-constants -fmerge-constants -fno-stack-check -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -Werror=date-time -Werror=incompatible-pointer-types -Werror=designated-init -fmacro-prefix-map=./= -Wno-packed-not-aligned -mrecord-mcount -Wno-declaration-after-statement -fshort-wchar -include /tmp/vbox.0/include/VBox/VBoxGuestMangling.h -fno-pie -I/lib/modules/4.18.5-1-MANJARO/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxsf/ -I/tmp/vbox.0/vboxsf/include -I/tmp/vbox.0/vboxsf/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DVBOX_WITH_HGCM -DIN_MODULE -DIN_GUEST_R0 -DRT_NO_EXPORT_SYMBOL -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS  -DMODULE  -DKBUILD_BASENAME='"VBoxGuestR0LibSharedFolders"' -DKBUILD_MODNAME='"vboxsf"' -c -o /tmp/vbox.0/.tmp_VBoxGuestR0LibSharedFolders.o /tmp/vbox.0/VBoxGuestR0LibSharedFolders.c
   ./tools/objtool/objtool orc generate  --module --no-fp  --retpoline "/tmp/vbox.0/.tmp_VBoxGuestR0LibSharedFolders.o";
/tmp/vbox.0/utils.c: In function ‘sf_init_inode’:
/tmp/vbox.0/utils.c:165:28: error: passing argument 1 of ‘sf_ftime_from_timespec’ from incompatible pointer type [-Werror=incompatible-pointer-types]
     sf_ftime_from_timespec(&inode->i_atime, &info->AccessTime);
/tmp/vbox.0/utils.c:53:53: note: expected ‘struct timespec *’ but argument is of type ‘struct timespec64 *’
 static void sf_ftime_from_timespec(struct timespec *tv, RTTIMESPEC *ts)
/tmp/vbox.0/utils.c:166:28: error: passing argument 1 of ‘sf_ftime_from_timespec’ from incompatible pointer type [-Werror=incompatible-pointer-types]
     sf_ftime_from_timespec(&inode->i_ctime, &info->ChangeTime);
/tmp/vbox.0/utils.c:53:53: note: expected ‘struct timespec *’ but argument is of type ‘struct timespec64 *’
 static void sf_ftime_from_timespec(struct timespec *tv, RTTIMESPEC *ts)
/tmp/vbox.0/utils.c:167:28: error: passing argument 1 of ‘sf_ftime_from_timespec’ from incompatible pointer type [-Werror=incompatible-pointer-types]
     sf_ftime_from_timespec(&inode->i_mtime, &info->ModificationTime);
/tmp/vbox.0/utils.c:53:53: note: expected ‘struct timespec *’ but argument is of type ‘struct timespec64 *’
 static void sf_ftime_from_timespec(struct timespec *tv, RTTIMESPEC *ts)
/tmp/vbox.0/utils.c: In function ‘sf_setattr’:
/tmp/vbox.0/utils.c:377:54: error: passing argument 2 of ‘sf_timespec_from_ftime’ from incompatible pointer type [-Werror=incompatible-pointer-types]
             sf_timespec_from_ftime(&info.AccessTime, &iattr->ia_atime);
/tmp/vbox.0/utils.c:63:69: note: expected ‘struct timespec *’ but argument is of type ‘struct timespec64 *’
 static void sf_timespec_from_ftime(RTTIMESPEC *ts, struct timespec *tv)
/tmp/vbox.0/utils.c:379:60: error: passing argument 2 of ‘sf_timespec_from_ftime’ from incompatible pointer type [-Werror=incompatible-pointer-types]
             sf_timespec_from_ftime(&info.ModificationTime, &iattr->ia_mtime);
/tmp/vbox.0/utils.c:63:69: note: expected ‘struct timespec *’ but argument is of type ‘struct timespec64 *’
 static void sf_timespec_from_ftime(RTTIMESPEC *ts, struct timespec *tv)
cc1: some warnings being treated as errors
make[2]: *** [scripts/Makefile.build:317: /tmp/vbox.0/utils.o] Error 1
make[1]: *** [Makefile:1500: _module_/tmp/vbox.0] Error 2
make: *** [/tmp/vbox.0/Makefile.include.footer:101: vboxsf] Error 2

As i've posted now for multiple Testing updates, ever since kernel 4.18 arrived, my SFs have never worked with it, whilst they remain good with the older kernels. I do not know why it's not also a problem for you, but i hope it stays good for you.

Why are you doing this? linux418 is coming with vbox modules and they are working for me.

Because the entire time i've used Manjaro, when booting Manjaro VM Guests in my Manjaro Host, every time there's a VM kernel update, during the subsequent VM reboot these errors occur [one for each of my two Shared Folders]:

$ dmesg | grep vboxsf
[    7.581224] vboxsf: loading out-of-tree module taints kernel.
[   32.010685] vboxsf: Old binary mount data not supported, remove obsolete mount.vboxsf and/or update your VBoxService.
[   32.018141] vboxsf: Old binary mount data not supported, remove obsolete mount.vboxsf and/or update your VBoxService.

Those errors only stop occurring once i run that command... for all kernels prior to 4.18. For 4.18, i cannot eliminate the errors, & [consequently?] SF do not work in my 4.18, but do continue to work when booted into 4.14 & 4.17.

I assume you are trying to automount via fstab.

Have you see this thread? VirtualBox guest mount.vboxsf

The /usr/bin/mount.vboxsf binary shipped in virtualbox-guest-utils cannot be used with kernels 4.16 or newer.
The existence of /usr/bin/mount.vboxsf will prevent mounting shared folders from fstab. A workaround is to declare usr/bin/mount.vboxsf as NoExtract in /etc/pacman.conf. See FS#58272 for more information.

No. Instead am simply using the VirtualBox native internal function to do the automounting [which does not create any fstab entry, same as reported by @servimo per your kindly provided linked thread].

Oh!! I did not know that. It might explain why my SF have never worked in 4.18, but contradicts my daily experience with 4.17 [in which, as i've already said, SF still work ok].

Given i am not using the VM's fstab for the automounting, i doubt this putative workaround would be relevant to me.

Unless i can solve this, once the particular Testing update arrives that renders 4.17 EOL, i might need to revert to 4.14 LTS & "permanently lock" my VM to that kernel. That'd be a pity coz i like to preview & test updated kernels first in my VMs before later allowing them into my real Manjaro KDE Host.

1 Like

Again with the cold boot problem on the 4.19 kernel (bare metal), the version from this update. My reports drag behind because cold boot (like really cold not just power off) happens at most once per day.

A comparison of journal logs (no Xorg log made for problematic boot). Journal entries are close to identical until with the stalled boot they end with systemd flushing journal to persistent storage.

End of journal for stalled boot:

systemd-journald[236]: Journal started
systemd-journald[236]: Runtime journal (/run/log/journal/8ec1a30fcb784dba854f50b061a9ce4a) is 8.0M, max 799.8M, 791.8M free.
systemd-modules-load[230]: Inserted module 'vhba'
systemd[1]: Starting Flush Journal to Persistent Storage...
systemd-journald[236]: Time spent on flushing to /var is 124.940ms for 751 entries.

Comparable and immediately following entries from successful boot are:

systemd-journald[230]: Journal started
systemd-journald[230]: Runtime journal (/run/log/journal/8ec1a30fcb784dba854f50b061a9ce4a) is 8.0M, max 799.8M, 791.8M free.
systemd-modules-load[227]: Inserted module 'vhba'
systemd[1]: Starting Flush Journal to Persistent Storage...
systemd-journald[230]: Time spent on flushing to /var is 3.690ms for 752 entries.
systemd-journald[230]: System journal (/var/log/journal/8ec1a30fcb784dba854f50b061a9ce4a) is 1.3G, max 4.0G, 2.6G free.
systemd[1]: Started udev Coldplug all Devices.
systemd[1]: Started udev Kernel Device Manager.
systemd[1]: Started Flush Journal to Persistent Storage.
systemd-modules-load[227]: Inserted module 'nvidia'
kernel: nvidia-nvlink: Nvlink Core is being initialized, major device n>
kernel: nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io>
kernel: NVRM: loading NVIDIA UNIX x86_64 Kernel Module  396.54  Tue Aug>

Using the Magic SysRq REISUB sequence triggers a reboot which has always been successful and once booted the 4.19 kernel functions well. It just seems to trip over something in the cold boot process, occasionally... at least on my machine.

inxi -Fz

  Kernel: 4.19.0-1-MANJARO x86_64 bits: 64 Desktop: Xfce
  Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: Z170-D3H v: N/A serial: <filter> 
  Mobo: Gigabyte model: Z170-D3H-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F2 date: 07/24/2015 
  Topology: Quad Core model: Intel Core i5-6500 bits: 64 type: MCP 
  L2 cache: 6144 KiB 
  Speed: 800 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 
  Device-1: NVIDIA GM204 [GeForce GTX 970] driver: nvidia v: 396.54 
  Display: x11 server: X.Org 1.20.1 driver: nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 396.54 
  Device-1: Intel Sunrise Point-H HD Audio driver: snd_hda_intel 
  Device-2: NVIDIA GM204 High Definition Audio driver: snd_hda_intel 
  Device-3: Kingston type: USB driver: hid-generic,snd-usb-audio,usbhid 
  Sound Server: ALSA v: k4.19.0-1-MANJARO 
  Device-1: Intel Ethernet I219-V driver: e1000e 
  IF: enp0s31f6 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 3.00 TiB used: 797.52 GiB (25.9%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
  ID-2: /dev/sdb vendor: Seagate model: ST2000VN000-1HJ164 size: 1.82 TiB 
  ID-3: /dev/sdc vendor: Crucial model: CT1050MX300SSD1 size: 978.09 GiB 
  ID-1: / size: 944.52 GiB used: 248.33 GiB (26.3%) fs: ext4 dev: /dev/sdc2 
  ID-2: swap-1 size: 17.19 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdc3 
  System Temperatures: cpu: 27.0 C mobo: N/A gpu: nvidia temp: 41 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
  Processes: 181 Uptime: 1h 25m Memory: 15.62 GiB used: 1.45 GiB (9.3%) 
  Shell: bash inxi: 3.0.21 

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by