[Testing Update] 2018-08-31 - Haskell, LibSVG, Python

Added some more packages ...

:: Different sync package(s) in repository community x86_64

                             PACKAGE           2018-08-30           2018-08-31
                               cgrep            6.6.25-72            6.6.25-73
                             cryptol             2.6.0-14             2.6.0-15
                               darcs            2.14.1-42            2.14.1-43
                                dart             1.24.3-1              2.0.0-1
                            dscanner              0.5.8-1              0.5.9-1
                firefox-adblock-plus                3.3-1              3.3.1-1
                    firefox-noscript             10.1.9-1
                           git-annex        6.20180807-19        6.20180807-20
                haskell-authenticate            1.3.4-161            1.3.4-162
                         haskell-aws              0.20-69              0.20-70
              haskell-binary-conduit               1.3-42               1.3-43
               haskell-conduit-extra             1.3.0-49             1.3.0-50
          haskell-cryptohash-conduit            0.1.1-210            0.1.1-211
          haskell-cryptonite-conduit            0.2.2-104            0.2.2-105
                         haskell-dav            1.3.2-115            1.3.2-116
                 haskell-hjsonschema             1.9.0-75             1.9.0-76
                    haskell-hopenpgp             2.7.2-11             2.7.2-12
                       haskell-hpack            0.29.7-10            0.29.7-11
                haskell-html-conduit             1.3.1-31             1.3.1-32
                        haskell-http         4000.3.12-43         4000.3.12-44
                haskell-http-conduit             2.3.2-35             2.3.2-36
                   haskell-js-jquery            3.3.1-113            3.3.1-114
                haskell-monad-logger             0.3.29-7             0.3.29-8
                    haskell-mustache             2.3.0-76             2.3.0-77
                       haskell-nonce             1.0.7-24             1.0.7-25
                  haskell-persistent             2.8.2-63             2.8.2-64
           haskell-persistent-sqlite              2.8.2-6              2.8.2-7
         haskell-persistent-template             2.5.4-88             2.5.4-89
                       haskell-sandi             0.4.2-44             0.4.2-45
                         haskell-sbv              7.10-17              7.10-18
                       haskell-shake            0.16.4-77            0.16.4-78
             haskell-simple-sendfile            0.2.27-75            0.2.27-76
                 haskell-skylighting             0.7.2-19             0.7.2-20
            haskell-skylighting-core             0.7.2-19              0.7.3-1
                        haskell-warp            3.2.23-17            3.2.23-18
                 haskell-xml-conduit             1.8.0-51             1.8.0-52
                  haskell-xml-hamlet             0.5.0-46             0.5.0-47
                       haskell-yesod             1.6.0-96             1.6.0-97
                  haskell-yesod-auth             1.6.3-92             1.6.3-93
                  haskell-yesod-core             1.6.6-23             1.6.6-24
               haskell-yesod-default            1.2.0-378            1.2.0-379
                  haskell-yesod-form             1.6.2-27             1.6.2-28
            haskell-yesod-persistent             1.6.0-86             1.6.0-87
                haskell-yesod-static             1.6.0-78             1.6.0-79
                  haskell-yesod-test             1.6.5-25             1.6.5-26
                             hindent             5.2.7-17             5.2.7-18
                         hledger-api              1.10-37              1.10-38
                         hledger-web              1.10-48              1.10-49
                               hlint             2.1.10-8             2.1.10-9
                      hopenpgp-tools            0.21.2-18            0.21.2-19
                   python-hypothesis             3.69.9-1            3.69.12-1
                  python2-hypothesis             3.69.9-1            3.69.12-1
                          ruby-rspec              3.7.0-2              3.8.0-1
                     ruby-rspec-core              3.7.1-1              3.8.0-1
             ruby-rspec-expectations              3.7.0-2              3.8.1-1
                    ruby-rspec-mocks              3.7.0-2              3.8.0-1
                  ruby-rspec-support              3.7.1-1              3.8.0-1
                            sdrangel              4.0.5-3              4.0.7-1
                          shellcheck             0.5.0-81             0.5.0-83
                               stack            1.7.1-116            1.7.1-117
                      tamarin-prover             1.4.0-88             1.4.0-89
                            three.js                r95-1                r96-1
                              xmobar               0.27-7               0.27-8
                              gifski                    -              0.8.4-2
                                peek                    -              1.3.1-3
                                 urh                    -              2.2.4-2

:: Different sync package(s) in repository extra x86_64

                             PACKAGE           2018-08-30           2018-08-31
                              cowsay              3.03-10               3.04-1
                          fontconfig 1:2.13.0+15+gc60ed9e-1         1:2.13.1-1
                              kdiff3 0.9.98.git20180821-1 0.9.98.git20180830-1
                             librsvg 2:2.44.1+4+g708b7d95-1         2:2.44.2-1
                        python-numpy             1.15.0-2             1.15.1-1
                       python2-numpy             1.15.0-2             1.15.1-1
                         seahorse 3.20.0+288+gce2340dc-1 3.29.92+6+gdd81db31-1

:: Different sync package(s) in repository multilib x86_64

                             PACKAGE           2018-08-30           2018-08-31
                  lib32-fontconfig 1:2.13.0+15+gc60ed9e-1           1:2.13.1-1
                       lib32-librsvg 2.44.1+4+g708b7d95-1             2.44.2-1
                        lib32-json-c                    -             0.13.1-2
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

Ready for Stable ?!?

  • We are ready to move this to our stable branch
  • I still see some issues (post about them)

0 voters


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

AMD-Ucode introduction

All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.

LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.

Something using Perl/Python/glibc broke

Rebuilds needed! If it's an AUR package, rebuild it. If it's a repo package, please report and check back regularly for rebuilds.

Items from previous update sets

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

When updating with pacman -Syyu I got the following message (not sure what to do with this):

Rebuilding 32-bit fontconfig cache.../usr/share/fonts/100dpi: failed to write cache
/usr/share/fonts/75dpi: failed to write cache
/usr/share/fonts/cyrillic: failed to write cache
/usr/share/fonts/encodings/large: failed to write cache
/usr/share/fonts/util: failed to write cache


I can confirm this, same output here. No other issues tho ...

I am getting the same error - but I am on unstable, I get ithe error twice, fonconfig & 32bit. I must be special :smiley:

+1 on the font cache write error.

Not adding much to the conversation but same error here as everyone else above.

2 Packages updated successfully.
LXQT+Kernel 4.19
Otherwise I have the same error as above.

Same error here , also at startup I got the message no internet available (think it is coming from octopi), while I just could connect to the internet.

I also get the errors about the chache not building for fontconfig

(1/3) Aktualisiere fontconfig                      [######################] 100%
Rebuilding fontconfig cache.../usr/share/fonts/100dpi: failed to write cache
/usr/share/fonts/75dpi: failed to write cache
/usr/share/fonts/cyrillic: failed to write cache
/usr/share/fonts/encodings/large: failed to write cache
/usr/share/fonts/util: failed to write cache

other than that - fine



I've got the same message too on Octopi, but after finish, Octopi icon turn into green. I've checked on pacman, there is no error showing.

And also: https://gitlab.freedesktop.org/fontconfig/fontconfig/issues/107

Besides this, no problems at all.


The false status of the internet connection, is an old error. It sometimes occurs since kernel... hmmm...?? 4.10 ? or older...

A minor:
After the past e.g.3 testing updates, after the updates were installed, the update notifier stays green with the "!", and shows for today: 5 updates available ? It's gone after a reboot :wink:


Yes I noticed yesterday on xfce (testing) the ! was there for a while after I did the update, but after a couple of minutes or so it was gone again. Only on Plasma (testing) I get the internet not available error, but it was some days ago I saw this error, and now it was there again.

(1/2) upgrading fontconfig [------------------------------] 100%
Rebuilding fontconfig cache.../usr/share/fonts/Type1: failed to write cache
/usr/share/fonts/cyrillic: failed to write cache
/usr/share/fonts/encodings/large: failed to write cache
/usr/share/fonts/util: failed to write cache

File check:

/usr/share/fonts/cyrillic: only fonts.alias file; no fonts or .uuid

/usr/share/fonts/encodings/large: no .uuid file

/usr/share/fonts/Type1: empty directory

/usr/share/fonts/util: map files, no fonts or .uuid


as others, same error

Hi everyone. What I found so far (using Manjaro XFCE 18 beta):

  • The Live ISO (18.0-beta-6) gave me a network error (unable to connect). My Ethernet is a RTL8111/8168/8411 (Realtek) and obviously works fine on Manjaro 17.x.

    --- In spite of this I crossed my fingers and bite the bullet: formatted and installed, then full updates and seems to be "fixed" but now there is another detail with the network: I get connection but is taking almost a minute while it detects (icon rolling) and finally link is up. Not sure if this is related to the Kernel, DHCP, etc. On 17.x only takes a few seconds to complete.

  • If you open pamac and try to update/refresh with no network connection the graphical interface goes crazy and prints hundreds of messages all over the screen.

  • Like the rest, got the red icon issue (Updates) that doesn't go away once it finished updating. If you close session/restart it disappears.

  • The icons in panel are not resizing correctly when you change it's size. For example, the network icon never resizes but the sound one does (although not perfect). I'm using the default theme, by the way.

  • The mouse wheel is not working in some dialogs. The one I recall now, for example: Settings --> Appearance --> Icons tab. In my case I installed more icons and the list goes beyond the screen but can only scroll using the side bar.

That's it for now.

I <3 kernel 4.19.

My ability to suspend my computer is back ! :blush:

We are still working on linux419 to improve this next LTS release of the kernel.


Forum kindly sponsored by