[Testing Update] 2018-09-20 - Kernels, Pamac, Palemoon

Hi community,

Welcome to another testing update. So what do we have with this one?

  • latest updates to some of our kernels
  • some fixes for Pamac
  • updated palemoon

We hope with all these changes Manjaro to be more efficient for you all.


#bladebook - shipping to Europe this fall!

Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.


#beta-release - 18.0 will be available in late October!

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.


Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.122 [EOL]
  • linux44 4.4.157
  • linux49 4.9.128
  • linux414 4.14.71
  • linux417 4.17.19 [EOL]
  • linux418 4.18.9
  • linux419 4.19-rc4
  • linux414-rt 4.14.63_rt40
  • linux416-rt 4.16.18_rt11

Package Updates (Mon Sep 10 20:46:48 CEST 2018)

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-18           2018-09-20
-------------------------------------------------------------------------------
                        palemoon-bin             28.0.1-1             28.1.0-1
                    palemoon-i18n-ar             28.0.1-1             28.1.0-1
                    palemoon-i18n-bg             28.0.1-1             28.1.0-1
                    palemoon-i18n-cs             28.0.1-1             28.1.0-1
                    palemoon-i18n-da             28.0.1-1             28.1.0-1
                    palemoon-i18n-de             28.0.1-1             28.1.0-1
                    palemoon-i18n-el             28.0.1-1             28.1.0-1
                 palemoon-i18n-en-gb             28.0.1-1             28.1.0-1
                 palemoon-i18n-es-ar             28.0.1-1             28.1.0-1
                 palemoon-i18n-es-es             28.0.1-1             28.1.0-1
                 palemoon-i18n-es-mx             28.0.1-1             28.1.0-1
                    palemoon-i18n-fi             28.0.1-1             28.1.0-1
                    palemoon-i18n-fr             28.0.1-1             28.1.0-1
                    palemoon-i18n-gl             28.0.1-1             28.1.0-1
                    palemoon-i18n-hr             28.0.1-1             28.1.0-1
                    palemoon-i18n-hu             28.0.1-1             28.1.0-1
                    palemoon-i18n-id             28.0.1-1             28.1.0-1
                    palemoon-i18n-is             28.0.1-1             28.1.0-1
                    palemoon-i18n-it             28.0.1-1             28.1.0-1
                    palemoon-i18n-ja             28.0.1-1             28.1.0-1
                    palemoon-i18n-kn             28.0.1-1             28.1.0-1
                    palemoon-i18n-ko             28.0.1-1             28.1.0-1
                    palemoon-i18n-nl             28.0.1-1             28.1.0-1
                    palemoon-i18n-pl             28.0.1-1             28.1.0-1
                 palemoon-i18n-pt-br             28.0.1-1             28.1.0-1
                 palemoon-i18n-pt-pt             28.0.1-1             28.1.0-1
                    palemoon-i18n-ro             28.0.1-1             28.1.0-1
                    palemoon-i18n-ru             28.0.1-1             28.1.0-1
                    palemoon-i18n-sk             28.0.1-1             28.1.0-1
                    palemoon-i18n-sl             28.0.1-1             28.1.0-1
                    palemoon-i18n-sr             28.0.1-1             28.1.0-1
                 palemoon-i18n-sv-se             28.0.1-1             28.1.0-1
                    palemoon-i18n-tl             28.0.1-1             28.1.0-1
                    palemoon-i18n-tr             28.0.1-1             28.1.0-1
                    palemoon-i18n-uk             28.0.1-1             28.1.0-1
                    palemoon-i18n-vi             28.0.1-1             28.1.0-1
                 palemoon-i18n-zh-cn             28.0.1-1             28.1.0-1
                 palemoon-i18n-zh-tw             28.0.1-1             28.1.0-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-18           2018-09-20
-------------------------------------------------------------------------------
                            linux414            4.14.70-1            4.14.71-1
                    linux414-headers            4.14.70-1            4.14.71-1
                            linux418             4.18.8-2             4.18.9-1
                    linux418-headers             4.18.8-2             4.18.9-1
                      linux419 4.19rc4.0916.g7876320-1 4.19rc4.0920.g4b92e7f-1
              linux419-headers 4.19rc4.0916.g7876320-1 4.19rc4.0920.g4b92e7f-1
                             linux44            4.4.156-1            4.4.157-1
                     linux44-headers            4.4.156-1            4.4.157-1
                             linux49            4.9.127-1            4.9.128-1
                     linux49-headers            4.9.127-1            4.9.128-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-18           2018-09-20
-------------------------------------------------------------------------------
                  linux414-acpi_call             1.1.0-58             1.1.0-59
                   linux414-bbswitch               0.8-58               0.8-59
                linux414-broadcom-wl      6.30.223.271-58      6.30.223.271-59
                   linux414-catalyst     1:15.201.1151-58     1:15.201.1151-59
                linux414-ndiswrapper              1.61-58              1.61-59
                     linux414-nvidia           1:396.54-5           1:396.54-6
               linux414-nvidia-340xx           340.107-17           340.107-18
               linux414-nvidia-390xx             390.87-3             390.87-4
                   linux414-nvidiabl              0.88-58              0.88-59
                      linux414-r8168          8.045.08-46          8.045.08-47
                  linux414-rt3562sta        2.4.1.1_r4-58        2.4.1.1_r4-59
                        linux414-spl             0.7.10-1             0.7.10-2
                   linux414-tp_smapi              0.41-58              0.41-59
                linux414-vhba-module          20161009-58          20161009-59
   linux414-virtualbox-guest-modules             5.2.18-6             5.2.18-7
    linux414-virtualbox-host-modules             5.2.18-6             5.2.18-7
                        linux414-zfs             0.7.10-1             0.7.10-2
                  linux418-acpi_call              1.1.0-4              1.1.0-5
                   linux418-bbswitch                0.8-4                0.8-5
                linux418-broadcom-wl       6.30.223.271-4       6.30.223.271-5
                   linux418-catalyst      1:15.201.1151-4      1:15.201.1151-5
                linux418-ndiswrapper               1.61-4               1.61-5
                     linux418-nvidia           1:396.54-4           1:396.54-5
               linux418-nvidia-340xx            340.107-4            340.107-5
               linux418-nvidia-390xx             390.87-4             390.87-5
                   linux418-nvidiabl               0.88-4               0.88-5
                      linux418-r8168           8.045.08-4           8.045.08-5
                        linux418-spl             0.7.10-2             0.7.10-3
                   linux418-tp_smapi               0.41-4               0.41-5
                linux418-vhba-module           20161009-4           20161009-5
   linux418-virtualbox-guest-modules             5.2.18-4             5.2.18-5
    linux418-virtualbox-host-modules             5.2.18-4             5.2.18-5
                        linux418-zfs             0.7.10-2             0.7.10-3
                  linux419-acpi_call           1.1.0-0.17           1.1.0-0.18
                   linux419-bbswitch             0.8-0.17             0.8-0.18
                linux419-broadcom-wl    6.30.223.271-0.17    6.30.223.271-0.18
                   linux419-catalyst   1:15.201.1151-0.17   1:15.201.1151-0.18
                linux419-ndiswrapper            1.61-0.17            1.61-0.18
               linux419-nvidia-340xx         340.107-0.17         340.107-0.18
               linux419-nvidia-390xx          390.87-0.17          390.87-0.18
                   linux419-nvidiabl            0.88-0.17            0.88-0.18
                      linux419-r8168        8.045.08-0.17        8.045.08-0.18
                        linux419-spl          0.7.10-0.17          0.7.10-0.18
                   linux419-tp_smapi            0.41-0.17            0.41-0.18
                linux419-vhba-module        20161009-0.17        20161009-0.18
   linux419-virtualbox-guest-modules          5.2.18-0.17          5.2.18-0.18
    linux419-virtualbox-host-modules          5.2.18-0.17          5.2.18-0.18
                        linux419-zfs          0.7.10-0.17          0.7.10-0.18
                   linux44-acpi_call            1.1.0-109            1.1.0-110
                    linux44-bbswitch              0.8-109              0.8-110
                 linux44-broadcom-wl      6.30.223.271-79      6.30.223.271-80
                    linux44-catalyst    1:15.201.1151-109    1:15.201.1151-110
                 linux44-ndiswrapper              1.61-77              1.61-78
                      linux44-nvidia           1:396.54-5           1:396.54-6
                linux44-nvidia-340xx           340.107-14           340.107-15
                linux44-nvidia-390xx             390.87-3             390.87-4
                    linux44-nvidiabl             0.88-109             0.88-110
                       linux44-r8168          8.045.08-31          8.045.08-32
                   linux44-rt3562sta        2.4.1.1_r4-77        2.4.1.1_r4-78
                         linux44-spl             0.7.10-1             0.7.10-2
                    linux44-tp_smapi             0.41-109             0.41-110
                 linux44-vhba-module          20161009-77          20161009-78
    linux44-virtualbox-guest-modules             5.2.18-6             5.2.18-7
     linux44-virtualbox-host-modules             5.2.18-6             5.2.18-7
                         linux44-zfs             0.7.10-1             0.7.10-2
                   linux49-acpi_call             1.1.0-95             1.1.0-96
                    linux49-bbswitch               0.8-95               0.8-96
                 linux49-broadcom-wl      6.30.223.271-95      6.30.223.271-96
                    linux49-catalyst     1:15.201.1151-95     1:15.201.1151-96
                 linux49-ndiswrapper              1.61-93              1.61-94
                      linux49-nvidia           1:396.54-5           1:396.54-6
                linux49-nvidia-340xx           340.107-14           340.107-15
                linux49-nvidia-390xx             390.87-3             390.87-4
                    linux49-nvidiabl              0.88-95              0.88-96
                       linux49-r8168          8.045.08-35          8.045.08-36
                   linux49-rt3562sta        2.4.1.1_r4-93        2.4.1.1_r4-94
                         linux49-spl             0.7.10-1             0.7.10-2
                    linux49-tp_smapi              0.41-95              0.41-96
                 linux49-vhba-module          20161009-93          20161009-94
    linux49-virtualbox-guest-modules             5.2.18-6             5.2.18-7
     linux49-virtualbox-host-modules             5.2.18-6             5.2.18-7
                         linux49-zfs             0.7.10-1             0.7.10-2
                               pamac           7.1.0rc3-1           7.1.0rc4-2
             pamac-tray-appindicator           7.1.0rc3-1           7.1.0rc4-2
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Ready for Stable ?!?

  • We are ready to move this to our stable branch
  • I still see some issues (post about them)

0 voters

5 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


AMD-Ucode introduction

All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Items from previous update sets

Something using Perl/Python/glibc broke

Rebuilds needed! If it's an AUR package, rebuild it. If it's a repo package, please report and check back regularly for rebuilds.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.


File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.


:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1


:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.


gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice


I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.


Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/


Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.


Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

Missing an update for linux419-nvidia.

Edit: all good now. :smile:

1 Like

So, I have linux419-nvidia-340xx installed. Does it mean I should delay updating?

I think you will be fine.

Looking at the above Packages Updates linux419-nvidia-340xx went from 340.107-0.17 to 340.107-0.18. It is the 396.54 driver that did not get updated/built against the new version of the 419 kernel (i.e., specifically the package linux419-nvidia) or perhaps missed being uploaded. For me this results in the graphical environment failing to start with 4.19.

At a quick glance this was the only problem, and 4.18 works well for me. :smiley:

Thank you. You are, of course, correct. All went well.

Basically ok, except for the ongoing broken VB Shared Folders, which has afflicted each of the 4.18.x variants.

$ uname -a
Linux Manjaro_KDE_VM 4.18.9-1-MANJARO #1 SMP PREEMPT Thu Sep 20 04:58:28 UTC 2018 x86_64 GNU/Linux

This is what I got on my host:

dmesg | grep vboxsf
[    8.362207] vboxsf: err -19 connecting to guest PCI-device
[    8.362416] vboxsf: make sure you are inside a VirtualBox VM
[    8.362612] vboxsf: and check dmesg for vboxguest errors

Maybe start an investigation. I know the maintainer and we may find a solution for it.

1 Like

https://lists.manjaro.org/pipermail/manjaro-packages/Week-of-Mon-20180917/019126.html

Hmmm, i get nothing in my Host [KDE Stable]:

Summary
 ██████████████████  ████████     kdemeoz@GA-Z97-HD3-Tower
 ██████████████████  ████████     OS: Manjaro 17.1.12 Hakoila
 ██████████████████  ████████     Kernel: x86_64 Linux 4.14.70-1-MANJARO
 ██████████████████  ████████     Uptime: 0m
 ████████            ████████     Packages: 1806
 ████████  ████████  ████████     Shell: bash 4.4.23
 ████████  ████████  ████████     Resolution: 1920x1080
 ████████  ████████  ████████     DE: KDE 5.50.0 / Plasma 5.13.5
 ████████  ████████  ████████     WM: KWin
 ████████  ████████  ████████     GTK Theme: QtCurve [GTK2], Breath-Dark_kdemeoz-GTK3 [GTK3]
 ████████  ████████  ████████     Icon Theme: hicolor
 ████████  ████████  ████████     Font: Lato Regular
 ████████  ████████  ████████     CPU: Intel Core i7-4790 @ 8x 4GHz [52.0°C]
 ████████  ████████  ████████     GPU: Mesa DRI Intel(R) Haswell Desktop 
                                  RAM: 883MiB / 31589MiB
[kdemeoz@GA-Z97-HD3-Tower ~]$ dmesg | grep vboxsf
[kdemeoz@GA-Z97-HD3-Tower ~]$

[kdemeoz@GA-Z97-HD3-Tower ~]$ sudo dmesg | grep vboxsf
[sudo] password for kdemeoz: 
[kdemeoz@GA-Z97-HD3-Tower ~]$ 

My Stable Xfce VM does give errors, BUT despite these its SF still work fine:

Summary
[kdemeoz@manjaro-xfce-vm ~]$ uname -a
Linux manjaro-xfce-vm 4.18.8-2-MANJARO #1 SMP PREEMPT Sun Sep 16 08:34:49 UTC 2018 x86_64 GNU/Linux

[kdemeoz@manjaro-xfce-vm ~]$ dmesg | grep vboxsf
[    8.365799] vboxsf: loading out-of-tree module taints kernel.
[   37.910633] vboxsf: Old binary mount data not supported, remove obsolete mount.vboxsf and/or update your VBoxService.
[   37.913601] vboxsf: Old binary mount data not supported, remove obsolete mount.vboxsf and/or update your VBoxService.

Here's the errors for my problematic KDE Testing VM [whose SF have been broken ever since kernel 4.18.3 per my [Testing Update] 2018-08-18 - Kernels, Adapta, Clipit, Python]

Summary
[kdemeoz@Manjaro_KDE_VM ~]$ uname -a
Linux Manjaro_KDE_VM 4.18.9-1-MANJARO #1 SMP PREEMPT Thu Sep 20 04:58:28 UTC 2018 x86_64 GNU/Linux

[kdemeoz@Manjaro_KDE_VM ~]$ dmesg | grep vboxsf
[    8.627049] vboxsf: loading out-of-tree module taints kernel.
[   30.421726] vboxsf: Old binary mount data not supported, remove obsolete mount.vboxsf and/or update your VBoxService.
[   30.424349] vboxsf: Old binary mount data not supported, remove obsolete mount.vboxsf and/or update your VBoxService.
[kdemeoz@Manjaro_KDE_VM ~]$ 
1 Like

Update without problems. After reboot is all good.
LXQT with Kernel 4.19.

I meant more in the VM itself ...

Oh. When you said...

...i therefore thought you meant... Host pc. Now i think you instead mean the Guest OS, ie, the VM. In that case, i already pasted my result, above, ie:

[kdemeoz@Manjaro_KDE_VM ~]$ uname -a
Linux Manjaro_KDE_VM 4.18.9-1-MANJARO #1 SMP PREEMPT Thu Sep 20 04:58:28 UTC 2018 x86_64 GNU/Linux

[kdemeoz@Manjaro_KDE_VM ~]$ dmesg | grep vboxsf
[    8.627049] vboxsf: loading out-of-tree module taints kernel.
[   30.421726] vboxsf: Old binary mount data not supported, remove obsolete mount.vboxsf and/or update your VBoxService.
[   30.424349] vboxsf: Old binary mount data not supported, remove obsolete mount.vboxsf and/or update your VBoxService.
[kdemeoz@Manjaro_KDE_VM ~]$

I tried to run Vmware but it doesn't work anymore. I tried to repeat what I did during the installation, but I can't run it.

That's VMWare's slogan, isn't it? :rofl:

I'd use VMWare on one of its supported OS, and use Virtualbox or plain KVM on a rolling-release distro.

1 Like

I restarted my computer again, and VMware is running now.

I have another problem that isn't related to this update.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by