[Testing Update] 2018-09-26 - Gnome, Gambas, Firefox

Hi community,

So it took us some more days to push additional packages for the upcoming stable update-pack.

Here the brief overall changes with this update:

  • Latest Firefox-Dev
  • Gambas
  • Gnome packages
  • upstream fixes

We hope with all these changes Manjaro to be more efficient for you all.


#bladebook - shipping to Europe this fall!

Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.


#beta-release - 18.0 will be available in late October!

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.122 [EOL]
  • linux44 4.4.157
  • linux49 4.9.128
  • linux414 4.14.71
  • linux417 4.17.19 [EOL]
  • linux418 4.18.9
  • linux419 4.19-rc4
  • linux414-rt 4.14.71_rt44
  • linux416-rt 4.16.18_rt11

Package Updates (Wed Sep 26 07:30:53 CEST 2018)

  • testing community x86_64: 296 new and 295 removed package(s)
  • testing extra x86_64: 13 new and 13 removed package(s)
  • testing multilib x86_64: 1 new and 1 removed package(s)
:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-25           2018-09-26
-------------------------------------------------------------------------------
                              babeld              1.8.2-1              1.8.3-1
                          browserify             16.2.2-1             16.2.3-1
                       cabal-install           2.2.0.0-79           2.2.0.0-80
                               cgrep            6.6.25-82            6.6.25-83
                          clementine             1.3.1-19             1.3.1-20
                          cozy-stack           2018M3S6-1           2018M4S1-1
                               crash              7.2.3-1              7.2.4-1
                             cryptol             2.6.0-31             2.6.0-32
                               darcs            2.14.1-60            2.14.1-61
                         dns-lexicon              2.7.7-1              2.7.9-1
                         emby-server            3.5.2.0-1            3.5.3.0-1
           firefox-developer-edition             63.0b8-1             63.0b9-1
  firefox-developer-edition-i18n-ach             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-af             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-an             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-ar             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-as             63.0b8-1             63.0b9-1
  firefox-developer-edition-i18n-ast             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-az             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-be             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-bg             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-bn-bd             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-bn-in             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-br             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-bs             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-ca             63.0b8-1             63.0b9-1
  firefox-developer-edition-i18n-cak             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-cs             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-cy             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-da             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-de             63.0b8-1             63.0b9-1
  firefox-developer-edition-i18n-dsb             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-el             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-en-gb             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-en-us             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-en-za             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-eo             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-es-ar             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-es-cl             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-es-es             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-es-mx             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-et             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-eu             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-fa             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-ff             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-fi             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-fr             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-fy-nl             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-ga-ie             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-gd             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-gl             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-gn             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-gu-in             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-he             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-hi-in             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-hr             63.0b8-1             63.0b9-1
  firefox-developer-edition-i18n-hsb             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-hu             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-hy-am             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-ia             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-id             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-is             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-it             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-ja             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-ka             63.0b8-1             63.0b9-1
  firefox-developer-edition-i18n-kab             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-kk             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-km             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-kn             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-ko             63.0b8-1             63.0b9-1
  firefox-developer-edition-i18n-lij             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-lt             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-lv             63.0b8-1             63.0b9-1
  firefox-developer-edition-i18n-mai             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-mk             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-ml             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-mr             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-ms             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-my             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-nb-no             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-ne-np             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-nl             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-nn-no             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-or             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-pa-in             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-pl             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-pt-br             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-pt-pt             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-rm             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-ro             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-ru             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-si             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-sk             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-sl             63.0b8-1             63.0b9-1
  firefox-developer-edition-i18n-son             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-sq             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-sr             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-sv-se             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-ta             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-te             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-th             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-tr             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-uk             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-ur             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-uz             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-vi             63.0b8-1             63.0b9-1
   firefox-developer-edition-i18n-xh             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-zh-cn             63.0b8-1             63.0b9-1
firefox-developer-edition-i18n-zh-tw             63.0b8-1             63.0b9-1
                           firewalld              0.6.1-3              0.6.2-1
                                 fzy                0.9-1                1.0-1
                       gambas3-devel             3.11.3-2             3.11.3-3
                     gambas3-gb-args             3.11.3-2             3.11.3-3
                    gambas3-gb-cairo             3.11.3-2             3.11.3-3
                    gambas3-gb-chart             3.11.3-2             3.11.3-3
                  gambas3-gb-clipper             3.11.3-2             3.11.3-3
                  gambas3-gb-complex             3.11.3-2             3.11.3-3
                 gambas3-gb-compress             3.11.3-2             3.11.3-3
                    gambas3-gb-crypt             3.11.3-2             3.11.3-3
                     gambas3-gb-data             3.11.3-2             3.11.3-3
                       gambas3-gb-db             3.11.3-2             3.11.3-3
                  gambas3-gb-db-form             3.11.3-2             3.11.3-3
                 gambas3-gb-db-mysql             3.11.3-2             3.11.3-3
                  gambas3-gb-db-odbc             3.11.3-2             3.11.3-3
            gambas3-gb-db-postgresql             3.11.3-2             3.11.3-3
               gambas3-gb-db-sqlite3             3.11.3-2             3.11.3-3
                     gambas3-gb-dbus             3.11.3-2             3.11.3-3
                  gambas3-gb-desktop             3.11.3-2             3.11.3-3
            gambas3-gb-desktop-gnome             3.11.3-2             3.11.3-3
              gambas3-gb-desktop-x11             3.11.3-2             3.11.3-3
           gambas3-gb-eval-highlight             3.11.3-2             3.11.3-3
                     gambas3-gb-form             3.11.3-2             3.11.3-3
              gambas3-gb-form-dialog             3.11.3-2             3.11.3-3
              gambas3-gb-form-editor             3.11.3-2             3.11.3-3
                 gambas3-gb-form-mdi             3.11.3-2             3.11.3-3
               gambas3-gb-form-stock             3.11.3-2             3.11.3-3
            gambas3-gb-form-terminal             3.11.3-2             3.11.3-3
                      gambas3-gb-gmp             3.11.3-2             3.11.3-3
                      gambas3-gb-gsl             3.11.3-2             3.11.3-3
                      gambas3-gb-gtk             3.11.3-2             3.11.3-3
               gambas3-gb-gtk-opengl             3.11.3-2             3.11.3-3
                     gambas3-gb-gtk3             3.11.3-2             3.11.3-3
                    gambas3-gb-httpd             3.11.3-2             3.11.3-3
                    gambas3-gb-image             3.11.3-2             3.11.3-3
             gambas3-gb-image-effect             3.11.3-2             3.11.3-3
              gambas3-gb-image-imlib             3.11.3-2             3.11.3-3
                 gambas3-gb-image-io             3.11.3-2             3.11.3-3
                  gambas3-gb-inotify             3.11.3-2             3.11.3-3
                   gambas3-gb-libxml             3.11.3-2             3.11.3-3
                  gambas3-gb-logging             3.11.3-2             3.11.3-3
                      gambas3-gb-map             3.11.3-2             3.11.3-3
                 gambas3-gb-markdown             3.11.3-2             3.11.3-3
                    gambas3-gb-media             3.11.3-2             3.11.3-3
               gambas3-gb-media-form             3.11.3-2             3.11.3-3
                gambas3-gb-memcached             3.11.3-2             3.11.3-3
                     gambas3-gb-mime             3.11.3-2             3.11.3-3
                    gambas3-gb-mysql             3.11.3-2             3.11.3-3
                  gambas3-gb-ncurses             3.11.3-2             3.11.3-3
                      gambas3-gb-net             3.11.3-2             3.11.3-3
                 gambas3-gb-net-curl             3.11.3-2             3.11.3-3
                 gambas3-gb-net-pop3             3.11.3-2             3.11.3-3
                 gambas3-gb-net-smtp             3.11.3-2             3.11.3-3
                   gambas3-gb-openal             3.11.3-2             3.11.3-3
                   gambas3-gb-opengl             3.11.3-2             3.11.3-3
              gambas3-gb-opengl-glsl             3.11.3-2             3.11.3-3
               gambas3-gb-opengl-glu             3.11.3-2             3.11.3-3
               gambas3-gb-opengl-sge             3.11.3-2             3.11.3-3
                  gambas3-gb-openssl             3.11.3-2             3.11.3-3
                   gambas3-gb-option             3.11.3-2             3.11.3-3
                     gambas3-gb-pcre             3.11.3-2             3.11.3-3
                      gambas3-gb-pdf             3.11.3-2             3.11.3-3
                      gambas3-gb-qt4             3.11.3-2             3.11.3-3
                  gambas3-gb-qt4-ext             3.11.3-2             3.11.3-3
                      gambas3-gb-qt5             3.11.3-2             3.11.3-3
               gambas3-gb-qt5-opengl             3.11.3-2             3.11.3-3
               gambas3-gb-qt5-webkit             3.11.3-2             3.11.3-3
                   gambas3-gb-report             3.11.3-2             3.11.3-3
                  gambas3-gb-scanner             3.11.3-2             3.11.3-3
                      gambas3-gb-sdl             3.11.3-2             3.11.3-3
                gambas3-gb-sdl-sound             3.11.3-2             3.11.3-3
                     gambas3-gb-sdl2             3.11.3-2             3.11.3-3
               gambas3-gb-sdl2-audio             3.11.3-2             3.11.3-3
                 gambas3-gb-settings             3.11.3-2             3.11.3-3
                   gambas3-gb-signal             3.11.3-2             3.11.3-3
                     gambas3-gb-util             3.11.3-2             3.11.3-3
                 gambas3-gb-util-web             3.11.3-2             3.11.3-3
                      gambas3-gb-v4l             3.11.3-2             3.11.3-3
                       gambas3-gb-vb             3.11.3-2             3.11.3-3
                      gambas3-gb-web             3.11.3-2             3.11.3-3
                 gambas3-gb-web-feed             3.11.3-2             3.11.3-3
                 gambas3-gb-web-form             3.11.3-2             3.11.3-3
                      gambas3-gb-xml             3.11.3-2             3.11.3-3
                 gambas3-gb-xml-html             3.11.3-2             3.11.3-3
                  gambas3-gb-xml-rpc             3.11.3-2             3.11.3-3
                 gambas3-gb-xml-xslt             3.11.3-2             3.11.3-3
                         gambas3-ide             3.11.3-2             3.11.3-3
                     gambas3-runtime             3.11.3-2             3.11.3-3
                      gambas3-script             3.11.3-2             3.11.3-3
                           git-annex        6.20180913-18        6.20180913-19
                       gitlab-runner             11.2.0-1             11.3.0-1
                               gmock              1.8.1-1              1.8.1-2
                         gnome-boxes             3.30.0-3             3.30.1-1
                      gnome-software             3.30.0-1             3.30.1-1
    gnome-software-packagekit-plugin             3.30.0-1             3.30.1-1
                         gnome-usage             3.28.0-1             3.30.0-1
                               gtest              1.8.1-1              1.8.1-2
                                gtop              0.1.5-1              1.0.0-1
                haskell-authenticate            1.3.4-178            1.3.4-179
                         haskell-aws              0.20-86              0.20-87
              haskell-binary-conduit               1.3-49               1.3-50
                     haskell-conduit           1.3.0.3-35           1.3.0.3-36
               haskell-conduit-extra             1.3.0-57             1.3.0-58
                   haskell-criterion           1.5.1.0-26           1.5.1.0-27
          haskell-cryptohash-conduit            0.1.1-218            0.1.1-219
          haskell-cryptonite-conduit            0.2.2-112            0.2.2-113
                         haskell-dav            1.3.2-127            1.3.2-128
                   haskell-esqueleto    2.5.3.20180402-73    2.5.3.20180402-74
                        haskell-feed          1.0.0.0-112          1.0.0.0-113
                      haskell-hakyll          4.12.4.0-14          4.12.4.0-15
                 haskell-hjsonschema             1.9.0-91             1.9.0-92
                    haskell-hopenpgp             2.7.2-20             2.7.2-21
                       haskell-hpack             0.31.0-5             0.31.0-6
                haskell-html-conduit             1.3.1-40             1.3.1-41
                        haskell-http         4000.3.12-58         4000.3.12-59
                haskell-http-conduit             2.3.2-51             2.3.2-52
                   haskell-js-jquery            3.3.1-128            3.3.1-129
                haskell-monad-logger            0.3.29-15            0.3.29-16
                    haskell-mustache             2.3.0-90             2.3.0-91
                       haskell-nonce             1.0.7-29             1.0.7-30
                  haskell-persistent             2.8.2-75             2.8.2-76
           haskell-persistent-sqlite             2.8.2-19             2.8.2-20
         haskell-persistent-template            2.5.4-101            2.5.4-102
            haskell-project-template           0.2.0.1-87           0.2.0.1-88
                         haskell-rio            0.1.5.0-7            0.1.5.0-8
                       haskell-sandi             0.4.2-51             0.4.2-52
                         haskell-sbv               7.12-2               7.12-3
              haskell-servant-server          0.13.0.1-89          0.13.0.1-90
                       haskell-shake            0.16.4-94            0.16.4-95
             haskell-simple-sendfile            0.2.27-83            0.2.27-84
                       haskell-store          0.4.3.2-146          0.4.3.2-147
           haskell-tagstream-conduit          0.5.5.3-206          0.5.5.3-207
                    haskell-unliftio            0.2.8.0-2            0.2.8.1-1
              haskell-wai-app-static          3.1.6.2-108          3.1.6.2-109
                 haskell-wai-conduit           3.0.0.4-66           3.0.0.4-67
          haskell-wai-handler-launch           3.0.2.4-71           3.0.2.4-72
                        haskell-warp             3.2.25-7             3.2.25-8
                    haskell-warp-tls           3.2.4.3-87           3.2.4.3-88
                 haskell-xml-conduit            1.8.0.1-2            1.8.0.1-3
                  haskell-xml-hamlet             0.5.0-57             0.5.0-58
                        haskell-yaml           0.10.2.0-1           0.10.2.0-2
                       haskell-yesod            1.6.0-119            1.6.0-120
                  haskell-yesod-auth           1.6.4.1-12           1.6.4.1-13
                  haskell-yesod-core             1.6.6-40             1.6.6-41
               haskell-yesod-default            1.2.0-395            1.2.0-396
                  haskell-yesod-form             1.6.2-49             1.6.2-50
            haskell-yesod-persistent            1.6.0-106            1.6.0-107
                haskell-yesod-static             1.6.0-95             1.6.0-96
                  haskell-yesod-test             1.6.5-48             1.6.5-49
                           hedgewars          0.9.24.1-59          0.9.24.1-60
                             hindent             5.2.7-29             5.2.7-30
                         hledger-api              1.10-58              1.10-59
                         hledger-web              1.10-75              1.10-76
                               hlint            2.1.10-22            2.1.10-23
                              hoogle          5.0.17.3-95          5.0.17.3-96
                      hopenpgp-tools            0.21.2-29            0.21.2-30
                                 ivy              2.4.0-4              2.4.0-5
                  libpackagekit-glib             1.1.10-2             1.1.11-1
                               lynis              2.6.8-1              2.6.9-1
                           mediawiki             1.31.0-1             1.31.1-1
                      mediawiki-math             1.31.0-1             1.31.1-1
                               nauty              26r10-1              26r11-1
                      nginx-mainline             1.15.3-1             1.15.4-1
                                 nsd             4.1.24-1             4.1.25-1
                          packagekit             1.1.10-2             1.1.11-1
                              pandoc           2.2.3.2-36           2.2.3.2-37
                     pandoc-citeproc             0.14.4-7             0.14.4-8
                     pandoc-crossref           0.3.2.1-93           0.3.2.1-94
                         php-mongodb              1.5.2-2              1.5.3-2
                           postgrest           0.5.0.0-29           0.5.0.0-30
                     python-eventlet             0.24.1-1             0.24.1-2
                      python-markups              3.0.0-4              3.0.0-5
                    python2-eventlet             0.24.1-1             0.24.1-2
                     python2-markups              3.0.0-4              3.0.0-5
                                qcad           3.21.3.0-1           3.21.3.1-1
                           rng-tools                6.4-1                6.5-1
                          shellcheck            0.5.0-103            0.5.0-104
                         simple-scan             3.30.0-1             3.30.1-1
                               stack            1.7.1-144            1.7.1-145
                     stylish-haskell           0.9.2.0-70           0.9.2.0-71
                      tamarin-prover            1.4.0-105            1.4.0-106
                      wireguard-dkms       0.0.20180918-1       0.0.20180925-1
                     wireguard-tools       0.0.20180918-1       0.0.20180925-1
                              xmobar              0.27-27              0.27-28
                                yarn              1.9.4-1             1.10.0-1
                     gambas3-gb-term                    -             3.11.3-3


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-25           2018-09-26
-------------------------------------------------------------------------------
                              apache             2.4.34-1             2.4.35-1
                        dconf-editor             3.30.0-1             3.30.2-1
                                 gdm 3.30.0+6+g5db19c5b-1             3.30.1-1
                      gnome-contacts               3.30-1             3.30.1-1
                       gnome-session             3.30.0-1             3.30.1-1
                             hylafax              6.0.6-8              6.0.7-1
                           libdazzle             3.30.0-2             3.30.1-1
                              libgdm 3.30.0+6+g5db19c5b-1             3.30.1-1
                          postgresql               10.5-1               10.5-2
                     postgresql-docs               10.5-1               10.5-2
                     postgresql-libs               10.5-1               10.5-2
                             sysprof             3.30.0-1             3.30.1-1
                                 vlc              3.0.4-3              3.0.4-4


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-25           2018-09-26
-------------------------------------------------------------------------------
                          lib32-dbus             1.12.8-1            1.12.10-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

4 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Items from previous update sets

AMD-Ucode introduction

All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Something using Perl/Python/glibc broke

Rebuilds needed! If it's an AUR package, rebuild it. If it's a repo package, please report and check back regularly for rebuilds.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.


File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.


:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1


:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.


gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice


I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.


Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/


Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.


Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

hi, its actually linux 4.19rc5.0923.g6 being offered from testing branch currently. I'm running it and it works fine on both my machines

@Ste74, @Chrysostomus
Seems, after this update, the bug with wifi connection was solved. In any case, I tried to forget the connection I had active and reconnect form the panel menu and it worked flawlessly.
Overall, the system seems much snappier and smoother, however, I still have the 2 gnome-shell problems, I am not sure if the patch you mentioned on the other posted was already in this update...

Also, what I noticed that some apps (at least Nautilus and Pamac, random get closed), I could not find any particular factor predicting this behavior.

1 Like

Brave soul.

not really, they're near enough release ready now and someone has to try them with bare metal installs or any potential issues may not be discovered before these kernels are actually released.

the first couple of release candidates were of course lacking certain features and modules so wouldn't work but the last 3 have been fine.

4 Likes

after update can't open nemo as root from the menu it prompts for password but does not open the following errors are from the terminal.
Tried XFC beta iso and thunar also failed but only sudo thunar worked

[robin0800@robins-desktop ~]$ gksu nemo

(nemo:1700): GLib-GIO-CRITICAL **: 11:08:05.501: g_dbus_proxy_new_sync: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(nemo:1700): GLib-GIO-CRITICAL **: 11:08:05.502: g_dbus_connection_get_unique_name: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
[robin0800@robins-desktop ~]$ sudo nemo
[sudo] password for robin0800: 

(nemo:1714): GLib-GIO-CRITICAL **: 11:08:18.417: g_dbus_proxy_new_sync: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(nemo:1714): GLib-GIO-CRITICAL **: 11:08:18.418: g_dbus_connection_get_unique_name: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
Segmentation fault
[robin0800@robins-desktop ~]$ 

1 Like

does nemo support the (not-so-) new admin protocol?

nemo admin://

It partially works nemo opens but I can delete contents but a copy and paste fails

[robin0800@robins-desktop ~]$ sudo cp ~/Documents/printer/i-network-printer.png admin:///usr/share/system-config-printer/icons
[sudo] password for robin0800: 
cp: cannot create regular file 'admin:///usr/share/system-config-printer/icons': No such file or directory
[robin0800@robins-desktop ~]$ 

this of course works

[robin0800@robins-desktop ~]$ sudo cp ~/Documents/printer/i-network-printer.png /usr/share/system-config-printer/icons
[sudo] password for robin0800: 
[robin0800@robins-desktop ~]$ 

@Ste74, just a follow up to my previous comment. I sort found a workaround (solution?) for the double shell issue. I decided to switch to the Wayland (commented the line in the /etc/gdm/costum.conf file)session and while logged in into Wayland session there is only one Gnome shell, as expected. Then I logged back to Xorg session and there also was only 1 gnome-shell process.

Then, again if I uncomment WaylandEnable=false line, then I automatically enter to Xorg session and I have 2 gnome-shell processes.

Whereas, if I comment WaylandEnable=false then I have only 1 gnome-shell process, no matter which session I log in (Xorg or Wayland).

So the problem seems to be with the custom.conf file. In any case, I was also surprised to find the README file in the home directory, with the warning about the zombie shell, as it supposed to be solved.

I gave it a try today: linux419+nvidia+zfs+cinnamon
works fine so far!

Ops.. forgot to remove it from the skel folder .. thank you to point me :grin:

By default the WaylandEnable=false in Manjaro Gnome edition is uncommented so you propose to comment it ( #WayandEnable=false ) ?

realy ? last time I've installed gnome edition it was commented out

Yes, in that case, I dont have the double gnome-session issue on Xorg session

Ok, in GDM upstream repo we have others commits related .. GDM 3.30.1 contain this new commits so we will see if 3.30.1 version solve the issue :thinking:

1 Like

I had problem with gnome-shell after suspend or hibernate. When I try to wake up the notebook, didn't show password prompt and besides seeing the mouse moving, I have a black screen.

My only solution is to kill gnome-shell and start again. This happen after gnome 3.30 upgrade.

the admin protocol is for GUI apps only. So it wont work for terminal stuff - you have sudo for things on the terminal.

I do confirm this issue, I have the same problem on Manjaro Cinnamon, both on VM and real hardware. I can't open Nemo with elevated privilege, whether from the GUI (right-click) or with pkexec nemo.

The same issue exists on Arch Linux. Here's a thread about it: https://bbs.archlinux.org/viewtopic.php?id=240394
The situation is pretty bizarre. It seems that it appeared with the release of GTK 3.24 and according to this thread, downgrading GTK to 3.22 should fix the issue. But bizarrely, even with GTK 3.24, a dbus that has been compiled without the --without-x option makes the issue non-existent for whatever reason (I tried this one, and it worked on my side, I swear).

It has been reported to Linux Mint GitHub, but it has been closed by lelgh123linux almost instantly.

So yeah, so far, I see four possibilities:

  • Linux Mint fixes Nemo, which seems unlikely for now considering how fast the issue has been closed;
  • GTK devs fix the bugs in GTK that cause such faulty behavior when using a dbus compiled with --without-x;
  • Manjaro provides its own package that provides a dbus compiled without --without-x instead of using the package that comes from Arch Linux;
  • The maintainer of Nemo imitate Gnome devs and removes this feature completly from Nemo (no offense).

Yes.

But since I can't freely paste files wherever I want with Nemo using admin://, it already makes it almost useless for me.

1 Like

Work around

Created the below nemo action place it in ~/.local/share/nemo/actions
[Nemo Action]

Name=Open Folder as Root
Comment=
Exec=gksu dbus-launch nemo %F
Icon-Name=filenew
Selection=s
Extensions=dir;

Oh well, I guess it's less frightening than building and installing a slightly different dbus package. :sweat_smile:

PKGBUILD for dbus (use it at your OWN RISK)
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Tom Gundersen <teg@jklm.no>
# Contributor: Link Dupont <link@subpop.net>

pkgbase=dbus
pkgname=(dbus dbus-docs)
pkgver=1.12.10
pkgrel=0
pkgdesc="Freedesktop.org message bus system"
url="https://wiki.freedesktop.org/www/Software/dbus/"
arch=(x86_64)
license=(GPL custom)
depends=(libsystemd expat)
makedepends=(systemd xmlto docbook-xsl python yelp-tools doxygen git autoconf-archive graphviz)
_commit=f98e784bb6f18b4c28feca6a6e9d12b7bf021a00  # tags/dbus-1.12.10^0
source=("git+https://anongit.freedesktop.org/git/dbus/dbus#commit=$_commit")
sha256sums=('SKIP')
validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90'  # Simon McVittie <simon.mcvittie@collabora.co.uk>
              '3C8672A0F49637FE064AC30F52A43A1E4B77B059') # Simon McVittie <simon.mcvittie@collabora.co.uk>

pkgver() {
  cd dbus
  git describe --tags | sed 's/^dbus-//;s/-/+/g'
}

prepare() {
  cd dbus

  # Reduce docs size
  printf '%s\n' >>Doxyfile.in \
    HAVE_DOT=yes DOT_IMAGE_FORMAT=svg INTERACTIVE_SVG=yes

  NOCONFIGURE=1 ./autogen.sh
}

build() {
  cd dbus
  ./configure \
    --prefix=/usr \
    --sysconfdir=/etc \
    --localstatedir=/var \
    runstatedir=/run \
    --libexecdir=/usr/lib/dbus-1.0 \
    --with-system-socket=/run/dbus/system_bus_socket \
    --with-dbus-session-bus-connect-address=unix:runtime=yes \
    --with-dbus-user=dbus \
    --enable-user-session \
    --disable-static
  make
}

check() {
  make -C dbus check
}

package_dbus() {
  provides=(libdbus)
  conflicts=(libdbus)
  replaces=(libdbus)

  DESTDIR="$pkgdir" make -C dbus install

  rm -r "$pkgdir/var/run"

  install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING

  # We have a pre-assigned uid (81)
  echo 'u dbus 81 "System Message Bus"' |
    install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/dbus.conf"

  # Split docs
  mv "$pkgdir/usr/share/doc" "$srcdir"
}

package_dbus-docs() {
  pkgdesc+=" (documentation)"
  depends=()

  install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING

  mv doc "$pkgdir/usr/share"
}

# vim:set sw=2 et:

Forum kindly sponsored by