[Testing Update] 2018-09-27 - Kernels, Gnome, Deepin, Grub, Calamares

Hi community,

So it took us some more days to push additional packages for the upcoming stable update-pack.

Here the brief overall changes with this update:

  • I managed to complete my work on the smooth bootup experience. (Will be default by 18.0-beta-7)
  • Most of our kernels got updated (Showing the Manufacturer Logo thou-out the bootup is supported by 4.18.10+)
  • Further modifications to grub-quiet and calamares to support the smooth bootup
  • Deepin and Gnome packages got updated
  • upstream fixes

We hope with all these changes Manjaro to be more efficient for you all.


#bladebook - shipping to Europe this fall!

Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.


#beta-release - 18.0 will be available in late October!

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.123 [EOL]
  • linux44 4.4.158
  • linux49 4.9.129
  • linux414 4.14.72
  • linux417 4.17.19 [EOL]
  • linux418 4.18.10
  • linux419 4.19-rc5
  • linux414-rt 4.14.71_rt44
  • linux416-rt 4.16.18_rt11

Package Updates (Thu Sep 27 06:57:24 CEST 2018)

  • testing community x86_64: 59 new and 57 removed package(s)
  • testing core x86_64: 16 new and 16 removed package(s)
  • testing extra x86_64: 68 new and 67 removed package(s)
  • testing multilib x86_64: 1 new and 1 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-26           2018-09-27
-------------------------------------------------------------------------------
      deepin-desktop-schemas-manjaro           3.2.18.3-1           3.2.18.4-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-26           2018-09-27
-------------------------------------------------------------------------------
                                ccid             1.4.29-3             1.4.30-1
              deepin-desktop-schemas           3.2.18.3-1           3.2.18.4-1
                 deepin-file-manager          1:4.6.8.4-2          1:4.6.8.6-1
                       deepin-go-lib           1.2.16.1-1           1.2.16.3-1
                     deepin-launcher            4.4.5.5-1            4.4.5.6-1
                              fossil                2.6-1                2.7-1
                           git-annex        6.20180913-19        6.20180913-20
                         haskell-dav            1.3.2-128            1.3.2-129
                 haskell-shakespeare             2.0.17-3             2.0.18-1
                  haskell-xml-hamlet             0.5.0-58             0.5.0-59
                       haskell-yesod            1.6.0-120            1.6.0-121
                  haskell-yesod-auth           1.6.4.1-13           1.6.4.1-14
                  haskell-yesod-core             1.6.6-41             1.6.6-42
               haskell-yesod-default            1.2.0-396            1.2.0-397
                  haskell-yesod-form             1.6.2-50             1.6.2-51
            haskell-yesod-persistent            1.6.0-107            1.6.0-108
                haskell-yesod-static             1.6.0-96             1.6.0-97
                  haskell-yesod-test             1.6.5-49             1.6.5-50
                             hledger              1.10-24              1.10-25
                         hledger-api              1.10-59              1.10-60
                          hledger-ui              1.10-44              1.10-45
                         hledger-web              1.10-76              1.10-77
                              kcptun           20180922-1           20180926-1
                             libcerf                1.6-1                1.7-1
                              marked              0.5.0-1              0.5.1-1
                        milkytracker            1.02.00-1            1.02.00-2
                               opera       55.0.2994.61-1       56.0.3051.31-1
                 opera-ffmpeg-codecs      68.0.3440.106-1      69.0.3497.100-1
                                  pd             0.48.2-5             0.49.0-1
                        python-click                6.7-2                7.0-1
                   python-jsonpickle              0.9.6-2                1.0-1
                     python-networkx                2.1-3                2.2-1
             python-oslo-concurrency             3.28.0-1             3.28.1-1
                  python-oslo-config              6.5.0-1              6.5.1-1
                      python-oslo-db             4.41.0-1             4.41.1-1
                    python-oslo-i18n             3.22.0-1             3.22.1-1
                     python-oslo-log             3.40.0-1             3.40.1-1
           python-oslo-serialization             2.28.0-1             2.28.1-1
                 python-pytest-xdist             1.23.0-1             1.23.1-1
                       python2-click                6.7-2                7.0-1
                  python2-jsonpickle              0.9.6-2                1.0-1
                    python2-networkx                2.1-3                2.2-1
            python2-oslo-concurrency             3.28.0-1             3.28.1-1
                 python2-oslo-config              6.5.0-1              6.5.1-1
                     python2-oslo-db             4.41.0-1             4.41.1-1
                   python2-oslo-i18n             3.22.0-1             3.22.1-1
                    python2-oslo-log             3.40.0-1             3.40.1-1
          python2-oslo-serialization             2.28.0-1             2.28.1-1
                python2-pytest-xdist             1.23.0-1             1.23.1-1
                            qjackctl              0.5.3-1              0.5.4-1
                          rust-racer              2.1.5-1              2.1.6-1
                              sakura              3.6.0-1              3.6.0-2
                      tamarin-prover            1.4.0-106            1.4.0-107
                            three.js                r96-1                r97-1
                            viewnior                1.6-3                1.7-1
                                yarn             1.10.0-1             1.10.1-1
                     python-cmarkgfm                    -              0.4.1-1
                    python2-cmarkgfm                    -              0.4.1-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-26           2018-09-27
-------------------------------------------------------------------------------
                          grub-quiet            2.03.0-11            2.03.0-12
                            linux318           3.18.122-1           3.18.123-1
                    linux318-headers           3.18.122-1           3.18.123-1
                            linux414            4.14.71-1            4.14.72-1
                    linux414-headers            4.14.71-1            4.14.72-1
                            linux418             4.18.9-1            4.18.10-1
                    linux418-headers             4.18.9-1            4.18.10-1
                             linux44            4.4.157-1            4.4.158-1
                     linux44-headers            4.4.157-1            4.4.158-1
                             linux49            4.9.128-1            4.9.129-1
                     linux49-headers            4.9.128-1            4.9.129-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-26           2018-09-27
-------------------------------------------------------------------------------
                           ding-libs              0.6.1-1              0.6.1-2
                              sqlite             3.25.1-1             3.25.2-1
                     sqlite-analyzer             3.25.1-1             3.25.2-1
                          sqlite-doc             3.25.1-1             3.25.2-1
                          sqlite-tcl             3.25.1-1             3.25.2-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-26           2018-09-27
-------------------------------------------------------------------------------
                 calamares-git 3.2.3.r4970.5c6ae3f1b-1 3.2.3.r4981.2e6dd6a07-1
                  linux318-acpi_call             1.1.0-63             1.1.0-64
                   linux318-bbswitch               0.8-63               0.8-64
                linux318-broadcom-wl      6.30.223.271-39      6.30.223.271-40
                   linux318-catalyst     1:15.201.1151-53     1:15.201.1151-54
                linux318-ndiswrapper              1.61-39              1.61-40
                     linux318-nvidia           1:396.54-2           1:396.54-3
               linux318-nvidia-340xx            340.107-6            340.107-7
               linux318-nvidia-390xx             390.87-2             390.87-3
                   linux318-nvidiabl              0.88-53              0.88-54
                      linux318-r8168          8.045.08-18          8.045.08-19
                  linux318-rt3562sta        2.4.1.1_r4-39        2.4.1.1_r4-40
                        linux318-spl             0.7.10-1             0.7.10-2
                   linux318-tp_smapi              0.41-63              0.41-64
                linux318-vhba-module          20161009-39          20161009-40
   linux318-virtualbox-guest-modules             5.2.18-2             5.2.18-3
    linux318-virtualbox-host-modules             5.2.18-2             5.2.18-3
                        linux318-zfs             0.7.10-1             0.7.10-2
                  linux418-acpi_call              1.1.0-5              1.1.0-6
                   linux418-bbswitch                0.8-5                0.8-6
                linux418-broadcom-wl       6.30.223.271-5       6.30.223.271-6
                   linux418-catalyst      1:15.201.1151-5      1:15.201.1151-6
                linux418-ndiswrapper               1.61-5               1.61-6
                     linux418-nvidia           1:396.54-5           1:396.54-6
               linux418-nvidia-340xx            340.107-5            340.107-6
               linux418-nvidia-390xx             390.87-5             390.87-6
                   linux418-nvidiabl               0.88-5               0.88-6
                      linux418-r8168           8.045.08-5           8.045.08-6
                        linux418-spl             0.7.10-3             0.7.10-4
                   linux418-tp_smapi               0.41-5               0.41-6
                linux418-vhba-module           20161009-5           20161009-6
   linux418-virtualbox-guest-modules             5.2.18-5             5.2.18-6
    linux418-virtualbox-host-modules             5.2.18-5             5.2.18-6
                        linux418-zfs             0.7.10-3             0.7.10-4


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-26           2018-09-27
-------------------------------------------------------------------------------
                     accountsservice             0.6.50-1             0.6.53-1
                                  gc              7.6.6-1              7.6.8-1
                gnome-control-center 3.30.0+24+g81dec85a2-1           3.30.1-1
                       gnome-desktop           1:3.30.0-1           1:3.30.1-1
                         gnome-mines             3.30.1-1           3.30.1.1-1
               gnome-settings-daemon 3.30.0+7+gcba29e41-1             3.30.1-1
                            libiscsi             1.17.0-2             1.18.0-1
                               libnm        1.14.0-1 1.14.1dev+13+g0d3234478-1
                          libnm-glib        1.14.0-1 1.14.1dev+13+g0d3234478-1
                             libthai             0.1.27-1             0.1.28-1
                               libuv             1.23.0-1             1.23.1-1
                            libwacom               0.30-1               0.31-1
                             libxml2              2.9.8-4              2.9.8-5
                              maxima             5.41.0-6             5.41.0-7
                      networkmanager        1.14.0-1 1.14.1dev+13+g0d3234478-1
                                 ntp          4.2.8.p11-2          4.2.8.p12-2
                        python-numpy             1.15.1-1             1.15.2-1
                    python-pycparser               2.18-2               2.19-1
                       python2-numpy             1.15.1-1             1.15.2-1
                   python2-pycparser               2.18-2               2.19-1
                                qemu              3.0.0-1              3.0.0-2
                     qemu-arch-extra              3.0.0-1              3.0.0-2
                  qemu-block-gluster              3.0.0-1              3.0.0-2
                    qemu-block-iscsi              3.0.0-1              3.0.0-2
                      qemu-block-rbd              3.0.0-1              3.0.0-2
                    qemu-guest-agent              3.0.0-1              3.0.0-2
                       qemu-headless              3.0.0-1              3.0.0-2
            qemu-headless-arch-extra              3.0.0-1              3.0.0-2
                                sbcl             1.4.10-1             1.4.11-1
                           sg3_utils               1.42-1               1.43-1
                              thunar 1.8.1.11.gf5147445-1              1.8.2-1
                             tracker              2.1.4-1              2.1.5-1
                      tracker-miners              2.1.4-1              2.1.5-1
                            jfsutils                    -             1.1.15-6


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-09-26           2018-09-27
-------------------------------------------------------------------------------
                       lib32-libxml2              2.9.8-3              2.9.8-4
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

4 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Items from previous update sets

AMD-Ucode introduction

All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Something using Perl/Python/glibc broke

Rebuilds needed! If it's an AUR package, rebuild it. If it's a repo package, please report and check back regularly for rebuilds.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.


File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.


:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1


:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.


gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice


I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.


Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/


Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.


Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

How do i enable this?


The latest grub-quiet already has these options set in /etc/default/grub

However, silent boot does not mean you'll get silent REboot. There are still some irritatating messages during reboot process.

should just work if your system has UEFI. the Gigabyte logo appears on mine without changing anything for the split second loading the OS from SSD allows it too.

i am not using grub-quiet, but have those GRUB_CMDLINE options for silent boot enabled.

@anon71843593 : my system has UEFI, but i don't get the logo.
Edit : I figured it out; I had the grub background commented out in my /etc/default/grub. Thanks for the clue that the default options work.

Another successful update, except for the now-chronic breakage of Shared Folders in this VM if booted into the 4.18 kernel >4.18.3. SF remain good with the LTS kernel.

$ uname -a
Linux Manjaro_KDE_VM 4.18.10-1-MANJARO #1 SMP PREEMPT Wed Sep 26 18:24:24 UTC 2018 x86_64 GNU/Linux

Slightly terrified about gdm reset my session selection back to Gnome, I was staring on default Gnome session after login puzzled about what the heck am I looking at, after reboot, I chose my prefered session and it remembers it correctly.

What does it mean? I have a msi mainboard. Will it show the msi logo during boot? Until the login screen appears? That would be nice.

I'm still having issues with hardware accelerated video playback since the first testing update after the last stable. I was first writing about it here.

I did some more testing with enabling/disabling hardware acceleration in both Chromium and Firefox. On the latest stable I can play 4K 60 FPS videos with hardware acceleration on without any issues (it's a bit laggy without hw accl.) If I switch to the testing branch and apply the updates, then even 1080p 60 FPS videos are unwatchable with hw. acceleration on due to random few seconds skipping in the videos (audio is still paying while the video is frozen). It also seems worse without hardware acceleration on testing, but the issue there isn't the same (for example at a Twitch.tv video play back you can see the skipped frame stats and it's increasing without hw. acceleration, meanwhile on hw. acceleration the stat stays the same while the few seconds skippings happening).

I haven't seen anyone else writing about this issue in the last days. Is it only affecting my system? (Deepin, Linux 4.18, Ryzen 1600, RX 560) What part of the testing update could cause this?

Is it a problem with streaming videos or playing any video file? I'm a little confused because you mentioned VLC in your previous post.

After this update my gnome-session got worse. I have gdm display users, but without icons. If I select a Gnome session (my usual behavior) I don't have gnome-shell and have only a dialog asking to change default folders name to english (rather than Spanish).

There's no gnome-shell process. I'm now working on i3 (with some errors too). I tried to edit /etc/gdm/custom.conf as other user suggested, but without luck

Google-Chrome recommends turning off Settings>Advanced>System>Use hardware acceleration when available. I have always done this when using Chrome. I do not use Firefox.

I've been doing some testing.

  • Deepin-movie crashes if I open any file with segmentation fault (it's happening both in stable and testing).
  • VLC hardware acceleration setting in the GUI does nothing (either watching stream or opening a file) mostly. I'm guessing it's falling back to software rendering a lot.
  • If I open a file from a HDD with ExFAT file system, it lags a bit meanwhile getting high CPU usage on one core by mount.exfat root process. Broswing files are laggy too, listing files are slow, etc.
  • If I open a Twitch stream with hardware acceleration on with Chrome, I get the same results with VLC via Streamlink (same seconds long lags).
  • With 4K videos in VLC I'm getting different results all the time, but I don't see big changes between stable or testing branch, hw. acceleration on or off either.
  • Using mpv with --hwdec=vdapu --vo=vdpau or --hwdec=vaapi --vo=vaapi gets better results lag and FPS-wise, also vaapi try stated in the console that "Using hardware decoding (vaapi), that doesn't happened while trying other settings, but with both options, the video colors were low contrast. Kinda like gaining performance, while losing vibrant colors, things were just more grey.
  • Software decoding in browsers are fine in low res./low frames videos, then with 720p60 videos frame skipping / FPS drops start. Hardware decoding does these seconds long freezes, but smooth between these hiccups.

Maybe it's just my system. I don't really know what's the source of the issue, or how deep it is. Reverting back to stable solves the main issue, the second long freezes while watching high res./ high FPS online videos.

Not quite as smooth as the Spitfire in Phil's post, this is my Manjaro 17.1 based ISO KDE notebook install. I've switched them to grub-quiet. The Gigabyte desktop does similar:

Seeing as they are SSD powered I'm not too fussed about the logo being smooth as it's on screen for seconds.

You forgot to remove the fsck hook.

2 Likes

i'll do it now, this is my grub config:

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=491088a2-6534-43e3-b7d4-2885e061f021"
GRUB_CMDLINE_LINUX="acpi_osi=Linux acpi_osi=! acpi_osi='Windows 2015' acpi=force acpi_enforce_resources=lax i915.modeset=1 rd.udev.log-priority=3 scsi_mod.use_blk_mq=1"

EDIT - thanks for that reminder, it works perfectly now :slight_smile:

1 Like

@philm , any return about driver e1000e ?

Testing with i219-V is OK :ok_hand:

1 Like

Hmm, after this update, thunar won't start anymore.
Anyone else having this issue?

EDIT

Seems it's because I have "thunar --daemon" in my autostart applications. Somehow it get's stuck or so. If I kill that one (or disable and reboot), things are working again.

1 Like

Nothing special on my side.

Network:
  Device-1: Intel Ethernet I219-V driver: e1000e v: 3.2.6-k
1 Like

Forum kindly sponsored by