[Testing Update] 2018-10-03 - Grub-Quiet, Firefox-Dev, LLVM, Clang

Hi community,

So it took us some more days to push additional packages for the upcoming stable update-pack.

Here the brief overall changes with this update:

  • I managed to complete my work on the smooth bootup experience. (Will be default by 18.0-beta-7 [KDE,XFCE])
  • added grub-quiet-fedora
  • LLVM and CLANG got updated to 7.0
  • Firefox-Dev is now at 63.0b10
  • Upstream fixes incl. haskell and python packages

We hope with all these changes Manjaro to be more efficient for you all.


#bladebook - shipping to Europe this fall!

Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.


#beta-release - 18.0 will be available in late October!

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.123 [EOL]
  • linux44 4.4.159
  • linux49 4.9.139
  • linux414 4.14.73
  • linux417 4.17.19 [EOL]
  • linux418 4.18.11
  • linux419 4.19-rc6
  • linux414-rt 4.14.71_rt44
  • linux416-rt 4.16.18_rt11

Package Updates (Wed Oct 3 11:59:55 CEST 2018)

  • testing community x86_64: 303 new and 303 removed package(s)
  • testing core x86_64: 4 new and 1 removed package(s)
  • testing extra x86_64: 47 new and 45 removed package(s)
  • testing multilib x86_64: 10 new and 10 removed package(s)
:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-02           2018-10-03
-------------------------------------------------------------------------------
                              arpack              3.6.2-1              3.6.3-1
                           autorandr                1.6-3                1.7-1
                              batctl             2018.1-1             2018.3-1
                             beignet              1.3.2-2 1.3.2+12+gfc5f430c-1
                                borg              1.1.6-3              1.1.7-2
                               carla             1.9.11-1             1.9.11-2
                                cgal             4.12.1-1               4.13-1
                      cryptominisat5              5.6.3-2              5.6.5-1
                             crystal             0.26.1-2             0.26.1-4
                              csound             6.11.0-6             6.11.0-7
                          csound-doc             6.11.0-6             6.11.0-7
                            dietlibc               0.33-5               0.34-1
                             dovecot            2.3.2.1-3              2.3.3-1
                            dropbear            2018.76-1            2018.76-2
                           duplicity             0.7.17-1             0.7.18-1
                              embree              3.2.0-1              3.2.1-1
                               faust             2.5.23-3             2.5.23-4
           firefox-developer-edition             63.0b9-1            63.0b10-1
  firefox-developer-edition-i18n-ach             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-af             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-an             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-ar             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-as             63.0b9-1            63.0b10-1
  firefox-developer-edition-i18n-ast             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-az             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-be             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-bg             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-bn-bd             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-bn-in             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-br             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-bs             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-ca             63.0b9-1            63.0b10-1
  firefox-developer-edition-i18n-cak             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-cs             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-cy             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-da             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-de             63.0b9-1            63.0b10-1
  firefox-developer-edition-i18n-dsb             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-el             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-en-gb             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-en-us             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-en-za             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-eo             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-es-ar             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-es-cl             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-es-es             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-es-mx             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-et             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-eu             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-fa             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-ff             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-fi             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-fr             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-fy-nl             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-ga-ie             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-gd             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-gl             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-gn             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-gu-in             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-he             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-hi-in             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-hr             63.0b9-1            63.0b10-1
  firefox-developer-edition-i18n-hsb             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-hu             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-hy-am             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-ia             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-id             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-is             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-it             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-ja             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-ka             63.0b9-1            63.0b10-1
  firefox-developer-edition-i18n-kab             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-kk             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-km             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-kn             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-ko             63.0b9-1            63.0b10-1
  firefox-developer-edition-i18n-lij             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-lt             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-lv             63.0b9-1            63.0b10-1
  firefox-developer-edition-i18n-mai             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-mk             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-ml             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-mr             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-ms             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-my             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-nb-no             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-ne-np             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-nl             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-nn-no             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-or             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-pa-in             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-pl             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-pt-br             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-pt-pt             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-rm             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-ro             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-ru             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-si             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-sk             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-sl             63.0b9-1            63.0b10-1
  firefox-developer-edition-i18n-son             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-sq             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-sr             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-sv-se             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-ta             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-te             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-th             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-tr             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-uk             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-ur             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-uz             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-vi             63.0b9-1            63.0b10-1
   firefox-developer-edition-i18n-xh             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-zh-cn             63.0b9-1            63.0b10-1
firefox-developer-edition-i18n-zh-tw             63.0b9-1            63.0b10-1
                       gambas3-devel             3.11.3-3             3.11.4-1
                     gambas3-gb-args             3.11.3-3             3.11.4-1
                    gambas3-gb-cairo             3.11.3-3             3.11.4-1
                    gambas3-gb-chart             3.11.3-3             3.11.4-1
                  gambas3-gb-clipper             3.11.3-3             3.11.4-1
                  gambas3-gb-complex             3.11.3-3             3.11.4-1
                 gambas3-gb-compress             3.11.3-3             3.11.4-1
                    gambas3-gb-crypt             3.11.3-3             3.11.4-1
                     gambas3-gb-data             3.11.3-3             3.11.4-1
                       gambas3-gb-db             3.11.3-3             3.11.4-1
                  gambas3-gb-db-form             3.11.3-3             3.11.4-1
                 gambas3-gb-db-mysql             3.11.3-3             3.11.4-1
                  gambas3-gb-db-odbc             3.11.3-3             3.11.4-1
            gambas3-gb-db-postgresql             3.11.3-3             3.11.4-1
               gambas3-gb-db-sqlite3             3.11.3-3             3.11.4-1
                     gambas3-gb-dbus             3.11.3-3             3.11.4-1
                  gambas3-gb-desktop             3.11.3-3             3.11.4-1
            gambas3-gb-desktop-gnome             3.11.3-3             3.11.4-1
              gambas3-gb-desktop-x11             3.11.3-3             3.11.4-1
           gambas3-gb-eval-highlight             3.11.3-3             3.11.4-1
                     gambas3-gb-form             3.11.3-3             3.11.4-1
              gambas3-gb-form-dialog             3.11.3-3             3.11.4-1
              gambas3-gb-form-editor             3.11.3-3             3.11.4-1
                 gambas3-gb-form-mdi             3.11.3-3             3.11.4-1
               gambas3-gb-form-stock             3.11.3-3             3.11.4-1
            gambas3-gb-form-terminal             3.11.3-3             3.11.4-1
                      gambas3-gb-gmp             3.11.3-3             3.11.4-1
                      gambas3-gb-gsl             3.11.3-3             3.11.4-1
                      gambas3-gb-gtk             3.11.3-3             3.11.4-1
               gambas3-gb-gtk-opengl             3.11.3-3             3.11.4-1
                     gambas3-gb-gtk3             3.11.3-3             3.11.4-1
                    gambas3-gb-httpd             3.11.3-3             3.11.4-1
                    gambas3-gb-image             3.11.3-3             3.11.4-1
             gambas3-gb-image-effect             3.11.3-3             3.11.4-1
              gambas3-gb-image-imlib             3.11.3-3             3.11.4-1
                 gambas3-gb-image-io             3.11.3-3             3.11.4-1
                  gambas3-gb-inotify             3.11.3-3             3.11.4-1
                   gambas3-gb-libxml             3.11.3-3             3.11.4-1
                  gambas3-gb-logging             3.11.3-3             3.11.4-1
                      gambas3-gb-map             3.11.3-3             3.11.4-1
                 gambas3-gb-markdown             3.11.3-3             3.11.4-1
                    gambas3-gb-media             3.11.3-3             3.11.4-1
               gambas3-gb-media-form             3.11.3-3             3.11.4-1
                gambas3-gb-memcached             3.11.3-3             3.11.4-1
                     gambas3-gb-mime             3.11.3-3             3.11.4-1
                    gambas3-gb-mysql             3.11.3-3             3.11.4-1
                  gambas3-gb-ncurses             3.11.3-3             3.11.4-1
                      gambas3-gb-net             3.11.3-3             3.11.4-1
                 gambas3-gb-net-curl             3.11.3-3             3.11.4-1
                 gambas3-gb-net-pop3             3.11.3-3             3.11.4-1
                 gambas3-gb-net-smtp             3.11.3-3             3.11.4-1
                   gambas3-gb-openal             3.11.3-3             3.11.4-1
                   gambas3-gb-opengl             3.11.3-3             3.11.4-1
              gambas3-gb-opengl-glsl             3.11.3-3             3.11.4-1
               gambas3-gb-opengl-glu             3.11.3-3             3.11.4-1
               gambas3-gb-opengl-sge             3.11.3-3             3.11.4-1
                  gambas3-gb-openssl             3.11.3-3             3.11.4-1
                   gambas3-gb-option             3.11.3-3             3.11.4-1
                     gambas3-gb-pcre             3.11.3-3             3.11.4-1
                      gambas3-gb-pdf             3.11.3-3             3.11.4-1
                      gambas3-gb-qt4             3.11.3-3             3.11.4-1
                  gambas3-gb-qt4-ext             3.11.3-3             3.11.4-1
                      gambas3-gb-qt5             3.11.3-3             3.11.4-1
               gambas3-gb-qt5-opengl             3.11.3-3             3.11.4-1
               gambas3-gb-qt5-webkit             3.11.3-3             3.11.4-1
                   gambas3-gb-report             3.11.3-3             3.11.4-1
                  gambas3-gb-scanner             3.11.3-3             3.11.4-1
                      gambas3-gb-sdl             3.11.3-3             3.11.4-1
                gambas3-gb-sdl-sound             3.11.3-3             3.11.4-1
                     gambas3-gb-sdl2             3.11.3-3             3.11.4-1
               gambas3-gb-sdl2-audio             3.11.3-3             3.11.4-1
                 gambas3-gb-settings             3.11.3-3             3.11.4-1
                   gambas3-gb-signal             3.11.3-3             3.11.4-1
                     gambas3-gb-term             3.11.3-3             3.11.4-1
                     gambas3-gb-util             3.11.3-3             3.11.4-1
                 gambas3-gb-util-web             3.11.3-3             3.11.4-1
                      gambas3-gb-v4l             3.11.3-3             3.11.4-1
                       gambas3-gb-vb             3.11.3-3             3.11.4-1
                      gambas3-gb-web             3.11.3-3             3.11.4-1
                 gambas3-gb-web-feed             3.11.3-3             3.11.4-1
                 gambas3-gb-web-form             3.11.3-3             3.11.4-1
                      gambas3-gb-xml             3.11.3-3             3.11.4-1
                 gambas3-gb-xml-html             3.11.3-3             3.11.4-1
                  gambas3-gb-xml-rpc             3.11.3-3             3.11.4-1
                 gambas3-gb-xml-xslt             3.11.3-3             3.11.4-1
                         gambas3-ide             3.11.3-3             3.11.4-1
                     gambas3-runtime             3.11.3-3             3.11.4-1
                      gambas3-script             3.11.3-3             3.11.4-1
                             gbrainy            1:2.3.6-1            1:2.3.7-1
                               giada             0.15.0-3             0.15.2-1
                              gitlab             11.3.0-1             11.3.1-1
                       gitlab-gitaly            0.121.0-1            0.123.0-1
                       gitlab-runner             11.3.0-1             11.3.1-1
                    gitlab-workhorse              6.1.0-1              7.0.0-1
                             glslang           7.8.2853-1           7.9.2888-1
                              grails              3.3.5-1              3.3.8-1
                         grails-docs              3.3.5-1              3.3.8-1
              haskell-binary-orphans           0.1.8.0-59           0.1.8.0-60
                   haskell-criterion           1.5.1.0-36           1.5.1.0-37
              haskell-deferred-folds            0.9.7.1-3              0.9.8-1
                      haskell-hakyll          4.12.4.0-30          4.12.4.0-31
                       haskell-hasql           1.3.0.3-17           1.3.0.3-18
                  haskell-hasql-pool               0.5-17               0.5-18
           haskell-hasql-transaction               0.7-17               0.7-18
                    haskell-hopenpgp             2.7.2-26             2.7.2-27
                 haskell-ixset-typed                0.4-4            0.4.0.1-1
                 haskell-juicypixels              3.3.1-1              3.3.2-1
                  haskell-statistics          0.14.0.2-77          0.14.0.2-78
                haskell-text-builder              0.6.3-8              0.6.3-9
     haskell-vector-binary-instances              0.2.4-5              0.2.5-1
                           highlight               3.44-1               3.45-1
                       highlight-gui               3.44-1               3.45-1
                      hopenpgp-tools            0.21.2-36            0.21.2-37
                               idris             1.3.0-69             1.3.0-70
                                ispc              1.9.2-3              1.9.2-4
                             jenkins              2.143-1              2.144-1
                               julia            2:1.0.0-3            2:1.0.1-1
                          julia-docs            2:1.0.0-3            2:1.0.1-1
                              kcptun           20180926-1           20181002-1
                             keybase              2.6.2-1              2.7.0-1
                         keybase-gui              2.6.2-1              2.7.0-1
                              kotlin             1.2.70-1             1.2.71-1
                                 ldc           2:1.11.0-1           2:1.11.0-4
                             libcerf                1.7-1                1.8-1
                          liblphobos           2:1.11.0-1           2:1.11.0-4
                  libretro-core-info              1.7.4-1              1.7.5-1
                         libva-utils              2.2.0-1              2.3.0-1
                               mixxx              2.1.3-1              2.1.4-1
                       mod_passenger              5.3.4-1              5.3.5-1
                                mpop              1.2.8-1              1.4.0-1
                                 mpv           1:0.29.0-1           1:0.29.1-1
                                mypy              0.620-2              0.630-1
                                nccl            2.3.5.5-1            2.3.5.5-2
                 nginx-mod-passenger              5.3.4-1              5.3.5-1
                 openshadinglanguage             1.9.10-2             1.9.10-3
                              pandoc              2.3.1-2              2.3.1-3
                     pandoc-citeproc             0.14.5-3             0.14.5-4
                     pandoc-crossref            0.3.3.0-7            0.3.3.0-8
                           passenger              5.3.4-1              5.3.5-1
                            perl-cgi               4.38-2               4.40-1
                          pigeonhole              0.5.2-2              0.5.3-1
                               ponyc             0.24.4-1             0.24.4-2
                           postgrest           0.5.0.0-42           0.5.0.0-43
                           py3status               3.12-3               3.13-1
                      python-distlib              0.2.7-2              0.2.8-1
                   python-hypothesis             3.73.4-1             3.74.0-1
                         python-jedi             0.12.1-2             0.13.0-1
                    python-justbytes               0.11-1               0.11-2
                       python-llfuse              1.3.4-3              1.3.5-1
                        python-magic               5.30-2               5.34-1
                      python-path.py             11.4.1-1             11.5.0-1
                       python-pytest              3.8.1-1              3.8.2-1
                           python-z3              4.7.1-2              4.7.1-3
           python-zope-configuration              4.2.2-1              4.3.0-1
                     python2-distlib              0.2.7-2              0.2.8-1
                  python2-hypothesis             3.73.4-1             3.74.0-1
                        python2-jedi             0.12.1-2             0.13.0-1
                      python2-llfuse              1.3.4-3              1.3.5-1
                       python2-magic               5.30-2               5.34-1
                     python2-path.py             11.4.1-1             11.5.0-1
                      python2-pytest              3.8.1-1              3.8.2-1
                     python2-pytorch              0.4.1-5                    -
                python2-pytorch-cuda              0.4.1-5                    -
                          python2-z3              4.7.1-2              4.7.1-3
          python2-zope-configuration              4.2.2-1              4.3.0-1
                        qtcurve-gtk2  1.9.1.git20170710-2              1:1.9-1
                         qtcurve-kde  1.9.1.git20170710-2              1:1.9-1
                         qtcurve-qt4  1.9.1.git20170710-2              1:1.9-1
                         qtcurve-qt5  1.9.1.git20170710-2              1:1.9-1
                       qtcurve-utils  1.9.1.git20170710-2              1:1.9-1
                              radcli             1.2.10-1             1.2.11-1
                           retroarch              1.7.4-1              1.7.5-1
                retroarch-assets-xmb               1:69-1               1:74-1
                                 scp            2018.76-1            2018.76-2
                          shellcheck            0.5.0-117            0.5.0-118
                             shotcut           18.09.16-1           18.10.01-1
                               sigal              1.4.0-4              1.4.1-1
                        speed-dreams              2.2.1-3                    -
                          strongswan              5.7.0-1              5.7.1-1
                             stunnel               5.48-2               5.49-1
                      tamarin-prover            1.4.0-117            1.4.0-118
                           tinyproxy              1.8.4-4             1.10.0-1
                             todoman              3.4.0-5              3.4.1-1
                                 tor            0.3.3.9-1            0.3.4.8-1
                                 upx               3.94-1               3.95-1
                                xpra              2.3.2-1              2.3.4-1
                                  z3              4.7.1-2              4.7.1-3
                             zn_poly                0.9-4              0.9.1-1
           python-keras-applications                    -              1.0.6-2
          python-keras-preprocessing                    -              1.0.5-1
                             tinyemu                    -         2018_09_23-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-02           2018-10-03
-------------------------------------------------------------------------------
                   grub-quiet-fedora                    -        2.03.f29.60-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-02           2018-10-03
-------------------------------------------------------------------------------
                               audit              2.8.4-1              2.8.4-2
                        python-audit                    -              2.8.4-2
                       python2-audit                    -              2.8.4-2


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-02           2018-10-03
-------------------------------------------------------------------------------
                              bzflag             2.4.14-1             2.4.16-1
                               clang              6.0.1-2              7.0.0-1
                               clazy                1.4-1                1.4-3
                         compiler-rt              6.0.1-2              7.0.0-2
                                  di               4.46-1               4.47-1
                     enlightenment16             1.0.18-1             1.0.19-1
                               fping                4.0-2                4.1-1
                       gnome-builder             3.30.0-2             3.30.1-1
                            kdevelop              5.2.4-1              5.2.4-2
                              libclc  0.2.0+506+96d10f2-1  0.2.0+539+dabae5a-1
                             libical              3.0.3-3              3.0.4-1
                      libsignon-glib               1.15-2                2.0-1
                               libva              2.2.0-2              2.3.0-1
                   libva-mesa-driver             18.2.1-1             18.2.1-2
                             libyaml              0.1.7-1              0.2.1-1
                                 lld              6.0.1-1              7.0.0-1
                                lldb              6.0.1-1              7.0.0-1
                                llvm              6.0.1-4              7.0.0-1
                           llvm-libs              6.0.1-4              7.0.0-1
                          llvm-ocaml              6.0.1-4              7.0.0-1
                               lua51              5.1.5-6              5.1.5-7
                               lua52              5.2.4-2              5.2.4-3
                                mesa             18.2.1-1             18.2.1-2
                          mesa-vdpau             18.2.1-1             18.2.1-2
              networkmanager-openvpn              1.8.4-1              1.8.6-1
                             numactl             2.0.11-2             2.0.12-1
                         opencl-mesa             18.2.1-1             18.2.1-2
                              openmp              6.0.1-1              7.0.0-1
                       python-django              2.1.1-1              2.1.2-1
                    python-pyparsing              2.2.1-1              2.2.2-1
                    python-shiboken2             5.11.2-1             5.11.2-2
                      python2-django            1.11.15-1            1.11.16-1
                   python2-pyparsing              2.2.1-1              2.2.2-1
                           qt5-tools             5.11.2-1             5.11.2-2
                           qtcreator              4.7.1-1              4.7.1-3
                           shiboken2             5.11.2-1             5.11.2-2
                             signond               8.59-1               8.60-1
           telepathy-accounts-signon                1.0-2                1.0-3
                        vulkan-intel             18.2.1-1             18.2.1-2
                       vulkan-radeon             18.2.1-1             18.2.1-2
                            xerces-c              3.2.1-2              3.2.2-1
                        zabbix-agent             3.4.14-3              4.0.0-2
                 zabbix-frontend-php             3.4.14-3              4.0.0-2
                        zabbix-proxy             3.4.14-3              4.0.0-2
                       zabbix-server             3.4.14-3              4.0.0-2
                               llvm6                    -              6.0.1-2
                          llvm6-libs                    -              6.0.1-2


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-02           2018-10-03
-------------------------------------------------------------------------------
                         lib32-clang              6.0.1-1              7.0.0-1
                        lib32-libelf              0.171-1              0.174-1
             lib32-libva-mesa-driver             18.2.1-1             18.2.1-2
                          lib32-llvm              6.0.1-1              7.0.0-1
                     lib32-llvm-libs              6.0.1-1              7.0.0-1
                          lib32-mesa             18.2.1-1             18.2.1-2
                    lib32-mesa-vdpau             18.2.1-1             18.2.1-2
                        lib32-sqlite             3.24.0-1             3.25.2-1
                  lib32-vulkan-intel             18.2.1-1             18.2.1-2
                 lib32-vulkan-radeon             18.2.1-1             18.2.1-2
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

2 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Items from previous update sets

AMD-Ucode introduction

All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Something using Perl/Python/glibc broke

Rebuilds needed! If it's an AUR package, rebuild it. If it's a repo package, please report and check back regularly for rebuilds.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.


File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.


:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1


:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.


gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice


I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.


Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/


Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.


Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

Firefox-kde-opensuse has no language packages of it's own.
Trying to install one of the language pack want's to remove firefox-kde-opensuse and install firefox.
I had to download the language pack for de from the torvic repo.
firefox-kde-i18n-de-62.0-1-any.pkg.tar.xz

2 Likes

Adding some more packages to get v18.0-beta8 ready ...

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-03
-------------------------------------------------------------------------------
  manjaro-xfce-gtk3-minimal-settings           20180714-2           20181003-1
          manjaro-xfce-gtk3-settings           20180714-2           20181003-1
                     update-notifier              0.7.5-2              0.7.6-1
                    matcha-gtk-theme                    -           20180619-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-03
-------------------------------------------------------------------------------
                        cozy-desktop              3.9.0-1              3.9.0-2
                             git-lfs              2.5.2-1              2.5.2-2
                      haskell-hakyll          4.12.4.0-31          4.12.4.0-32
                       haskell-hslua              1.0.0-1              1.0.1-1
           haskell-hslua-module-text              0.2.0-1              0.2.0-2
                              pandoc              2.3.1-3              2.3.1-4
                     pandoc-citeproc             0.14.5-4             0.14.5-5
                     pandoc-crossref            0.3.3.0-8            0.3.3.0-9
                  perl-authen-radius               0.26-2               0.27-1
             perl-b-hooks-endofscope               0.21-4               0.24-1
                       perl-datetime               1.49-2               1.50-1
                perl-datetime-locale               1.20-1               1.22-1
                             perl-gd               2.68-2               2.69-1
                     python-oslotest              3.6.0-2              3.7.0-1
                          python-pbr              4.2.0-1              4.3.0-1
                    python2-oslotest              3.6.0-2              3.7.0-1
                         python2-pbr              4.2.0-1              4.3.0-1
                              rubber                1.4-2              1.5.1-1
                          shellcheck            0.5.0-118            0.5.0-119


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-03
-------------------------------------------------------------------------------
                   manjaro-architect             0.9.18-1             0.9.19-1
          manjaro-architect-launcher             0.9.18-1             0.9.19-1
                    xfce4-panel-gtk3             4.13.3-3             4.13.3-4
                 xfce4-settings-gtk3             4.13.4-5             4.13.5-1
               manjaro-architect-dev                    - 0.9.18.r0.g9aa632a-1
      manjaro-architect-dev-launcher                    - 0.9.18.r0.g9aa632a-1
1 Like

Suffering from the same issue.
what is torvic repo? do they have language pack for en-gb?

Yes, here is strits mirror of the torvic9 repository:
http://mirror.strits.dk/torvic9/x86_64/

However, Theodin is curently building 62.0.3 on the opensuse build server.

I'm sure it will soon be in Theodin's Arch repository, currently at 62.0.2:
https://thaodan.de/home/bidar/home-thaodan/x86_64/

PS. I'm not sure why Manjaro is still at 62.0, and not 62.0.2.
It almost seems like this package is not being tracked, and/or merged with any regularity.

Note: This is not about missing language packs per-say, firefox-kde-opensuse provides firefox and thus the same language pack packages can be used by both. This is more about a versioning mismatch of 62.0 vs 62.0.3. Unfortunately, the language pack packages have a strict dependency on the Firefox version, 62.0.3 in this instance, which is what is causing the issue.

Matcha theme is a nice addition! :slight_smile:

1 Like

It is always the same issue with firefox-kde-opensuse. @jonathon is sometimes "too" fast with security updates of firefox :wink:

I pretty sure the i18n packages don't need to strictly depend on minor revision releases (as in Major.Minor.Revision), but hey, it is what it is.

Yeah, I also have the same problem with firefox-kde-opensuse. I just withhold updates and wait a couple of days till firefox-kde shows up. It's an annoyance but nothing serious.

I think the issue can be solved if there would be separate language packs for kde version and if it would depend on them. On another hand, such language packs would be identical so having just differently named the same packages is also a not a clean solution.

I guess only a few and most likely experienced users install ff-kde version so we can handle this annoyance ;).

Well, since firefox-kde-opensuse is the default for the Netrunner Edition, it's not quite just experienced users. But like I said, it is what it is.

well normally it is no problem in stable, but this time the language pack updates are waiting since the 18-09-21-update...

I do understand what your saying.

However, Theodin seems to update the firefox-kde-opensuse package in his arch repo quite regularly, but for some reason or another Manjaro doesn't seem to push it to stable with the others. For example, 62.0.2 has been in his repository and Manjaro testing since September, yet Manjaro is still only providing 62.0 of his package in the stable branch.

And yes this does effect stable, as of right now anyone using firefox-kde-opensuse can not install the extra language packs. These will want to remove firefox-kde-opensuse and install firefox since they have a strict dependency on Firefox being greater than, or equal to, version 62.0.3..
Screenshot_20181003_143756

Well, I didn't update the stable branch since weeks. firefox-kde-opensuse is a thirdparty package we re-sign and push to our repos when available. @jonathon is mostly coordinating security updates and pushes firefox on regular basis over to all branches. I doubt he wants to build also the firefox-kde-opensuse package. The language-packages are also upstream fixed with >= in the PKGBUILD. Currently I've no focus on the firefox-kde-opensuse package, as we normally don't use it at all on our end. However, you may ping me when there is a new package available.

understandable. Maybe loosening the strict dependency (as @AJSlye suggests) would really be a good idea?

First, yes, I do realize that these are third party packages, and that the i18n packages are coming from upstream.

Second, I wasn't complaining mind you, I was just pointing something out.

I was also editing my thread post and did change that to say:

Thus giving Manjaro credit where it is due, since this was updated to 62.0.2 in testing.

I would never suggest that @jonathon have to compile this extensive and time consuming application.
I think it's more of a matter of what, and when, things get pushed out into stable.

Just like I didn't understand why, if firefox-kde-opensuse 62.0.2 was already in testing, that it didn't get pushed out into stable last month with the other firefox 62.0.2 packages?

NOTE: I'm also not the only one that was originally asking for this package to be provided.
I am however, very thankful for the effort, and all that you are trying to do in this regard..

1 Like

Added some more packages to testing. Looking forward to build KDE 18.0-beta8 :wink:

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-03
-------------------------------------------------------------------------------
                    linux-rt-manjaro               4.16-1               4.18-1
          linux-rt-manjaro-acpi_call               4.16-1               4.18-1
           linux-rt-manjaro-bbswitch               4.16-1               4.18-1
        linux-rt-manjaro-broadcom-wl               4.16-1               4.18-1
           linux-rt-manjaro-catalyst               4.16-1               4.18-1
            linux-rt-manjaro-headers               4.16-1               4.18-1
       linux-rt-manjaro-nvidia-340xx               4.16-1               4.18-1
             linux-rt-manjaro-nvidia               4.16-1               4.18-1
           linux-rt-manjaro-nvidiabl               4.16-1               4.18-1
              linux-rt-manjaro-r8168               4.16-1               4.18-1
          linux-rt-manjaro-rt3562sta               4.16-1               4.18-1
           linux-rt-manjaro-tp_smapi               4.16-1               4.18-1
        linux-rt-manjaro-vhba-module               4.16-1               4.18-1
linux-rt-manjaro-virtualbox-guest-modules          4.16-1               4.18-1
linux-rt-manjaro-virtualbox-host-modules           4.16-1               4.18-1
       linux-rt-manjaro-nvidia-304xx                    -               4.18-1
                         linux418-rt                    -         4.18.7_rt5-1
               linux418-rt-acpi_call                    -              1.1.0-1
                linux418-rt-bbswitch                    -                0.8-1
             linux418-rt-broadcom-wl                    -       6.30.223.271-1
                linux418-rt-catalyst                    -      1:15.201.1151-1
                 linux418-rt-headers                    -         4.18.7_rt5-1
                  linux418-rt-nvidia                    -           1:410.57-1
            linux418-rt-nvidia-304xx                    -          1:304.137-1
            linux418-rt-nvidia-340xx                    -            340.107-1
            linux418-rt-nvidia-390xx                    -             390.87-1
                linux418-rt-nvidiabl                    -               0.88-1
                   linux418-rt-r8168                    -           8.045.08-1
                linux418-rt-tp_smapi                    -               0.41-1
             linux418-rt-vhba-module                    -           20161009-1
linux418-rt-virtualbox-guest-modules                    -             5.2.18-1
 linux418-rt-virtualbox-host-modules                    -             5.2.18-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-03
-------------------------------------------------------------------------------
                            audacity              2.2.2-3              2.3.0-1
                           auditbeat              6.4.1-1              6.4.2-1
                bash-language-server              1.5.2-1              1.5.3-1
                       elasticsearch              6.4.1-1              6.4.2-1
                            filebeat              6.4.1-1              6.4.2-1
                           git-annex         6.20180926-3         6.20180926-4
   haskell-bytestring-strict-builder           0.4.5.1-32           0.4.5.1-33
                       haskell-hasql           1.3.0.3-18           1.3.0.3-19
                  haskell-hasql-pool               0.5-18               0.5-19
           haskell-hasql-transaction               0.7-18               0.7-19
                 haskell-hledger-lib              1.10-19               1.11-1
           haskell-postgresql-binary          0.12.1.1-51          0.12.1.1-52
                      haskell-rebase             1.2.4-36                1.3-1
                    haskell-rerebase             1.2.2-36                1.3-1
                 haskell-tasty-rerun            1.1.12-35             1.1.13-1
                haskell-text-builder              0.6.3-9             0.6.3-10
                   heartbeat-elastic              6.4.1-1              6.4.2-1
                             hledger              1.10-32               1.11-1
                         hledger-api              1.10-73               1.11-1
                          hledger-ui              1.10-55               1.11-1
                         hledger-web              1.10-90               1.11-1
                               idris             1.3.0-70             1.3.0-71
                              kibana              6.4.1-1              6.4.2-1
                             liblscp              0.5.8-3              0.6.0-1
                            logstash              6.4.1-1              6.4.2-1
                         meterbridge              0.9.2-2              0.9.3-1
                          metricbeat              6.4.1-1              6.4.2-1
                          packetbeat              6.4.1-1              6.4.2-1
                               pdfjs            1.9.426-3           1.10.100-1
                                 pm2              3.1.3-1              3.2.1-1
                           postgrest           0.5.0.0-43           0.5.0.0-44
                           python-fs              2.1.0-1              2.1.1-1
                         python-furl              1.2.1-1              2.0.0-1
                          python2-fs              2.1.0-1              2.1.1-1
                        python2-furl              1.2.1-1              2.0.0-1
                         qutebrowser              1.4.2-2              1.5.0-1
          haskell-cassava-megaparsec                    -              1.0.0-1
            haskell-hspec-megaparsec                    -              1.1.0-1
                          libchewing                    -              0.5.1-1
                        scim-chewing                    -              0.3.5-4


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-03
-------------------------------------------------------------------------------
                                grub           2.03.0-7.1             2.03.0-8
                   grub-quiet-fedora        2.03.60.f29-2        2.03.60.f29-3


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-03
-------------------------------------------------------------------------------
                 calamares-git 3.2.3.r4987.040c5cdf6-1 3.2.3.r5043.69d86ce2c-1
                             firefox             62.0.3-0                    -
                    firefox-i18n-ach             62.0.3-0                    -
                     firefox-i18n-af             62.0.3-0                    -
                     firefox-i18n-an             62.0.3-0                    -
                     firefox-i18n-ar             62.0.3-0                    -
                     firefox-i18n-as             62.0.3-0                    -
                    firefox-i18n-ast             62.0.3-0                    -
                     firefox-i18n-az             62.0.3-0                    -
                     firefox-i18n-be             62.0.3-0                    -
                     firefox-i18n-bg             62.0.3-0                    -
                  firefox-i18n-bn-bd             62.0.3-0                    -
                  firefox-i18n-bn-in             62.0.3-0                    -
                     firefox-i18n-br             62.0.3-0                    -
                     firefox-i18n-bs             62.0.3-0                    -
                     firefox-i18n-ca             62.0.3-0                    -
                    firefox-i18n-cak             62.0.3-0                    -
                     firefox-i18n-cs             62.0.3-0                    -
                     firefox-i18n-cy             62.0.3-0                    -
                     firefox-i18n-da             62.0.3-0                    -
                     firefox-i18n-de             62.0.3-0                    -
                    firefox-i18n-dsb             62.0.3-0                    -
                     firefox-i18n-el             62.0.3-0                    -
                  firefox-i18n-en-gb             62.0.3-0                    -
                  firefox-i18n-en-us             62.0.3-0                    -
                  firefox-i18n-en-za             62.0.3-0                    -
                     firefox-i18n-eo             62.0.3-0                    -
                  firefox-i18n-es-ar             62.0.3-0                    -
                  firefox-i18n-es-cl             62.0.3-0                    -
                  firefox-i18n-es-es             62.0.3-0                    -
                  firefox-i18n-es-mx             62.0.3-0                    -
                     firefox-i18n-et             62.0.3-0                    -
                     firefox-i18n-eu             62.0.3-0                    -
                     firefox-i18n-fa             62.0.3-0                    -
                     firefox-i18n-ff             62.0.3-0                    -
                     firefox-i18n-fi             62.0.3-0                    -
                     firefox-i18n-fr             62.0.3-0                    -
                  firefox-i18n-fy-nl             62.0.3-0                    -
                  firefox-i18n-ga-ie             62.0.3-0                    -
                     firefox-i18n-gd             62.0.3-0                    -
                     firefox-i18n-gl             62.0.3-0                    -
                     firefox-i18n-gn             62.0.3-0                    -
                  firefox-i18n-gu-in             62.0.3-0                    -
                     firefox-i18n-he             62.0.3-0                    -
                  firefox-i18n-hi-in             62.0.3-0                    -
                     firefox-i18n-hr             62.0.3-0                    -
                    firefox-i18n-hsb             62.0.3-0                    -
                     firefox-i18n-hu             62.0.3-0                    -
                  firefox-i18n-hy-am             62.0.3-0                    -
                     firefox-i18n-id             62.0.3-0                    -
                     firefox-i18n-is             62.0.3-0                    -
                     firefox-i18n-it             62.0.3-0                    -
                     firefox-i18n-ja             62.0.3-0                    -
                     firefox-i18n-ka             62.0.3-0                    -
                    firefox-i18n-kab             62.0.3-0                    -
                     firefox-i18n-kk             62.0.3-0                    -
                     firefox-i18n-km             62.0.3-0                    -
                     firefox-i18n-kn             62.0.3-0                    -
                     firefox-i18n-ko             62.0.3-0                    -
                    firefox-i18n-lij             62.0.3-0                    -
                     firefox-i18n-lt             62.0.3-0                    -
                     firefox-i18n-lv             62.0.3-0                    -
                    firefox-i18n-mai             62.0.3-0                    -
                     firefox-i18n-mk             62.0.3-0                    -
                     firefox-i18n-ml             62.0.3-0                    -
                     firefox-i18n-mr             62.0.3-0                    -
                     firefox-i18n-ms             62.0.3-0                    -
                     firefox-i18n-my             62.0.3-0                    -
                  firefox-i18n-nb-no             62.0.3-0                    -
                     firefox-i18n-nl             62.0.3-0                    -
                  firefox-i18n-nn-no             62.0.3-0                    -
                     firefox-i18n-or             62.0.3-0                    -
                  firefox-i18n-pa-in             62.0.3-0                    -
                     firefox-i18n-pl             62.0.3-0                    -
                  firefox-i18n-pt-br             62.0.3-0                    -
                  firefox-i18n-pt-pt             62.0.3-0                    -
                     firefox-i18n-rm             62.0.3-0                    -
                     firefox-i18n-ro             62.0.3-0                    -
                     firefox-i18n-ru             62.0.3-0                    -
                     firefox-i18n-si             62.0.3-0                    -
                     firefox-i18n-sk             62.0.3-0                    -
                     firefox-i18n-sl             62.0.3-0                    -
                    firefox-i18n-son             62.0.3-0                    -
                     firefox-i18n-sq             62.0.3-0                    -
                     firefox-i18n-sr             62.0.3-0                    -
                  firefox-i18n-sv-se             62.0.3-0                    -
                     firefox-i18n-ta             62.0.3-0                    -
                     firefox-i18n-te             62.0.3-0                    -
                     firefox-i18n-th             62.0.3-0                    -
                     firefox-i18n-tr             62.0.3-0                    -
                     firefox-i18n-uk             62.0.3-0                    -
                     firefox-i18n-ur             62.0.3-0                    -
                     firefox-i18n-uz             62.0.3-0                    -
                     firefox-i18n-vi             62.0.3-0                    -
                     firefox-i18n-xh             62.0.3-0                    -
                  firefox-i18n-zh-cn             62.0.3-0                    -
                  firefox-i18n-zh-tw             62.0.3-0                    -


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-03
-------------------------------------------------------------------------------
                                 apr              1.6.3-1              1.6.5-1
                             firefox             62.0.2-1             62.0.3-1
                    firefox-i18n-ach             62.0.2-1             62.0.3-1
                     firefox-i18n-af             62.0.2-1             62.0.3-1
                     firefox-i18n-an             62.0.2-1             62.0.3-1
                     firefox-i18n-ar             62.0.2-1             62.0.3-1
                     firefox-i18n-as             62.0.2-1             62.0.3-1
                    firefox-i18n-ast             62.0.2-1             62.0.3-1
                     firefox-i18n-az             62.0.2-1             62.0.3-1
                     firefox-i18n-be             62.0.2-1             62.0.3-1
                     firefox-i18n-bg             62.0.2-1             62.0.3-1
                  firefox-i18n-bn-bd             62.0.2-1             62.0.3-1
                  firefox-i18n-bn-in             62.0.2-1             62.0.3-1
                     firefox-i18n-br             62.0.2-1             62.0.3-1
                     firefox-i18n-bs             62.0.2-1             62.0.3-1
                     firefox-i18n-ca             62.0.2-1             62.0.3-1
                    firefox-i18n-cak             62.0.2-1             62.0.3-1
                     firefox-i18n-cs             62.0.2-1             62.0.3-1
                     firefox-i18n-cy             62.0.2-1             62.0.3-1
                     firefox-i18n-da             62.0.2-1             62.0.3-1
                     firefox-i18n-de             62.0.2-1             62.0.3-1
                    firefox-i18n-dsb             62.0.2-1             62.0.3-1
                     firefox-i18n-el             62.0.2-1             62.0.3-1
                  firefox-i18n-en-gb             62.0.2-1             62.0.3-1
                  firefox-i18n-en-us             62.0.2-1             62.0.3-1
                  firefox-i18n-en-za             62.0.2-1             62.0.3-1
                     firefox-i18n-eo             62.0.2-1             62.0.3-1
                  firefox-i18n-es-ar             62.0.2-1             62.0.3-1
                  firefox-i18n-es-cl             62.0.2-1             62.0.3-1
                  firefox-i18n-es-es             62.0.2-1             62.0.3-1
                  firefox-i18n-es-mx             62.0.2-1             62.0.3-1
                     firefox-i18n-et             62.0.2-1             62.0.3-1
                     firefox-i18n-eu             62.0.2-1             62.0.3-1
                     firefox-i18n-fa             62.0.2-1             62.0.3-1
                     firefox-i18n-ff             62.0.2-1             62.0.3-1
                     firefox-i18n-fi             62.0.2-1             62.0.3-1
                     firefox-i18n-fr             62.0.2-1             62.0.3-1
                  firefox-i18n-fy-nl             62.0.2-1             62.0.3-1
                  firefox-i18n-ga-ie             62.0.2-1             62.0.3-1
                     firefox-i18n-gd             62.0.2-1             62.0.3-1
                     firefox-i18n-gl             62.0.2-1             62.0.3-1
                     firefox-i18n-gn             62.0.2-1             62.0.3-1
                  firefox-i18n-gu-in             62.0.2-1             62.0.3-1
                     firefox-i18n-he             62.0.2-1             62.0.3-1
                  firefox-i18n-hi-in             62.0.2-1             62.0.3-1
                     firefox-i18n-hr             62.0.2-1             62.0.3-1
                    firefox-i18n-hsb             62.0.2-1             62.0.3-1
                     firefox-i18n-hu             62.0.2-1             62.0.3-1
                  firefox-i18n-hy-am             62.0.2-1             62.0.3-1
                     firefox-i18n-id             62.0.2-1             62.0.3-1
                     firefox-i18n-is             62.0.2-1             62.0.3-1
                     firefox-i18n-it             62.0.2-1             62.0.3-1
                     firefox-i18n-ja             62.0.2-1             62.0.3-1
                     firefox-i18n-ka             62.0.2-1             62.0.3-1
                    firefox-i18n-kab             62.0.2-1             62.0.3-1
                     firefox-i18n-kk             62.0.2-1             62.0.3-1
                     firefox-i18n-km             62.0.2-1             62.0.3-1
                     firefox-i18n-kn             62.0.2-1             62.0.3-1
                     firefox-i18n-ko             62.0.2-1             62.0.3-1
                    firefox-i18n-lij             62.0.2-1             62.0.3-1
                     firefox-i18n-lt             62.0.2-1             62.0.3-1
                     firefox-i18n-lv             62.0.2-1             62.0.3-1
                    firefox-i18n-mai             62.0.2-1             62.0.3-1
                     firefox-i18n-mk             62.0.2-1             62.0.3-1
                     firefox-i18n-ml             62.0.2-1             62.0.3-1
                     firefox-i18n-mr             62.0.2-1             62.0.3-1
                     firefox-i18n-ms             62.0.2-1             62.0.3-1
                     firefox-i18n-my             62.0.2-1             62.0.3-1
                  firefox-i18n-nb-no             62.0.2-1             62.0.3-1
                     firefox-i18n-nl             62.0.2-1             62.0.3-1
                  firefox-i18n-nn-no             62.0.2-1             62.0.3-1
                     firefox-i18n-or             62.0.2-1             62.0.3-1
                  firefox-i18n-pa-in             62.0.2-1             62.0.3-1
                     firefox-i18n-pl             62.0.2-1             62.0.3-1
                  firefox-i18n-pt-br             62.0.2-1             62.0.3-1
                  firefox-i18n-pt-pt             62.0.2-1             62.0.3-1
                     firefox-i18n-rm             62.0.2-1             62.0.3-1
                     firefox-i18n-ro             62.0.2-1             62.0.3-1
                     firefox-i18n-ru             62.0.2-1             62.0.3-1
                     firefox-i18n-si             62.0.2-1             62.0.3-1
                     firefox-i18n-sk             62.0.2-1             62.0.3-1
                     firefox-i18n-sl             62.0.2-1             62.0.3-1
                    firefox-i18n-son             62.0.2-1             62.0.3-1
                     firefox-i18n-sq             62.0.2-1             62.0.3-1
                     firefox-i18n-sr             62.0.2-1             62.0.3-1
                  firefox-i18n-sv-se             62.0.2-1             62.0.3-1
                     firefox-i18n-ta             62.0.2-1             62.0.3-1
                     firefox-i18n-te             62.0.2-1             62.0.3-1
                     firefox-i18n-th             62.0.2-1             62.0.3-1
                     firefox-i18n-tr             62.0.2-1             62.0.3-1
                     firefox-i18n-uk             62.0.2-1             62.0.3-1
                     firefox-i18n-ur             62.0.2-1             62.0.3-1
                     firefox-i18n-uz             62.0.2-1             62.0.3-1
                     firefox-i18n-vi             62.0.2-1             62.0.3-1
                     firefox-i18n-xh             62.0.2-1             62.0.3-1
                  firefox-i18n-zh-cn             62.0.2-1             62.0.3-1
                  firefox-i18n-zh-tw             62.0.2-1             62.0.3-1
                         fuse-common              3.2.5-1              3.2.6-1
                               fuse3              3.2.5-1              3.2.6-1
                           gst-libav             1.14.3-1             1.14.4-1
                     gst-plugins-bad             1.14.3-1             1.14.4-1
                    gst-plugins-base             1.14.3-1             1.14.4-1
               gst-plugins-base-libs             1.14.3-1             1.14.4-1
                    gst-plugins-good             1.14.3-1             1.14.4-1
                    gst-plugins-ugly             1.14.3-1             1.14.4-1
                          gst-python             1.14.3-1             1.14.4-1
                         gst-python2             1.14.3-1             1.14.4-1
                           gstreamer             1.14.3-1             1.14.4-1
                     gstreamer-vaapi             1.14.3-1             1.14.4-1
                                js60             60.2.1-1             60.2.2-1
                          libchewing              0.5.1-1                    -
               libnautilus-extension 3.30.0+20+gce52f6493-1           3.30.1-1
                            nautilus 3.30.0+20+gce52f6493-1           3.30.1-1
                        scim-chewing              0.3.5-4                    -


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-03
-------------------------------------------------------------------------------
                       lib32-ncurses                6.1-2                6.1-3
3 Likes

Please excuse my ignorance and curiosity, but on Stable KDE, since I've moved to the regular Firefox package ages ago at the direction of the maintainers. What is the benefit of firefox-kde-opensuse?

Ìt is just about a dialog function. With it it looks more integrated ...

There are two major pros:

  1. It uses kdialog (open/save dialog windows native to Plasma).
  2. It allows for global menus in Plasma

It has also some additional patches so it could display some sites in a different way then vanilla package. Firefox notoriously has problems with some sites (Chrome/Chromium NEVER), while kde-opensuse version somewhat manages it a bit better (still not perfect).

1 Like

Forum kindly sponsored by