[Testing Update] 2018-10-05 - Kernels, Grub-Quiet, Python, Haskell

Hi community,

So it took us some more days to push additional packages for the upcoming stable update-pack.

Here the brief overall changes with this update:

  • I managed to complete my work on the smooth bootup experience. (Will be default since 18.0-beta-7)
  • updated most of our kernels
  • more work went into grub-quiet
  • Upstream fixes incl. haskell and python packages

We hope with all these changes Manjaro to be more efficient for you all.


#bladebook - shipping to Europe this fall!

Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.


#beta-release - 18.0 will be available in late October!

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.59
  • linux318 3.18.123 [EOL]
  • linux44 4.4.159
  • linux49 4.9.131
  • linux414 4.14.74
  • linux417 4.17.19 [EOL]
  • linux418 4.18.12
  • linux419 4.19-rc6
  • linux414-rt 4.14.71_rt44
  • linux416-rt 4.16.18_rt11

Package Updates (Fri Oct 5 20:51:31 CEST 2018)

  • testing community x86_64: 207 new and 212 removed package(s)
  • testing core x86_64: 15 new and 15 removed package(s)
  • testing extra x86_64: 129 new and 128 removed package(s)
  • testing multilib x86_64: 4 new and 4 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-05
-------------------------------------------------------------------------------
                           bumblebee             3.2.1-21             3.2.1-22
                   grub-theme-adapta                1.4-1                    -
                     grub-theme-blue                1.4-1                    -
                  grub-theme-blurred                1.0-2                    -
               grub-theme-glassfield                1.4-1                    -
              grub-theme-manjaro-dog                1.4-1                    -
                   manjaro-gdm-theme           20180719-1           20181004-1
        manjaro-openbox-basic-config            1.18.12-2                    -
          manjaro-openbox-grub-theme                1.3-1                    -
     manjaro-openbox-grub-theme-18.0                1.0-6                    -
     manjaro-openbox-grub-theme-blue                1.0-1                    -
manjaro-openbox-grub-theme-glassfield                1.0-2                    -
      manjaro-openbox-minimal-config            1.18.12-2                    -
      manjaro-openbox-regular-config            1.18.12-2                    -
            manjaro-openbox-settings           20180530-2                    -
                    matcha-gtk-theme           20180619-1           20180926-1
      openbox-basic-desktop-settings           1.18.0.8-1                    -
     openbox-common-desktop-settings           1.18.0.8-1                    -
            openbox-desktop-settings           1.18.0.8-1                    -
    openbox-minimal-desktop-settings           1.18.0.8-1                    -
    openbox-regular-desktop-settings           1.18.0.8-1                    -
                     update-notifier              0.7.6-1              0.7.7-1
               manjaro-gnome-vanilla                    -                0.1-1
           manjaro-grub-theme-adapta                    -                1.4-2
             manjaro-grub-theme-blue                    -                1.4-2
          manjaro-grub-theme-blurred                    -                1.4-2
            manjaro-grub-theme-brown                    -                1.4-2
           manjaro-grub-theme-doggie                    -                1.4-2
       manjaro-grub-theme-glassfield                    -                1.4-2
            manjaro-grub-theme-light                    -                1.4-2
              manjaro-openbox-config                    -           1.18.0.8-5
    manjaro-openbox-desktop-settings                    -           1.18.0.8-5


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-05
-------------------------------------------------------------------------------
               aarch64-linux-gnu-gcc              8.2.0-1              8.2.0-2
 aarch64-linux-gnu-linux-api-headers               4.17-1               4.18-1
                      acpi_call-dkms            1.1.0-162            1.1.0-164
                              acpica           20180927-1           20181003-1
                           alacritty              0.2.0-3              0.2.1-1
                  alacritty-terminfo              0.2.0-3              0.2.1-1
                               amule              10998-3              10998-4
                             ansible              2.6.5-1              2.7.0-1
                            apparmor             2.13.0-9            2.13.0-10
                      aspnet-runtime          2.1.4+402-1          2.1.5+403-1
                               bmake           20180512-1           20180919-1
                           bumblebee             3.2.1-19             3.2.1-20
                       cabal-install           2.2.0.0-87           2.2.0.0-88
                               cgrep            6.6.25-87            6.6.25-88
                                cimg              2.2.1-1              2.4.0-1
                          cozy-stack           2018M4S1-1      2018M4S1+fix1-1
                             cryptol             2.6.0-39             2.6.0-40
                               darcs            2.14.1-68            2.14.1-69
                     deepin-terminal              3.0.5-1              3.0.6-1
                          diffoscope                102-1                103-1
                              djview             4.10.6-1             4.10.6-2
                      dnscrypt-proxy             2.0.16-1             2.0.17-1
                         dotnet-host          2.1.4+402-1          2.1.5+403-1
                      dotnet-runtime          2.1.4+402-1          2.1.5+403-1
                          dotnet-sdk          2.1.4+402-1          2.1.5+403-1
                            fail2ban           0.10.3.1-2             0.10.4-1
                           filezilla             3.37.1-1             3.37.4-1
                                 fio               3.10-1               3.11-1
                         flatbuffers              1.9.0-2             1.10.0-1
                    gimp-plugin-gmic              2.3.6-1              2.4.0-1
                           git-annex         6.20180926-4         6.20180926-5
                              gitlab             11.3.1-1             11.3.3-1
                            gitolite              3.6.9-1             3.6.10-1
                                gmic              2.3.6-1              2.4.0-1
                                 gmm                5.2-1                5.3-1
                             gmp-ecm              7.0.4-1              7.0.4-2
                         go-ethereum             1.8.15-1             1.8.16-1
                        gst-validate             1.14.3-1             1.14.4-1
                haskell-authenticate            1.3.4-188            1.3.4-189
                         haskell-aws              0.20-96              0.20-97
              haskell-binary-conduit               1.3-52               1.3-53
                     haskell-conduit           1.3.0.3-38           1.3.0.3-39
               haskell-conduit-extra             1.3.0-60             1.3.0-61
                   haskell-criterion           1.5.1.0-37           1.5.1.0-38
          haskell-cryptohash-conduit            0.1.1-222            0.1.1-223
          haskell-cryptonite-conduit            0.2.2-116            0.2.2-117
                         haskell-dav            1.3.2-136            1.3.2-137
              haskell-deferred-folds              0.9.8-1              0.9.9-1
                   haskell-esqueleto    2.5.3.20180402-82    2.5.3.20180402-83
                        haskell-feed          1.0.0.0-116          1.0.0.0-117
                       haskell-foldl              1.4.4-5              1.4.5-1
                      haskell-hakyll          4.12.4.0-32          4.12.4.0-33
                       haskell-hasql           1.3.0.3-19           1.3.0.3-21
                  haskell-hasql-pool               0.5-19               0.5-21
           haskell-hasql-transaction               0.7-19               0.7-21
                 haskell-hjsonschema            1.9.0-103            1.9.0-104
                    haskell-hopenpgp             2.7.2-27             2.7.2-29
                       haskell-hpack            0.31.0-14            0.31.0-15
                haskell-html-conduit             1.3.1-44             1.3.1-45
                        haskell-http         4000.3.12-66         4000.3.12-67
                haskell-http-conduit             2.3.2-60             2.3.2-61
          haskell-incremental-parser           0.3.1.1-37           0.3.1.1-38
                   haskell-js-jquery            3.3.1-136            3.3.1-137
                haskell-monad-logger            0.3.29-18            0.3.29-19
            haskell-mono-traversable           1.0.9.0-13           1.0.9.0-14
           haskell-monoid-subclasses              0.4.6-5            0.4.6.1-1
                    haskell-mustache             2.3.0-97             2.3.0-98
                  haskell-persistent             2.8.2-84             2.8.2-85
           haskell-persistent-sqlite             2.8.2-29             2.8.2-30
         haskell-persistent-template            2.5.4-110            2.5.4-111
            haskell-project-template           0.2.0.1-90           0.2.0.1-91
                       haskell-sandi             0.4.2-54             0.4.2-55
                         haskell-sbv               7.12-9              7.12-10
              haskell-servant-server         0.13.0.1-101         0.13.0.1-102
                       haskell-shake           0.16.4-102           0.16.4-103
             haskell-simple-sendfile            0.2.27-86            0.2.27-87
                       haskell-store          0.4.3.2-150          0.4.3.2-151
           haskell-tagstream-conduit          0.5.5.3-210          0.5.5.3-211
                haskell-text-builder             0.6.3-10             0.6.3-12
                      haskell-turtle             1.5.11-3             1.5.12-2
              haskell-wai-app-static          3.1.6.2-119          3.1.6.2-120
                 haskell-wai-conduit           3.0.0.4-71           3.0.0.4-72
          haskell-wai-handler-launch           3.0.2.4-79           3.0.2.4-80
                        haskell-warp            3.2.25-15            3.2.25-16
                    haskell-warp-tls           3.2.4.3-95           3.2.4.3-96
                 haskell-xml-conduit            1.8.0.1-6            1.8.0.1-7
                  haskell-xml-hamlet             0.5.0-64             0.5.0-65
                        haskell-yaml           0.10.2.0-6           0.10.2.0-7
                       haskell-yesod            1.6.0-133            1.6.0-134
                  haskell-yesod-auth           1.6.4.1-26           1.6.4.1-27
                  haskell-yesod-core             1.6.6-52             1.6.6-53
               haskell-yesod-default            1.2.0-407            1.2.0-408
                  haskell-yesod-form             1.6.2-63             1.6.2-64
            haskell-yesod-persistent            1.6.0-120            1.6.0-121
                haskell-yesod-static            1.6.0-107            1.6.0-108
                  haskell-yesod-test             1.6.5-62             1.6.5-63
                           hedgewars          0.9.24.1-62          0.9.24.1-63
                             hindent             5.2.7-35             5.2.7-36
                         hledger-api               1.11-1               1.11-2
                         hledger-web               1.11-1               1.11-2
                               hlint            2.1.10-28            2.1.10-29
                              hoogle         5.0.17.3-105         5.0.17.3-106
                      hopenpgp-tools            0.21.2-37            0.21.2-39
                             jetring               0.25-1               0.27-1
                   krita-plugin-gmic              2.3.6-1              2.4.0-1
                        lastpass-cli              1.3.1-1              1.3.1-2
                          libchewing              0.5.1-1              0.5.1-2
                        libfilezilla             0.13.2-1             0.14.0-1
                        libircclient                1.9-3               1.10-1
                            libmupdf             1.13.0-1             1.14.0-1
                     libspatialindex              1.8.5-1                    -
                      linuxdoc-tools             0.9.72-2             0.9.73-1
                                llpp                 28-1                 30-1
                              lutris             0.4.20-1             0.4.20-2
                               lxcfs              3.0.1-1              3.0.2-1
                                 mpv           1:0.29.1-1           1:0.29.1-2
                               mupdf             1.13.0-1             1.14.0-1
                            mupdf-gl             1.13.0-1             1.14.0-1
                         mupdf-tools             1.13.0-1             1.14.0-1
                                mxml               2.11-1               2.12-1
                             nyancat              1.4.4-2              1.5.2-1
                       otf-fira-code              1.205-3              1.206-1
                              pandoc              2.3.1-4              2.3.1-5
                     pandoc-citeproc             0.14.5-5             0.14.5-6
                     pandoc-crossref            0.3.3.0-9           0.3.3.0-10
                           partclone             0.2.89-2             0.2.89-3
                               pdfjs           1.10.100-1           1.10.100-2
                           postgrest           0.5.0.0-44           0.5.0.0-46
                      python-awkward             0.0.10-1              0.1.0-1
                     python-cmarkgfm              0.4.1-1              0.4.2-1
                      python-cypari2              1.2.1-3              1.3.0-1
              python-doublex-expects           0.7.0rc2-3              0.7.0-1
                      python-etesync              0.5.5-1              0.5.6-1
                   python-hypothesis             3.74.0-1             3.74.2-1
                       python-pipenv           2018.7.1-2           2018.7.1-3
                      python-pytorch              0.4.1-5             1.0rc1-1
                 python-pytorch-cuda              0.4.1-5             1.0rc1-1
              python-readme-renderer               22.0-1               22.0-2
                        python-rtree              0.8.3-1              0.8.3-2
                   python-tensorflow             1.10.1-2             1.11.0-1
              python-tensorflow-cuda             1.10.1-2             1.11.0-1
               python-tensorflow-opt             1.10.1-2             1.11.0-1
          python-tensorflow-opt-cuda             1.10.1-2             1.11.0-1
                     python-testpath              0.3.1-2              0.4.2-1
                      python-webtest             2.0.30-2             2.0.32-1
                        python-wheel             0.32.0-1             0.32.1-1
                      python-zconfig              3.2.0-2              3.3.0-1
                    python-zope-copy              4.1.0-2                4.2-1
              python-zope-exceptions              4.2.0-2                4.3-1
                 python-zope-testing              4.6.2-2                4.7-1
                    python2-cmarkgfm              0.4.1-1              0.4.2-1
                     python2-cypari2              1.2.1-3              1.3.0-1
             python2-doublex-expects           0.7.0rc2-3              0.7.0-1
                  python2-hypothesis             3.74.0-1             3.74.2-1
                      python2-pipenv           2018.7.1-2           2018.7.1-3
             python2-readme-renderer               22.0-1               22.0-2
                     python2-webtest             2.0.30-2             2.0.32-1
                       python2-wheel             0.32.0-1             0.32.1-1
                     python2-zconfig              3.2.0-2              3.3.0-1
                   python2-zope-copy              4.1.0-2                4.2-1
             python2-zope-exceptions              4.2.0-2                4.3-1
                python2-zope-testing              4.6.2-2                4.7-1
                               rhash              1.3.6-1                    -
                        riot-desktop             0.16.4-1             0.16.5-1
                            riot-web             0.16.4-1             0.16.5-1
                          shellcheck            0.5.0-119            0.5.0-120
                           shorewall            5.2.0.4-1              5.2.1-1
                      shorewall-core            5.2.0.4-1              5.2.1-1
                          shorewall6            5.2.0.4-1              5.2.1-1
                                 sox             14.4.2-3             14.4.2-4
                               stack            1.7.1-157            1.7.1-158
                          stone-soup             0.22.0-1             0.22.1-1
                     stylish-haskell           0.9.2.0-76           0.9.2.0-77
                             synergy              1.8.8-3             1.10.1-1
                      tamarin-prover            1.4.0-118            1.4.0-119
                         tensorboard             1.10.0-1             1.11.0-1
                          tensorflow             1.10.1-2             1.11.0-1
                     tensorflow-cuda             1.10.1-2             1.11.0-1
                      tensorflow-opt             1.10.1-2             1.11.0-1
                 tensorflow-opt-cuda             1.10.1-2             1.11.0-1
                               tmuxp              1.4.0-4             1.5.0a-1
                       ttf-fira-code              1.205-3              1.206-1
                                 tup              0.7.8-1              0.7.8-2
                               v2ray               3.45-1             3.45.1-1
                              wcslib             5.19.1-1               5.20-1
                          x-docs-pdf           20140422-2                    -
                                  xa              2.3.8-1              2.3.8-2
                              xmobar              0.27-35              0.27-36
                                zart              2.3.6-1              2.4.0-1
                             zn_poly              0.9.1-1              0.9.1-2
                           exploitdb                    -           20181005-1
                        intel-gmmlib                    -             18.3.0-1
                  intel-media-driver                    -             18.3.0-1
                         lsp-plugins                    -              1.1.4-2
         python-pylons-sphinx-themes                    -             1.0.10-1
        python2-pylons-sphinx-themes                    -             1.0.10-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-05
-------------------------------------------------------------------------------
                          grub-quiet            2.03.0-13            2.03.0-16
                            linux316            3.16.58-1            3.16.59-1
                    linux316-headers            3.16.58-1            3.16.59-1
                            linux414            4.14.73-1            4.14.74-1
                    linux414-headers            4.14.73-1            4.14.74-1
                            linux418            4.18.11-1            4.18.12-1
                    linux418-headers            4.18.11-1            4.18.12-1
                      linux419 4.19rc6.0930.g17b57b1-1 4.19rc6.1004.gbefad94-1
              linux419-headers 4.19rc6.0930.g17b57b1-1 4.19rc6.1004.gbefad94-1
                             linux49            4.9.130-1            4.9.131-1
                     linux49-headers            4.9.130-1            4.9.131-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-05
-------------------------------------------------------------------------------
                   archlinux-keyring           20180808-1           20181003-1
                               glib2 2.58.0+31+g2a7d4d2dc-1           2.58.1-1
                          glib2-docs 2.58.0+31+g2a7d4d2dc-1           2.58.1-1
                               patch              2.7.6-1              2.7.6-3


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-05
-------------------------------------------------------------------------------
                     libxfce4ui-gtk3             4.13.4-1             4.13.4-2
                  linux316-acpi_call             1.1.0-45             1.1.0-46
                   linux316-bbswitch               0.8-44               0.8-45
                linux316-broadcom-wl      6.30.223.271-24      6.30.223.271-25
                   linux316-catalyst     1:15.201.1151-32     1:15.201.1151-34
                linux316-ndiswrapper              1.61-24              1.61-25
                     linux316-nvidia           1:410.57-1           1:410.57-2
               linux316-nvidia-340xx            340.107-3            340.107-4
               linux316-nvidia-390xx             390.87-2             390.87-3
                   linux316-nvidiabl              0.88-34              0.88-35
                      linux316-r8168          8.045.08-10          8.045.08-11
                  linux316-rt3562sta        2.4.1.1_r4-24        2.4.1.1_r4-25
                        linux316-spl             0.7.10-2             0.7.10-3
                   linux316-tp_smapi              0.41-44              0.41-45
                linux316-vhba-module          20161009-24          20161009-25
   linux316-virtualbox-guest-modules             5.2.18-2             5.2.18-3
    linux316-virtualbox-host-modules             5.2.18-2             5.2.18-3
                        linux316-zfs             0.7.10-2             0.7.10-3
                  linux414-acpi_call             1.1.0-60             1.1.0-61
                   linux414-bbswitch               0.8-60               0.8-61
                linux414-broadcom-wl      6.30.223.271-60      6.30.223.271-61
                   linux414-catalyst     1:15.201.1151-60     1:15.201.1151-61
                linux414-ndiswrapper              1.61-60              1.61-61
                     linux414-nvidia           1:410.57-1           1:410.57-2
               linux414-nvidia-340xx           340.107-19           340.107-20
               linux414-nvidia-390xx             390.87-5             390.87-6
                   linux414-nvidiabl              0.88-60              0.88-61
                      linux414-r8168          8.045.08-48          8.045.08-49
                  linux414-rt3562sta        2.4.1.1_r4-60        2.4.1.1_r4-61
                        linux414-spl             0.7.10-3             0.7.10-4
                   linux414-tp_smapi              0.41-60              0.41-61
                linux414-vhba-module          20161009-60          20161009-61
   linux414-virtualbox-guest-modules             5.2.18-8             5.2.18-9
    linux414-virtualbox-host-modules             5.2.18-8             5.2.18-9
                        linux414-zfs             0.7.10-3             0.7.10-4
                  linux418-acpi_call              1.1.0-7              1.1.0-8
                   linux418-bbswitch                0.8-7                0.8-8
                linux418-broadcom-wl       6.30.223.271-7       6.30.223.271-8
                   linux418-catalyst      1:15.201.1151-7      1:15.201.1151-8
                linux418-ndiswrapper               1.61-7               1.61-8
                     linux418-nvidia           1:410.57-1           1:410.57-2
               linux418-nvidia-340xx            340.107-7            340.107-8
               linux418-nvidia-390xx             390.87-7             390.87-8
                   linux418-nvidiabl               0.88-7               0.88-8
                      linux418-r8168           8.045.08-7           8.045.08-8
                        linux418-spl             0.7.10-5             0.7.10-6
                   linux418-tp_smapi               0.41-7               0.41-8
                linux418-vhba-module           20161009-7           20161009-8
   linux418-virtualbox-guest-modules             5.2.18-7             5.2.18-8
    linux418-virtualbox-host-modules             5.2.18-7             5.2.18-8
                        linux418-zfs             0.7.10-5             0.7.10-6
                  linux419-acpi_call           1.1.0-0.21           1.1.0-0.22
                   linux419-bbswitch             0.8-0.21             0.8-0.22
                linux419-broadcom-wl    6.30.223.271-0.21    6.30.223.271-0.22
                linux419-ndiswrapper            1.61-0.21            1.61-0.22
                     linux419-nvidia        1:410.57-0.21        1:410.57-0.22
               linux419-nvidia-340xx         340.107-0.21         340.107-0.22
               linux419-nvidia-390xx          390.87-0.21          390.87-0.22
                   linux419-nvidiabl            0.88-0.21            0.88-0.22
                      linux419-r8168        8.045.08-0.21        8.045.08-0.22
                        linux419-spl          0.7.10-0.21          0.7.10-0.22
                   linux419-tp_smapi            0.41-0.21            0.41-0.22
                linux419-vhba-module        20161009-0.21        20161009-0.22
   linux419-virtualbox-guest-modules          5.2.18-0.21          5.2.18-0.22
    linux419-virtualbox-host-modules          5.2.18-0.21          5.2.18-0.22
                        linux419-zfs          0.7.10-0.21          0.7.10-0.22
                   linux49-acpi_call             1.1.0-97             1.1.0-98
                    linux49-bbswitch               0.8-97               0.8-98
                 linux49-broadcom-wl      6.30.223.271-97      6.30.223.271-98
                    linux49-catalyst     1:15.201.1151-97     1:15.201.1151-98
                 linux49-ndiswrapper              1.61-95              1.61-96
                      linux49-nvidia           1:410.57-1           1:410.57-2
                linux49-nvidia-340xx           340.107-16           340.107-17
                linux49-nvidia-390xx             390.87-5             390.87-6
                    linux49-nvidiabl              0.88-97              0.88-98
                       linux49-r8168          8.045.08-37          8.045.08-38
                   linux49-rt3562sta        2.4.1.1_r4-95        2.4.1.1_r4-96
                         linux49-spl             0.7.10-3             0.7.10-4
                    linux49-tp_smapi              0.41-97              0.41-98
                 linux49-vhba-module          20161009-95          20161009-96
    linux49-virtualbox-guest-modules             5.2.18-8             5.2.18-9
     linux49-virtualbox-host-modules             5.2.18-8             5.2.18-9
                         linux49-zfs             0.7.10-3             0.7.10-4
                        nvidia-utils           1:410.57-2           1:410.57-3
                           pamac-dev         7.2.0.dev2-1         7.2.0.dev3-1
         pamac-dev-tray-appindicator         7.2.0.dev2-1         7.2.0.dev3-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-05
-------------------------------------------------------------------------------
                      appstream-glib             0.7.12-1             0.7.13-1
                               cmake             3.12.2-1             3.12.3-1
                           djvulibre             3.5.27-3             3.5.27-4
                            easy-rsa              3.0.4-1              3.0.5-1
                             flatpak              1.0.2-1              1.0.3-1
                     flatpak-builder              1.0.0-1              1.0.1-1
                      fontconfig 2:2.13.0+15+gc60ed9e-1 2:2.13.1+12+g5f5ec56-1
                          git-review             1.26.0-2             1.27.0-1
               gnome-settings-daemon           3.30.1.1-1           3.30.1.2-1
                gnome-sound-recorder             3.28.1-1             3.28.1-2
           gtk-update-icon-cache 3.24.1+2+ged57e564a9-1 3.24.1+8+g220f77d8c1-1
                            gtk3 3.24.1+2+ged57e564a9-1 3.24.1+8+g220f77d8c1-1
                            jbig2dec               0.14-1               0.15-1
                            libepoxy              1.5.2-1              1.5.3-1
                           libmilter             8.15.2-1             8.15.2-2
                              libotr              4.1.1-1              4.1.1-2
                            libunrar            1:5.6.7-1            1:5.6.8-1
                           mercurial              4.7.1-1              4.7.2-1
                        pyqt5-common             5.11.2-2             5.11.3-1
                    python-packaging               17.1-2               18.0-1
                        python-pyqt5             5.11.2-2             5.11.3-1
               python-qscintilla-qt5             2.10.7-3             2.10.8-1
        python-qscintilla-qt5-common             2.10.7-3             2.10.8-1
                          python-sip            4.19.12-5            4.19.13-1
                    python-sip-pyqt5            4.19.12-5            4.19.13-1
                   python2-packaging               17.1-2               18.0-1
                       python2-pyqt5             5.11.2-2             5.11.3-1
              python2-qscintilla-qt5             2.10.7-3             2.10.8-1
                         python2-sip            4.19.12-5            4.19.13-1
                   python2-sip-pyqt5            4.19.12-5            4.19.13-1
                      qscintilla-qt5             2.10.7-3             2.10.8-1
                           sharutils             4.15.2-2             4.15.2-3
                                 sip            4.19.12-5            4.19.13-1
                         spirv-tools             2018.4-1             2018.5-1
                            testdisk                7.0-4                7.0-5
                             tracker              2.1.5-1              2.1.5-2
                   ttf-mph-2b-damase   001.000.4.dfsg.2-6   001.000.4.dfsg.2-7
                               unrar            1:5.6.7-1            1:5.6.8-1
                        vorbis-tools              1.4.0-7              1.4.0-8
                               xclip               0.13-1               0.13-2
                             xournal         0.4.8.2016-1         0.4.8.2016-3
                              zenity             3.28.1-1             3.30.0-1
                               rhash                    -              1.3.6-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-03           2018-10-05
-------------------------------------------------------------------------------
                lib32-fontconfig 2:2.13.0+15+gc60ed9e-1 2:2.13.1+12+g5f5ec56-1
                   lib32-gdk-pixbuf2            2.36.12-1             2.38.0-1
                         lib32-glib2             2.56.2-1             2.58.1-1
                         lib32-libva              2.2.0-1              2.3.0-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

2 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Items from previous update sets

AMD-Ucode introduction

All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Something using Perl/Python/glibc broke

Rebuilds needed! If it's an AUR package, rebuild it. If it's a repo package, please report and check back regularly for rebuilds.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.


File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.


:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1


:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.


gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice


I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.


Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/


Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.


Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

Only one problem on testing: Carla has a bug in it's current version. It doesn't save some parameters / settings when opening and saving projects without changing anything.
This is pretty annoying because it destroyed a part of my LMMS project (which uses Carla).. and I have to redo my settings there everytime I re-save and re-open my project.

So I think it would be a good idea to hold back the current carla package.
The version on stable (1.9.9-3) works perfectly.

Btw. the bug is already know by Carla's author:


So I hope it will be fixed in next release.

Everything else runs good, so except Carla, this should be ready for stable now.

Nice, I see intel-media-driver is available via community repo now. I have some comments though: its package contains these files:

/usr/lib/dri/iHD_drv_video.so
/usr/lib/igfxcmrt64.so
/usr/share/licenses/intel-media-driver/LICENSE.md

but AUR package provided also this one: /etc/profile.d/intel-media.sh - a script that sets LIBVA_DRIVERS_PATH=/usr/lib/dri and LIBVA_DRIVER_NAME=iHD

Now if anyone installs intel-media-driver, actually it does not change driver from i965 to iHD. It has to be set manually.

Probably you can use IgnorePkg in /etc/pacman.conf after the = put the name of the package to ignore it in the update process.

I know, did that, thanks anyway.
But other users will update this package without knowing about the bug and it may destroy partly their projects. So holding the package back for all would be better.

1 Like

I totally agree.

1 Like

Seems it is disabled by default for a reason:

DINSTALL_DRIVER_SYSCONF=OFF
1 Like

Since the latest version of update-notifier, 0.7.7-1, which if i understand correctly brought in AUR support for Trizen [which i use as my AUR Helper, not yaourt], it does not work properly for me. This applies both to my Testing KDE VM, & as of today also my Tower's real Stable KDE.

It still works properly for the standard repos' updates, but it goes awry when it tries to manage AUR. Here's what i captured ~45' ago in my Stable KDE [same thing happens in my Testing KDE VM, but i've not tried to capture any pics there].

20181009_001

Each time i click "Update now" [for AUR updates only i mean], the notification hides & a terminal window appears, briefly [couple of seconds maximum]. Sometimes there's some red text in the window [but it vanishes before i can read it], whilst other times the window is completely empty. Soon after the terminal window disappears, the notification reappears, but if i try clicking again, the same pointless cycle repeats.

Furthermore, extrapolating from just one of those listed AUR packages supposedly needing update, it seems to be simply wrong [so maybe they all are?]. When i check with Octopi, there is no Teamviewer13 update available.

What's going on here please?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by