[Testing Update] 2018-10-07 - Linux419 LTS, Pamac-Dev, SPL/ZFS

Hi community,

So it took us some more days to push additional packages for the upcoming stable update-pack.

Here the brief overall changes with this update:

We hope with all these changes Manjaro to be more efficient for you all.


#bladebook - shipping to Europe this fall!

Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.


#beta-release - 18.0 will be available in late October!

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.59
  • linux318 3.18.123 [EOL]
  • linux44 4.4.159
  • linux49 4.9.131
  • linux414 4.14.74
  • linux417 4.17.19 [EOL]
  • linux418 4.18.12
  • linux419 4.19-rc7
  • linux414-rt 4.14.71_rt44
  • linux416-rt 4.16.18_rt11

Package Updates (Sun Oct 7 17:56:53 CEST 2018)

  • testing community x86_64: 45 new and 43 removed package(s)
  • testing core x86_64: 4 new and 4 removed package(s)
  • testing extra x86_64: 49 new and 55 removed package(s)
  • testing multilib x86_64: 7 new and 12 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-06           2018-10-07
-------------------------------------------------------------------------------
                      amarok 2.9.0.r245.g68a1f0ecdd-1 2.9.0.r249.g67c651bc60-1
              manjaro-bspwm-settings           20180908-2           20181007-1
      manjaro-bspwm-settings-minimal           20180908-2           20181007-1
  manjaro-xfce-gtk3-minimal-settings           20181003-1           20181007-1
          manjaro-xfce-gtk3-settings           20181003-1           20181007-1
             manjaro-ranger-settings                    -           20181007-2
              manjaro-theme-settings                    -           20181007-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-06           2018-10-07
-------------------------------------------------------------------------------
                           bettercap                2.9-1               2.10-1
                              catch2              2.4.1-1              2.4.1-2
                     deepin-terminal              3.0.6-1              3.0.7-1
                           drumstick              1.1.1-2              1.1.1-3
                                 fzf             0.17.4-1             0.17.5-1
          haskell-control-monad-free              0.6.1-6              0.6.2-1
                    haskell-hopenpgp             2.7.2-30             2.7.2-31
                  haskell-http-media            0.7.1.2-6            0.7.1.3-1
                     haskell-servant          0.13.0.1-45          0.13.0.1-46
              haskell-servant-server         0.13.0.1-104         0.13.0.1-105
             haskell-servant-swagger             1.1.5-70             1.1.5-71
                    haskell-swagger2             2.2.2-62             2.2.2-63
                     haskell-wizards              1.0.2-7              1.0.2-8
                           highlight               3.45-1               3.46-1
                       highlight-gui               3.45-1               3.46-1
                             hledger               1.11-2               1.11-3
                         hledger-api               1.11-4               1.11-6
                          hledger-ui               1.11-2               1.11-3
                         hledger-web               1.11-4               1.11-5
                      hopenpgp-tools            0.21.2-40            0.21.2-41
                                mypy              0.630-1              0.630-2
                  papirus-icon-theme           20180816-1           20181007-1
                                 pcb            1:4.1.2-1            1:4.1.3-1
                            pgadmin4                3.3-2                3.4-1
                           postgrest           0.5.0.0-48           0.5.0.0-49
                       python-pillow              5.2.0-3              5.3.0-1
                  python-ruamel-yaml            0.15.71-1            0.15.72-1
                      python2-pillow              5.2.0-3              5.3.0-1
                        ruby-rubydns              2.0.1-3              2.0.2-1
                               smali              2.2.4-1              2.2.5-1
                              sqlmap              1.2.9-1             1.2.10-1
                              stlink              1.5.0-2              1.5.1-1
                       supercollider              3.9.3-4              3.9.3-5
                          unrealircd             4.0.18-1              4.2.0-1
                            usbredir              0.7.1-1              0.8.0-1
                               v2ray             3.46.2-1             3.46.4-1
                      wireguard-dkms       0.0.20180925-1       0.0.20181006-2
                     wireguard-tools       0.0.20180925-1       0.0.20181006-2


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-06           2018-10-07
-------------------------------------------------------------------------------
                      linux419 4.19rc6.1004.gbefad94-1 4.19rc7.1007.g0238df6-1
              linux419-headers 4.19rc6.1004.gbefad94-1 4.19rc7.1007.g0238df6-1
                             mhwd-db              0.6.3-2              0.6.3-3


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-06           2018-10-07
-------------------------------------------------------------------------------
                              psmisc               23.1-1               23.2-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-06           2018-10-07
-------------------------------------------------------------------------------
                   libva-mesa-driver             18.2.2-0                    -
                        linux316-spl             0.7.10-3             0.7.11-1
                        linux316-zfs             0.7.10-3             0.7.11-1
                        linux318-spl             0.7.10-2             0.7.11-1
                        linux318-zfs             0.7.10-2             0.7.11-1
                        linux414-spl             0.7.10-4             0.7.11-1
                        linux414-zfs             0.7.10-4             0.7.11-1
                        linux417-spl             0.7.10-1             0.7.11-1
                        linux417-zfs             0.7.10-1             0.7.11-1
                        linux418-spl             0.7.10-6             0.7.11-1
                        linux418-zfs             0.7.10-6             0.7.11-1
                  linux419-acpi_call           1.1.0-0.22           1.1.0-0.23
                   linux419-bbswitch             0.8-0.22             0.8-0.23
                linux419-broadcom-wl    6.30.223.271-0.22    6.30.223.271-0.23
                linux419-ndiswrapper            1.61-0.22            1.61-0.23
                     linux419-nvidia        1:410.57-0.22        1:410.57-0.23
               linux419-nvidia-340xx         340.107-0.22         340.107-0.23
               linux419-nvidia-390xx          390.87-0.22          390.87-0.23
                   linux419-nvidiabl            0.88-0.22            0.88-0.23
                      linux419-r8168        8.045.08-0.22        8.045.08-0.23
                        linux419-spl          0.7.10-0.22          0.7.11-0.23
                   linux419-tp_smapi            0.41-0.22            0.41-0.23
                linux419-vhba-module        20161009-0.22        20161009-0.23
   linux419-virtualbox-guest-modules          5.2.18-0.22          5.2.18-0.23
    linux419-virtualbox-host-modules          5.2.18-0.22          5.2.18-0.23
                        linux419-zfs          0.7.10-0.22          0.7.11-0.23
                         linux44-spl             0.7.10-3             0.7.11-1
                         linux44-zfs             0.7.10-3             0.7.11-1
                         linux49-spl             0.7.10-4             0.7.11-1
                         linux49-zfs             0.7.10-4             0.7.11-1
                                mesa             18.2.2-0                    -
                          mesa-vdpau             18.2.2-0                    -
                         opencl-mesa             18.2.2-0                    -
                           pamac-dev         7.2.0.dev4-1         7.2.0.dev5-1
         pamac-dev-tray-appindicator         7.2.0.dev4-1         7.2.0.dev5-1
                            spl-dkms             0.7.10-1             0.7.11-1
                           spl-utils             0.7.10-1             0.7.11-1
                         thunar-gtk3              1.8.2-1              1.8.2-3
                        vulkan-intel             18.2.2-0                    -
                       vulkan-radeon             18.2.2-0                    -
                            zfs-dkms             0.7.10-1             0.7.11-1
                           zfs-utils             0.7.10-1             0.7.11-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-06           2018-10-07
-------------------------------------------------------------------------------
                               baloo             5.50.0-1             5.50.0-2
                              clamav            0.100.1-1            0.100.2-1
                                 git             2.19.0-1             2.19.1-1
                libtorrent-rasterbar            1:1.1.9-2           1:1.1.10-1
                   libva-mesa-driver             18.2.1-2             18.2.2-1
                              libx11              1.6.6-1              1.6.6-2
                                mesa             18.2.1-2             18.2.2-1
                          mesa-vdpau             18.2.1-2             18.2.2-1
                             ocl-icd             2.2.12-1             2.2.12-2
                         opencl-mesa             18.2.1-2             18.2.2-1
                           sg3_utils               1.43-1               1.44-1
                        vulkan-intel             18.2.1-2             18.2.2-1
                       vulkan-radeon             18.2.1-2             18.2.2-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-06           2018-10-07
-------------------------------------------------------------------------------
             lib32-libva-mesa-driver             18.2.2-0                    -
                          lib32-mesa             18.2.2-0                    -
                    lib32-mesa-vdpau             18.2.2-0                    -
                  lib32-vulkan-intel             18.2.2-0                    -
                 lib32-vulkan-radeon             18.2.2-0                    -


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-06           2018-10-07
-------------------------------------------------------------------------------
              lib32-gst-plugins-good             1.14.3-1             1.14.4-1
             lib32-libva-mesa-driver             18.2.1-2             18.2.2-1
                          lib32-mesa             18.2.1-2             18.2.2-1
                    lib32-mesa-vdpau             18.2.1-2             18.2.2-1
                       lib32-ocl-icd             2.2.12-1             2.2.12-2
                  lib32-vulkan-intel             18.2.1-2             18.2.2-1
                 lib32-vulkan-radeon             18.2.1-2             18.2.2-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

6 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Items from previous update sets

AMD-Ucode introduction

All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Something using Perl/Python/glibc broke

Rebuilds needed! If it's an AUR package, rebuild it. If it's a repo package, please report and check back regularly for rebuilds.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.


File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.


:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1


:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.


gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice


I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.


Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/


Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.


Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

1 Like

Added some more packages:

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-06           2018-10-07
-------------------------------------------------------------------------------
       manjaro-i3-solarized-settings           20160701-1                    -
                    matcha-gtk-theme           20181006-1           20181007-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-06           2018-10-07
-------------------------------------------------------------------------------
                                 apm              2.1.2-1              2.1.3-1
                            electron              2.0.9-1             2.0.11-1
                 haskell-hledger-lib               1.11-2             1.11.1-1
                             hledger               1.11-3             1.11.1-1
                         hledger-api               1.11-6             1.11.1-1
                          hledger-ui               1.11-3             1.11.1-1
                         hledger-web               1.11-5             1.11.1-1
                            homebank              5.2.1-1              5.2.2-1
                                josm              14178-1              14289-1
                               opera       56.0.3051.31-1       56.0.3051.36-1
                               pynac             0.7.22-4             0.7.22-5
                                qcad           3.21.3.1-1           3.21.3.2-1
                              synbak                3.6-1                3.7-1
                          youtube-dl         2018.09.26-1         2018.10.05-1

One point i want to mention, not a big deal for me, but on kernels 4.19 and 4.18 there is a remove event when i connect my wacom tablet, so i have to power it off and on again to work. Some people might not know about this and they have issues to use a tablet, see here and here even tho their issue might not be quite related as i suppose they tried to power off and on the tablet or to replug it in the USB.
It happens in Gnome and KDE Plasma too
Here is what i get in the Xorg Log on both kernels mentioned above:

	Information	[   393.892] (II) event17 - Wacom Cintiq 22HD Pen: is tagged by udev as: Tablet
	Information	[   393.935] (II) event17 - Wacom Cintiq 22HD Pen: device is a tablet
	Information	[   393.935] (II) event17 - Wacom Cintiq 22HD Pen: device removed
	Information	[   393.965] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-3/1-3.1/1-3.1:1.0/0003:056A:00FA.0005/input/input18/event17"
	Information	[   394.019] (II) event17 - Wacom Cintiq 22HD Pen: is tagged by udev as: Tablet
	Information	[   394.033] (II) event17 - Wacom Cintiq 22HD Pen: device is a tablet
	Information	[   394.034] (II) event17 - Wacom Cintiq 22HD Pen: device removed

This is an instant connect/disconnect but it doesn't happen in 4.14 kernel. Can we trace where the difference is?
Here is the Xorg Log for 4.14 kernel:

	Information	[    25.425] (II) config/udev: Adding input device Wacom Cintiq 22HD Pad (/dev/input/event17)
	Information	[    25.429] (**) Wacom Cintiq 22HD Pad: always reports core events
	Information	[    25.429] (**) Option "Device" "/dev/input/event17"
	Information	[    25.486] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-3/1-3.1/1-3.1:1.0/0003:056A:00FA.0005/input/input18/event17"
	Information	[    25.489] (II) config/udev: Adding input device Wacom Cintiq 22HD Pen (/dev/input/event16)
	Information	[    25.489] (**) Wacom Cintiq 22HD Pen: always reports core events
	Information	[    25.489] (**) Option "Device" "/dev/input/event16"
	Information	[    25.526] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-3/1-3.1/1-3.1:1.0/0003:056A:00FA.0005/input/input16/event16"
	Information	[    25.527] (**) Wacom Cintiq 22HD Pen eraser: always reports core events
	Information	[    25.527] (**) Option "Device" "/dev/input/event16"
	Information	[    25.546] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-3/1-3.1/1-3.1:1.0/0003:056A:00FA.0005/input/input16/event16"

Both are taken on the same machine and are the first to happen.

Is this also present in v4.14+ kernels? If so, when did you remember it happened the first time for you? As needed you may contact Jiri Kosina the maintainer of the module.

No, on 4.14 works as is supposed, there is no remove event in xorg log and the tablet works right away, only in 4.18 and 4.19 the remove event comes instantly at turning on the tablet, so i have to turn it off and on again to work. Was introduced in 4.18 as was working fine even in 4.17 kernel if i recall correctly.
I'll try to contact Jiri and point him to this discussion. Thanks!!! :wink:

We have still linux417 in our repos. Please review that one also.

Ok, went back to some of my notes and indeed was happening in 4.17 too and i made a test and it does the same as in 4.18 and 4.19.
Another note of mine pointed me to the first introduction to kernel 4.16 ... so that is when was introduced

That means from 4.16 UP all have the same remove event right when the tablet is first turned on or connected.

Notice manjaro 18.0 beta 9 is out. Already installed 18.0 beta 7. Is it possible to upgrade without reinstalling? I did download 18.0 beta 9 just in case.
PS: Simple update of Testing does not accomplish this according to Manjaro Hello.

Please test if linux415 doesn't have this regression.

This is just a string in /etc/os-release file. When you have updated in testing you're on the same status as Beta9. Only our ISOs update that string. We didn't had updated the package manjaro-release yet. If we would have released a v17.1.13 version of that package, you might wonder about a "downgrade" instead.

Just trying to keep up. LOL Thanks.
Why downgrade?

It isn't actually a downgrade.

Whenever a release happens /etc/os-release gets updated. So if you start on beta7 your release string reads beta7. When v18 is released the os-release string will change to v18. However, if there are more betas and a v17.1.13 gets released in the interim, your os-release string would change to v17.1.13.

It is just a string, it has no real meaning. It doesn't effect what files are in your system. Manjaro is rolling.

/etc/os-release:
NAME="Manjaro Linux"
ID=manjaro
ID_LIKE=arch
PRETTY_NAME="Manjaro Linux"
ANSI_COLOR="1;32"
HOME_URL="https://www.manjaro.org/"
SUPPORT_URL="https://www.manjaro.org/"
BUG_REPORT_URL="https://bugs.manjaro.org/"
What's wrong with this picture???

Sorry it is /etc/lsb-release

DISTRIB_ID=ManjaroLinux
DISTRIB_RELEASE=18.0-beta-7
DISTRIB_CODENAME=Illyria
DISTRIB_DESCRIPTION="Manjaro Linux"

Does not say 18.0-beta-9

Right, it gets updated when there is a release. The betas are not releases.

linux415 works perfectly with no issue :slight_smile: same as linux414 - all good


I tested again the 4.16 and the event remove is present on metal and vbox, same results. The regression came about kernel 4.16 upwards ... On KDE i can see also the notifications that are simultaneously.
image

It seems that depending on the USB port used and how many devices are connected, the even changes its name. So here is now the xorg log using linux416 on another machine:

	Information	[    83.477] (**) Option "Device" "/dev/input/event8"
	Information	[    83.479] (II) event8  - Wacom Cintiq 22HD Pen: is tagged by udev as: Tablet
	Information	[    83.869] (II) event8  - Wacom Cintiq 22HD Pen: device is a tablet
	Information	[    83.869] (II) event8  - Wacom Cintiq 22HD Pen: device removed
	Information	[    83.880] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:06.0/usb2/2-2/2-2:1.0/0003:056A:00FA.0002/input/input9/event8"
	Information	[    83.909] (II) event8  - Wacom Cintiq 22HD Pen: is tagged by udev as: Tablet
	Information	[    83.930] (II) event8  - Wacom Cintiq 22HD Pen: device is a tablet
	Information	[    83.942] (II) event8  - Wacom Cintiq 22HD Pen: device removed

I am facing issues with installation of python-h5py. I need these dependent packages like octave, gdal and others for my work. hdf5 is required by octave in our repository also. What do you suggest? Will it be possible without uninstalling octave, gdal and others?

:: python-h5py and hdf5-openmpi are in conflict. Remove hdf5-openmpi? [y/N] Y
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'hdf5' required by python-h5py
:: removing hdf5-openmpi breaks dependency 'hdf5' required by alembic
:: removing hdf5-openmpi breaks dependency 'hdf5' required by cgns
:: removing hdf5-openmpi breaks dependency 'hdf5' required by gdal
:: removing hdf5-openmpi breaks dependency 'hdf5' required by netcdf
:: removing hdf5-openmpi breaks dependency 'hdf5' required by octave
:: removing hdf5-openmpi breaks dependency 'hdf5' required by paraview

python-h5py is required by tensorflow packages in my system.

Those other packages claim to depend on hdf5. Have you tried installing hdf5 instead of hdf5-openmpi? python-h5py depends on hdf5

Thanks. I will try that tomorrow morning. Its late night now. For time being I updated everything except tensorflow ones.

1 Like

Forum kindly sponsored by