[Testing Update] 2018-10-08 - Upstream Updates

Hi community,

So it took us some more days to push additional packages for the upcoming stable update-pack.

Here the brief overall changes with this update:

We hope with all these changes Manjaro to be more efficient for you all.

#bladebook - shipping to Europe this fall!

Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.

#beta-release - 18.0 will be available in late October!

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.30.

Current supported Kernels

  • linux316 3.16.59
  • linux318 3.18.123 [EOL]
  • linux44 4.4.159
  • linux49 4.9.131
  • linux414 4.14.74
  • linux417 4.17.19 [EOL]
  • linux418 4.18.12
  • linux419 4.19-rc7
  • linux414-rt 4.14.71_rt44
  • linux416-rt 4.16.18_rt11

Package Updates (Mon Oct 8 07:20:36 CEST 2018)

  • testing community x86_64: 12 new and 8 removed package(s)
  • testing core x86_64: 1 new and 1 removed package(s)
  • testing extra x86_64: 2 new and 4 removed package(s)
:: Different sync package(s) in repository community x86_64

                             PACKAGE           2018-10-07           2018-10-08
                bash-language-server              1.5.3-1              1.5.4-1
                  blender 17:2.79.b.git3.32432d91-9 17:2.79.b.git3.32432d91-10
                            collectd              5.8.0-9             5.8.0-10
                              gitlab             11.3.3-1             11.3.4-1
                               glava              1.5.1-1              1.5.2-1
                          googlemaps           20180405-3           20180602-1
                      wireguard-dkms       0.0.20181006-2       0.0.20181007-1
                     wireguard-tools       0.0.20181006-2       0.0.20181007-1
                        pathological                    -             1.1.3-10
         pulseaudio-equalizer-ladspa                    -              3.0.0-1
                         python-gast                    -              0.2.0-1
                      python2-pygame                    -              1.9.4-1

:: Different overlay package(s) in repository core x86_64

                             PACKAGE           2018-10-07           2018-10-08
                     manjaro-release            17.1.12-1           18.0.0rc-1

:: Different sync package(s) in repository extra x86_64

                             PACKAGE           2018-10-07           2018-10-08
                               ncmpc               0.31-1               0.32-1
                          ocamlbuild             0.12.0-3             0.13.1-1
                        pathological             1.1.3-10                    -
                      python2-pygame              1.9.3-1                    -
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Items from previous update sets

AMD-Ucode introduction

All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.

LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.

Something using Perl/Python/glibc broke

Rebuilds needed! If it's an AUR package, rebuild it. If it's a repo package, please report and check back regularly for rebuilds.

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.

:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1

:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.

gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54

Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice

I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.

Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.

Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/

Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.

Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.


My ranger became unrunable, it ran once at first but second run is defunct. Rebooting machine wont solve this.

loading...Traceback (most recent call last):
                                              File "/usr/bin/ranger", line 36, in <module>
                                                                                              sys.exit(ranger.main())  # pylint: disable=no-member
                                                                                                                                                    File "/usr/lib/python3.7/site-packages/ranger/core/main.py", line 226, in main
                                    File "/usr/lib/python3.7/site-packages/ranger/gui/ui.py", line 184, in destroy
                                                                                                                      check_output(['tmux', 'set-window-option', '-u', 'automatic-rename'])
                                                                                                                                                                                             File "/usr/lib/python3.7/site-packages/ranger/ext/spawn.py", line 35, in check_output
                                                                   process = Popen(popenargs, stderr=fd_devnull, **kwargs)
                                                                                                                            File "/usr/lib/python3.7/subprocess.py", line 756, in __init__
                                                                                                                                                                                              restore_signals, start_new_session)
                File "/usr/lib/python3.7/subprocess.py", line 1499, in _execute_child
                                                                                         raise child_exception_type(errno_num, err_msg, err_filename)
                                                                                                                                                     FileNotFoundError: [Errno 2] No such file or directory: 'tmux': 'tmux'
        ~ (sway) 1 $ 

No idea why, yet.

PS: unformated lines are part of the output, not done by me pasting it.

Please test:

pamac install https://manjaro.moson.eu/pool/overlay/ranger-1.9.2-0-any.pkg.tar.xz

1 Like

YES, this package works flawlesly.

You are welcome :wink:

1 Like

I just updated my home machine, and it may be this update or that last one since I hadn't updated since then.

Gnome notifications keeps appearing saying Activation of network connection failed and then disappears. Not drop when browsing web or downloading files. The notification appears every 2 minutes or so.

Wired connection, RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

Is it for users of Manjaro 18.0-rc1? My Mac mini processor is an INtel.

I am afraid of updates. The pacman -Syyu reminders me Thanos.

Sorry, but if you are afraid of updates you shouldn't use a rolling release and especially not the testing branch.

Sorry for my poor comment because I am autistic and deaf-born. I mean I was afraid of running the latest updates because they break the boot and grub. Better staying in the stable until they fix broken boot and grub.

those changes won't break anything boot related. the instruction was specific to AMD users since the amd-ucode has been split from the linux-firmware package to mirror the structure used for intel machines.

Sorry, if I was to harsh.
If your machine is using Intel, the message wasn't for you, because it stated AMD...
But aside from this my advice is still, if you are wishing to stay in the stable, do it literally and switch back to stable so that you have to fear less.

My Manjaro is already stable-branched, but when I ran sudo pacman -Syyu, I have checked lsb_release, it appeared as Manjaro 18.0-rc1 instead of 17.1.12 Hakoila. As I was counselled to ignore it and still afraid of reboting, then I decided to follow these above instructions, I replaced amd-ucode for intel-ucode because if not, boot and grub have already been broken. I rebooted and it works. I am using an external HD. I have reinstalled 12 times and had n idea of what happened with boot and grub, I thought it was because it is an external HD or because of my Mac mini.

I upgraded to Illyra 18.0-rc1 on my laptop without these instructins and it worked because my SSD is internal.

intel-ucode would have already been installed, it's a default package on all ISO and architect profiles.

I have remembered that, in my other topic, the guy has suggested me to check if *-ucode is installed or not. Before rebooting, following these above instructions, I have checked if intel-ucode was installed or not. Then in that latest update, intel-ucode was not installed, it is why my book and grub were broken. After having intel-ucode installed and having rebooting, it worked. Not just amd-ucode, [maybe] it seems that intel-ucode was also split from the linux-firmware package among 18.0-beta6 and 18.0-rc1.

intel-ucode was never in linux-firmware. the latest update may not have included intel-ucode if there were no updates for it.

what most likely fixed your broken external HDD installation were the grub installation steps. if for whatever reason grub broke during the last upgrade, you were basically re-installing grub again by using those amd-ucode related instructions to re-install intel-ucode.

Actually, I did not install amd-ucode. Both amd-ucode and intel-ucode were not installed. Therefore, I remembered that guy has suggested me to check if it was or not in my other topic, I followed the above instructions.

Please check my comment Boot EFI stopped working in a removable external HDD on Mac mini and go to the "pacman -Qs ucode", you can see both they were not installed. I did not understand his suggestion, I thought he asked me to remove them even if they were not installed and I did not know what caused the broken boot and grub. Then I checked this topic to make sure what happened with the boot and grub and read these above instructions, I understood what happened.

Please forgive me because my cognitive understanding is limited due to my autism and to my deafness, @micsim35, @folky and @gohlip. Thank you a lot for your help and your patience.

@AgentS, I forgot of thanking you. Please forgive for my limited cognitive understanding. I thank you a lot for your help and your patience. I appreciate your good treatment for autistic and deaf-born people like me.

I think gtest is now orphaned for me:

$ pacman -Qdt
gtest 1.8.1-3

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by