[Testing Update] 2018-10-16 - Linux419, Plasma, KDE Apps, Deepin, Mkinitcpio, VB, Xorg

Hi community,

So it took us some more days to push additional packages for the upcoming stable update-pack.

Here the brief overall changes with this update:

  • We added KDE Plasma 5.14.1 and Framework 5.51.0
  • Xorg-Server is now at 1.20.2
  • Virtualbox has a new version
  • linux419 is now at RC8
  • glibc and mkinitcpio got some fixes added. For the later you may take a look at this if you boot from USB
  • Deepin got some packages updated
  • Upstream fixes incl. python

We hope with all these changes Manjaro to be more efficient for you all.


#rc-release - 18.0 will be available in late October!

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a rc-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our rc-build with the latest KDE v5.13 instead. And our GNOME fans may try our rc-build with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.59
  • linux318 3.18.124 [EOL]
  • linux44 4.4.161
  • linux49 4.9.133
  • linux414 4.14.76
  • linux417 4.17.19 [EOL]
  • linux418 4.18.14
  • linux419 4.19-rc8
  • linux414-rt 4.14.71_rt44
  • linux416-rt 4.16.18_rt11

Package Updates (Tue Oct 16 18:57:51 CEST 2018)

  • testing community x86_64: 92 new and 85 removed package(s)
  • testing core x86_64: 8 new and 7 removed package(s)
  • testing extra x86_64: 198 new and 190 removed package(s)
  • testing multilib x86_64: 3 new and 2 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-14           2018-10-16
-------------------------------------------------------------------------------
             breeze-maia-icon-themes             5.50.0-1             5.51.0-1
      deepin-desktop-schemas-manjaro           3.2.18.7-1           3.2.18.8-1
                           downgrade              6.0.0-1              6.0.0-2
linux414-rt-virtualbox-guest-modules             5.2.18-4             5.2.20-1
 linux414-rt-virtualbox-host-modules             5.2.18-4             5.2.20-1
linux416-rt-virtualbox-guest-modules             5.2.16-3             5.2.20-1
 linux416-rt-virtualbox-host-modules             5.2.16-3             5.2.20-1
linux418-rt-virtualbox-guest-modules             5.2.18-2             5.2.20-1
 linux418-rt-virtualbox-host-modules             5.2.18-2             5.2.20-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-14           2018-10-16
-------------------------------------------------------------------------------
                      acpi_call-dkms            1.1.0-164            1.1.0-166
                            apparmor            2.13.0-10             2.13.1-3
                               bazel             0.17.2-1             0.18.0-1
                            checksec              1.8.0-1              1.9.0-1
                             clojure              1.9.0-7              1.9.0-8
                             cm256cc              1.0.1-1              1.0.2-1
                            collectd             5.8.0-10             5.8.0-11
                              cython             0.28.5-1               0.29-1
                             cython2             0.28.5-1               0.29-1
                   deepin-calculator              1.0.6-1              1.0.7-1
              deepin-desktop-schemas           3.2.18.7-1           3.2.18.8-1
                   deepin-screenshot              4.1.0-2              4.1.1-1
                     deepin-terminal              3.0.7-1              3.0.8-1
                             fatsort          1.4.2.439-1          1.5.0.456-1
                           firewalld              0.6.2-1              0.6.3-1
                           fwbuilder              5.3.7-1              5.3.7-2
                             gbrainy            1:2.3.7-1            1:2.3.8-1
                     grub-customizer              5.0.8-2              5.1.0-1
                    iio-sensor-proxy                2.4-4                2.5-1
                                 iwd                0.8-1                0.9-1
                             jenkins              2.146-1              2.147-1
                          kdeconnect              1.3.1-1              1.3.2-1
                               ktikz               0.12-1               0.12-2
                             libcerf                1.8-1                1.9-1
                           libpinyin              2.2.0-1              2.2.1-1
                             libsass              3.4.9-1              3.5.4-1
                           libsigrok              0.5.0-5              0.5.1-1
                              libva1              1.8.3-1              1.8.3-2
                           limesuite            18.10.0-1            18.10.0-2
                               lldpd              1.0.1-1              1.0.1-2
                           lttng-ust             2.10.1-2             2.10.2-1
                              mapnik             3.0.20-5             3.0.21-1
                          maxima-ecl             5.42.0-1             5.42.1-1
                                 min              1.7.1-1              1.8.0-1
                             mongodb              4.0.2-1              4.0.3-1
                            openipmi             2.0.25-3             2.0.25-4
                             paxtest             0.9.15-1             0.9.15-2
                            pcsclite             1.8.23-3             1.8.24-1
                python-async-timeout              3.0.0-2              3.0.1-1
                      python-awkward              0.2.0-1              0.2.1-1
                   python-click-repl              0.1.5-1              0.1.6-1
                    python-freezegun             0.3.10-2             0.3.11-1
                   python-hypothesis             3.76.0-1             3.77.0-1
                     python-lttngust             2.10.1-2             2.10.2-1
                   python-pyrsistent             0.14.4-1             0.14.5-1
                         python-tqdm             4.26.0-1             4.27.0-1
                        python-webob              1.8.2-2              1.8.3-1
                   python-webob-docs              1.8.2-2              1.8.3-1
                   python2-freezegun             0.3.10-2             0.3.11-1
                  python2-hypothesis             3.76.0-1             3.77.0-1
                    python2-lttngust             2.10.1-2             2.10.2-1
                  python2-pyrsistent             0.14.4-1             0.14.5-1
                python2-subprocess32              3.5.2-1              3.5.3-1
                        python2-tqdm             4.26.0-1             4.27.0-1
                       python2-webob              1.8.2-2              1.8.3-1
                               qtikz               0.12-1               0.12-2
                     ruby2.3-bundler             1.16.2-1             1.16.6-1
                               sassc              3.5.0-1              3.5.0-2
                             shotcut           18.10.01-1           18.10.08-1
                           teeworlds              0.6.4-1              0.6.5-1
                    telegram-desktop              1.4.2-1              1.4.3-1
                             tinyemu         2018_09_23-1         2018_09_23-3
                             tribler         7.1.0_beta-1          7.1.0_rc2-1
                        vim-fugitive                2.4-1                2.4-2
                          virtualbox             5.2.18-1             5.2.20-1
                  virtualbox-ext-vnc             5.2.18-1             5.2.20-1
               virtualbox-guest-dkms             5.2.18-1             5.2.20-1
                virtualbox-guest-iso             5.2.18-1             5.2.20-1
              virtualbox-guest-utils             5.2.18-1             5.2.20-1
          virtualbox-guest-utils-nox             5.2.18-1             5.2.20-1
                virtualbox-host-dkms             5.2.18-1             5.2.20-1
                      virtualbox-sdk             5.2.18-1             5.2.20-1
                          wiredtiger     3.0.0.20180814-1     3.1.0.20180920-1
                              xmonad               0.14-4               0.15-1
                      xmonad-contrib               0.14-4               0.15-1
                               zcash              2.0.0-2              2.0.1-1
                         advancecomp                    -                2.1-2
                                 ghi                    - 1.2.0.r23.g0bf0e97-1
                             jslinux                    -         2018_09_23-3
                 libva1-intel-driver                    -              1.8.3-1
                   teamspeak3-server                    -              3.4.0-2
                            usbguard                    -              0.7.4-4
                         usbguard-qt                    -              0.7.4-4


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-14           2018-10-16
-------------------------------------------------------------------------------
                      linux419 4.19rc7.1014.g3a27203-1 4.19rc8.1016.gb955a91-1
              linux419-headers 4.19rc7.1014.g3a27203-1 4.19rc8.1016.gb955a91-1
                          mkinitcpio                    -                 25-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-14           2018-10-16
-------------------------------------------------------------------------------
                               glibc               2.28-4               2.28-5
                         lib32-glibc               2.28-4               2.28-5
                          mkinitcpio                 24-2                 24-3
                             texinfo                6.5-1                6.5-2
                                zstd              1.3.5-1              1.3.6-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-14           2018-10-16
-------------------------------------------------------------------------------
                 calamares-git 3.2.3.r5058.fe171b84b-1 3.2.3.r5086.7bd99940b-1
                         kinfocenter             5.14.0-1             5.14.1-1
   linux316-virtualbox-guest-modules             5.2.18-3             5.2.20-1
    linux316-virtualbox-host-modules             5.2.18-3             5.2.20-1
   linux318-virtualbox-guest-modules             5.2.18-4             5.2.20-1
    linux318-virtualbox-host-modules             5.2.18-4             5.2.20-1
   linux414-virtualbox-guest-modules            5.2.18-10             5.2.20-1
    linux414-virtualbox-host-modules            5.2.18-10             5.2.20-1
   linux417-virtualbox-guest-modules             5.2.18-4             5.2.20-1
    linux417-virtualbox-host-modules             5.2.18-4             5.2.20-1
   linux418-virtualbox-guest-modules             5.2.18-9             5.2.20-1
    linux418-virtualbox-host-modules             5.2.18-9             5.2.20-1
   linux419-virtualbox-guest-modules          5.2.18-0.24          5.2.20-0.24
    linux419-virtualbox-host-modules          5.2.18-0.24          5.2.20-0.24
    linux44-virtualbox-guest-modules            5.2.18-10             5.2.20-1
     linux44-virtualbox-host-modules            5.2.18-10             5.2.20-1
    linux49-virtualbox-guest-modules            5.2.18-11             5.2.20-1
     linux49-virtualbox-host-modules            5.2.18-11             5.2.20-1
                   manjaro-tools-iso             0.15.9-1             0.15.9-2
                  manjaro-tools-yaml             0.15.9-1             0.15.9-2
                           pamac-dev         7.2.0.dev6-2         7.2.0.dev6-3
         pamac-dev-tray-appindicator         7.2.0.dev6-2         7.2.0.dev6-3
                         xorg-server                    -             1.20.2-0
                  xorg-server-common                    -             1.20.2-0
                   xorg-server-devel                    -             1.20.2-0
                    xorg-server-xdmx                    -             1.20.2-0
                  xorg-server-xephyr                    -             1.20.2-0
                   xorg-server-xnest                    -             1.20.2-0
                    xorg-server-xvfb                    -             1.20.2-0
                xorg-server-xwayland                    -             1.20.2-0


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-14           2018-10-16
-------------------------------------------------------------------------------
                              attica             5.50.0-1             5.51.0-1
                               baloo             5.50.0-2             5.51.0-1
                           bluedevil           1:5.14.0-1           1:5.14.1-1
                            bluez-qt             5.50.0-1             5.51.0-1
                              breeze             5.14.0-1             5.14.1-1
                         breeze-grub             5.14.0-1             5.14.1-1
                          breeze-gtk             5.14.0-1             5.14.1-1
                        breeze-icons             5.50.0-1             5.51.0-1
                            discover             5.14.0-1             5.14.1-1
                             drkonqi             5.14.0-1             5.14.1-1
                                 exo             0.12.2-1             0.12.3-1
                 extra-cmake-modules             5.50.0-1             5.51.0-1
                frameworkintegration             5.50.0-1             5.51.0-1
                                gvim           8.1.0374-1           8.1.0470-1
                               hplip           1:3.18.6-1           1:3.18.6-2
                         kactivities             5.50.0-1             5.51.0-1
                   kactivities-stats             5.50.0-1             5.51.0-1
                   kactivitymanagerd             5.14.0-1             5.14.1-1
                             kapidox             5.50.0-1             5.51.0-1
                            karchive             5.50.0-1             5.51.0-1
                               kauth             5.50.0-1             5.51.0-1
                          kbookmarks             5.50.0-1             5.51.0-1
                            kcmutils             5.50.0-1             5.51.0-1
                             kcodecs             5.50.0-1             5.51.0-1
                         kcompletion             5.50.0-1             5.51.0-1
                             kconfig             5.50.0-1             5.51.0-1
                      kconfigwidgets             5.50.0-1             5.51.0-1
                         kcoreaddons             5.50.0-1             5.51.0-1
                              kcrash             5.50.0-1             5.51.0-1
                         kdbusaddons             5.50.0-1             5.51.0-1
                       kde-cli-tools             5.14.0-1             5.14.1-1
                      kde-gtk-config             5.14.0-1             5.14.1-1
                        kdeclarative             5.50.0-1             5.51.0-1
                         kdecoration             5.14.0-1             5.14.1-1
                                kded             5.50.0-1             5.51.0-1
                     kdelibs4support             5.50.0-1             5.51.0-1
                    kdeplasma-addons             5.14.0-1             5.14.1-1
                     kdesignerplugin             5.50.0-1             5.51.0-1
                               kdesu             5.50.0-1             5.51.0-1
                           kdewebkit             5.50.0-1             5.51.0-1
                              kdnssd             5.50.0-1             5.51.0-1
                           kdoctools             5.50.0-1             5.51.0-1
                          kemoticons             5.50.0-1             5.51.0-1
                       kfilemetadata             5.50.0-1             5.51.0-1
                             kgamma5             5.14.0-1             5.14.1-1
                        kglobalaccel             5.50.0-1             5.51.0-1
                          kguiaddons             5.50.0-1             5.51.0-1
                           kholidays           1:5.50.0-1           1:5.51.0-1
                            khotkeys             5.14.0-1             5.14.1-1
                               khtml             5.50.0-1             5.51.0-1
                               ki18n             5.50.0-1             5.51.0-1
                         kiconthemes             5.50.0-1             5.51.0-1
                           kidletime             5.50.0-1             5.51.0-1
                       kimageformats             5.50.0-1             5.51.0-1
                         kinfocenter             5.14.0-1             5.14.1-1
                               kinit             5.50.0-1             5.51.0-1
                                 kio             5.50.0-1             5.51.0-1
                           kirigami2             5.50.0-1             5.51.0-1
                         kitemmodels             5.50.0-1             5.51.0-1
                          kitemviews             5.50.0-1             5.51.0-1
                         kjobwidgets             5.50.0-1             5.51.0-1
                                 kjs             5.50.0-1             5.51.0-1
                            kjsembed             5.50.0-1             5.51.0-1
                        kmediaplayer             5.50.0-1             5.51.0-1
                           kmenuedit             5.14.0-1             5.14.1-1
                          knetattach             5.14.0-1             5.14.1-1
                           knewstuff             5.50.0-1             5.51.0-1
                      knotifications             5.50.0-1             5.51.0-1
                       knotifyconfig             5.50.0-1             5.51.0-1
                            kpackage             5.50.0-1             5.51.0-1
                              kparts             5.50.0-1             5.51.0-1
                             kpeople             5.50.0-1             5.51.0-1
                           kplotting             5.50.0-1             5.51.0-1
                                kpty             5.50.0-1             5.51.0-1
                               kross             5.50.0-1             5.51.0-1
                             krunner             5.50.0-1             5.51.0-1
                             kscreen             5.14.0-1             5.14.1-1
                       kscreenlocker             5.14.0-1             5.14.1-1
                            kservice             5.50.0-1             5.51.0-1
                         ksshaskpass             5.14.0-1             5.14.1-1
                           ksysguard             5.14.0-1             5.14.1-1
                         ktexteditor             5.50.0-1             5.51.0-1
                        ktextwidgets             5.50.0-1             5.51.0-1
                     kunitconversion             5.50.0-1             5.51.0-1
                             kwallet             5.50.0-1             5.51.0-1
                         kwallet-pam             5.14.0-1             5.14.1-1
                            kwayland             5.50.0-1             5.51.0-1
                kwayland-integration             5.14.0-1             5.14.1-1
                      kwidgetsaddons             5.50.0-1             5.51.0-1
                                kwin             5.14.0-1             5.14.1-1
                       kwindowsystem             5.50.0-1             5.51.0-1
                             kwrited             5.14.0-1             5.14.1-1
                             kxmlgui             5.50.0-1             5.51.0-1
                       kxmlrpcclient             5.50.0-1             5.51.0-1
                          libkscreen             5.14.0-1             5.14.1-1
                        libksysguard             5.14.0-1             5.14.1-1
                        libmpdclient               2.15-1               2.16-1
                             libpqxx              6.2.4-1              6.2.5-1
                              libssh              0.8.3-1              0.8.4-1
                         libssh-docs              0.8.3-1              0.8.4-1
                            lighttpd             1.4.50-1             1.4.51-1
                               milou             5.14.0-1             5.14.1-1
                     modemmanager-qt             5.50.0-1             5.51.0-1
                            net-snmp              5.7.3-9                5.8-1
                   networkmanager-qt             5.50.0-1             5.51.0-1
                              oxygen             5.14.0-1             5.14.1-1
                        oxygen-icons           1:5.50.0-1           1:5.51.0-1
                    oxygen-icons-svg           1:5.50.0-1           1:5.51.0-1
                                 php             7.2.11-1             7.2.11-2
                          php-apache             7.2.11-1             7.2.11-2
                             php-cgi             7.2.11-1             7.2.11-2
                           php-dblib             7.2.11-1             7.2.11-2
                           php-embed             7.2.11-1             7.2.11-2
                         php-enchant             7.2.11-1             7.2.11-2
                             php-fpm             7.2.11-1             7.2.11-2
                              php-gd             7.2.11-1             7.2.11-2
                            php-imap             7.2.11-1             7.2.11-2
                            php-intl             7.2.11-1             7.2.11-2
                            php-odbc             7.2.11-1             7.2.11-2
                           php-pgsql             7.2.11-1             7.2.11-2
                          php-phpdbg             7.2.11-1             7.2.11-2
                          php-pspell             7.2.11-1             7.2.11-2
                            php-snmp             7.2.11-1             7.2.11-2
                          php-sodium             7.2.11-1             7.2.11-2
                          php-sqlite             7.2.11-1             7.2.11-2
                            php-tidy             7.2.11-1             7.2.11-2
                             php-xsl             7.2.11-1             7.2.11-2
          plasma-browser-integration             5.14.0-1             5.14.1-1
                      plasma-desktop             5.14.0-1             5.14.1-1
                    plasma-framework             5.50.0-1             5.51.0-1
                  plasma-integration             5.14.0-1             5.14.1-1
                           plasma-nm             5.14.0-1             5.14.1-1
                           plasma-pa             5.14.0-1             5.14.1-1
                          plasma-sdk             5.14.0-1             5.14.1-1
                        plasma-vault             5.14.0-1             5.14.1-1
              plasma-wayland-session             5.14.0-2             5.14.1-1
                    plasma-workspace             5.14.0-2             5.14.1-1
         plasma-workspace-wallpapers             5.14.0-1             5.14.1-1
                    polkit-kde-agent             5.14.0-1             5.14.1-1
                          powerdevil             5.14.0-1             5.14.1-1
                              prison             5.50.0-1             5.51.0-1
                             purpose             5.50.0-1             5.51.0-1
                                qemu              3.0.0-2              3.0.0-3
                     qemu-arch-extra              3.0.0-2              3.0.0-3
                  qemu-block-gluster              3.0.0-2              3.0.0-3
                    qemu-block-iscsi              3.0.0-2              3.0.0-3
                      qemu-block-rbd              3.0.0-2              3.0.0-3
                    qemu-guest-agent              3.0.0-2              3.0.0-3
                       qemu-headless              3.0.0-2              3.0.0-3
            qemu-headless-arch-extra              3.0.0-2              3.0.0-3
                  qqc2-desktop-style             5.50.0-1             5.51.0-1
                              quagga              1.2.4-1              1.2.4-2
                                sane             1.0.27-1             1.0.27-2
                            sddm-kcm             5.14.0-1             5.14.1-1
                               solid             5.50.0-1             5.51.0-1
                              sonnet             5.50.0-1             5.51.0-1
                          subversion             1.10.2-2             1.10.3-1
                         syndication             5.50.0-1             5.51.0-1
                 syntax-highlighting             5.50.0-1             5.51.0-1
                      systemsettings             5.14.0-1             5.14.1-1
                        threadweaver             5.50.0-1             5.51.0-1
                        user-manager             5.14.0-1             5.14.1-1
                                 vim           8.1.0374-1           8.1.0470-1
                         vim-runtime           8.1.0374-1           8.1.0470-1
              xdg-desktop-portal-kde             5.14.0-1             5.14.1-1
                        zabbix-agent              4.0.0-2              4.0.0-3
                 zabbix-frontend-php              4.0.0-2              4.0.0-3
                        zabbix-proxy              4.0.0-2              4.0.0-3
                       zabbix-server              4.0.0-2              4.0.0-3


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-10-14           2018-10-16
-------------------------------------------------------------------------------
                        lib32-libva1              1.8.3-1              1.8.3-3
                        lib32-libx11              1.6.6-1              1.6.7-1
           lib32-libva1-intel-driver                    -              1.8.3-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

4 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Items from previous update sets

AMD-Ucode introduction

All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.


LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.


Something using Perl/Python/glibc broke

Rebuilds needed! If it's an AUR package, rebuild it. If it's a repo package, please report and check back regularly for rebuilds.


Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.

icon-kde-513


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.


File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.


Kernel 4.9 issues

Seems on rare conditions you may face a faulty boot with linux49. It results in messages similar like this: <module> likely not compiled with -mcmodel=kernel. Also you will land in the emergency console.

We recommend to install at least another kernel as backup. You may follow this post to recover. v4.9.107-2 is known to be working.


:: alpm-octopi-utils: installing “pacman” (5.1.0-2) breaks the dependency with «pacman <5.1»

Make sure your mirrors are up-to-date. All package management tools should be compatible with pacman 5.1


:: ffmpeg2.8: installing x265 (2.8-1) breaks dependency ‘libx265.so=151-64’

ffmpeg2.8 is no longer in the repos. Remove it, and if you need it, rebuild/reinstall it from the AUR.


gcc54 and gcc5 are in conflict

For those using CUDA, if this error comes up, run the update from terminal
sudo pacman -Syyu
and type YES to replace gcc5 with gcc54


Extension "Workspace to Dock" is bugged

Be careful like there is a bug if you use the Extension "Workspace to Dock". You need to update/install this version in ~/.local/share/gnome-shell/extensions/ for not have desktop freeze after reboot : https://github.com/passingthru67/workspaces-to-dock/archive/master.zip

Thanks for nabd who have solved this issue : [Testing Update] 2018-05-11 - Kernels, GCC8, Gnome 3.28.2, Cinnamon, KDE Apps 18.04.1, LibreOffice


I see a lot of pacnew files

Well, there is no manual intervention needed for pacnew files coming from filesystem package. The best thing you can do is, do nothing.

Never, ever, ever, ever, ever merge the pacnew file for /etc/{passwd,shadow,gshadow,group}, unless you want to make the new comments match aesthetically with your in-use user accounts database. The only practical difference that merging can ever cause is to accidentally delete users or mangle the whole file's syntax and render your computer maybe unbootable.

More advice in this regard you may find here.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24, support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

Normal users follow:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

To switch to opensource drivers do:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux


Changes made to Glibc

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.


Changes made to PAM

pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.


Samba units renamed

Note: In samba 4.8.0-1, the units were renamed from smbd.service and nmbd.service to smb.service and nmb.service.

To provide basic file sharing through SMB start/enable smb.service and/or nmb.service services. See the smbd(8) and nmbd(8) man pages for details, as the nmb.service service may not always be required.


Directory permissions differ

Directory permissions differ on /var/lib/samba/private/
filesystem: 755 package: 700

sudo chmod 700 /var/lib/samba/private/


Samba - Error 255: net usershare add: cannot convert name "Everyone" to a SID.

Currently there seems to be an issue when using group = sambashare with Samba 4.8.1-1, which is used by default in thesmb.conf provided by Manjaro. Changing it to group = +sambashare or force group = +sambashare resolves this. However, we might fill out a bug report, to see why that is currently needed.

Commenting/removing group = sambashare is also a viable solution.


Long delay for starting Desktop Environment

There's a bug which is exhausting the entropy pool. This is refilled over time through e.g. disk activity and mouse movement. You can increase the fill rate with a software solution:

sudo pacman -S haveged
sudo systemctl enable haveged
sudo systemctl start haveged

An alternative method if activating the haveged service is not something you want to do is to press the shift key 8-10 times in succession.

Sorry , did you mean 16 instead 14?
[Testing Update] 2018-10-16- Linux419, Plasma, KDE Apps, Deepin, Mkinitcpio, VB, Xorg

16 updates all good, thanks.

[details=bob@Manjaro-Testing~$

[2018-10-16 15:54] [ALPM] upgraded glibc (2.28-4 -> 2.28-5)
[2018-10-16 15:54] [ALPM-SCRIPTLET] Generating locales...
[2018-10-16 15:54] [ALPM-SCRIPTLET]   en_US.UTF-8... done
[2018-10-16 15:54] [ALPM-SCRIPTLET] Generation complete.
[2018-10-16 15:54] [ALPM] upgraded xorg-server-common (1.20.1-1 -> 1.20.2-0)
[2018-10-16 15:54] [ALPM] upgraded xorg-server (1.20.1-1 -> 1.20.2-0)
[2018-10-16 15:54] [ALPM] upgraded zstd (1.3.5-1 -> 1.3.6-1)
[2018-10-16 15:54] [ALPM] upgraded kcoreaddons (5.50.0-1 -> 5.51.0-1)
[2018-10-16 15:54] [ALPM] upgraded kauth (5.50.0-1 -> 5.51.0-1)
[2018-10-16 15:54] [ALPM] upgraded kitemmodels (5.50.0-1 -> 5.51.0-1)
[2018-10-16 15:54] [ALPM] upgraded lib32-glibc (2.28-4 -> 2.28-5)
[2018-10-16 15:54] [ALPM] upgraded lib32-libx11 (1.6.6-1 -> 1.6.7-1)
[2018-10-16 15:54] [ALPM] upgraded libssh (0.8.3-1 -> 0.8.4-1)
[2018-10-16 15:54] [ALPM] upgraded mkinitcpio (24-2 -> 25-1)
[2018-10-16 15:54] [ALPM] upgraded linux419 (4.19rc7.1014.g3a27203-1 -> 4.19rc8.1016.gb955a91-1)
[2018-10-16 15:54] [ALPM] upgraded net-snmp (5.7.3-9 -> 5.8-1)
[2018-10-16 15:54] [ALPM] upgraded pcsclite (1.8.23-3 -> 1.8.24-1)
[2018-10-16 15:54] [ALPM] upgraded subversion (1.10.2-2 -> 1.10.3-1)
[2018-10-16 15:54] [ALPM] upgraded texinfo (6.5-1 -> 6.5-2)
[2018-10-16 15:54] [ALPM] transaction completed
[2018-10-16 15:54] [ALPM] running '60-linux419.hook'...
[2018-10-16 15:54] [ALPM] running '90-linux419.hook'...
[2018-10-16 15:54] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'default'
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64.img
[2018-10-16 15:54] [ALPM-SCRIPTLET] ==> Starting build: 4.19.0-1-MANJARO
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-10-16 15:54] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-10-16 15:54] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64.img
[2018-10-16 15:54] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-10-16 15:54] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'fallback'
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64-fallback.img -S autodetect
[2018-10-16 15:54] [ALPM-SCRIPTLET] ==> Starting build: 4.19.0-1-MANJARO
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2018-10-16 15:54] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-10-16 15:54] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-10-16 15:54] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64-fallback.img
[2018-10-16 15:55] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-10-16 15:55] [ALPM] running '99-grub-quiet.hook'...
[2018-10-16 15:55] [ALPM-SCRIPTLET] Generating grub configuration file ...
[2018-10-16 15:55] [ALPM-SCRIPTLET] Found linux image: /boot/vmlinuz-4.19-x86_64
[2018-10-16 15:55] [ALPM-SCRIPTLET] Found initrd image: /boot/intel-ucode.img /boot/amd-ucode.img /boot/initramfs-4.19-x86_64.img
[2018-10-16 15:55] [ALPM-SCRIPTLET] Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
[2018-10-16 15:55] [ALPM-SCRIPTLET] Found Manjaro Linux (18.0.0-rc) on /dev/sda1
[2018-10-16 15:55] [ALPM-SCRIPTLET] Found memtest86+ image: /boot/memtest86+/memtest.bin
[2018-10-16 15:55] [ALPM-SCRIPTLET] done
[2018-10-16 15:55] [ALPM] running 'detect-old-perl-modules.hook'...
[2018-10-16 15:55] [ALPM] running 'systemd-daemon-reload.hook'...
[2018-10-16 15:55] [ALPM] running 'systemd-tmpfiles.hook'...
[2018-10-16 15:55] [ALPM] running 'systemd-update.hook'...
[2018-10-16 15:55] [ALPM] running 'texinfo-install.hook'...
[2018-10-16 15:55] [ALPM] running 'update-mime-database.hook'...

[/details]

The upgrade went fine on KDE 18.0RC1 edition, but the kernel update (4.19RC8) did not work for me. While booting up there was a lot of text running on the screen (kernel-panic?), but the system works. When try-ing to reboot, the system halts/freezes after unmounting all drives. These lines where in red while booting up:

okt 16 22:23:52 lwlaptop kernel: BUG: unable to handle kernel paging request at 000006df0000001b
okt 16 22:23:51 lwlaptop systemd-udevd[302]: worker [319] failed while handling '/devices/pci0000:00/INT33C3:00/i2c-1/i2c-SYN1B7C:01'

And several of this line while trying to reboot:

okt 16 22:33:11 lwlaptop kernel: PKCS#7 signature not signed with a trusted key

Downgrading the kernel to 4.19RC7 fixed it.
This is my system (with RC7 kernel):

inxi -Fxxxz
System:    Host: lwlaptop Kernel: 4.19.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
           Desktop: KDE Plasma 5.14.1 tk: Qt 5.11.2 info: latte-dock wm: kwin_x11 dm: SDDM 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Aspire E5-771 v: N/A serial: <filter> 
           Mobo: Acer model: EA70_HB v: Type2 - A01 Board Version serial: <filter> UEFI: Insyde v: 1.05 
           date: 05/13/2014 
Battery:   ID-1: BAT1 charge: 32.3 Wh condition: 32.3/48.9 Wh (66%) volts: 16.1/15.2 model: AC14B8K 
           type: Li-ion serial: <filter> status: Full 
CPU:       Topology: Dual Core model: Intel Core i3-4030U bits: 64 type: MT MCP arch: Haswell rev: 1 
           L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15207 
           Speed: 800 MHz min/max: 800/1900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Acer Incorporated ALI driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:0a16 
           Display: x11 server: X.Org 1.20.2 driver: modesetting alternate: fbdev,intel,vesa 
           compositor: kwin_x11 resolution: 1600x900~60Hz 
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.2.2 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:03.0 chip ID: 8086:0a0c 
           Device-2: Intel 8 Series HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:9c20 
           Sound Server: ALSA v: k4.19.0-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI 
           driver: r8168 v: 8.045.08-NAPI port: 3000 bus ID: 04:00.0 chip ID: 10ec:8168 
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: Foxconn driver: ath9k 
           v: kernel port: 3000 bus ID: 05:00.0 chip ID: 168c:0036 
           IF: wlp5s0 state: up mac: <filter> 
Drives:    Local Storage: total: 465.76 GiB used: 36.70 GiB (7.9%) 
           ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: GPT 
Partition: ID-1: / size: 39.12 GiB used: 9.22 GiB (23.6%) fs: ext4 dev: /dev/sda3 
           ID-2: /home size: 19.56 GiB used: 2.15 GiB (11.0%) fs: ext4 dev: /dev/sda4 
           ID-3: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 41.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 164 Uptime: 14m Memory: 3.78 GiB used: 1.15 GiB (30.3%) Init: systemd v: 239 Compilers: 
           gcc: 8.2.1 Shell: bash v: 4.4.23 running in: konsole inxi: 3.0.26

Worked fine over here. also using kernel 4.18

Imgur

I hesitated to update after reading this, but took the plunge and am finding that all 10 of my kernal 4.19 DE's are booting and running fine after the update. I didn't notice any error messages while booting.

1 Like

Thank you very much Phil – today’s Testing update has solved the previous [relatively longterm] problem] – my Shared Folders are now good again. :joy: :+1: :clap:

[kdemeoz@Manjaro_KDE_VM ~]$ uname -a
Linux Manjaro_KDE_VM 4.19.0-1-MANJARO #1 SMP PREEMPT Tue Oct 16 18:21:31 UTC 2018 x86_64 GNU/Linux
[kdemeoz@Manjaro_KDE_VM ~]$

Per my post though for my previous Testing Update [Testing Update] 2018-10-11 - Kernels, Gnome, KDE, PHP, Python, Haskell, the new PulseAudio EQ remains broken... certainly that should be fixed before pushing to Stable.

3 Likes

as per Arch wiki says:

**Warning:** The equalizer module is considered unstable and might be removed from PulseAudio. For more, see the [mailing list](https://lists.freedesktop.org/archives/pulseaudio-discuss/2014-March/020174.html).

pulseeffects is the suggested module.

if really want to use pulseaudio-equalizer, this should fix this no-effect issue (at least on my end)

**Note:** If qpaeq has no effect, install [pavucontrol](https://www.archlinux.org/packages/?name=pavucontrol) and change "ALSA Playback on" to "FFT based equalizer on ..." while the media player is running.

https://wiki.archlinux.org/index.php/PulseAudio

2 Likes

Thanks for your info. Atm i don't really understand what i need to do to fix it, so i shall study those links carefully tomorrow. Hopefully i'll get on top of it.

This might be an unnecessary remark, but btw: The EQ did not just "break" for no reason with that recent Manjaro update; it specifically included a new version, per @philm's initial post back in that thread:
pulseaudio-equalizer-ladspa 2.7.1-1
I've not tried it yet, but i presume that if i were to Downgrade to its previous version, it would work fine once again [given in my Stable Manjaro i use it all day every day & it works fine].

EDIT-1: Oh dear - i was wrong; the Stable version [good] is also 2.7.1-1, so my previous claim was rubbish. Groan.

EDIT-2: With respect, are you certain that you & i are talking about the same thing? Maybe i'm misunderstanding you, but aren't you talking about pulseaudio-equalizer, whereas i am talking about pulseaudio-equalizer-ladspa, re which i quote this from the Arch PA wiki https://wiki.archlinux.org/index.php/PulseAudio:

Alternative equalizers
pulseaudio-equalizer-ladspa (based on swh-plugins) can be used as an alternative to pulseaudio-equalizer.

pulseeffects applies peak limiting, compression, reverberation, auto volume and 15 bands equalization to Pulseaudio applications output.

To my reading of the wiki, the Warning you quoted specifically applies to pulseaudio-equalizer, which is the PulseAudio has an integrated 10-band equalizer system. That's not what i'm using, & which recently broke in Testing. "My" one instead is the Description: A 15-band equalizer for PulseAudio https://www.archlinux.org/packages/community/any/pulseaudio-equalizer-ladspa/ [which weirdly is at version 3.0.0-1, so now this is even more confusing]

1 Like

57 updates all good.
Thanks!

Host: xxx-pc Kernel: 4.19.0-1-MANJARO x86_64 bits: 64
Desktop: LXQt 0.13.0 Distro: Manjaro Linux
Machine:
Type: Desktop Mobo: ASRock model: FM2A88M-HD+ R3.0
serial: UEFI [Legacy]: American Megatrends v: P1.50
date: 01/11/2016
CPU:
Topology: Quad Core
model: AMD A8-7670K Radeon R7 10 Compute Cores 4C+6G bits: 64
type: MCP L2 cache: 2048 KiB
Speed: 1892 MHz min/max: 1900/3600 MHz Core speeds (MHz):
1: 1890 2: 1895 3: 2392 4: 2395
Graphics:
Device-1: AMD Kaveri [Radeon R7 Graphics] driver: radeon
v: kernel
Display: x11 server: X.org 1.20.2 driver: modesetting

With 4.19rc8.1016.gb955a91-1 I've added a patch to fix following issue. Did the last rc7 work for you? I've to test it also on the #bladebook to see if I'd added a regression.

1 Like

sorry for the confusing. i normally do no install pulseaudio if i can avoid so assumed pulseaudio-equalizer to be similar to pulseaudio-equalizer-ladspa.

anyways, i did try ladspa and it work on this testing branch using the 4.19 kernel. you should probably check(install pavucontrol) and see if your streams and being sent through lasdpa


(look example at lower-left pic of screenshot)

4.19 looking good on this update. Thanks.

Yes, did not have any problem with the touchpad. This is the output from dmesg:

dmesg | grep input
[    0.842538] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0
[    0.842589] input: Sleep Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1
[    0.842638] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input2
[    0.842679] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input3
[    1.356998] input: HID 04d9:1135 as /devices/pci0000:00/0000:00:14.0/usb2/2-2/2-2:1.0/0003:04D9:1135.0001/input/input4
[    1.357065] hid-generic 0003:04D9:1135.0001: input,hidraw0: USB HID v1.10 Mouse [HID 04d9:1135] on usb-0000:00:14.0-2/input0
[    1.712667] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input5
[    8.957242] input: SYN1B7C:01 06CB:2970 Mouse as /devices/pci0000:00/INT33C3:00/i2c-1/i2c-SYN1B7C:01/0018:06CB:2970.0002/input/input6
[    8.957275] input: SYN1B7C:01 06CB:2970 Touchpad as /devices/pci0000:00/INT33C3:00/i2c-1/i2c-SYN1B7C:01/0018:06CB:2970.0002/input/input7
[    8.957333] hid-generic 0018:06CB:2970.0002: input,hidraw1: I2C HID v1.00 Mouse [SYN1B7C:01 06CB:2970] on i2c-SYN1B7C:01
[    9.487697] input: PC Speaker as /devices/platform/pcspkr/input/input9
[   10.741862] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[   10.809187] input: HD WebCam: HD WebCam as /devices/pci0000:00/0000:00:14.0/usb2/2-7/2-7:1.0/input/input10
[   10.976971] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card1/input11
[   11.494140] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input12
[   11.505477] input: Acer WMI hotkeys as /devices/virtual/input/input13
[   11.576701] input: HDA Intel HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/sound/card0/input14
[   11.576789] input: HDA Intel HDMI HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.0/sound/card0/input15
[   11.576870] input: HDA Intel HDMI HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.0/sound/card0/input16
[   11.576959] input: HDA Intel HDMI HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:03.0/sound/card0/input17
[   11.577043] input: HDA Intel HDMI HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:03.0/sound/card0/input18
[   12.074300] input: SYN1B7C:01 06CB:2970 Touchpad as /devices/pci0000:00/INT33C3:00/i2c-1/i2c-SYN1B7C:01/0018:06CB:2970.0002/input/input20
[   12.074485] hid-multitouch 0018:06CB:2970.0002: input,hidraw1: I2C HID v1.00 Mouse [SYN1B7C:01 06CB:2970] on i2c-SYN1B7C:01
[  313.067405] input: HID 04d9:1135 as /devices/pci0000:00/0000:00:14.0/usb2/2-2/2-2:1.0/0003:04D9:1135.0003/input/input22
[  313.067645] hid-generic 0003:04D9:1135.0003: input,hidraw0: USB HID v1.10 Mouse [HID 04d9:1135] on usb-0000:00:14.0-2/input0

Tried re-installing the 4.19RC8. No strange output when installing, but the same issue when booting up. And now my touchpad is not working anymore: (EDIT: Also SUSPEND not working anymore (probably because of touchpad-issue?))

dmesg | grep SYN
[    9.509046] i2c_hid i2c-SYN1B7C:01: i2c-SYN1B7C:01 supply vdd not found, using dummy regulator
[    9.509072] i2c_hid i2c-SYN1B7C:01: Linked as a consumer to regulator.0
[    9.509075] i2c_hid i2c-SYN1B7C:01: i2c-SYN1B7C:01 supply vddl not found, using dummy regulator

I really do appreciate your help, but unfortunately we are still talking about different things. My original post specified the symptom... it is NOT that sound is not coming through the updated EQ, because the sound is fine through the EQ. The specific issue is

In other words, if i change the EQ profile from "Flat" to "Full Bass & Treble" to "Techno" to "Pop", etc, the sliders do not move at all. Until that recent Testing update, they worked correctly. Yes i can manually drag each slider up & down, & the sound output changes accordingly, but that is not the point... i wish to continue being able to use the various sound profiles.

im using the pulseaudio-equalizer-ladspa fron AUR which doesnt have this issue. install the one from aur if you want this behaviour. if you want to stay with the community version,
copy contents from /usr/share/pulseaudio-equalizer-ladspa/presets/* to $HOME/.config/pulse/presets/

2 Likes

Using for daily! Every update is better than previous :heart_eyes:

And grub-quiet working awesome :sunglasses:

All good here with kernel419 and those sweet sweet KDE updates.

System:    Host: zoki-pc Kernel: 4.19.0-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.14.1 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: H170M-PLUS v: Rev X.0x serial: <root required> 
           UEFI: American Megatrends v: 3805 date: 05/16/2018 
CPU:       Topology: Quad Core model: Intel Core i5-6600K bits: 64 type: MCP L2 cache: 6144 KiB 
           Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
Graphics:  Device-1: Intel HD Graphics 530 driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.2 driver: intel unloaded: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) v: 4.5 Mesa 18.2.2 
Audio:     Device-1: Intel Sunrise Point-H HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.19.0-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V driver: e1000e 
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 
Drives:    Local Storage: total: 232.89 GiB used: 152.16 GiB (65.3%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
Partition: ID-1: / size: 227.94 GiB used: 152.16 GiB (66.8%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 27.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0

Forum kindly sponsored by