[Testing Update] 2019-03-14 - Kernels, Plasma, Deepin, Pamac, Python, Ruby

I get Create Document / Empty File and it works, see scrn shots. 1.8.4git-955b94a Thunar ver.
Screenshot_2019-03-18_07-58-47
Screenshot_2019-03-18_08-00-37

Are you using gtk3 packages? Version of your xfdesktop-gtk3 and gtk3-classic?

Yes, I am:
Classic = 3.24.5-1
Desktop = 4.13.2-14

gtk3-classic 3.24.7-1 is affected, it's not a big deal as I'll just wait for an upstream fix. Maybe worth mentioning as a "known issue" if it gets pushed to a stable announcement but again, minor issues.:slightly_smiling_face:

I'm back from #clt2019. Please check if pamac 7.3.5-2 fixes the reported issues ...

1 Like

Hi Philm.
Sorry, still the same for me . Still enable to create new file with right clic into Thunar. I did relog into session. Same small empty window.

$ pacman -Q pamac
pamac-gtk 7.3.5-2

$ pamac info pamac-gtk
Nom                       : pamac-gtk
Version                   : 7.3.5-2
Description               : A Package Manager based on libalpm with AUR and
                            Appstream support
URL                       : https://gitlab.manjaro.org/applications/pamac
Licences                  : GPL3
D√©p√īt                     : extra
Taille                    : 575,5 ko
Dépend de                 : pamac-cli vte3>=0.38 gtk3>=3.22
Requis par                : pamac-dev-tray-appindicator
Fournit                   : pamac=7.3.5-2
Remplace                  : pamac
Est en conflit avec       : pamac pamac-aur
Paqueteur                 : Philip Mueller <philm@manjaro.org>
Compilé le                : 18/03/2019
Installé le               : 18/03/2019
Motif d’installation      : Explicitement installé

Downgraded from 2.66.0-1 to 2.64.2-1

It didn't work on my side, and I take the blame for it, because I completely missed a very important detail in my previous explanation to make it work. Reminder here.

vercmp now works properly since we are using $1 instead of $2 in post-installation. It doesn't fail and show an error. The problem now is that we are not using the right comparison, so the test just doesn't execute. Let me explain.

Currently, the comparison used is "less than", or -lt in bash. We are testing if the value given by vercmp is lesser than 0. It is only the case if the version given in the first argument (here, it is $1) is a lower version than the second argument of vercmp (see the manual of vercmp).

However, in the post_install() function, $1 is the version of the package that is installed. Thus, what is happening here is that vercmp is comparing 7.3.5-2 vs 7.3.5-2 and since both versions are the same, vercmp returns 0 as the output. Is 0 is lesser than 0? NO. Therefore, the instruction in the first if is not executed at all.

So instead of using "less than", we could use "less or equal than", or -le in bash. Instead of if [ "$(vercmp $1 7.3.5-3)" -lt 0 ]; then, we would have something like if [ "$(vercmp $1 7.3.5-3)" -le 0 ]; then. (I'm taking into account the next rebuild.)

@philm Sorry for the lost time because of an error in my logic. :frowning:

Here's the details for the VM I used to test out the rebuild. The .pacsave didn't get replaced.

Pamac details - Manjaro Gnome
Synchronizing package databases...
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...

Downloading systemd-libs (241.607-1-x86_64)...
Downloading e2fsprogs (1.45.0-1-x86_64)...
Downloading systemd (241.607-1-x86_64)...
Downloading nspr (4.21-1-x86_64)...
Downloading linux419 (4.19.29-1-x86_64)...
Downloading lib32-pcre (8.43-1-x86_64)...
Downloading lib32-systemd (241.607-1-x86_64)...
Downloading at-spi2-core (2.32.0-1-x86_64)...
Downloading atk (2.32-1-x86_64)...
Downloading dconf (0.32.0-1-x86_64)...
Downloading glib-networking (2.60.0.1-1-x86_64)...
Downloading libsoup (2.66.0-1-x86_64)...
Downloading gtk3 (3.24.7-1-x86_64)...
Downloading baobab (3.32.0-1-x86_64)...
Downloading double-conversion (3.1.4-1-x86_64)...
Downloading file-roller (3.32.0-1-x86_64)...
Downloading firefox (66.0-0-x86_64)...
Downloading gtksourceview4 (4.0.3-1-x86_64)...
Downloading gobject-introspection-runtime (1.60.0-1-x86_64)...
Downloading gedit (3.32.0-1-x86_64)...
Downloading geocode-glib (3.26.1-1-x86_64)...
Downloading upower (0.99.10-1-x86_64)...
Downloading libwbclient (4.9.5-1-x86_64)...
Downloading tevent (1:0.9.39-1-x86_64)...
Downloading ldb (1:1.4.6-1-x86_64)...
Downloading smbclient (4.9.5-1-x86_64)...
Downloading lua52-lpeg (1.0.2-1-x86_64)...
Downloading grilo (0.3.7-1-x86_64)...
Downloading webkit2gtk (2.24.0-1-x86_64)...
Downloading gnome-control-center (3.30.3+4+g26287234b-1-x86_64)...
Downloading qt5-base (5.12.1-3.1-x86_64)...
Downloading libdazzle (3.32.0-1-x86_64)...
Downloading protobuf (3.7.0-1-x86_64)...
Downloading libphonenumber (8.10.6-1-x86_64)...
Downloading ntp (4.2.8.p13-2-x86_64)...
Downloading pamac-common (7.3.5-2-x86_64)...
Downloading pamac-cli (7.3.5-2-x86_64)...
Downloading udisks2 (2.8.2-1-x86_64)...
Downloading yelp-xsl (3.32.0-1-any)...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Running pre-transaction hooks...
Remove Firefox Distribution Settings
Save Linux kernel modules
Removing pamac (7.3.4-2)...
/etc/pamac.conf installed as /etc/pamac.conf.pacsave.
Upgrading systemd-libs (241.588-1 -> 241.607-1)...
Upgrading e2fsprogs (1.44.6-1 -> 1.45.0-1)...
Upgrading at-spi2-core (2.30.1-1 -> 2.32.0-1)...
Upgrading atk (2.30.0-1 -> 2.32-1)...
Upgrading at-spi2-atk (2.30.1-1 -> 2.32.0-1)...
Upgrading dconf (0.30.1-1 -> 0.32.0-1)...
Upgrading gtk-update-icon-cache (3.24.5-1 -> 3.24.7-1)...
Upgrading systemd (241.588-1 -> 241.607-1)...
Upgrading tdb (1.3.16-1 -> 1.3.18-1)...
Upgrading glib-networking (2.58.0-1 -> 2.60.0.1-1)...
Upgrading libsoup (2.64.2-1 -> 2.66.0-1)...
Upgrading gtk3 (3.24.5-1 -> 3.24.7-1)...
Upgrading baobab (3.30.0-1 -> 3.32.0-1)...
Upgrading double-conversion (3.1.1-1 -> 3.1.4-1)...
Upgrading file-roller (3.30.1-1 -> 3.32.0-1)...
Upgrading nspr (4.20-1 -> 4.21-1)...
Upgrading firefox (65.0.2-1 -> 66.0-0)...
Installing gtksourceview4 (4.0.3-1)...
Upgrading gobject-introspection-runtime (1.58.3-1 -> 1.60.0-1)...
Upgrading gedit (3.30.2-1 -> 3.32.0-1)...
Upgrading geocode-glib (3.26.0-1 -> 3.26.1-1)...
Upgrading upower (0.99.9-1 -> 0.99.10-1)...
Upgrading libwbclient (4.9.4-2 -> 4.9.5-1)...
Upgrading talloc (2.1.14-1 -> 2.1.16-1)...
Upgrading tevent (1:0.9.37-1 -> 1:0.9.39-1)...
Upgrading ldb (1:1.4.3-1 -> 1:1.4.6-1)...
Upgrading smbclient (4.9.4-2 -> 4.9.5-1)...
Upgrading lua52-lpeg (1.0.1-2 -> 1.0.2-1)...
Upgrading grilo (0.3.6-1 -> 0.3.7-1)...
Upgrading webkit2gtk (2.22.7-1 -> 2.24.0-1)...
Upgrading gnome-control-center (3.30.3-1 -> 3.30.3+4+g26287234b-1)...
Upgrading qt5-base (5.12.1-2.1 -> 5.12.1-3.1)...
Upgrading kvantum-manjaro (0.12.0-1 -> 0.13.0-1)...
Upgrading lib32-pcre (8.42-1 -> 8.43-1)...
Upgrading lib32-systemd (241.588-1 -> 241.607-1)...
Upgrading libdazzle (3.30.2-1 -> 3.32.0-1)...
Upgrading libgexiv2 (0.10.8-2 -> 0.12.0-1)...
Upgrading protobuf (3.6.1.3-1 -> 3.7.0-1)...
Upgrading libphonenumber (8.10.1-2 -> 8.10.6-1)...
Upgrading linux419 (4.19.28-1 -> 4.19.29-1)...
Upgrading linux419-virtualbox-guest-modules (6.0.4-10 -> 6.0.4-11)...
Upgrading ntp (4.2.8.p12-2 -> 4.2.8.p13-2)...
Installing pamac-common (7.3.5-2)...
Configuring pamac-common...
==> An authentication agent is required
    Cinnamon, Deepin, GNOME, GNOME Flashback, KDE, LXDE, LXQt, MATE and Xfce
    have an authentication agent already.
    See https://wiki.archlinux.org/index.php/Polkit#Authentication_agents
    for other desktop environments.
Installing pamac-cli (7.3.5-2)...
Installing pamac-gtk (7.3.5-2)...
Configuring pamac-gtk...
==> Enable Pamac Updates Indicator via
    Gnome Tweak
Upgrading systemd-sysvcompat (241.588-1 -> 241.607-1)...
Upgrading terminus-font (4.46-1.1 -> 4.47-2)...
Upgrading udisks2 (2.8.1-1 -> 2.8.2-1)...
Upgrading yelp-xsl (3.30.1-1 -> 3.32.0-1)...
Running post-transaction hooks...
Updating linux419 module dependencies...
Updating linux419 initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'default'
  -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64.img
==> Starting build: 4.19.29-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'fallback'
  -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64-fallback.img -S autodetect
==> Starting build: 4.19.29-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64-fallback.img
==> Image generation successful
Updating Grub-Bootmenu
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-4.19-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
Copy Firefox Distribution Settings
Updating fontconfig cache...
Updating GIO module cache...
Compiling GSettings XML schema files...
Probing GTK3 input method modules...
Updating icon theme caches...
Restore Linux kernel modules

e[1;1me[1;32m==>e[1;0me[1;1m Warning:
	 -> Kernel has been updated. Modules of the current kernel
	 -> have been backed up so you can continue to use your
	 -> computer. However, the new kernel will only work 
	 -> at next boot.
	e[1;0m
	e[1;0m
Updating journal message catalog...
Reloading system manager configuration...
Updating udev hardware database...
Applying kernel sysctl settings...
Creating system user accounts...
Creating temporary files...
Reloading device manager configuration...
Arming ConditionNeedsUpdate...
Updating the info directory file...
Updating the desktop file MIME type cache...
Updating the MIME type database...
Updating X fontdir indices...
Transaction successfully finished.

Btw, it was not necessary to use $1 instead of $2 in the post_upgrade() function in the .install. For the post_upgrade() function, $1 is the version of the new package (the one replacing) and $2 is the version of the old package (the one being replaced). Quoting man PKGBUILD :

   post_upgrade
       Run after files are extracted. Two arguments are passed in this
       order: new package full version string, old package full version
       string.

It is necessary to use $1 in post_install() because there is only one argument passed in this function, the version of the package being installed.

   post_install
       Run right after files are extracted. One argument is passed: new
       package full version string.

In this case, using the same line for the if in both post_install() and post_upgrade() doesn't seems to be much a problem, because the instruction executed if the condition is verified will only do something if the .pacsave file exists and if it doesn't, it does nothing at all.

But this could be something significant in the future if you have to use arguments passed in post_install()/post_upgrade()/etc.

1 Like

Still doesn't work me too.

No errors as far as I can see in /var/log/pacman.log when upgrading an up to date stable to testing in a VirtualBox machine. Tweaked configuration is still not imported.

My /var/log/pacman.log related to this migration (sorry for the french messages in it).
[2019-03-19 08:03] [PAMAC] synchronizing package lists
[2019-03-19 08:04] [PAMAC] synchronizing package lists
[2019-03-19 08:04] [PACMAN] Running 'pacman -Syy'
[2019-03-19 08:04] [PACMAN] synchronizing package lists
[2019-03-19 08:05] [PAMAC] synchronizing package lists
[2019-03-19 08:06] [PAMAC] synchronizing package lists
[2019-03-19 08:07] [ALPM] transaction started
[2019-03-19 08:07] [ALPM] warning: /etc/pamac.conf saved as /etc/pamac.conf.pacsave
[2019-03-19 08:07] [ALPM] removed pamac (7.3.4-2)
[2019-03-19 08:07] [ALPM] upgraded glib2 (2.58.3-1 -> 2.60.0-1)
[2019-03-19 08:07] [ALPM] upgraded e2fsprogs (1.44.6-1 -> 1.45.0-1)
[2019-03-19 08:07] [ALPM] upgraded at-spi2-core (2.30.1-1 -> 2.32.0-1)
[2019-03-19 08:07] [ALPM] upgraded atk (2.30.0-1 -> 2.32-1)
[2019-03-19 08:07] [ALPM] upgraded at-spi2-atk (2.30.1-1 -> 2.32.0-1)
[2019-03-19 08:07] [ALPM] upgraded dconf (0.30.1-1 -> 0.32.0-1)
[2019-03-19 08:07] [ALPM] upgraded double-conversion (3.1.1-1 -> 3.1.4-1)
[2019-03-19 08:07] [ALPM] upgraded firefox-ublock-origin (1.18.4-1 -> 1.18.6-1)
[2019-03-19 08:07] [ALPM] upgraded foomatic-db-nonfree-ppds (3:20190301-1 -> 3:20190312-1)
[2019-03-19 08:07] [ALPM] upgraded foomatic-db-ppds (3:20190301-1 -> 3:20190312-1)
[2019-03-19 08:07] [ALPM] upgraded glib-networking (2.58.0-1 -> 2.60.0.1-1)
[2019-03-19 08:07] [ALPM] upgraded glib2-docs (2.58.3-1 -> 2.60.0-1)
[2019-03-19 08:07] [ALPM] upgraded gobject-introspection-runtime (1.58.3-1 -> 1.60.0-1)
[2019-03-19 08:07] [ALPM] upgraded gtk-update-icon-cache (3.24.5-1 -> 3.24.7-1)
[2019-03-19 08:07] [ALPM] upgraded tdb (1.3.16-1 -> 1.3.18-1)
[2019-03-19 08:07] [ALPM] upgraded libsoup (2.64.2-1 -> 2.66.0-1)
[2019-03-19 08:07] [ALPM] upgraded gtk3 (3.24.5-1 -> 3.24.7-1)
[2019-03-19 08:07] [ALPM] upgraded nspr (4.20-1 -> 4.21-1)
[2019-03-19 08:07] [ALPM] upgraded lua52-lpeg (1.0.1-2 -> 1.0.2-1)
[2019-03-19 08:07] [ALPM] upgraded grilo (0.3.6-1 -> 0.3.7-1)
[2019-03-19 08:07] [ALPM] upgraded qt5-base (5.12.1-2.1 -> 5.12.1-3.1)
[2019-03-19 08:07] [ALPM] upgraded kvantum-manjaro (0.12.0-1 -> 0.13.0-1)
[2019-03-19 08:07] [ALPM] upgraded talloc (2.1.14-1 -> 2.1.16-1)
[2019-03-19 08:07] [ALPM] upgraded tevent (1:0.9.37-1 -> 1:0.9.39-1)
[2019-03-19 08:07] [ALPM] upgraded ldb (1:1.4.3-1 -> 1:1.4.6-1)
[2019-03-19 08:07] [ALPM] upgraded lib32-pcre (8.42-1 -> 8.43-1)
[2019-03-19 08:07] [ALPM] upgraded lib32-glib2 (2.58.3-1 -> 2.60.0-1)
[2019-03-19 08:07] [ALPM] upgraded libgexiv2 (0.10.8-2 -> 0.12.0-1)
[2019-03-19 08:07] [ALPM] upgraded libwbclient (4.9.4-2 -> 4.9.5-1)
[2019-03-19 08:08] [ALPM] upgraded linux419 (4.19.28-1 -> 4.19.29-1)
[2019-03-19 08:08] [ALPM] upgraded linux419-virtualbox-guest-modules (6.0.4-10 -> 6.0.4-11)
[2019-03-19 08:08] [ALPM] upgraded ntp (4.2.8.p12-2 -> 4.2.8.p13-2)
[2019-03-19 08:08] [ALPM] installed pamac-common (7.3.5-2)
[2019-03-19 08:08] [ALPM-SCRIPTLET] ==> An authentication agent is required
[2019-03-19 08:08] [ALPM-SCRIPTLET]     Cinnamon, Deepin, GNOME, GNOME Flashback, KDE, LXDE, LXQt, MATE and Xfce
[2019-03-19 08:08] [ALPM-SCRIPTLET]     have an authentication agent already.
[2019-03-19 08:08] [ALPM-SCRIPTLET]     See https://wiki.archlinux.org/index.php/Polkit#Authentication_agents
[2019-03-19 08:08] [ALPM-SCRIPTLET]     for other desktop environments.
[2019-03-19 08:08] [ALPM] installed pamac-cli (7.3.5-2)
[2019-03-19 08:08] [ALPM] installed pamac-gtk (7.3.5-2)
[2019-03-19 08:08] [ALPM-SCRIPTLET] ==> Enable Pamac Updates Indicator via
[2019-03-19 08:08] [ALPM-SCRIPTLET]     Gnome Tweak
[2019-03-19 08:08] [ALPM] upgraded python-psutil (5.5.0-1 -> 5.6.0-1)
[2019-03-19 08:08] [ALPM] upgraded smbclient (4.9.4-2 -> 4.9.5-1)
[2019-03-19 08:08] [ALPM] upgraded samba (4.9.4-2 -> 4.9.5-1)
[2019-03-19 08:08] [ALPM] upgraded terminus-font (4.46-1.1 -> 4.47-2)
[2019-03-19 08:08] [ALPM] upgraded udisks2 (2.8.1-1 -> 2.8.2-1)
[2019-03-19 08:08] [ALPM] upgraded upower (0.99.9-1 -> 0.99.10-1)
[2019-03-19 08:08] [ALPM] upgraded webkit2gtk (2.22.7-1 -> 2.24.0-1)
[2019-03-19 08:08] [ALPM] upgraded yelp-xsl (3.30.1-1 -> 3.32.0-1)
[2019-03-19 08:08] [ALPM] transaction completed
[2019-03-19 08:08] [ALPM] running '60-linux419.hook'...
[2019-03-19 08:08] [ALPM] running '90-linux419.hook'...
[2019-03-19 08:08] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'default'
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64.img
[2019-03-19 08:08] [ALPM-SCRIPTLET] ==> Starting build: 4.19.29-1-MANJARO
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2019-03-19 08:08] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2019-03-19 08:08] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64.img
[2019-03-19 08:08] [ALPM-SCRIPTLET] ==> Image generation successful
[2019-03-19 08:08] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'fallback'
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64-fallback.img -S autodetect
[2019-03-19 08:08] [ALPM-SCRIPTLET] ==> Starting build: 4.19.29-1-MANJARO
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2019-03-19 08:08] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2019-03-19 08:08] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2019-03-19 08:08] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64-fallback.img
[2019-03-19 08:08] [ALPM-SCRIPTLET] ==> Image generation successful
[2019-03-19 08:08] [ALPM] running '99-grub.hook'...
[2019-03-19 08:08] [ALPM-SCRIPTLET] Création du fichier de configuration GRUB…
[2019-03-19 08:08] [ALPM-SCRIPTLET] Arrière-plan trouvé : /usr/share/grub/background.png
[2019-03-19 08:08] [ALPM-SCRIPTLET] Image Linux trouvée : /boot/vmlinuz-4.19-x86_64
[2019-03-19 08:08] [ALPM-SCRIPTLET] Image mémoire initiale trouvée : /boot/amd-ucode.img /boot/initramfs-4.19-x86_64.img
[2019-03-19 08:08] [ALPM-SCRIPTLET] Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
[2019-03-19 08:08] [ALPM-SCRIPTLET] Found memtest86+ image: /boot/memtest86+/memtest.bin
[2019-03-19 08:08] [ALPM-SCRIPTLET] fait
[2019-03-19 08:08] [ALPM] running 'fontconfig.hook'...
[2019-03-19 08:08] [ALPM] running 'gio-querymodules.hook'...
[2019-03-19 08:08] [ALPM] running 'glib-compile-schemas.hook'...
[2019-03-19 08:08] [ALPM] running 'gtk-query-immodules-3.0.hook'...
[2019-03-19 08:08] [ALPM] running 'gtk-update-icon-cache.hook'...
[2019-03-19 08:08] [ALPM] running 'systemd-daemon-reload.hook'...
[2019-03-19 08:08] [ALPM] running 'systemd-sysusers.hook'...
[2019-03-19 08:08] [ALPM] running 'systemd-tmpfiles.hook'...
[2019-03-19 08:08] [ALPM] running 'systemd-udev-reload.hook'...
[2019-03-19 08:08] [ALPM] running 'systemd-update.hook'...
[2019-03-19 08:08] [ALPM] running 'texinfo-install.hook'...
[2019-03-19 08:08] [ALPM] running 'update-desktop-database.hook'...
[2019-03-19 08:08] [ALPM] running 'update-mime-database.hook'...
[2019-03-19 08:08] [ALPM] running 'xorg-mkfontscale.hook'...

I reported a bug here: https://gitlab.manjaro.org/applications/pamac/issues/576

I agree, here is not a hook
pamac is removed just before (we cant test)
pamac-common is already installed in post_update() function ($1 == this curent version)

2 bad test :

  • test .pacsave date and if modified at this day
if [ -f "/etc/pamac.conf.pacsave" ]; then
    fdate=$(stat -c "%x" /etc/pamac.conf.pacsave) # ? good also with ssd ?
    fdate=${fdate%%:*}
    if [[ "$fdate" == "$(date "+%Y-%m-%d %H")" ]]; then
        pacsave modified in hour of this day so pamac? removed
    fi
fi
  • test grep in pacman.log if pamac is removed at this day
    grep $date and "removed pamac "
    better than testing .save date but grep in big logs is long

  • or in manjaro-system test if "pamac" is installed (so ! pamac-common but in this update) and create a /etc/pamac.conf.save and in pamac-common.install only test if pamac.conf.save exist, update .conf and remove .save

1 Like

After further testing, this is specific to kernel 5.0.x, with kernel 4.19 there's no such delay. As soon as I use kernel 5.0 on battery power the shutdown delay returns (mains power is seemingly okay). Going for shutdown or restart produces the same behaviour. I don't use hibernate because the SSD boots from cold just as fast as the laptop resumes from hibernation.

There's nothing in the logs so I'm none the wiser what the conflict is. I guess I need to try eliminating commands entered in grub for power management but they have been fine with all previous kernels.

I've found that there is often a two minute delay in a restart after a major update regardless of the kernel in use. So far it's affected 4.19, 4.20 and 5.0 and IIRC, is caused by a stop job for session 2 running. However, it only happens on the first reboot or shut down after the update. I always assumed it was because I update and reboot from a tty and don't log out of the GUI session.

yeah, that's nothing unusual but it's not just after an update this time. It's happened again since when I've not applied any updates.

Don't want to bother but if this hits stable without a Compiz rebuild, all the Compiz users will end up with a desktop without window borders. :wink:

2 Likes

Sounds liberating. :grin:

1 Like

Well, that's one way to view it. :smiley: But on a serious note, if somebody with GitLab access could bump the revision and trigger a rebuild for the compiz-manjaro package, it would be great!

Some extra stuff bois.
https://lists.manjaro.org/pipermail/manjaro-packages/Week-of-Mon-20190318/021742.html
https://lists.manjaro.org/pipermail/manjaro-packages/Week-of-Mon-20190318/021743.html

The .install for pamac-common has been reworked a little bit. @fredb74

3 Likes

@philm Good news, looks like the transition is done correctly and that the old conf file is restored successfully now. I tried in VM with Pamac GTK, Pamac CLI and pacman, in three different editions, jumping from Stable to Testing.

Manjaro Gnome - Pamac GTK
Synchronizing package databases...
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Downloading glib2 (2.60.0-1-x86_64)...
Downloading e2fsprogs (1.45.0-1-x86_64)...
Downloading nspr (4.21-1-x86_64)...
Downloading linux419 (4.19.30-1-x86_64)...
Downloading at-spi2-core (2.32.0-1-x86_64)...
Downloading atk (2.32-1-x86_64)...
Downloading at-spi2-atk (2.32.0-1-x86_64)...
Downloading dconf (0.32.0-1-x86_64)...
Downloading gtk-update-icon-cache (3.24.7-1-x86_64)...
Downloading tdb (1.3.18-1-x86_64)...
Downloading glib-networking (2.60.0.1-1-x86_64)...
Downloading libsoup (2.66.0-1-x86_64)...
Downloading gtk3 (3.24.7-1-x86_64)...
Downloading baobab (3.32.0-1-x86_64)...
Downloading double-conversion (3.1.4-1-x86_64)...
Downloading file-roller (3.32.0-1-x86_64)...
Downloading firefox (66.0-0-x86_64)...
Downloading gtksourceview4 (4.0.3-1-x86_64)...
Downloading gobject-introspection-runtime (1.60.0-1-x86_64)...
Downloading gedit (3.32.0-1-x86_64)...
Downloading geocode-glib (3.26.1-1-x86_64)...
Downloading upower (0.99.10-1-x86_64)...
Downloading libwbclient (4.9.5-1-x86_64)...
Downloading talloc (2.1.16-1-x86_64)...
Downloading tevent (1:0.9.39-1-x86_64)...
Downloading ldb (1:1.4.6-1-x86_64)...
Downloading smbclient (4.9.5-1-x86_64)...
Downloading lua52-lpeg (1.0.2-1-x86_64)...
Downloading grilo (0.3.7-1-x86_64)...
Downloading webkit2gtk (2.24.0-1-x86_64)...
Downloading gnome-control-center (3.30.3+4+g26287234b-1-x86_64)...
Downloading qt5-base (5.12.1-3.1-x86_64)...
Downloading libdazzle (3.32.0-1-x86_64)...
Downloading protobuf (3.7.0-1-x86_64)...
Downloading libphonenumber (8.10.6-1-x86_64)...
Downloading linux419-virtualbox-guest-modules (6.0.4-12-x86_64)...
Downloading ntp (4.2.8.p13-2-x86_64)...
Downloading pamac-common (7.3.5-3-x86_64)...
Downloading pamac-cli (7.3.5-2-x86_64)...
Downloading pamac-gtk (7.3.5-2-x86_64)...
Downloading udisks2 (2.8.2-1-x86_64)...
Downloading yelp-xsl (3.32.0-1-any)...
Downloading kvantum-manjaro (0.13.0-1-any)...
Downloading libgexiv2 (0.12.0-1-x86_64)...
Downloading terminus-font (4.47-2-any)...
Downloading lib32-pcre (8.43-1-x86_64)...
Downloading lib32-glib2 (2.60.0-1-x86_64)...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Running pre-transaction hooks...
Remove Firefox Distribution Settings
Save Linux kernel modules
Removing pamac (7.3.4-2)...
/etc/pamac.conf installed as /etc/pamac.conf.pacsave.
Upgrading glib2 (2.58.3-1 -> 2.60.0-1)...
Upgrading e2fsprogs (1.44.6-1 -> 1.45.0-1)...
Upgrading at-spi2-core (2.30.1-1 -> 2.32.0-1)...
Upgrading atk (2.30.0-1 -> 2.32-1)...
Upgrading at-spi2-atk (2.30.1-1 -> 2.32.0-1)...
Upgrading dconf (0.30.1-1 -> 0.32.0-1)...
Upgrading gtk-update-icon-cache (3.24.5-1 -> 3.24.7-1)...
Upgrading tdb (1.3.16-1 -> 1.3.18-1)...
Upgrading glib-networking (2.58.0-1 -> 2.60.0.1-1)...
Upgrading libsoup (2.64.2-1 -> 2.66.0-1)...
Upgrading gtk3 (3.24.5-1 -> 3.24.7-1)...
Upgrading baobab (3.30.0-1 -> 3.32.0-1)...
Upgrading double-conversion (3.1.1-1 -> 3.1.4-1)...
Upgrading file-roller (3.30.1-1 -> 3.32.0-1)...
Upgrading nspr (4.20-1 -> 4.21-1)...
Upgrading firefox (65.0.2-1 -> 66.0-0)...
Installing gtksourceview4 (4.0.3-1)...
Upgrading gobject-introspection-runtime (1.58.3-1 -> 1.60.0-1)...
Upgrading gedit (3.30.2-1 -> 3.32.0-1)...
Upgrading geocode-glib (3.26.0-1 -> 3.26.1-1)...
Upgrading upower (0.99.9-1 -> 0.99.10-1)...
Upgrading libwbclient (4.9.4-2 -> 4.9.5-1)...
Upgrading talloc (2.1.14-1 -> 2.1.16-1)...
Upgrading tevent (1:0.9.37-1 -> 1:0.9.39-1)...
Upgrading ldb (1:1.4.3-1 -> 1:1.4.6-1)...
Upgrading smbclient (4.9.4-2 -> 4.9.5-1)...
Upgrading lua52-lpeg (1.0.1-2 -> 1.0.2-1)...
Upgrading grilo (0.3.6-1 -> 0.3.7-1)...
Upgrading webkit2gtk (2.22.7-1 -> 2.24.0-1)...
Upgrading gnome-control-center (3.30.3-1 -> 3.30.3+4+g26287234b-1)...
Upgrading qt5-base (5.12.1-2.1 -> 5.12.1-3.1)...
Upgrading kvantum-manjaro (0.12.0-1 -> 0.13.0-1)...
Upgrading lib32-pcre (8.42-1 -> 8.43-1)...
Upgrading lib32-glib2 (2.58.3-1 -> 2.60.0-1)...
Upgrading libdazzle (3.30.2-1 -> 3.32.0-1)...
Upgrading libgexiv2 (0.10.8-2 -> 0.12.0-1)...
Upgrading protobuf (3.6.1.3-1 -> 3.7.0-1)...
Upgrading libphonenumber (8.10.1-2 -> 8.10.6-1)...
Upgrading linux419 (4.19.28-1 -> 4.19.30-1)...
Upgrading linux419-virtualbox-guest-modules (6.0.4-10 -> 6.0.4-12)...
Upgrading ntp (4.2.8.p12-2 -> 4.2.8.p13-2)...
Installing pamac-common (7.3.5-3)...
Configuring pamac-common...
==> An authentication agent is required
    Cinnamon, Deepin, GNOME, GNOME Flashback, KDE, LXDE, LXQt, MATE and Xfce
    have an authentication agent already.
    See https://wiki.archlinux.org/index.php/Polkit#Authentication_agents
    for other desktop environments.
e[1;1me[1;32m==>e[1;0me[1;1m You had an old /etc/pamac.conf.pacsave file. We restore it for you.e[1;0m
e[1;1me[1;32m==>e[1;0me[1;1m You can find your new pamac.conf saved as `/etc/pamac-new-03191128.conf`e[1;0m
Installing pamac-cli (7.3.5-2)...
Installing pamac-gtk (7.3.5-2)...
Configuring pamac-gtk...
==> Enable Pamac Updates Indicator via
    Gnome Tweak
Upgrading terminus-font (4.46-1.1 -> 4.47-2)...
Upgrading udisks2 (2.8.1-1 -> 2.8.2-1)...
Upgrading yelp-xsl (3.30.1-1 -> 3.32.0-1)...
Running post-transaction hooks...
Updating linux419 module dependencies...
Updating linux419 initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'default'
  -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64.img
==> Starting build: 4.19.30-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'fallback'
  -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64-fallback.img -S autodetect
==> Starting build: 4.19.30-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64-fallback.img
==> Image generation successful
Updating Grub-Bootmenu
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-4.19-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
Copy Firefox Distribution Settings
Updating fontconfig cache...
Updating GIO module cache...
Compiling GSettings XML schema files...
Probing GTK3 input method modules...
Updating icon theme caches...
Restore Linux kernel modules

e[1;1me[1;32m==>e[1;0me[1;1m Warning:
	 -> Kernel has been updated. Modules of the current kernel
	 -> have been backed up so you can continue to use your
	 -> computer. However, the new kernel will only work 
	 -> at next boot.
	e[1;0m
	e[1;0m
Reloading system manager configuration...
Creating system user accounts...
Reloading device manager configuration...
Arming ConditionNeedsUpdate...
Updating the info directory file...
Updating the desktop file MIME type cache...
Updating the MIME type database...
Updating X fontdir indices...
Transaction successfully finished.

gnome-pamac-conf-file

Manjaro Cinnamon - Pamac CLI
[ami@mjrocin Desktop]$ ls /etc | grep pa
apparmor.d
libpaper.d
pacman.conf
pacman.d
pacman-mirrors.conf
pamac.conf
pamac.conf.pacnew
pam.d
papersize
passwd
passwd-
vdpau_wrapper.cfg
wpa_supplicant
[ami@mjrocin Desktop]$ pamac upgrade
==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required
Authenticating as: Ami (ami)
Password: 
==== AUTHENTICATION COMPLETE ====
Synchronizing package databases...
Refreshing community.db...
Refreshing multilib.db...                                                       
Starting full system upgrade...                                                 
Resolving dependencies...
Checking inter-conflicts...
To upgrade (46):
  glib2                              2.60.0-1     (2.58.3-1)     core       2.5 MB
  e2fsprogs                          1.45.0-1     (1.44.6-1)     core       1.1 MB
  at-spi2-core                       2.32.0-1     (2.30.1-1)     extra      237.3 kB
  atk                                2.32-1       (2.30.0-1)     extra      355.2 kB
  at-spi2-atk                        2.32.0-1     (2.30.1-1)     extra      56.7 kB
  dconf                              0.32.0-1     (0.30.1-1)     extra      91.6 kB
  gtk-update-icon-cache              3.24.7-1     (3.24.5-1)     extra      14.2 kB
  tdb                                1.3.18-1     (1.3.16-1)     extra      69.4 kB
  glib-networking                    2.60.0.1-1   (2.58.0-1)     extra      97.7 kB
  libsoup                            2.66.0-1     (2.64.2-1)     extra      522.6 kB
  gtk3                               3.24.7-1     (3.24.5-1)     extra      11.1 MB
  baobab                             3.32.0-1     (3.30.0-1)     extra      269.6 kB
  double-conversion                  3.1.4-1      (3.1.1-1)      extra      52.1 kB
  file-roller                        3.32.0-1     (3.30.1-1)     extra      889.1 kB
  nspr                               4.21-1       (4.20-1)       core       193.8 kB
  firefox                            66.0-0       (65.0.2-1)     extra      48.8 MB
  geocode-glib                       3.26.1-1     (3.26.0-1)     extra      90.6 kB
  gobject-introspection-runtime      1.60.0-1     (1.58.3-1)     extra      180.3 kB
  qt5-base                           5.12.1-3.1   (5.12.1-2.1)   extra      12.8 MB
  kvantum-manjaro                    0.13.0-1     (0.12.0-1)     community  77.6 kB
  talloc                             2.1.16-1     (2.1.14-1)     extra      57.1 kB
  tevent                             1:0.9.39-1   (1:0.9.37-1)   extra      49.5 kB
  ldb                                1:1.4.6-1    (1:1.4.3-1)    extra      194.2 kB
  lib32-pcre                         8.43-1       (8.42-1)       multilib   345.5 kB
  lib32-glib2                        2.60.0-1     (2.58.3-1)     multilib   1.1 MB
  libebml                            1.3.7-1      (1.3.6-1)      extra      65.5 kB
  protobuf                           3.7.0-1      (3.6.1.3-1)    extra      1.9 MB
  protobuf-c                         1.3.1-2      (1.3.1-1)      extra      92.8 kB
  libgadu                            1.12.2-8     (1.12.2-6)     extra      98.2 kB
  libgexiv2                          0.12.0-1     (0.10.8-2)     community  63.6 kB
  libmatroska                        1.5.0-1      (1.4.9-1)      extra      138.3 kB
  libwbclient                        4.9.5-1      (4.9.4-2)      extra      34.1 kB
  linux414                           4.14.107-1   (4.14.105-1)   core       64.3 MB
  linux414-virtualbox-guest-modules  6.0.4-8      (6.0.4-7)      extra      214.8 kB
  lua52-lpeg                         1.0.2-1      (1.0.1-2)      extra      23.8 kB
  ntp                                4.2.8.p13-2  (4.2.8.p12-2)  extra      1.8 MB
  python-psutil                      5.6.0-1      (5.5.0-1)      community  379.2 kB
  smbclient                          4.9.5-1      (4.9.4-2)      extra      6.1 MB
  samba                              4.9.5-1      (4.9.4-2)      extra      6.3 MB
  terminus-font                      4.47-2       (4.46-1.1)     community  974.1 kB
  udisks2                            2.8.2-1      (2.8.1-1)      extra      897.0 kB
  udiskie                            1.7.7-1      (1.7.5-2)      community  122.8 kB
  upower                             0.99.10-1    (0.99.9-1)     extra      170.1 kB
  vlc                                3.0.6-9      (3.0.6-8)      extra      11.2 MB
  webkit2gtk                         2.24.0-1     (2.22.7-1)     extra      17.8 MB
  yelp-xsl                           3.32.0-1     (3.30.1-1)     extra      241.6 kB
To install (3):
  pamac-common                       7.3.5-3                     extra      369.2 kB
  pamac-cli                          7.3.5-2                     extra      50.5 kB
  pamac-gtk                          7.3.5-2                     extra      117.9 kB
To remove (1):
  pamac                              7.3.4-2                     

Total download size: 194.7 MB
Total installed size: -34.4 MB
Total removed size: 3.4 MB
Commit transaction ? [y/N] y
Downloading glib2 (2.60.0-1-x86_64)...
Downloading e2fsprogs (1.45.0-1-x86_64)...                                                                                                                                                                          
Downloading nspr (4.21-1-x86_64)...                                                                                                                                                                                 
Downloading linux414 (4.14.107-1-x86_64)...                                                                                                                                                                         
Downloading at-spi2-core (2.32.0-1-x86_64)...                                                                                                                                                                       
Downloading atk (2.32-1-x86_64)...                                                                                                                                                                                  
Downloading at-spi2-atk (2.32.0-1-x86_64)...                                                                                                                                                                        
Downloading dconf (0.32.0-1-x86_64)...                                                                                                                                                                              
Downloading gtk-update-icon-cache (3.24.7-1-x86_64)...                                                                                                                                                              
Downloading tdb (1.3.18-1-x86_64)...                                                                                                                                                                                
Downloading glib-networking (2.60.0.1-1-x86_64)...                                                                                                                                                                  
Downloading libsoup (2.66.0-1-x86_64)...                                                                                                                                                                            
Downloading gtk3 (3.24.7-1-x86_64)...                                                                                                                                                                               
Downloading baobab (3.32.0-1-x86_64)...                                                                                                                                                                             
Downloading double-conversion (3.1.4-1-x86_64)...                                                                                                                                                                   
Downloading file-roller (3.32.0-1-x86_64)...                                                                                                                                                                        
Downloading firefox (66.0-0-x86_64)...                                                                                                                                                                              
Downloading geocode-glib (3.26.1-1-x86_64)...                                                                                                                                                                       
Downloading gobject-introspection-runtime (1.60.0-1-x86_64)...                                                                                                                                                      
Downloading qt5-base (5.12.1-3.1-x86_64)...                                                                                                                                                                         
Downloading talloc (2.1.16-1-x86_64)...                                                                                                                                                                             
Downloading tevent (1:0.9.39-1-x86_64)...                                                                                                                                                                           
Downloading ldb (1:1.4.6-1-x86_64)...                                                                                                                                                                               
Downloading libebml (1.3.7-1-x86_64)...                                                                                                                                                                             
Downloading protobuf (3.7.0-1-x86_64)...                                                                                                                                                                            
Downloading protobuf-c (1.3.1-2-x86_64)...                                                                                                                                                                          
Downloading libgadu (1.12.2-8-x86_64)...                                                                                                                                                                            
Downloading libmatroska (1.5.0-1-x86_64)...                                                                                                                                                                         
Downloading libwbclient (4.9.5-1-x86_64)...                                                                                                                                                                         
Downloading linux414-virtualbox-guest-modules (6.0.4-8-x86_64)...                                                                                                                                                   
Downloading lua52-lpeg (1.0.2-1-x86_64)...                                                                                                                                                                          
Downloading ntp (4.2.8.p13-2-x86_64)...                                                                                                                                                                             
Downloading pamac-common (7.3.5-3-x86_64)...                                                                                                                                                                        
Downloading pamac-cli (7.3.5-2-x86_64)...                                                                                                                                                                           
Downloading pamac-gtk (7.3.5-2-x86_64)...                                                                                                                                                                           
Downloading smbclient (4.9.5-1-x86_64)...                                                                                                                                                                           
Downloading samba (4.9.5-1-x86_64)...                                                                                                                                                                               
Downloading udisks2 (2.8.2-1-x86_64)...                                                                                                                                                                             
Downloading upower (0.99.10-1-x86_64)...                                                                                                                                                                            
Downloading vlc (3.0.6-9-x86_64)...                                                                                                                                                                                 
Downloading webkit2gtk (2.24.0-1-x86_64)...                                                                                                                                                                         
Downloading yelp-xsl (3.32.0-1-any)...                                                                                                                                                                              
Downloading kvantum-manjaro (0.13.0-1-any)...                                                                                                                                                                       
Downloading libgexiv2 (0.12.0-1-x86_64)...                                                                                                                                                                          
Downloading python-psutil (5.6.0-1-x86_64)...                                                                                                                                                                       
Downloading terminus-font (4.47-2-any)...                                                                                                                                                                           
Downloading udiskie (1.7.7-1-any)...                                                                                                                                                                                
Downloading lib32-pcre (8.43-1-x86_64)...                                                                                                                                                                           
Downloading lib32-glib2 (2.60.0-1-x86_64)...                                                                                                                                                                        
Checking keyring...                                                                                                                                                                                          [49/49]
Checking integrity...                                                                                                                                                                                        [49/49]
Loading packages files...                                                                                                                                                                                    [49/49]
Checking file conflicts...                                                                                                                                                                                   [49/49]
Checking available disk space...                                                                                                                                                                             [50/50]
Running pre-transaction hooks...
Remove Firefox Distribution Settings                                                                                                                                                                           [1/1]
Removing pamac (7.3.4-2)...                                                                                                                                                                                    [1/1]
/etc/pamac.conf installed as /etc/pamac.conf.pacsave.
Removing pamac (7.3.4-2)...                                                                                                                                                                                    [1/1]
Upgrading glib2 (2.58.3-1 -> 2.60.0-1)...                                                                                                                                                                     [1/49]
Upgrading e2fsprogs (1.44.6-1 -> 1.45.0-1)...                                                                                                                                                                 [2/49]
Upgrading at-spi2-core (2.30.1-1 -> 2.32.0-1)...                                                                                                                                                              [3/49]
Upgrading atk (2.30.0-1 -> 2.32-1)...                                                                                                                                                                         [4/49]
Upgrading at-spi2-atk (2.30.1-1 -> 2.32.0-1)...                                                                                                                                                               [5/49]
Upgrading dconf (0.30.1-1 -> 0.32.0-1)...                                                                                                                                                                     [6/49]
Upgrading gtk-update-icon-cache (3.24.5-1 -> 3.24.7-1)...                                                                                                                                                     [7/49]
Upgrading tdb (1.3.16-1 -> 1.3.18-1)...                                                                                                                                                                       [8/49]
Upgrading glib-networking (2.58.0-1 -> 2.60.0.1-1)...                                                                                                                                                         [9/49]
Upgrading libsoup (2.64.2-1 -> 2.66.0-1)...                                                                                                                                                                  [10/49]
Upgrading gtk3 (3.24.5-1 -> 3.24.7-1)...                                                                                                                                                                     [11/49]
Upgrading baobab (3.30.0-1 -> 3.32.0-1)...                                                                                                                                                                   [12/49]
Upgrading double-conversion (3.1.1-1 -> 3.1.4-1)...                                                                                                                                                          [13/49]
Upgrading file-roller (3.30.1-1 -> 3.32.0-1)...                                                                                                                                                              [14/49]
Upgrading nspr (4.20-1 -> 4.21-1)...                                                                                                                                                                         [15/49]
Upgrading firefox (65.0.2-1 -> 66.0-0)...                                                                                                                                                                    [16/49]
Upgrading geocode-glib (3.26.0-1 -> 3.26.1-1)...                                                                                                                                                             [17/49]
Upgrading gobject-introspection-runtime (1.58.3-1 -> 1.60.0-1)...                                                                                                                                            [18/49]
Upgrading qt5-base (5.12.1-2.1 -> 5.12.1-3.1)...                                                                                                                                                             [19/49]
Upgrading kvantum-manjaro (0.12.0-1 -> 0.13.0-1)...                                                                                                                                                          [20/49]
Upgrading talloc (2.1.14-1 -> 2.1.16-1)...                                                                                                                                                                   [21/49]
Upgrading tevent (1:0.9.37-1 -> 1:0.9.39-1)...                                                                                                                                                               [22/49]
Upgrading ldb (1:1.4.3-1 -> 1:1.4.6-1)...                                                                                                                                                                    [23/49]
Upgrading lib32-pcre (8.42-1 -> 8.43-1)...                                                                                                                                                                   [24/49]
Upgrading lib32-glib2 (2.58.3-1 -> 2.60.0-1)...                                                                                                                                                              [25/49]
Upgrading libebml (1.3.6-1 -> 1.3.7-1)...                                                                                                                                                                    [26/49]
Upgrading protobuf (3.6.1.3-1 -> 3.7.0-1)...                                                                                                                                                                 [27/49]
Upgrading protobuf-c (1.3.1-1 -> 1.3.1-2)...                                                                                                                                                                 [28/49]
Upgrading libgadu (1.12.2-6 -> 1.12.2-8)...                                                                                                                                                                  [29/49]
Upgrading libgexiv2 (0.10.8-2 -> 0.12.0-1)...                                                                                                                                                                [30/49]
Upgrading libmatroska (1.4.9-1 -> 1.5.0-1)...                                                                                                                                                                [31/49]
Upgrading libwbclient (4.9.4-2 -> 4.9.5-1)...                                                                                                                                                                [32/49]
Upgrading linux414 (4.14.105-1 -> 4.14.107-1)...                                                                                                                                                             [33/49]
Upgrading linux414-virtualbox-guest-modules (6.0.4-7 -> 6.0.4-8)...                                                                                                                                          [34/49]
Upgrading lua52-lpeg (1.0.1-2 -> 1.0.2-1)...                                                                                                                                                                 [35/49]
Upgrading ntp (4.2.8.p12-2 -> 4.2.8.p13-2)...                                                                                                                                                                [36/49]
Installing pamac-common (7.3.5-3)...                                                                                                                                                                         [37/49]
Configuring pamac-common...
==> An authentication agent is required
    Cinnamon, Deepin, GNOME, GNOME Flashback, KDE, LXDE, LXQt, MATE and Xfce
    have an authentication agent already.
    See https://wiki.archlinux.org/index.php/Polkit#Authentication_agents
    for other desktop environments.
==> You had an old /etc/pamac.conf.pacsave file. We restore it for you.
==> You can find your new pamac.conf saved as `/etc/pamac-new-03190315.conf`
Installing pamac-cli (7.3.5-2)...                                                                                                                                                                            [38/49]
Installing pamac-gtk (7.3.5-2)...                                                                                                                                                                            [39/49]
Configuring pamac-gtk...
==> Enable Pamac Updates Indicator via
    Gnome Tweak
Upgrading python-psutil (5.5.0-1 -> 5.6.0-1)...                                                                                                                                                              [40/49]
Upgrading smbclient (4.9.4-2 -> 4.9.5-1)...                                                                                                                                                                  [41/49]
Upgrading samba (4.9.4-2 -> 4.9.5-1)...                                                                                                                                                                      [42/49]
Upgrading terminus-font (4.46-1.1 -> 4.47-2)...                                                                                                                                                              [43/49]
Upgrading udisks2 (2.8.1-1 -> 2.8.2-1)...                                                                                                                                                                    [44/49]
Upgrading udiskie (1.7.5-2 -> 1.7.7-1)...                                                                                                                                                                    [45/49]
Upgrading upower (0.99.9-1 -> 0.99.10-1)...                                                                                                                                                                  [46/49]
Upgrading vlc (3.0.6-8 -> 3.0.6-9)...                                                                                                                                                                        [47/49]
Upgrading webkit2gtk (2.22.7-1 -> 2.24.0-1)...                                                                                                                                                               [48/49]
Upgrading yelp-xsl (3.30.1-1 -> 3.32.0-1)...                                                                                                                                                                 [49/49]
Running post-transaction hooks...
Updating linux414 module dependencies...                                                                                                                                                                      [1/19]
Updating linux414 initcpios...                                                                                                                                                                                [2/19]
==> Building image from preset: /etc/mkinitcpio.d/linux414.preset: 'default'
  -> -k /boot/vmlinuz-4.14-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.14-x86_64.img
==> Starting build: 4.14.107-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.14-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux414.preset: 'fallback'
  -> -k /boot/vmlinuz-4.14-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.14-x86_64-fallback.img -S autodetect
==> Starting build: 4.14.107-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.14-x86_64-fallback.img
==> Image generation successful
Updating Grub-Bootmenu                                                                                                                                                                                        [3/19]
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/amd-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
Copy Firefox Distribution Settings                                                                                                                                                                            [4/19]
Updating fontconfig cache...                                                                                                                                                                                  [5/19]
Updating GIO module cache...                                                                                                                                                                                  [6/19]
Compiling GSettings XML schema files...                                                                                                                                                                       [7/19]
No such key ‚Äúpanels-resizable‚ÄĚ in schema ‚Äúorg.cinnamon‚ÄĚ as specified in override file ‚Äú/usr/share/glib-2.0/schemas/99_manjaro-cinnamon.gschema.override‚ÄĚ; ignoring override for this key.
No such key ‚Äúuse-transparent-background‚ÄĚ in schema ‚Äúorg.gnome.Terminal.Legacy.Profile‚ÄĚ as specified in override file ‚Äú/usr/share/glib-2.0/schemas/99_manjaro-cinnamon.gschema.override‚ÄĚ; ignoring override for this key.
No such key ‚Äúbackground-transparency-percent‚ÄĚ in schema ‚Äúorg.gnome.Terminal.Legacy.Profile‚ÄĚ as specified in override file ‚Äú/usr/share/glib-2.0/schemas/99_manjaro-cinnamon.gschema.override‚ÄĚ; ignoring override for this key.
Probing GTK3 input method modules...                                                                                                                                                                          [8/19]
Updating icon theme caches...                                                                                                                                                                                 [9/19]
Reloading system manager configuration...                                                                                                                                                                    [10/19]
Creating system user accounts...                                                                                                                                                                             [11/19]
Creating temporary files...                                                                                                                                                                                  [12/19]
Reloading device manager configuration...                                                                                                                                                                    [13/19]
Arming ConditionNeedsUpdate...                                                                                                                                                                               [14/19]
Updating the info directory file...                                                                                                                                                                          [15/19]
Updating the desktop file MIME type cache...                                                                                                                                                                 [16/19]
Updating the MIME type database...                                                                                                                                                                           [17/19]
Updating the vlc plugin cache...                                                                                                                                                                             [18/19]
Updating X fontdir indices...                                                                                                                                                                                [19/19]
Transaction successfully finished.
[ami@mjrocin Desktop]$ ls /etc | grep pa
apparmor.d
libpaper.d
pacman.conf
pacman.d
pacman-mirrors.conf
pamac.conf
pamac.conf.pacnew
pamac-new-03190315.conf
pam.d
papersize
passwd
passwd-
vdpau_wrapper.cfg
wpa_supplicant
[ami@mjrocin Desktop]$ 
Manjaro XFCE - pacman
[ami@xfcenew Bureau]$ ls /etc | grep pa
apparmor.d
libpaper.d
pacman.conf
pacman.d
pacman-mirrors.conf
pamac.conf
pam.d
papersize
passwd
passwd-
vdpau_wrapper.cfg
wpa_supplicant
[ami@xfcenew Bureau]$ sudo pacman -Syu
[sudo] Mot de passe de ami : 
:: Synchronisation des bases de données de paquets…
 core                     147,4 KiB   465K/s 00:00 [######################] 100%
 extra                   1866,8 KiB   461K/s 00:04 [######################] 100%
 community                  5,2 MiB   468K/s 00:11 [######################] 100%
 multilib                 183,7 KiB   525K/s 00:00 [######################] 100%
:: Début de la mise à jour complète du système…
:: Remplacer pamac par extra/pamac-gtk ? [O/n] o
résolution des dépendances…
recherche des conflits entre paquets…

Paquets (55) at-spi2-atk-2.32.0-1  at-spi2-core-2.32.0-1  atk-2.32-1
             dconf-0.32.0-1  double-conversion-3.1.4-1  e2fsprogs-1.45.0-1
             file-roller-3.32.0-1  firefox-66.0-0  firefox-i18n-en-us-66.0-0
             firefox-i18n-fr-66.0-0  geocode-glib-3.26.1-1
             glib-networking-2.60.0.1-1  glib2-2.60.0-1  glib2-docs-2.60.0-1
             gobject-introspection-runtime-1.60.0-1
             gtk-update-icon-cache-3.24.7-1  gtk3-classic-3.24.7-1
             kvantum-manjaro-0.13.0-1  ldb-1:1.4.6-1  lib32-dconf-0.32.0-1
             lib32-glib2-2.60.0-1  lib32-gtk3-classic-3.24.7-1
             lib32-pcre-8.43-1  libebml-1.3.7-1  libgadu-1.12.2-8
             libgexiv2-0.12.0-1  libmatroska-1.5.0-1  libsoup-2.66.0-1
             libva-vdpau-driver-0.7.4-4  libwbclient-4.9.5-1
             linux419-4.19.30-1  linux419-virtualbox-guest-modules-6.0.4-12
             matcha-gtk-theme-20190309-1  nspr-4.21-1  ntp-4.2.8.p13-2
             pamac-7.3.4-2 [suppression]  pamac-cli-7.3.5-2
             pamac-common-7.3.5-3  pamac-gtk-7.3.5-2  protobuf-3.7.0-1
             protobuf-c-1.3.1-2  python-psutil-5.6.0-1  qt5-base-5.12.1-3.1
             samba-4.9.5-1  smbclient-4.9.5-1  talloc-2.1.16-1  tdb-1.3.18-1
             terminus-font-4.47-2  tevent-1:0.9.39-1  udiskie-1.7.7-1
             udisks2-2.8.2-1  upower-0.99.10-1  vlc-3.0.6-9
             webkit2gtk-2.24.0-1  yelp-xsl-3.32.0-1

Taille totale du téléchargement :  199,67 MiB
Taille totale installée :        738,22 MiB
Taille de mise à jour nette :    -35,55 MiB

:: Procéder à l’installation ? [O/n] o
:: Récupération des paquets…
 glib2-2.60.0-1-x86_64      2,4 MiB   519K/s 00:05 [######################] 100%
 e2fsprogs-1.45.0-1-...  1054,7 KiB   524K/s 00:02 [######################] 100%
 nspr-4.21-1-x86_64       189,2 KiB   526K/s 00:00 [######################] 100%
 glib2-docs-2.60.0-1...  1379,7 KiB   523K/s 00:03 [######################] 100%
 linux419-4.19.30-1-...    75,5 MiB   502K/s 02:34 [######################] 100%
 at-spi2-core-2.32.0...   231,7 KiB   527K/s 00:00 [######################] 100%
 atk-2.32-1-x86_64        346,9 KiB   526K/s 00:01 [######################] 100%
 at-spi2-atk-2.32.0-...    55,4 KiB   503K/s 00:00 [######################] 100%
 dconf-0.32.0-1-x86_64     89,5 KiB   526K/s 00:00 [######################] 100%
 double-conversion-3...    50,9 KiB   565K/s 00:00 [######################] 100%
 gtk-update-icon-cac...    13,8 KiB   602K/s 00:00 [######################] 100%
 tdb-1.3.18-1-x86_64       67,8 KiB   538K/s 00:00 [######################] 100%
 glib-networking-2.6...    95,4 KiB   530K/s 00:00 [######################] 100%
 libsoup-2.66.0-1-x86_64  510,3 KiB   524K/s 00:01 [######################] 100%
 gtk3-classic-3.24.7...     4,7 MiB   455K/s 00:11 [######################] 100%
 file-roller-3.32.0-...   868,2 KiB   325K/s 00:03 [######################] 100%
 firefox-66.0-0-x86_64     46,5 MiB   479K/s 01:39 [######################] 100%
 firefox-i18n-en-us-...   364,3 KiB   523K/s 00:01 [######################] 100%
 firefox-i18n-fr-66....   434,8 KiB   524K/s 00:01 [######################] 100%
 geocode-glib-3.26.1...    88,4 KiB   533K/s 00:00 [######################] 100%
 gobject-introspecti...   176,1 KiB   529K/s 00:00 [######################] 100%
 qt5-base-5.12.1-3.1...    12,2 MiB   523K/s 00:24 [######################] 100%
 talloc-2.1.16-1-x86_64    55,8 KiB   536K/s 00:00 [######################] 100%
 tevent-1:0.9.39-1-x...    48,3 KiB   537K/s 00:00 [######################] 100%
 ldb-1:1.4.6-1-x86_64     189,7 KiB   527K/s 00:00 [######################] 100%
 libebml-1.3.7-1-x86_64    64,0 KiB   533K/s 00:00 [######################] 100%
 protobuf-3.7.0-1-x86_64 1831,4 KiB   523K/s 00:04 [######################] 100%
 protobuf-c-1.3.1-2-...    90,6 KiB   460K/s 00:00 [######################] 100%
 libgadu-1.12.2-8-x86_64   95,9 KiB   533K/s 00:00 [######################] 100%
 libmatroska-1.5.0-1...   135,1 KiB   526K/s 00:00 [######################] 100%
 libva-vdpau-driver-...    37,0 KiB   529K/s 00:00 [######################] 100%
 libwbclient-4.9.5-1...    33,3 KiB   528K/s 00:00 [######################] 100%
 linux419-virtualbox...    30,9 KiB   542K/s 00:00 [######################] 100%
 ntp-4.2.8.p13-2-x86_64  1797,7 KiB   523K/s 00:03 [######################] 100%
 pamac-common-7.3.5-...   360,6 KiB   523K/s 00:01 [######################] 100%
 pamac-cli-7.3.5-2-x...    49,3 KiB   530K/s 00:00 [######################] 100%
 pamac-gtk-7.3.5-2-x...   115,1 KiB   533K/s 00:00 [######################] 100%
 smbclient-4.9.5-1-x...     5,9 MiB   523K/s 00:11 [######################] 100%
 samba-4.9.5-1-x86_64       6,0 MiB   481K/s 00:13 [######################] 100%
 udisks2-2.8.2-1-x86_64   876,0 KiB   524K/s 00:02 [######################] 100%
 upower-0.99.10-1-x86_64  166,1 KiB   524K/s 00:00 [######################] 100%
 vlc-3.0.6-9-x86_64        10,7 MiB   520K/s 00:21 [######################] 100%
 webkit2gtk-2.24.0-1...    17,0 MiB   511K/s 00:34 [######################] 100%
 yelp-xsl-3.32.0-1-any    235,9 KiB   528K/s 00:00 [######################] 100%
 kvantum-manjaro-0.1...    75,8 KiB   474K/s 00:00 [######################] 100%
 libgexiv2-0.12.0-1-...    62,2 KiB   531K/s 00:00 [######################] 100%
 matcha-gtk-theme-20...  1269,4 KiB   523K/s 00:02 [######################] 100%
 python-psutil-5.6.0...   370,3 KiB   524K/s 00:01 [######################] 100%
 terminus-font-4.47-...   951,2 KiB   502K/s 00:02 [######################] 100%
 udiskie-1.7.7-1-any      119,9 KiB   531K/s 00:00 [######################] 100%
 lib32-pcre-8.43-1-x...   337,4 KiB   525K/s 00:01 [######################] 100%
 lib32-glib2-2.60.0-...  1039,9 KiB   523K/s 00:02 [######################] 100%
 lib32-dconf-0.32.0-...    49,5 KiB   532K/s 00:00 [######################] 100%
 lib32-gtk3-classic-...     2,6 MiB   523K/s 00:05 [######################] 100%
(54/54) vérification des clés dans le trousseau    [######################] 100%
(54/54) vérification de l’intégrité des paquets    [######################] 100%
(54/54) chargement des fichiers des paquets        [######################] 100%
(54/54) analyse des conflits entre fichiers        [######################] 100%
(55/55) vérification de l’espace disque dispon...  [######################] 100%
:: Exécution des crochets de pré-transaction…
(1/1) Remove Firefox Distribution Settings
:: Traitement des changements du paquet…
(1/1) désinstallation de pamac                     [######################] 100%
avertissement : /etc/pamac.conf enregistré en tant que /etc/pamac.conf.pacsave
( 1/54) mise à jour de glib2                       [######################] 100%
( 2/54) mise à jour de e2fsprogs                   [######################] 100%
( 3/54) mise à jour de at-spi2-core                [######################] 100%
( 4/54) mise à jour de atk                         [######################] 100%
( 5/54) mise à jour de at-spi2-atk                 [######################] 100%
( 6/54) mise à jour de dconf                       [######################] 100%
( 7/54) mise à jour de double-conversion           [######################] 100%
( 8/54) mise à jour de gtk-update-icon-cache       [######################] 100%
( 9/54) mise à jour de tdb                         [######################] 100%
(10/54) mise à jour de glib-networking             [######################] 100%
(11/54) mise à jour de libsoup                     [######################] 100%
(12/54) mise à jour de gtk3-classic                [######################] 100%

 ==> For detailed information about gtk-classic
  -> Please consult /usr/share/gtk-3.0/README.md
  
  
(13/54) mise à jour de file-roller                 [######################] 100%
(14/54) mise à jour de nspr                        [######################] 100%
(15/54) mise à jour de firefox                     [######################] 100%
(16/54) mise à jour de firefox-i18n-en-us          [######################] 100%
(17/54) mise à jour de firefox-i18n-fr             [######################] 100%
(18/54) mise à jour de geocode-glib                [######################] 100%
(19/54) mise à jour de glib2-docs                  [######################] 100%
(20/54) mise à jour de gobject-introspection-r...  [######################] 100%
(21/54) mise à jour de qt5-base                    [######################] 100%
(22/54) mise à jour de kvantum-manjaro             [######################] 100%
(23/54) mise à jour de talloc                      [######################] 100%
(24/54) mise à jour de tevent                      [######################] 100%
(25/54) mise à jour de ldb                         [######################] 100%
(26/54) mise à jour de lib32-pcre                  [######################] 100%
(27/54) mise à jour de lib32-glib2                 [######################] 100%
(28/54) mise à jour de lib32-dconf                 [######################] 100%
(29/54) mise à jour de lib32-gtk3-classic          [######################] 100%
(30/54) mise à jour de libebml                     [######################] 100%
(31/54) mise à jour de protobuf                    [######################] 100%
(32/54) mise à jour de protobuf-c                  [######################] 100%
(33/54) mise à jour de libgadu                     [######################] 100%
(34/54) mise à jour de libgexiv2                   [######################] 100%
(35/54) mise à jour de libmatroska                 [######################] 100%
(36/54) mise à jour de libva-vdpau-driver          [######################] 100%
(37/54) mise à jour de libwbclient                 [######################] 100%
(38/54) mise à jour de linux419                    [######################] 100%
(39/54) mise à jour de linux419-virtualbox-gue...  [######################] 100%
(40/54) mise à jour de matcha-gtk-theme            [######################] 100%
(41/54) mise à jour de ntp                         [######################] 100%
(42/54) installation de pamac-common               [######################] 100%
==> An authentication agent is required
    Cinnamon, Deepin, GNOME, GNOME Flashback, KDE, LXDE, LXQt, MATE and Xfce
    have an authentication agent already.
    See https://wiki.archlinux.org/index.php/Polkit#Authentication_agents
    for other desktop environments.
==> You had an old /etc/pamac.conf.pacsave file. We restore it for you.
==> You can find your new pamac.conf saved as `/etc/pamac-new-03193407.conf`
(43/54) installation de pamac-cli                  [######################] 100%
(44/54) installation de pamac-gtk                  [######################] 100%
==> Enable Pamac Updates Indicator via
    Gnome Tweak
(45/54) mise à jour de python-psutil               [######################] 100%
(46/54) mise à jour de smbclient                   [######################] 100%
(47/54) mise à jour de samba                       [######################] 100%
(48/54) mise à jour de terminus-font               [######################] 100%
(49/54) mise à jour de udisks2                     [######################] 100%
(50/54) mise à jour de udiskie                     [######################] 100%
(51/54) mise à jour de upower                      [######################] 100%
(52/54) mise à jour de vlc                         [######################] 100%
(53/54) mise à jour de webkit2gtk                  [######################] 100%
Nouvelles dépendances optionnelles pour webkit2gtk
    gst-plugins-bad: media decoding [installé]
(54/54) mise à jour de yelp-xsl                    [######################] 100%
:: Exécution des crochets de post-transaction…
( 1/22) Updating linux419 module dependencies...
( 2/22) Updating linux419 initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'default'
  -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64.img
==> Starting build: 4.19.30-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'fallback'
  -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64-fallback.img -S autodetect
==> Starting build: 4.19.30-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64-fallback.img
==> Image generation successful
( 3/22) Updating Grub-Bootmenu
Création du fichier de configuration GRUB…
Thème trouvé : /usr/share/grub/themes/manjaro/theme.txt
Image Linux trouvée : /boot/vmlinuz-4.19-x86_64
Image mémoire initiale trouvée : /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
fait
( 4/22) Copy Firefox Distribution Settings
( 5/22) Updating 32-bit fontconfig cache...
( 6/22) Updating fontconfig cache...
( 7/22) Updating 32-bit GIO module cache...
( 8/22) Updating GIO module cache...
( 9/22) Compiling GSettings XML schema files...
(10/22) Probing 32-bit GTK3 input method modules...
(11/22) Probing GTK3 input method modules...
(12/22) Updating icon theme caches...
(13/22) Reloading system manager configuration...
(14/22) Creating system user accounts...
(15/22) Creating temporary files...
(16/22) Reloading device manager configuration...
(17/22) Arming ConditionNeedsUpdate...
(18/22) Updating the info directory file...
(19/22) Updating the desktop file MIME type cache...
(20/22) Updating the MIME type database...
(21/22) Updating the vlc plugin cache...
(22/22) Updating X fontdir indices...
[ami@xfcenew Bureau]$ ls /etc | grep pa
apparmor.d
libpaper.d
pacman.conf
pacman.d
pacman-mirrors.conf
pamac.conf
pamac-new-03193407.conf
pam.d
papersize
passwd
passwd-
vdpau_wrapper.cfg
wpa_supplicant
[ami@xfcenew Bureau]$ 

Looks like we are going somewhere for this issue, at last. :slight_smile:

1 Like

pamac-gtk and pamac-dev conflicts

need to make pamac dev seperate also.
manjaro application utility also needs update to use either pamac-gtk or pamac-qt

Same for me too. Done a migration using pamac GUI, and it works. Thanks @philm!

Third time’s a charm :slight_smile:

Forum kindly sponsored by