[Testing Update] 2019-05-07 - Kernels, Gnome, Calamares, Grub, Manjaro-Tools, Haskell, KDE-Dev

Hello community,

I am happy to announce another Testing Update!
After three weeks of vacation in Vietnam I'm back to rumble.

This update holds the following changes:

  • Calamares got updated and rebuild against kpmcore 4.0
  • Grub package got redesigned to support also 32bit UEFI installs. Hopefully the languages bug is also solved by this
  • KDE-Dev ISO got updated and therefore all KDE-Git packages aswell
  • Most of our Kernels got updated. Some might had noticed that dmesg is now restricted to root. To rave you can go here.
  • Manjaro-Tools got adjusted to work better with Ruffus. Issues can be discussed here.
  • XFCE-GTK3 got renewed packages
  • Also Gnome got updated to 3.32.2.
  • For all using Haskell, you find now the latest updates in our repos.

Give us the usual feedback and let us know what you think about this update.

Current supported Kernels

  • linux316 3.16.65
  • linux318 3.18.139 [EOL]
  • linux44 4.4.179 (no legacy nvidia-340 module!)
  • linux49 4.9.173
  • linux414 4.14.116
  • linux419 4.19.40
  • linux420 4.20.17 [EOL]
  • linux50 5.0.13
  • linux51 5.1.0 (few extramodules build, but not all yet!)
  • linux419-rt 4.19.37_rt19
  • linux50-rt 5.0.10_rt7

Package Updates (Tue May 7 06:27:40 CEST 2019)

  • testing community x86_64: 879 new and 871 removed package(s)
  • testing core x86_64: 14 new and 14 removed package(s)
  • testing extra x86_64: 90 new and 82 removed package(s)
  • testing multilib x86_64: 5 new and 5 removed package(s)

The full list of package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Items from previous update sets

Gnome 3.32: Two extensions removed from our repos.

We have dropped two packages that shipped additional extensions for Gnome: gnome-shell-extensions-topicons-plus-huttli and gnome-shell-extensions-taskbar. We won't maintain Topicons Plus and Taskbar anymore.

Those extensions are not in active development anymore and may not work properly (or not work at all) on Gnome 3.32. Notably, it has been reported that using Topicons Plus on Gnome 3.32 may leads to very high CPU usage.

We strongly recommend you to disable those extensions if they are enabled (Tweaks > Extensions) and remove those packages with your favorite package manager. To prevent potential problems with the next version of Gnome, you may do those steps (or at least the first one) before upgrading your system.

Gnome 3.32: Various problems

There is currently several problems with Gnome 3.32. Here is what we know so far.

1. Possibility of broken extensions
Broken extensions is something to expect when transitioning between major versions of Gnome, especially if you are using extensions that are not shipped by default on Manjaro Gnome. If you have a broken extension taken from somewhere else than Manjaro official repositories, you will have to contact the maintainer on the source you have taken the extension from to get more support. You may also want to report the problem to the developer(s) of the extension (if not the same person/group).

It is possible that extensions become so broken on Gnome 3.32 that it makes Gnome Shell crash completely when trying to log in, thus making Gnome completely unusable. For example, we have a report of such issue with a third-party extension (that doesn't come from Manjaro's official repositories) called Extensions.

To decrease the risk of breakage (especially if running Gnome extensions that does not come from Manjaro official repositories) and make the upgrade smoother, you can disable all Gnome extensions (Tweaks > Extensions) before upgrading your system, then enable them one by one only after being logged in a completely new session on Gnome 3.32.

2. Using world clocks can break Gnome Shell completely
If you have configured world clocks in Gnome, it may make Gnome Shell segfaults and crashes when trying to log in for a graphical session, making Gnome unusable. If it happens, you will need to reset your parameters for world clocks with the following command (do it in TTY): dbus-launch gsettings reset org.gnome.clocks world-clocks.
See this Arch Linux thread and this ticket from upstream.

3. Gnome Shell may crash completely when resuming from sleep if you use Wayland
If you are using Wayland (instead of X.org), Gnome Shell may crash when resuming from sleep. Upstream is aware of this issue. As a workaround, you may use X.org instead of Wayland for now.

4. Miscellaneous
Some programs don't get focused after being launched. Reported to upstream and confirmed for distributions other than Manjaro too.

Yaourt: Rest in peace

Yaourt has been removed from our repositories completely. We won't maintain the yaourt package anymore, which means that you will not receive any updates from us for this package. A very old package named yaourt-gui-manjaro has been removed at the same time too.

If you are still using Yaourt, we strongly encourage you to switch to an alternative like Pamac CLI (package: pamac-cli), Trizen (package: trizen), Yay (package: yay) or Pacaur (package: pacaur); and uninstall Yaourt from your system.

In addition to that, we have dropped support for several packages that depended on yaourt: allservers, pacli and pacli-jwm. Those packages has been removed from the official repositories completely.

vlc-nightly has been dropped

The vlc-nightly package, which was really useful in a time when VLC 3 was not officially out yet, has been dropped on our side and is not in the official repositories anymore. If you still have this package and you want the latest stable version of VLC media player, remove vlc-nightly, then install the vlc package.

Otherwise, you can continue to use vlc-nightly from the AUR (but you'll have to compile it yourself).

Kodi 18.1: extensions may not work properly.

Kodi 18.1 is now available in our repositories. Since this is a major version change, extensions for Kodi (if you use some) may stop working properly. Developers of those extensions will need to make them compatible with Kodi 18.

If Kodi 18.1 doesn't work properly for you and you absolutely need to use your extensions, you may use the old kodi package in /var/cache/pacman/pkg in order to downgrade Kodi to version 17.6. Please note that it is a temporary workaround and that the software provided in the old kodi package may stop working properly in the future too. You should not keep the downgrade forever.

Notifications looking weird in XFCE

Since the package dunst includes now dunstfy in the main package notifications may not displayed properly in XFCE. Please uninstall that package to solve that issue. Normally not needed in that edition.

Plasma will not reboot from the Application Launcher

If you update from within Plasma (e.g. from the konsole), you may need to issue a systemctl reboot to reboot.

I can't open Nemo with elevated privileges (as root)

Workaround found: Use the dbus-x11 package instead of the regular dbus package. This package is available in the official repositories and provides dbus compiled without the --without-x option.

To replace dbus with dbus-x11 package, simply install dbus-x11 with your favorite package manager: dbus will be replaced by dbus-x11.

Pamac: "Failed to commit transaction - Transaction not prepared" at the end

So far, it has only been a false alarm: updates are applied successfully.

AMD-Ucode introduction

Unless you've already done this previously, All users of AMD-APUs/CPUs should install this update like this:

sudo pacman -Syyu
sudo pacman -S amd-ucode
sudo pacman -R intel-ucode
sudo update-grub

Step 3 is optional.

Rebuilding fontconfig cache: failed to write cache

Please ignore this message. Upstream already works on a solution. More about the issue here.

LibreOffice has no window decoration in KDE

New line export SAL_USE_VCLPLUGIN=gtk3_kde5, once merged into existing /etc/profile.d/libreoffice-fresh.sh , fixes a moderately longterm issue. If it doesn't work for you, you may use gtk instead of gtk3_kde5 as UI framework.

Installing glibc (2.28-4) breaks the dependency “glibc=2.27” required by lib32-glibc

Install the update either:

  • from terminal: sudo pacman -Syu or;
  • with Octopi instead of Pamac.

Something using Perl/Python/glibc broke

Rebuilds needed!

  • If it's an AUR package, try to reinstall it from AUR. It most likely needs to be rebuilt.
  • If it's a repo package, please report and check back regularly for updates.

I've lost a Thunderbird addon/feature

Thunderbird 60 disables incompatible addons by default. There's an about:config switch should you want to force-enable the addon, but many addons simply will not work with the newer Quantum-based Thunderbird.

Read more about Thunderbird 60 here: Thunderbird 60

Firefox - WebGL not working anymore

You may try the following solution:

Open about:config and set security.sandbox.content.read_path_whitelist to /sys/.

libutf8proc>=2.1.1-3 update may require manual intervention

This should normally be automatically fixed via manjaro-system update.

The libutf8proc package prior to version 2.1.1-3 had an incorrect soname link. This has been fixed in 2.1.1-3, so the upgrade will need to overwrite the untracked soname link created by ldconfig. If you get an error

libutf8proc: /usr/lib/libutf8proc.so.2 exists in filesystem

when updating, use

pacman -Suy --overwrite usr/lib/libutf8proc.so.2

to perform the upgrade.

Pamac: "Invalid or corrupted package."

If you receive an "Invalid or corrupted package." error message with Pamac and if the details contains an output similar to the following:

Synchronizing package databases...
Starting full system upgrade...

Resolving dependencies...
Checking inter-conflicts...
Downloading manjaro-system-20180716-1-any.pkg.tar.xz...
Checking keyring...
Checking integrity...
Loading packages files...
Checking file conflicts...
Checking available disk space...
Upgrading manjaro-system (20180702-1 -> 20180716-1)...
==> Fix libutf8proc upgrade ...
resolving dependencies...
looking for conflicting packages...

Packages (1) libutf8proc-2.1.1-4

Total Download Size:   0.05 MiB
Total Installed Size:  0.32 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
downloading libutf8proc-2.1.1-4-x86_64.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libutf8proc...
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
Running post-transaction hooks...
Arming ConditionNeedsUpdate...
Warning: lock file missing /var/lib/pacman/db.lck
Starting full system upgrade...
Resolving dependencies...
Checking inter-conflicts...
Error: could not open file /var/lib/pacman/local/libutf8proc-2.1.1-2/files: No such file or directory
Warning: could not fully load metadata for package libutf8proc-2.1.1-2

Failed to prepare transaction:
invalid or corrupted package

Try the following steps: close Pamac window first, then launch it again and start the update procedure again. It should continue from where it left off.

Issues with folder view widget in KDE v5.13

KDE introduced a new setting for icon sizes. Now you're able to define also the size for your panel. If you have a high-DPI display, you may want to increase the value. This will fix the display issue with given widget.


Pulseaudio changes

With this update we have a /etc/pulse/default.pa.pacnew. It may be necessary to merge (some lines related to “GSettings” in /etc/pulse/default.pa ) if 'default.pa' has been customised.

File conflict engrampa.tap

thunar-archive-plugin: /usr/lib/xfce4/thunar-archive-plugin/engrampa.tap exists in filesystem (owned by engrampa-thunar-plugin)

thunar-archive-plugin has added native support for the Engrampa archive manager. engrampa-thunar-plugin is no longer needed. Remove engrampa-thunar-plugin to continue with the update.

No Sound:
Please edit at the Loudspeaker / Configuration tab, your analog or digital sounddriver. Currently it will not be saved until the next boot, so one has to edit the Configuration tab again.

xfce, update was fine, grub.pacnew should be announced for stable.

1 Like

Manjaro mate here, 21 updates, 108 Mb. Went flawlessly.

Looks like not broadcom-dkms-wl YET!

With plasma-desktop=5.15.80.r6581.gdf39dd93-1 and plasma-framework=5.58.0.r15155.g9100f847a-1 installs (KDE git version), there are some issues with the interface:


The Application Menu shifts from it's position.
The Panel has a stripe artifact above the shadow.
If my speculation is correct, the qt5-base needs a rebuild ...

1 Like

I'm waiting for r8168 module (linux51-r8168) because I don't have internet connection without it. :slight_smile:


Using 5.1 since RC5 (self-built) and no issues since then. The release version is also troublefree on a pure AMD system (Zen+ + Vega)


No issue, Xfce 4.13. Updated to kernel linux51 5.1.0. Restart and everything works. Thank you! :smiley:


Another flawless update!
Kernel 5.0.13, KDE, btrfs, luks

What about Nvidia drivers for Kernel 5.1? They seem to be still missing. I would recommend not to suggest a kernel update as long as central kernel modules and drivers (virtualbox, nvidia) are still missing.

its not upto anyone as manjaro settings notifier will say new kernel available.regardless of settings

You need to build it yourself based on beta 430.09, because previous versions are incompatible with 5.1. You need only those files that are placed in nvidia-related folders.

audit=0 makes me a happy grinner :smile:

no problems with the update :+1:


Does the KDE-Dev ISO got this adjustment, so we can actually try to "burn" that ISO on a USB drive on ISO mode and see if it works?

If not, it could be good to produce a new development ISO of any edition just to try that out.

Update, reboot, everything is running. :+1:
LXQT with Kernel 5.0.

I'm seeing elevated cpu rates with the new version of xfwm4. Anything from simple animations to videos spike it ~20% more than normal. Seems to be related to xfce's own compositor -- disabling this seems to solve the issue.

1 Like


Hopefully the languages bug is also solved by this ---> neee

Manjaro stable, Fresh install: no localisation...

so I did:
sudo mkdir /boot/grub/locale
sudo cp /usr/share/locale/de/LC_MESSAGES/grub.mo /boot/grub/locale/de.mo
sudo update-grub
sudo reboot
Now grub 2.03.4 was in german.
*Then updated to 2.03.5 --> reboot:--> grub is in english again...
Used Grub-Customizer to change "Advanced options for"
into "Erweiterte Optionen für".
Then (reboot) grub 2.03.5 was in german.
*Updated to grub 2.03.6
reboot:--> grub is in english ... AND in german too!

Removed Grub-Customizer,
renamed drawer /grub.d/ /to grub.d.old/
new install of grub 2.03.6, sudo update-grub.
reboot:--> grub is in english again...
changed /etc/grub.d/10_linux:
"Advanced options for" to "Erweiterte Optionen für".
Reboot. Now grub 2.03.6 is in german.
Installed (and used) Grub-Customizer: menu stays in german...
Installed linux51: menu stays in german

How can I help You??! :tiger:

1 Like

Kernel upgraded, nvidia did not?

bob@Lenova~$ inxi-Fxzc0
[bob@Lenova ~]$ inxi -Fxzc0
  Host: Lenova Kernel: 5.0.13-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.3.0 Desktop: Xfce 4.13.3git-e8bf69 Distro: Manjaro Linux 
  Type: Desktop System: LENOVO product: 10181 v: Lenovo K450e 
  serial: <filter> 
  Mobo: LENOVO model: N/A v: 31900058 STD serial: <filter> BIOS: LENOVO 
  v: I1KT38AUS date: 06/10/2014 
  Device-1: hidpp_battery_0 model: Logitech M570 charge: 90% 
  status: Discharging 
  Topology: Quad Core model: Intel Core i5-4460 bits: 64 type: MCP 
  arch: Haswell rev: 3 L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 25554 
  Speed: 1996 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 1996 2: 1996 
  3: 1996 4: 1995 
  Device-1: NVIDIA GK208 [GeForce GT 720] vendor: Micro-Star MSI 
  driver: nvidia v: 418.56 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.4 driver: nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GT 720/PCIe/SSE2 v: 4.6.0 NVIDIA 418.56 
  direct render: Yes 
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k5.0.13-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8168 v: 8.045.08-NAPI port: d000 bus ID: 03:00.0 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 1.82 TiB used: 29.36 GiB (1.6%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-08M2NA0 
  size: 931.51 GiB 
  ID-2: /dev/sdb type: USB vendor: Western Digital model: WD Elements 25A2 
  size: 931.48 GiB 
  ID-1: / size: 899.39 GiB used: 29.36 GiB (3.3%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 16.77 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
  System Temperatures: cpu: 46.0 C mobo: N/A gpu: nvidia temp: 53 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 28% 
  Processes: 188 Uptime: 8m Memory: 7.72 GiB used: 790.3 MiB (10.0%) 
  Init: systemd Compilers: gcc: 8.3.0 Shell: bash v: 5.0.3 inxi: 3.0.34 

Or to rant ... :wink:

No issues, linux51 running well on AMD hardware.


Forum kindly sponsored by