[Testing Update] 2019-05-22 - Kernels, XFCE 4.14-pre1, Virtualbox, LibreOffice

Is it normal way that dmsg needs root privilege anymore ?

$ dmesg
dmesg: échec de lecture du tampon de noyau: Opération non permise

That means core buffer reading failure: Operation not allowed

$ inxi -b
Host: steph-tour Kernel: 5.0.18-1-MANJARO x86_64 bits: 64
Desktop: Xfce 4.13.4git-2a9104 Distro: Manjaro Linux
Type: Desktop Mobo: Gigabyte model: GA-A55M-S2HP serial:
BIOS: Award v: F2 date: 07/13/2011
Dual Core: AMD A4-3300 APU with Radeon HD Graphics type: MCP
speed: 881 MHz min/max: 800/2500 MHz
Device-1: NVIDIA GF119 [GeForce GT 610] driver: nvidia v: 390.116
Display: tty server: X.Org 1.20.4 driver: nvidia
resolution: 1920x1080~60Hz
OpenGL: renderer: GeForce GT 610/PCIe/SSE2 v: 4.6.0 NVIDIA 390.116
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8168

Yes, it is now the new default: dmesg needs elevated privileges to be used. It has been the new default for more than 14 days on Testing.

On a user that is a member of the wheel group (i.e. an administrator of the system on a standard Manjaro system), you may use journalctl -k to see kernel messages without having to type your password everytime. It also works if your user is a member of adm or systemd-journal; being a member of one of these groups is enough.

Quote from man journalctl.

All users are granted access to their private per-user journals.
However, by default, only root and users who are members of a few
special groups are granted access to the system journal and the
journals of other users. Members of the groups "systemd-journal",
"adm", and "wheel" can read all journal files. Note that the two latter
groups traditionally have additional privileges specified by the
distribution. Members of the "wheel" group can often perform
administrative tasks.


It's normal, you can control it via kernel.dmesg_restrict=1 or 0 to turn off.

1 Like

All good for me.:grinning:
LXQT+ Kernel 5.1


Easy to override this new default, if you wish.

Anything in particular you want people to check out? Or more like general errors in dmesg / journalctl?
I am running the below setup and would be happy to upgrade to 5.1 later this morning. No LVM though.
KDE, btrfs, luks, nVidia 418.74, Virtualbox

I remember I did have issues when I tried a while ago, after 5.1 became available, but can't remember what they were.

There is a patch for a major kernel bug, fstrim on 5.1 systems + luks (+ lvm?) could cause massive data loss.

There is already a thread on it.

Can the Wine-Staging package be rebuilt? Some patches have been added to since it was built (See: Wine and Gallium Nine Standalone)

Updating without issues from Terminal, KDE and Kernel 5.1

Oops? Looking out for a massive data loss...we'll, that doesn't sound encouraging :slight_smile:
I feel I am in good shape with my snapshots/backups so could handle a breakdown fairly quickly but maybe I better wait for this patch to find it's way to Manjaro.

However, if I can help the team with my testing I will switch over.

This package is taken from Arch. If the problem can be replicated on an Arch system then ask there to rebuild.

If some patches were added, it should change package version and update should be on its way. If from some reason the package was altered but versioning kept the same (happens sometimes) it's a bit tricky for packagers because they have to add new version to it in order not to create conflicts. Anyway, wine-staging have often releases so even if the version didn't change with those patches, some update will come soon and the patches will be included. Be patient. Of course you can always compile the package yourself if you know how.

As to update itself, all went fine, no apparent issues (Manjaro KDE).

all good for me: linux419+nvidia+zfs+cinnamon

thank you!

1 Like

When can we expect XFCE 4.14 in stable? :grin:

Just be patient or:


with Xfce 4.13.4git-2a9104
there is now a little less flickering at the desktop startup.

Hello everybody,

i noticed some kernel errors after latest testing update:

journalctl -p err:

-- Reboot --
Mai 23 12:39:56 LXKA-10HFQN2 kernel: DMAR: DRHD: handling fault status reg 2
Mai 23 12:39:56 LXKA-10HFQN2 kernel: DMAR: [INTR-REMAP] Request device [f0:1f.0] fault index 3c3d [fault reason 37] Blocked a compatibility format interrupt request
Mai 23 12:40:12 LXKA-10HFQN2 ModemManager[688]: <error> SIM is missing and SIM hot swap is configured, but ports are not opened.
Mai 23 12:40:27 LXKA-10HFQN2 systemd[1]: Failed to start Network Manager Wait Online.
Mai 23 12:45:20 LXKA-10HFQN2 lightdm[1054]: gkr-pam: unable to locate daemon control file

inxi -Fz:

System:    Host: some host Kernel: 4.19.45-1-MANJARO x86_64 bits: 64 Desktop: Cinnamon 4.0.10 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Latitude 7390 v: N/A serial: <filter> 
           Mobo: Dell model: 09386V v: A00 serial: <filter> UEFI: Dell v: 1.9.3 date: 04/26/2019 
Battery:   ID-1: BAT0 charge: 57.8 Wh condition: 57.8/60.0 Wh (96%) 
CPU:       Topology: Quad Core model: Intel Core i5-8350U bits: 64 type: MT MCP L2 cache: 6144 KiB 
           Speed: 700 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 728 2: 718 3: 727 4: 748 5: 751 6: 780 7: 726 8: 767 
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Display: x11 server: X.Org 1.20.4 driver: intel unloaded: modesetting tty: N/A 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.0.4 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
           Device-2: Realtek type: USB driver: snd-usb-audio 
           Device-3: Sennheiser Headset [PC 8] type: USB driver: hid-generic,snd-usb-audio,usbhid 
           Sound Server: ALSA v: k4.19.45-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM driver: e1000e 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi 
           IF: wlp2s0 state: down mac: <filter> 
           Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
           IF: enp59s0u1u2 state: up speed: 100 Mbps duplex: full mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
           IF-ID-2: wwp0s20f0u2i12 state: down mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 47.55 GiB (10.0%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: PM961 NVMe SED 512GB size: 476.94 GiB 
Partition: ID-1: / size: 451.46 GiB used: 47.54 GiB (10.5%) fs: ext4 dev: /dev/dm-0 
           ID-2: swap-1 size: 16.96 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
Sensors:   System Temperatures: cpu: 50.5 C mobo: N/A 
           Fan Speeds (RPM): cpu: 4205 
Info:      Processes: 265 Uptime: 5h 45m Memory: 15.42 GiB used: 2.22 GiB (14.4%) Shell: zsh inxi: 3.0.34 

sudo systemctl status --failed:

sudo systemctl --failed
  UNIT                               LOAD   ACTIVE SUB    DESCRIPTION                
● NetworkManager-wait-online.service loaded failed failed Network Manager Wait Online

Tumbler 0.2.4 (used by Thunar) now has max file size limits for thumbnails. 2 Gb for video files and 200 Mb for photo/pdf files according to this commit.

To get back all thumbnails, the user will need to create a local config file per Xfce documentation.

mkdir -p ~/.config/tumbler
cp /etc/xdg/tumbler/tumbler.rc ~/.config/tumbler/

kill tumblerd process then log back in.

The config file will probably get updated so this is what it looks like without file size limits.

# [TypeNameOfPlugin]
# Disabled:    Set to true to avoid loading the plugin. By default all
#              plugins are loaded.
# Priority:    Priority of the plugin if more plugins support the same
#              uri-scheme / mime-type combination.
# Locations:   ;-separated path list the plugin will be used in. If the
#              source file is not a child of one of the locations, the
#              plugin won't be used and another plugin with a lower
#              priority will be tried.
#              Absolute paths, environement variables, ~/ and ~username/
#              are allowed. Leave empty to allow all locations.
# MaxFileSize: Maximum size of the source file the plugin will still
#              try to generate a plugin for. The size is in bytes,
#              0 disabled the check.
# For more information see http://docs.xfce.org/xfce/thunar/tumbler

# Image Thumbnailers

# Jpeg thumbnailer (from exif data if possible)

# Supports all type GdkPixbuf supports

# RAW image files using libopenraw

# Video Thumbnailers

# Download cover from omdbapi.com or themoviedb.org if an
# API key is given. This plugin is disabled because it
# sends your (private) movie names over the internet.

# ffmpegthumbnailer plugin

# GStreamer plugin

# Other Thumbnailers

# FreeType thumbnailer

# PDF/PS thumbnailer

# Open document thumbnailer (ODF)

# thumnailers provided by .thumbnailer desktop files

TTY update with Xfce, intel chips, using 4.19 kernel. Smooth as always.

Gotta say, since I switched to testing half a year ago, have had no issues. Of course, this is as close to a vanilla install as you're likely to see, only addition from AUR is chrome. And BTW thanks for the update to mcomix. It's not critical but I enjoy using it to look in archived photo galleries.

1 Like

Forum kindly sponsored by