[Testing Update] 2019-06-27 - Kernels, XFCE, Mesa, Plasma5, Systemd, Cinnamon, XFCE

Hi Philm, yes, I have rebooted.... I have 4 flatpak apps, just (re)installing the AUR versions for now. I can't see anything strange in the log. (Maybe I am not looking at the right log ;-))

I can confirm that flatpaks stopped working.
I get this error message:

bwrap: No permissions to creating new namespace, likely because the kernel does not allow non-privileged user namespaces. On e.g. debian this can be enabled with 'sysctl kernel.unprivileged_userns_clone=1'.
1 Like

If you aren't already doing so try the iso profiles as your base to work from with your custom ISO from gitlab.manjaro.org and not the ones in the manjaro repository

well problem is with the update in the testing branch.
and i use the same profile to create iso.
two days ago i built iso using same profile on testing branch and it was working.
but today the iso is not booting.
and only culprit seems to me is systemd.

I might try it myself later, I have a custom KDE ISO too for personal usage but last built it with 17.1 gitlab iso-tools and profiles. It's still viable as an install source surprisingly and will update without issues (apart from the obvious time it takes)

Confirmed, we had similar reports on Unstable too.

The message given by Flatpak pretty much says the problem: you need to set this kernel parameter to 1 (meaning yes, true, etc.). (It says "On Debian,...", but it is not specific to Debian only.)

As for why you now need to explicitly do that now when you didn't have to bother messing with kernel parameters by yourself before, good question.

It is possible to configure the kernel at compile time so this kernel parameter is set at 1/yes/true/etc. by default for everyone.

1 Like

Which kernel has this issue? Additionally added apparmor patches got added only to 5.1 kernel series. systemd I just updated today with updates to dbus. Currently only manjaro-tools-git work. I'll try to rebuild an ISO later this week.

Sorry for the hassle and delay of our next stable update.

Permission issues might be due to apparmor. We will update the profiles for that purpose. Already working closely with #canonical on the matter.

2 Likes

I have the Flatpak issues on both 5.1 and 4.19 Kernels.

Looks as if apparmor is orphaned, but I dare not remove it.

$ pacman -Qdt
apparmor 2.13.3-2

For some reason, on one HP EliteBook 8440p laptop , I can no longer connect to my WEP router, but had no problems connecting to my WPA/WPA2 Router.

On another T61 laptop, I have no problem connecting to the same WEP router.

Please test if dbus 1.12.16-1.2 fixes the dependency issue with apparmor. Please also test dbus-x11.

1 Like

FYI (maybe helpful?)

Facing the same problem. Are you on amd cpu?

no on intel cpu

15616421952321122337766

if you have backup restore to it.
else chroot and update.
i think the problem was with dbus package and its solved.

I did the update hour ago. Is the update gonna fix the issue?

yes it should fix the issue.
if you update

I will try and report thanks :slight_smile:

There were no updates

Forum kindly sponsored by