[Testing Update] 2019-06-27 - Kernels, XFCE, Mesa, Plasma5, Systemd, Cinnamon, XFCE

Which kernel has this issue? Additionally added apparmor patches got added only to 5.1 kernel series. systemd I just updated today with updates to dbus. Currently only manjaro-tools-git work. I'll try to rebuild an ISO later this week.

Sorry for the hassle and delay of our next stable update.

Permission issues might be due to apparmor. We will update the profiles for that purpose. Already working closely with #canonical on the matter.

2 Likes

I have the Flatpak issues on both 5.1 and 4.19 Kernels.

Looks as if apparmor is orphaned, but I dare not remove it.

$ pacman -Qdt
apparmor 2.13.3-2

For some reason, on one HP EliteBook 8440p laptop , I can no longer connect to my WEP router, but had no problems connecting to my WPA/WPA2 Router.

On another T61 laptop, I have no problem connecting to the same WEP router.

Please test if dbus 1.12.16-1.2 fixes the dependency issue with apparmor. Please also test dbus-x11.

1 Like

FYI (maybe helpful?)

Facing the same problem. Are you on amd cpu?

no on intel cpu

15616421952321122337766

if you have backup restore to it.
else chroot and update.
i think the problem was with dbus package and its solved.

I did the update hour ago. Is the update gonna fix the issue?

yes it should fix the issue.
if you update

I will try and report thanks :slight_smile:

There were no updates

change branch to unstable there will be updates

1 Like

Thank you soo much worked flawlessly

curl 7.65.1-2 core dump seems to have been fixed. Which also affected rtorrent (8 hours and no crashes with 7.65.1-3), and maybe other curl applications.

Great to hear that dbus fixed most of the issues.

4 Likes

There's unfortunately a problem with widgets in KDE - simply no reaction after choosing "add widgets"
. Anyone experiencing such an issue?

This happened to me today with one of AppImages I have:

 ./minter-console-0.5.0-x86_64_d094b8e27a6a26c34083684f238bd241.appimage 
[8355:0628/023400.548893:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /tmp/.mount_minterdqchoq/chrome-sandbox is owned by root and has mode 4755.
fish: ā€œ./minter-console-0.5.0-x86_64_dā€¦ā€ terminated by signal SIGTRAP (Trace or breakpoint trap)

I had to do
sudo sysctl kernel.unprivileged_userns_clone=1
"Mainstream" distros solve this in some another way since Fedora and openSUSE (what I am sure of) do run that AppImage as usual.

Forum kindly sponsored by