[Testing Update] 2020-03-16 - KDE Framework, Haskell, Python, Gnome Themes and Extensions

Hello community,

here is another Testing Update for you:

KDE Frameworks are over 70 addon libraries to Qt which provide a wide variety of commonly needed functionality in mature, peer reviewed and well tested libraries

Some feature-updates:

  • Wifi-Fixes for linux414 and *linux419
  • Small fixes to Gnome extensions and themes
  • KDE Framework got updated to 5.68
  • Haskell and Python updates

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 19.0.2 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.82
  • linux44 4.4.216
  • linux49 4.9.216
  • linux414 4.14.173
  • linux419 4.19.109
  • linux54 5.4.25
  • linux55 5.5.9
  • linux56 5.6-rc6
  • linux419-rt 4.19.106_rt45
  • linux54-rt 5.4.24_rt15

Package Changes (Mon Mar 16 20:54:10 CET 2020)

  • testing community x86_64: 632 new and 652 removed package(s)
  • testing core x86_64: 9 new and 9 removed package(s)
  • testing extra x86_64: 176 new and 176 removed package(s)
  • testing multilib x86_64: 1 new and 1 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Older issues

Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in


To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

I'm getting the below:

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing libappindicator-gtk2 (12.10.0-14) breaks dependency 'libappindicator' required by ocs-store
:: installing libindicator-gtk2 (12.10.1-9) breaks dependency 'libindicator' required by o

Was just going to uninstall the OCS-Store, but I get the below:

Warning: nitroshare optionally requires libappindicator-gtk2: export a menu into the Unity Menu bar
Warning: python-pyqt5 optionally requires qt5-websockets: QtWebSockets


Went ahead and uninstalled OCS-Store and looks like it did not break Nitroshare.

Caffeine does not work on testing or unstable, Gnome
autostart does not work on testing (did not try in unstable) I had conky autostart on testing machine after update to Gnome 3.36 it does not load I have to run it in terminal to start.
(maybe both are just Gnome bugs)

One thing i noticed is that now Pamac Tray in KDE Plasma will not open Pamac when clicked, but rather show the second menu with the options

Package Manager


Is not a big deal, but now it requires two click to open Pamac from there, while previously just one click did the job. :slight_smile:


Getting the same.

Open an issue if it is an issue for you guys ...

1 Like

We were just mentioning it to bring it to the dev's attention. After all that is what the thread is for.

Done :slight_smile:


Hm, conky autostarts here in testing. Configured via Gnome Tweak long time ago.

Are you on Wayland or Xorg? I am on Wayland. Weird thing is that that conky process is running in htop but can not see it on desktop.

I put there --pause=5 and it started now.

I have checked what is installed on second Gnome with caffeine and I was missing some libraries. I installed Gnome in i3 Manjaro so was not full Manjaro install.
BTW Manjaro i3 and Gnome DE work almost perfectly together.

Xorg, I gave up on Wayland when I found out that FPS is locked at 60, and I have 144Hz monitor.

This update appeared on my machines. The thing is I'm on stable!! :fish:

I am seeing no mirrors syncing a new stable update. Last stable update was: [Stable Update] 2020-03-14 - Kernels, Plasma 5.18.3, KDE Frameworks 5.67, KDE Apps 19.12.3, Firefox, Kodi

If pacman-mirrors -G outputs stable there is nothing to worry about, possible your mirror is just now syncing, or pamac just decided to check for updates now.

Ok, I know what happened. My desktop has been out of order for quite some time, but on saturday I finally fixed it and updated the system. Th thing is I forgot to update my laptop, but, as I'm no longer used to updating two machines, I didn't recall my laptop wasn't the updated and though the notification couldn't possibly be right!!

Sorry me...

I believe it is in Testing already:

$ pacman -Qi hplip
Name            : hplip
Version         : 1:3.20.3-1
Description     : Drivers for HP DeskJet, OfficeJet, Photosmart, Business Inkjet and some LaserJet
Architecture    : x86_64
URL             : https://hplipopensource.com
Licenses        : GPL2  custom
Groups          : None
Provides        : None
Depends On      : python-dbus  python-distro  ghostscript  net-snmp  foomatic-db-engine  python-gobject
Optional Deps   : cups: for printing support [installed]
                  sane: for scanner support [installed]
                  xsane: sane scanner frontend
                  python-pillow: for commandline scanning support [installed]
                  python-reportlab: for pdf output in hp-scan [installed]
                  rpcbind: for network support [installed]
                  python-pyqt5: for running GUI and hp-toolbox [installed]
                  libusb: for advanced usb support [installed]
                  wget: for network support [installed]
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 27.17 MiB
Packager        : Andreas Radke <andyrtr@archlinux.org>
Build Date      : Tue 10 Mar 2020 03:21:44 PM EDT
Install Date    : Sun 15 Mar 2020 06:06:47 PM EDT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

Edit: This was actually from the 2020-03-15 update, so you may want to check your mirrors.

1 Like

Pamac list is empty. See bug https://gitlab.manjaro.org/applications/pamac/issues/778 ; this a blocker bug.

And I have it on testing.

Capture du 2020-03-18 09-48-58

@philm: only fix I found for now is to downgrade archlinux-appstream-data package.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by