[Testing Update] 2020-03-27 - Palemoon, Firefox-Dev, AMDVLK, UKUI, Python, Haskell

Hello community,

here is another Testing Update for you:


Give our first preview of XFCE 19.1 Lysia release a try-out!

Some feature-updates:

  • Another update for Palemoon and Firefox-Dev
  • AMDVLK driver is now at 2020.Q1.4
  • More updates to UKUI
  • Haskell and Python updates/cleanups

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 19.0.2 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.82
  • linux44 4.4.217
  • linux49 4.9.217
  • linux414 4.14.174
  • linux419 4.19.113
  • linux54 5.4.28
  • linux55 5.5.13
  • linux56 5.6-rc7
  • linux419-rt 4.19.106_rt45
  • linux54-rt 5.4.26_rt17

Package Changes (Fri Mar 27 12:15:59 CET 2020)

  • testing community x86_64: 326 new and 325 removed package(s)
  • testing core x86_64: 1 new and 1 removed package(s)
  • testing extra x86_64: 10 new and 10 removed package(s)
  • testing multilib x86_64: 1 new and 1 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-26           2020-03-27
-------------------------------------------------------------------------------
                        palemoon-bin           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-ar           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-bg           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-cs           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-da           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-de           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-el           28.9.0.1-1           28.9.0.2-1
                 palemoon-i18n-en-gb           28.9.0.1-1           28.9.0.2-1
                 palemoon-i18n-es-ar           28.9.0.1-1           28.9.0.2-1
                 palemoon-i18n-es-es           28.9.0.1-1           28.9.0.2-1
                 palemoon-i18n-es-mx           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-fi           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-fr           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-gl           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-hr           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-hu           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-id           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-is           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-it           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-ja           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-kn           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-ko           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-nl           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-pl           28.9.0.1-1           28.9.0.2-1
                 palemoon-i18n-pt-br           28.9.0.1-1           28.9.0.2-1
                 palemoon-i18n-pt-pt           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-ro           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-ru           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-sk           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-sl           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-sr           28.9.0.1-1           28.9.0.2-1
                 palemoon-i18n-sv-se           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-tl           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-tr           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-uk           28.9.0.1-1           28.9.0.2-1
                    palemoon-i18n-vi           28.9.0.1-1           28.9.0.2-1
                 palemoon-i18n-zh-cn           28.9.0.1-1           28.9.0.2-1
                 palemoon-i18n-zh-tw           28.9.0.1-1           28.9.0.2-1
                               snapd             2.44.1-1                    -
                              muffin                    -            4.4.3-0.1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-26           2020-03-27
-------------------------------------------------------------------------------
               aarch64-linux-gnu-gcc              9.2.0-1              9.3.0-1
                              aeolus              0.9.7-3              0.9.8-1
                                agda              2.6.1-9             2.6.1-10
                arm-none-eabi-newlib              3.1.0-2              3.3.0-1
                        aws-c-common             0.4.22-2             0.4.34-1
                         aws-sdk-cpp            1.7.284-1            1.7.301-1
                               bochs              2.6.9-3             2.6.11-1
                       cabal-install           3.0.0.0-63           3.0.0.0-65
                               cgrep            6.6.32-11            6.6.32-12
                             cryptol             2.8.0-88             2.8.0-89
                               darcs           2.14.2-199           2.14.2-200
                               dhall            1.30.0-24            1.30.0-25
                          dhall-bash            1.0.28-26            1.0.28-27
                          dhall-json             1.6.2-25             1.6.2-26
                         dns-lexicon             3.3.18-1             3.3.19-1
                      dnscrypt-proxy             2.0.41-1             2.0.42-1
                             drumkv1             0.9.12-1             0.9.13-1
                              fcitx5     0.0.0.20200325-1     0.0.0.20200326-1
           firefox-developer-edition             75.0b8-1             75.0b9-1
  firefox-developer-edition-i18n-ach             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-af             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-an             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-ar             75.0b8-1             75.0b9-1
  firefox-developer-edition-i18n-ast             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-az             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-be             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-bg             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-bn             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-br             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-bs             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-ca             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-ca-valencia       75.0b8-1             75.0b9-1
  firefox-developer-edition-i18n-cak             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-cs             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-cy             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-da             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-de             75.0b8-1             75.0b9-1
  firefox-developer-edition-i18n-dsb             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-el             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-en-ca             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-en-gb             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-en-us             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-eo             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-es-ar             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-es-cl             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-es-es             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-es-mx             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-et             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-eu             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-fa             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-ff             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-fi             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-fr             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-fy-nl             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-ga-ie             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-gd             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-gl             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-gn             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-gu-in             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-he             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-hi-in             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-hr             75.0b8-1             75.0b9-1
  firefox-developer-edition-i18n-hsb             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-hu             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-hy-am             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-ia             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-id             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-is             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-it             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-ja             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-ka             75.0b8-1             75.0b9-1
  firefox-developer-edition-i18n-kab             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-kk             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-km             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-kn             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-ko             75.0b8-1             75.0b9-1
  firefox-developer-edition-i18n-lij             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-lt             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-lv             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-mk             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-mr             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-ms             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-my             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-nb-no             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-ne-np             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-nl             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-nn-no             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-oc             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-pa-in             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-pl             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-pt-br             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-pt-pt             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-rm             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-ro             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-ru             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-si             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-sk             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-sl             75.0b8-1             75.0b9-1
  firefox-developer-edition-i18n-son             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-sq             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-sr             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-sv-se             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-ta             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-te             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-th             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-tl             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-tr             75.0b8-1             75.0b9-1
  firefox-developer-edition-i18n-trs             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-uk             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-ur             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-uz             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-vi             75.0b8-1             75.0b9-1
   firefox-developer-edition-i18n-xh             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-zh-cn             75.0b8-1             75.0b9-1
firefox-developer-edition-i18n-zh-tw             75.0b8-1             75.0b9-1
                             fscrypt              0.2.6-3              0.2.7-1
                           git-annex        8.20200309-32        8.20200309-33
                          git-repair        1.20200102-55        1.20200102-56
                              gitlab             12.8.7-1             12.9.0-1
                       gitlab-gitaly             12.8.5-1             12.9.0-1
                    gitlab-workhorse             8.24.0-1             8.27.0-1
                      grafana-zabbix             3.10.5-1             3.11.0-1
                       haskell-aeson            1.4.7.0-1            1.4.7.1-1
         haskell-aeson-better-errors          0.9.1.0-164          0.9.1.0-165
                haskell-aeson-compat             0.3.9-82             0.3.9-83
                  haskell-aeson-diff           1.1.0.8-79           1.1.0.8-80
                haskell-aeson-pretty             0.8.8-28             0.8.8-29
                    haskell-aeson-qq             0.8.3-38             0.8.3-39
                  haskell-aeson-yaml           1.0.6.0-12           1.0.6.0-13
                haskell-authenticate             1.3.5-85             1.3.5-86
          haskell-authenticate-oauth           1.6.0.1-65           1.6.0.1-66
                         haskell-aws              0.22-17              0.22-18
            haskell-binary-instances            1.0.0.1-1            1.0.0.1-2
               haskell-binary-tagged               0.2-47               0.2-48
                  haskell-bower-json          1.0.0.1-162          1.0.0.1-163
                 haskell-casa-client              0.0.1-6              0.0.1-7
                  haskell-casa-types              0.0.1-6              0.0.1-7
                       haskell-cborg            0.2.2.1-6            0.2.2.1-7
                  haskell-cborg-json            0.2.2.0-6            0.2.2.0-7
                  haskell-cheapskate           0.1.1.2-54           0.1.1.2-55
                   haskell-criterion           1.5.6.2-18           1.5.6.2-19
       haskell-criterion-measurement           0.1.2.0-32           0.1.2.0-33
                         haskell-dav             1.3.4-66             1.3.4-67
                 haskell-descriptive             0.9.5-94             0.9.5-95
                haskell-doctemplates             0.8.1-11             0.8.1-12
                   haskell-esqueleto              3.3.2-1              3.3.2-2
                     haskell-githash           0.1.3.3-81           0.1.3.3-82
            haskell-hackage-security           0.6.0.0-53           0.6.0.0-55
             haskell-haddock-library             1.8.0-40             1.8.0-41
                      haskell-hakyll          4.13.2.0-30          4.13.2.0-31
                       haskell-hasql              1.4.2-1              1.4.2-2
                  haskell-hasql-pool             0.5.1-75             0.5.1-76
           haskell-hasql-transaction            1.0.0.1-5            1.0.0.1-6
                haskell-hjsonpointer             1.5.0-78             1.5.0-79
                 haskell-hledger-lib             1.17.1-1             1.17.1-2
                    haskell-hopenpgp             2.9.4-45             2.9.4-46
                       haskell-hpack            0.33.0-94            0.33.0-95
                   haskell-hspec-wai             0.10.1-9            0.10.1-10
              haskell-hspec-wai-json             0.10.1-9            0.10.1-10
                haskell-hsyaml-aeson           0.2.0.0-24           0.2.0.0-25
                        haskell-http        4000.3.14-152        4000.3.14-153
                 haskell-http-client           0.6.4.1-21           0.6.4.1-22
             haskell-http-client-tls          0.3.5.3-206          0.3.5.3-207
                haskell-http-conduit           2.3.7.3-98           2.3.7.3-99
               haskell-http-download           0.2.0.0-21           0.2.0.0-22
                haskell-http-streams           0.8.7.1-64           0.8.7.1-66
                       haskell-http2             2.0.3-63             2.0.3-64
                  haskell-httpd-shed           0.4.1.1-81           0.4.1.1-82
                         haskell-hxt          9.3.1.18-48          9.3.1.18-49
   haskell-insert-ordered-containers             0.2.3-18             0.2.3-19
                       haskell-ipynb              0.1-161              0.1-162
                        haskell-jose           0.8.2.0-67           0.8.2.0-68
                   haskell-js-jquery            3.3.1-391            3.3.1-392
                  haskell-lens-aeson               1.1-18               1.1-19
                       haskell-lukko           0.1.1.1-12            0.1.1.2-1
             haskell-microlens-aeson           2.3.0.4-44           2.3.0.4-45
                 haskell-microstache          1.0.1.1-139          1.0.1.1-140
                    haskell-mustache             2.3.1-69             2.3.1-70
                 haskell-network-uri           2.6.3.0-48           2.6.3.0-49
             haskell-optparse-simple          0.1.1.2-158          0.1.1.2-159
                haskell-pandoc-types              1.20-25              1.20-26
                      haskell-pantry            0.4.0.1-9           0.4.0.1-11
                        haskell-path              0.7.0-3              0.7.0-4
                     haskell-path-io             1.6.0-11             1.6.0-12
                  haskell-persistent          2.10.5.2-10          2.10.5.2-11
               haskell-persistent-qq           2.9.1.1-57           2.9.1.1-58
           haskell-persistent-sqlite          2.10.6.2-34          2.10.6.2-35
         haskell-persistent-template           2.8.2.3-12           2.8.2.3-13
             haskell-persistent-test            2.0.3.1-6            2.0.3.1-7
                  haskell-pipes-http            1.0.6-118            1.0.6-119
           haskell-postgresql-binary            0.12.2-31            0.12.2-32
             haskell-rio-prettyprint           0.1.0.0-44           0.1.0.0-45
                         haskell-sbv               8.6-50               8.6-51
                   haskell-serialise            0.2.2.0-6            0.2.2.0-7
                     haskell-servant              0.17-13              0.17-14
              haskell-servant-server              0.17-13              0.17-14
             haskell-servant-swagger             1.1.8-14             1.1.8-15
                       haskell-shake            0.18.5-58            0.18.5-59
                 haskell-shakespeare            2.0.24-16            2.0.24-17
                 haskell-skylighting           0.8.3.2-46           0.8.3.2-47
            haskell-skylighting-core           0.8.3.2-46           0.8.3.2-47
                   haskell-snap-core           1.0.4.1-59           1.0.4.1-60
                 haskell-snap-server          1.1.1.1-172          1.1.1.1-173
                   haskell-sourcemap            0.1.6-170            0.1.6-171
                  haskell-statistics           0.15.2.0-9          0.15.2.0-10
                    haskell-swagger2                2.5-1                2.5-2
       haskell-tamarin-prover-theory             1.4.1-72             1.4.1-73
                     haskell-texmath          0.12.0.1-39          0.12.0.1-40
                   haskell-tree-diff               0.1-72               0.1-73
                  haskell-uri-encode           1.5.0.5-59           1.5.0.5-60
              haskell-wai-app-static           3.1.7.1-60           3.1.7.1-61
                   haskell-wai-extra          3.0.29.1-28          3.0.29.1-29
          haskell-wai-handler-launch           3.0.3.1-29           3.0.3.1-30
                  haskell-wai-logger             2.3.6-57             2.3.6-58
                        haskell-warp             3.3.9-11             3.3.9-12
                    haskell-warp-tls            3.2.11-48            3.2.11-49
                        haskell-wreq          0.5.3.2-169          0.5.3.2-170
                  haskell-xml-hamlet           0.5.0.1-66           0.5.0.1-67
                haskell-xss-sanitize             0.3.6-96             0.3.6-97
                        haskell-yaml           0.11.3.0-7           0.11.3.0-8
                       haskell-yesod           1.6.0.1-64           1.6.0.1-65
                  haskell-yesod-auth             1.6.10-2             1.6.10-3
                  haskell-yesod-core          1.6.17.3-22          1.6.17.3-23
               haskell-yesod-default            1.2.0-705            1.2.0-706
                  haskell-yesod-form            1.6.7-143            1.6.7-144
            haskell-yesod-persistent           1.6.0.4-88           1.6.0.4-89
                haskell-yesod-static          1.6.0.1-345          1.6.0.1-346
                  haskell-yesod-test            1.6.9-104            1.6.9-105
                             hledger           1.17.1.1-2           1.17.1.1-3
                          hledger-ui           1.17.1.1-3           1.17.1.1-4
                         hledger-web             1.17.1-7             1.17.1-8
                               hlint            2.2.11-31            2.2.11-32
                      home-assistant            0.107.5-1            0.107.7-1
                              hoogle         5.0.17.15-19         5.0.17.15-20
                      hopenpgp-tools             0.23.1-5             0.23.1-6
                              hwinfo              21.68-2              21.69-1
                           hypercorn              0.9.1-1              0.9.3-1
                               idris            1.3.2-106            1.3.2-107
                             jenkins              2.227-1              2.228-1
                          latte-dock              0.9.9-1             0.9.10-1
                            libmupdf             1.16.1-2             1.16.1-3
                            metacity             3.36.0-1             3.36.1-1
                               mupdf             1.16.1-2             1.16.1-3
                            mupdf-gl             1.16.1-2             1.16.1-3
                         mupdf-tools             1.16.1-2             1.16.1-3
                              nodejs            13.11.0-1            13.12.0-1
                                 npm             6.14.3-1             6.14.4-1
                   npm-check-updates              4.0.6-1              4.1.0-1
                          obs-studio             25.0.1-1             25.0.3-1
                             padthv1             0.9.12-1             0.9.13-1
                              pandoc             2.9.2-73             2.9.2-74
                     pandoc-citeproc              0.17-54              0.17-55
                     pandoc-crossref           0.3.6.2-51           0.3.6.2-52
                           postgrest            6.0.2-108            6.0.2-109
                      python-blessed             1.17.3-1             1.17.4-1
                     python-cfn-lint             0.29.0-2             0.29.2-1
                       python-gitlab             1.14.0-1              2.1.2-1
                        python-json5              0.9.3-1              0.9.4-1
                       python-minidb              2.0.2-4              2.0.3-1
              python-openstackclient              5.1.0-1              5.2.0-1
                 python-openstacksdk             0.43.0-1             0.44.0-1
                   python-persistent              4.6.3-1              4.6.4-1
                       python-pg8000             1.14.0-1             1.14.1-1
                    python-softlayer              5.8.5-1              5.8.6-1
                       python-stestr              2.6.0-2              3.0.0-1
                       ruby-net-ping              2.0.6-3              2.0.7-1
                            sagemath               9.0-11               9.0-12
                    sagemath-jupyter               9.0-11               9.0-12
                             samplv1             0.9.12-1             0.9.13-1
                          shellcheck            0.7.0-200            0.7.0-201
                      signal-desktop             1.32.1-2             1.32.3-1
                               stack    2.1.3.20200310-29    2.1.3.20200310-31
                     stylish-haskell          0.11.0.0-11          0.11.0.0-12
                             synthv1             0.9.12-1             0.9.13-1
                      tamarin-prover            1.4.1-309            1.4.1-310
                             taskell           1.9.2.0-62           1.9.2.0-63
                           ukui-menu              2.0.2-2              2.0.3-1
                    ukui-screensaver             2.0.10-2              2.1.0-1
                ukui-session-manager              2.0.0-2              2.0.1-1
                ukui-settings-daemon              1.2.0-1              1.2.1-1
                             unbound             1.10.0-1             1.10.0-2
         v2ray-domain-list-community       202003250001-1       202003261452-1
                              vegeta             12.8.1-1             12.8.2-1
                        vim-nerdtree              6.4.0-1              6.4.1-1
                                  wt              4.2.2-1              4.3.0-1
                              xmobar              0.33-19              0.33-20
                                pocl                    -                1.4-3


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-26           2020-03-27
-------------------------------------------------------------------------------
                                nano                4.8-1                4.9-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-26           2020-03-27
-------------------------------------------------------------------------------
                               snapd               2.44-1             2.44.1-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-26           2020-03-27
-------------------------------------------------------------------------------
                              amdvlk          2020.Q1.3-1          2020.Q1.4-1
                               dav1d              0.5.2-1              0.6.0-1
                              ffmpeg            1:4.2.2-3            1:4.2.2-4
                           kirigami2             5.68.0-1             5.68.0-2
                           memcached             1.5.20-1             1.5.21-1
                              netpbm           10.73.30-1           10.73.31-1
                          prometheus             2.17.0-1             2.17.1-1
                                 vlc             3.0.8-10             3.0.8-11
                            xine-lib             1.2.10-1             1.2.10-2


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-26           2020-03-27
-------------------------------------------------------------------------------
                        lib32-amdvlk          2020.Q1.3-1          2020.Q1.4-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

7 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Older issues

HP Device Manager


Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:
https://gitlab.manjaro.org/applications/pamac/issues/757

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.


Weird font glitches (see screenshots below).

If you have weird glitches like below...

Screenshots

Screenshot%20from%202020-01-16%2023-59-49
string3
strings%20mismatch
post%20transaction%20hooks

... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.


Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in

/usr/lib/python3.7/site-packages/

To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.


System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.


xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.


Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.


Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

Could you guys please try to look into why bbswitch doesn't build for linux56?

Some more package updates ...

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-26           2020-03-27
-------------------------------------------------------------------------------
                           baloo-git5.69.0.r2716.g28a534cc-15.69.0.r2723.g26e9b4af-1
                          breeze-git5.18.80.r1973.g7b336d45-15.18.80.r1976.g8e302333-1
                    breeze-icons-git5.69.0.r1524.g4959eb87-15.69.0.r1527.g0b834e41-1
                         drkonqi-git5.18.80.r499.g7154b5d4-15.18.80.r500.g32b11e57-1
             extra-cmake-modules-git5.69.0.r3142.g1bd96af-15.69.0.r3143.g6136a97-1
            frameworkintegration-git5.69.0.r512.g9a4eeba-15.69.0.r513.g5db6722-1
                     kactivities-git5.69.0.r1280.gd3626bab-15.69.0.r1281.g63be46e5-1
               kactivities-stats-git5.69.0.r274.ge212fd8-15.69.0.r275.g21445ba-1
               kactivitymanagerd-git5.15.80.r1270.g7b20b05-15.15.80.r1271.g244f61f-1
                           kauth-git5.69.0.r349.g85dd540-15.69.0.r350.g420c607-1
                      kbookmarks-git5.69.0.r323.g5caaa35-15.69.0.r325.gd49b079-1
                        kcmutils-git5.69.0.r378.g3fe22e0-15.69.0.r379.gfc639ac-1
                     kcompletion-git5.69.0.r354.g73336ec-15.69.0.r355.ga636f5f-1
                  kconfigwidgets-git5.69.0.r449.g57066c9-15.69.0.r450.gb8d79ca-1
                          kcrash-git5.69.0.r297.g91129f2-15.69.0.r298.g4297a0a-1
                     kdbusaddons-git5.69.0.r303.ge4de03a-15.69.0.r304.g7f8d778-1
                   kde-cli-tools-git5.18.80.r1758.g5d1c3d7-15.18.80.r1759.g836300d-1
                    kdeclarative-git5.69.0.r760.gcebaeb4-15.69.0.r761.gcb18820-1
                            kded-git5.69.0.r304.g449e8e8-15.69.0.r305.ge72c85b-1
                kdeplasma-addons-git5.18.80.r8320.g7eaad09e1-15.18.80.r8324.g06dc3bbc2-1
                 kdesignerplugin-git5.69.0.r274.gfb0118e-15.69.0.r275.g5494006-1
                           kdesu-git5.69.0.r391.g7291ba5-15.69.0.r392.g6c56e93-1
                       kdewebkit-git5.69.0.r223.ga29cf6e-15.69.0.r225.g0f0b4bf-1
                       kdoctools-git5.69.0.r531.gdef339c-15.69.0.r534.gc2e0be3-1
                      kemoticons-git5.69.0.r312.g22074de-15.69.0.r313.gcf9cfe8-1
                   kfilemetadata-git5.69.0.r685.g76f8542-15.69.0.r686.g78b95b2-1
                    kglobalaccel-git5.69.0.r353.g856a172-15.69.0.r354.gc14934d-1
                        khotkeys-git5.18.80.r1981.g5a814d2-15.18.80.r1982.g414e87e-1
                     kiconthemes-git5.69.0.r416.gdebe353-15.69.0.r417.gd9cb221-1
                   kimageformats-git5.57.0.r261.g203f459-15.57.0.r262.g52fbe18-1
                     kinfocenter-git5.18.80.r1658.g1ecc6d8-15.18.80.r1667.g7028c25-1
                           kinit-git5.69.0.r337.g7601ffd-15.69.0.r338.g0cccf02-1
                             kio-git5.69.0.r3841.g50bc53ff-15.69.0.r3852.g930fa43e-1
                       kirigami2-git5.69.0.r2117.g0aa162f2-15.69.0.r2122.g9b6ec041-1
                     kjobwidgets-git5.69.0.r288.g2b43834-15.69.0.r289.g2f14890-1
                        kjsembed-git5.69.0.r238.g313f715-15.69.0.r239.g97aa443-1
                    kmediaplayer-git5.69.0.r232.g00f255d-15.69.0.r233.geee919f-1
                      knetattach-git5.18.80.r7503.g38a874ab8-15.18.80.r7517.g43d5a1830-1
                       knewstuff-git5.69.0.r792.gf1dcbddf-15.69.0.r794.g7d6db881-1
                  knotifications-git5.69.0.r516.gfd94df4-15.69.0.r517.g9a29388-1
                   knotifyconfig-git5.69.0.r276.g4caaf10-15.69.0.r277.g8e0f19f-1
                        kpackage-git5.69.0.r569.g5b389a5-15.69.0.r570.g3bd2dab-1
                          kparts-git5.69.0.r391.g2589a41-15.69.0.r392.gc56b490-1
                         kpeople-git5.69.0.r1247.gf88b7d9-15.69.0.r1248.gaea6d71-1
                            kpty-git5.69.0.r251.g81084ae-15.69.0.r252.g705decf-1
                         krunner-git5.69.0.r414.ge6ce9b1-15.69.0.r415.g7d579a0-1
                   kscreenlocker-git5.18.80.r768.gb060c85-15.18.80.r769.gd439d87-1
                        kservice-git5.69.0.r749.gb984898-15.69.0.r750.g36933c5-1
                     ktexteditor-git5.69.0.r2345.g93964fad-15.69.0.r2346.g5b968e54-1
                    ktextwidgets-git5.69.0.r304.gb66a6ff-15.69.0.r305.ga9f219c-1
                 kunitconversion-git5.69.0.r299.g8e3c5b2-15.69.0.r300.gb7bab9d-1
                         kwallet-git5.69.0.r951.ga1dab3d-15.69.0.r952.g1a22e6b-1
                  kwidgetsaddons-git5.69.0.r641.g2e9cace-15.69.0.r643.gf626436-1
                   kwindowsystem-git5.69.0.r504.g492dec5-15.69.0.r505.g39d7a70-1
                         kxmlgui-git5.69.0.r609.g452847e-15.69.0.r610.g9404efe-1
                   kxmlrpcclient-git5.69.0.r388.gda9ebe356-15.69.0.r389.g9bb8a54ad-1
                    libksysguard-git5.18.80.r1778.g7a13a67-15.18.80.r1783.g108d5c5-1
                          oxygen-git5.18.80.r4361.g19771d84-15.18.80.r4362.g13c540b9-1
      plasma-browser-integration-git5.18.80.r1019.g88e4480b-15.18.80.r1020.gfa5d96d3-1
                  plasma-desktop-git5.18.80.r7503.g38a874ab8-15.18.80.r7517.g43d5a1830-1
                plasma-framework-git5.69.0.r15390.gf363a06ae-15.69.0.r15393.gf6bb0229b-1
                       plasma-nm-git5.18.80.r2828.g91fa9cd5-15.18.80.r2831.g5ef90506-1
                       plasma-pa-git5.18.80.r813.g87c37d5-15.18.80.r814.g36120da-1
                      plasma-sdk-git5.18.80.r2163.g60f1a6c-15.18.80.r2164.g4c3b89a-1
          plasma-wayland-session-git5.18.80.r8834.gdceb791c0-15.18.80.r8842.gd6821b3d2-1
                plasma-workspace-git5.18.80.r8834.gdceb791c0-15.18.80.r8842.gd6821b3d2-1
     plasma-workspace-wallpapers-git5.18.80.r189.g0ca88ac-15.18.80.r191.ga71ebd8-1
                      powerdevil-git5.18.80.r2264.g46a31ad7-15.18.80.r2265.gc829d217-1
                         purpose-git5.69.0.r748.g2c58ee9-15.69.0.r750.g00e456f-1
              qqc2-desktop-style-git5.69.0.r344.geecb8f6-15.69.0.r345.ga6208d9-1
                        sddm-kcm-git5.18.80.r525.gf365fd6-15.18.80.r526.g76b514b-1
                          sonnet-git5.69.0.r523.g12d1e20-15.69.0.r524.g2ce07be-1
                     syndication-git5.69.0.r759.gff6d11a-15.69.0.r760.g1cd8312-1
             syntax-highlighting-git5.69.0.r1098.gb2ace3e-15.69.0.r1100.g213d4bb-1
                  systemsettings-git5.18.80.r2211.g7f84fcbd-15.18.80.r2213.g76c6324f-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-26           2020-03-27
-------------------------------------------------------------------------------
                   arm-none-eabi-gcc              9.2.0-1              9.3.0-1
                          cockatrice              2.7.2-3              2.7.4-3
           firefox-developer-edition             75.0b9-1            75.0b10-1
  firefox-developer-edition-i18n-ach             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-af             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-an             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-ar             75.0b9-1            75.0b10-1
  firefox-developer-edition-i18n-ast             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-az             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-be             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-bg             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-bn             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-br             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-bs             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-ca             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-ca-valencia       75.0b9-1            75.0b10-1
  firefox-developer-edition-i18n-cak             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-cs             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-cy             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-da             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-de             75.0b9-1            75.0b10-1
  firefox-developer-edition-i18n-dsb             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-el             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-en-ca             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-en-gb             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-en-us             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-eo             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-es-ar             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-es-cl             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-es-es             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-es-mx             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-et             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-eu             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-fa             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-ff             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-fi             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-fr             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-fy-nl             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-ga-ie             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-gd             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-gl             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-gn             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-gu-in             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-he             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-hi-in             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-hr             75.0b9-1            75.0b10-1
  firefox-developer-edition-i18n-hsb             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-hu             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-hy-am             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-ia             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-id             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-is             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-it             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-ja             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-ka             75.0b9-1            75.0b10-1
  firefox-developer-edition-i18n-kab             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-kk             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-km             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-kn             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-ko             75.0b9-1            75.0b10-1
  firefox-developer-edition-i18n-lij             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-lt             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-lv             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-mk             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-mr             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-ms             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-my             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-nb-no             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-ne-np             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-nl             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-nn-no             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-oc             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-pa-in             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-pl             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-pt-br             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-pt-pt             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-rm             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-ro             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-ru             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-si             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-sk             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-sl             75.0b9-1            75.0b10-1
  firefox-developer-edition-i18n-son             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-sq             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-sr             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-sv-se             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-ta             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-te             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-th             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-tl             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-tr             75.0b9-1            75.0b10-1
  firefox-developer-edition-i18n-trs             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-uk             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-ur             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-uz             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-vi             75.0b9-1            75.0b10-1
   firefox-developer-edition-i18n-xh             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-zh-cn             75.0b9-1            75.0b10-1
firefox-developer-edition-i18n-zh-tw             75.0b9-1            75.0b10-1
                            gir-to-d             0.20.0-4             0.21.0-1
                               gsoap             2.8.99-1            2.8.100-1
                      haskell-hakyll          4.13.2.0-31          4.13.2.0-32
            haskell-jira-wiki-markup              1.1.3-1              1.1.4-1
                            lollypop             1.2.29-1             1.2.30-1
                           mediawiki             1.34.0-2             1.34.1-1
                      mediawiki-math             1.34.0-2             1.34.1-1
                               opera       67.0.3575.97-1      67.0.3575.115-1
                 opera-ffmpeg-codecs      80.0.3987.132-1      80.0.3987.149-1
                              pandoc             2.9.2-74             2.9.2-75
                     pandoc-citeproc              0.17-55              0.17-56
                     pandoc-crossref           0.3.6.2-52           0.3.6.2-53
            python-django-extensions              2.2.8-1              2.2.9-1
                        python-qiniu              7.2.7-1              7.2.8-1
              retroarch-assets-ozone              1:278-1              1:289-1
                retroarch-assets-xmb              1:278-1              1:289-1
               riscv64-linux-gnu-gcc              9.2.0-2              9.3.0-1
                          shellcheck            0.7.0-201            0.7.0-202
                         simple-scan             3.36.0-1             3.36.1-1
                ukui-session-manager              2.0.1-1              2.0.2-1
                         vapoursynth                R48-3                R49-1
                        wire-desktop          3.15.2922-1          3.16.2923-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-26           2020-03-27
-------------------------------------------------------------------------------
               calamares-git 3.2.21.r7473.b88e5589e-1 3.2.21.r7513.af4a7086d-1
                           pamac-cli              9.4.0-3              9.4.0-4
                        pamac-common              9.4.0-3              9.4.0-4
                pamac-flatpak-plugin              9.4.0-3              9.4.0-4
                           pamac-gtk              9.4.0-3              9.4.0-4
                   pamac-snap-plugin              9.4.0-3              9.4.0-4
             pamac-tray-appindicator              9.4.0-3              9.4.0-4


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-26           2020-03-27
-------------------------------------------------------------------------------
                             devhelp             3.36.0-1             3.36.1-1
                           evolution             3.36.0-1             3.36.1-1
                evolution-bogofilter             3.36.0-1             3.36.1-1
               evolution-data-server             3.36.0-1             3.36.1-1
                       evolution-ews             3.36.0-1             3.36.1-1
              evolution-spamassassin             3.36.0-1             3.36.1-1
                                gimp            2.10.18-4            2.10.18-5
                gnome-control-center             3.36.0-1             3.36.1-1
                        gnome-robots             3.36.0-1             3.36.1-1
                              gpaste             3.36.2-1             3.36.3-1
                                gvfs             1.44.0-1             1.44.1-1
                            gvfs-afc             1.44.0-1             1.44.1-1
                            gvfs-goa             1.44.0-1             1.44.1-1
                         gvfs-google             1.44.0-1             1.44.1-1
                        gvfs-gphoto2             1.44.0-1             1.44.1-1
                            gvfs-mtp             1.44.0-1             1.44.1-1
                            gvfs-nfs             1.44.0-1             1.44.1-1
                            gvfs-smb             1.44.0-1             1.44.1-1
              libgnome-games-support            1.6.0.1-1              1.6.1-1
                          libmypaint              1.4.0-1              1.5.1-1
               libnautilus-extension             3.36.0-1             3.36.1-1
                    mypaint-brushes1              1.3.0-1              1.3.1-1
                            nautilus             3.36.0-1             3.36.1-1
                            rinutils              0.2.0-1              0.4.0-1
                      vulkan-headers          1:1.2.135-1          1:1.2.136-1

2 Likes

Currently we get this error:

==> Starting build()...
make -C /usr/lib/modules/5.6.0-1-MANJARO/build M="$(pwd)" modules
make[1]: Entering directory '/usr/lib/modules/5.6.0-1-MANJARO/build'
  CC [M]  /home/phil/dev/git/manjaro/repositories/gitlab/extra/extramodules/linux56-extramodules/bbswitch/src/bbswitch-0.8/bbswitch.o
/home/phil/dev/git/manjaro/repositories/gitlab/extra/extramodules/linux56-extramodules/bbswitch/src/bbswitch-0.8/bbswitch.c: In function 'bbswitch_init':
/home/phil/dev/git/manjaro/repositories/gitlab/extra/extramodules/linux56-extramodules/bbswitch/src/bbswitch-0.8/bbswitch.c:460:63: error: passing argument 4 of 'proc_create' from incompatible pointer type [-Werror=incompatible-pointer-types]
  460 |     acpi_entry = proc_create("bbswitch", 0664, acpi_root_dir, &bbswitch_fops);
      |                                                               ^~~~~~~~~~~~~~
      |                                                               |
      |                                                               struct file_operations *
In file included from ./include/acpi/acpi_bus.h:83,
                 from ./include/linux/acpi.h:32,
                 from /home/phil/dev/git/manjaro/repositories/gitlab/extra/extramodules/linux56-extramodules/bbswitch/src/bbswitch-0.8/bbswitch.c:32:
./include/linux/proc_fs.h:64:24: note: expected 'const struct proc_ops *' but argument is of type 'struct file_operations *'
   64 | struct proc_dir_entry *proc_create(const char *name, umode_t mode, struct proc_dir_entry *parent, const struct proc_ops *proc_ops);
      |                        ^~~~~~~~~~~
cc1: some warnings being treated as errors
make[2]: *** [scripts/Makefile.build:268: /home/phil/dev/git/manjaro/repositories/gitlab/extra/extramodules/linux56-extramodules/bbswitch/src/bbswitch-0.8/bbswitch.o] Error 1
make[1]: *** [Makefile:1683: /home/phil/dev/git/manjaro/repositories/gitlab/extra/extramodules/linux56-extramodules/bbswitch/src/bbswitch-0.8] Error 2
make[1]: Leaving directory '/usr/lib/modules/5.6.0-1-MANJARO/build'
make: *** [Makefile:13: default] Error 2
==> ERROR: A failure occurred in build().

1 Like

more packages ...


:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                           baloo-git5.69.0.r2723.g26e9b4af-15.69.0.r2727.g1e7145ac-1
                    breeze-icons-git5.69.0.r1527.g0b834e41-15.69.0.r1528.g1bbf2a54-1
                     kcoreaddons-git5.69.0.r960.g9348039-15.69.0.r961.gfcdf263-1
                             kio-git5.69.0.r3852.g930fa43e-15.69.0.r3853.g8fdfce00-1
                      knetattach-git5.18.80.r7517.g43d5a1830-15.18.80.r7520.g4753f61f7-1
                          latte-dock            0.9.9-1.2                    -
                  plasma-desktop-git5.18.80.r7517.g43d5a1830-15.18.80.r7520.g4753f61f7-1
                       plasma-nm-git5.18.80.r2831.g5ef90506-15.18.80.r2837.gd39cbb96-1
          plasma-wayland-session-git5.18.80.r8842.gd6821b3d2-15.18.80.r8844.g9be7dedb8-1
                plasma-workspace-git5.18.80.r8842.gd6821b3d2-15.18.80.r8844.g9be7dedb8-1
                                fann                    -              2.2.0-5
                        mycroft-core                    -             20.2.1-1
             plasma5-applets-mycroft                    -       r132.fbc7a50-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                           findomain              1.4.3-1              1.4.5-1
                 gnome-initial-setup             3.36.0-1             3.36.1-1
                      gnome-software             3.34.2-2             3.36.0-1
    gnome-software-packagekit-plugin             3.34.2-2             3.36.0-1
                       haskell-■■■■■              0.52-22              0.52-23
                        haskell-spdx           1.0.0.1-20            1.0.0.2-1
                         haskell-vty             5.28.1-2             5.28.2-1
                          hledger-ui           1.17.1.1-4           1.17.1.1-5
               intel-compute-runtime        20.11.16158-1        20.12.16259-1
             intel-graphics-compiler         1:1.0.3529-1         1:1.0.3586-1
             mkinitcpio-systemd-tool                 23-1                 25-1
                               peony              2.0.1-1              2.1.0-1
                    perl-test-simple           1.302172-1           1.302173-1
                        python-cliff              3.0.0-2              3.1.0-1
                       python-peewee             3.13.1-1             3.13.2-1
                             taskell           1.9.2.0-63           1.9.2.0-64
                           verilator              4.024-1              4.030-1
                        vim-nerdtree              6.4.1-1              6.4.2-1
                         vim-ansible                    -                2.1-2


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                       device-mapper           2.02.186-5           2.02.187-1
                                lvm2           2.02.186-5           2.02.187-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                           calamares           3.2.20.1-1             3.2.21-1
                       calamares-git3.2.21.r7513.af4a7086d-13.2.21.r7552.276195c2b-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                            epiphany             3.36.0-1             3.36.1-1
                     glib-networking             2.64.0-1             2.64.1-1
                      gnome-terminal           3.36.0.1-2             3.36.1-2
               gtk-update-icon-cache1:3.24.14+9+g429a6287e0-1          1:3.24.16-1
                                gtk31:3.24.14+9+g429a6287e0-1          1:3.24.16-1
                              kdiff3              1.8.1-1              1.8.2-1
                              libqmi             1.24.6-1             1.24.8-1
                           memcached             1.5.21-1             1.5.22-1
                          vte-common             0.60.0-1             0.60.1-1
                                vte3             0.60.0-1             0.60.1-1
                          malcontent                    -              0.7.0-1
2 Likes

Hm, konsole and tmux doesn't like each other, switched to gnome terminal :wink:

This time it should be more like:

"Hello Community,

Yes we have completely lost our bleep bleep bleepin minds. Count them, not one, not two, but three sets of up dates for the same date."
:sweat_smile: :rofl: :joy: :sweat_smile: :rofl: :joy:

Seriously though why three different sets of updates for the 27th?

Try (GNU) screen. Gnome terminal seems an odd replacement as it's a gtk application.

screen is odd replacement for tmux :slight_smile:

1 Like

I don't see a r8168 kernel module for linux56 up on gitlab. There was a patch posted in the comments of the AUR dkms package that with a slight modification builds the module for me for linux56. I don't know if this will help anyone but I thought I would share.

Patch: https://pastebin.com/HbsiyeVh

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by