[Testing Update] 2020-03-29 - Systemd, Gnome 3.36.1, Wine 5.5, Haskell, Python

Hello community,

here is another Testing Update for you:


Give our second preview of Manjaro 19.1 Lysia release a try-out: Gnome, Plasma, XFCE

Some feature-updates:

  • More Gnome 3.36.1 updates
  • Wine 5.5 released
  • Systemd got updated to 245.3
  • Haskell and Python updates/cleanups

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 19.0.2 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.82
  • linux44 4.4.217
  • linux49 4.9.217
  • linux414 4.14.174
  • linux419 4.19.113
  • linux54 5.4.28
  • linux55 5.5.13
  • linux56 5.6-rc7
  • linux419-rt 4.19.106_rt45
  • linux54-rt 5.4.26_rt17

Package Changes (Sun Mar 29 12:20:57 CEST 2020)

  • testing community x86_64: 275 new and 243 removed package(s)
  • testing core x86_64: 6 new and 6 removed package(s)
  • testing extra x86_64: 30 new and 31 removed package(s)
  • testing multilib x86_64: 7 new and 7 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-27           2020-03-29
-------------------------------------------------------------------------------
                               cpu-x3.2.4.r193.g73fe01e-53.2.4.r194.gf6db693-1
                         kcodecs-git5.69.0.r300.g8351b2a-15.69.0.r301.g2536577-1
                           ki18n-git5.69.0.r388.gd8b3982-15.69.0.r389.g1097127-1
                   kimageformats-git5.57.0.r262.g52fbe18-15.57.0.r264.g1d12b34-1
                             kio-git5.69.0.r3853.g8fdfce00-15.69.0.r3857.g5a4500c8-1
                   kscreenlocker-git5.18.80.r769.gd439d87-15.18.80.r771.gdecf7c9-1
                plasma-framework-git5.69.0.r15393.gf6bb0229b-15.69.0.r15394.gb7e88d2a1-1
          plasma-wayland-session-git5.18.80.r8844.g9be7dedb8-15.18.80.r8846.g11579f9b7-1
                plasma-workspace-git5.18.80.r8844.g9be7dedb8-15.18.80.r8846.g11579f9b7-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-27           2020-03-29
-------------------------------------------------------------------------------
                                agda             2.6.1-10             2.6.1-11
                               arcus              4.4.0-1              4.5.0-1
                      aspnet-runtime       3.1.3.sdk103-1     3.1.3.sdk103.2-1
                             buildah             1.14.3-1             1.14.5-1
                       cabal-install           3.0.0.0-65           3.0.0.0-66
                            calcurse              4.5.1-1              4.6.0-1
                               cgrep            6.6.32-12            6.6.32-13
                             cryptol             2.8.0-89             2.8.0-90
                                cura              4.4.1-1              4.5.0-1
                    cura-binary-data              4.4.0-1              4.5.0-1
            cura-resources-materials              4.4.0-1              4.5.0-1
                          curaengine              4.4.0-1              4.5.0-1
                               darcs           2.14.2-200           2.14.2-201
                                dart              2.7.1-1              2.7.2-1
                               dhall            1.30.0-25            1.30.0-26
                          dhall-bash            1.0.28-27            1.0.28-28
                          dhall-json             1.6.2-26             1.6.2-27
                         dotnet-host       3.1.3.sdk103-1     3.1.3.sdk103.2-1
                      dotnet-runtime       3.1.3.sdk103-1     3.1.3.sdk103.2-1
                          dotnet-sdk       3.1.3.sdk103-1     3.1.3.sdk103.2-1
                        emptyepsilon         2020.02.18-1         2020.03.22-1
                          emscripten            1.39.10-2            1.39.11-1
                           espeak-ng               1.50-1               1.50-2
              firefox-tree-style-tab              3.4.7-1              3.4.8-1
                    gimp-plugin-gmic              2.8.4-2              2.9.0-1
                           git-annex        8.20200309-33        8.20200309-35
                          git-repair        1.20200102-56        1.20200102-57
                               gitea             1.11.1-1             1.11.3-1
                                gmic              2.8.4-2              2.9.0-1
                       haskell-aeson            1.4.7.1-1            1.4.7.1-2
         haskell-aeson-better-errors          0.9.1.0-165          0.9.1.0-166
                haskell-aeson-compat             0.3.9-83             0.3.9-84
                  haskell-aeson-diff           1.1.0.8-80           1.1.0.8-81
                haskell-aeson-pretty             0.8.8-29             0.8.8-30
                    haskell-aeson-qq             0.8.3-39             0.8.3-40
                  haskell-aeson-yaml           1.0.6.0-13           1.0.6.0-14
                  haskell-attoparsec          0.13.2.3-20           0.13.2.4-1
          haskell-attoparsec-iso8601           1.0.1.0-54           1.0.1.0-55
                haskell-authenticate             1.3.5-86             1.3.5-87
          haskell-authenticate-oauth           1.6.0.1-66           1.6.0.1-67
                         haskell-aws              0.22-18              0.22-19
            haskell-binary-instances            1.0.0.1-2            1.0.0.1-3
               haskell-binary-tagged               0.2-48               0.2-49
                  haskell-bower-json          1.0.0.1-163          1.0.0.1-164
                       haskell-■■■■■              0.52-23              0.52-24
            haskell-bsb-http-chunked           0.0.0.4-84           0.0.0.4-85
                 haskell-casa-client              0.0.1-7              0.0.1-8
                  haskell-casa-types              0.0.1-7              0.0.1-8
                     haskell-cassava           0.5.2.0-20           0.5.2.0-21
          haskell-cassava-megaparsec             2.0.1-22             2.0.1-23
                       haskell-cborg            0.2.2.1-7            0.2.2.1-8
                  haskell-cborg-json            0.2.2.0-7            0.2.2.0-8
                  haskell-cheapskate           0.1.1.2-55           0.1.1.2-56
               haskell-conduit-extra              1.3.5-2              1.3.5-3
                  haskell-config-ini           0.2.4.0-95           0.2.4.0-96
                haskell-configurator          0.3.0.0-110          0.3.0.0-111
                   haskell-criterion           1.5.6.2-19           1.5.6.2-21
       haskell-criterion-measurement           0.1.2.0-33           0.1.2.0-34
          haskell-cryptohash-conduit            0.1.1-353            0.1.1-354
          haskell-cryptonite-conduit            0.2.2-247            0.2.2-248
                    haskell-css-text           0.1.3.0-78           0.1.3.0-79
             haskell-data-serializer           0.3.4.1-22           0.3.4.1-23
                haskell-data-textual           0.3.0.3-20           0.3.0.3-21
                         haskell-dav             1.3.4-67             1.3.4-68
                        haskell-dbus             1.2.11-1             1.2.12-1
               haskell-dbus-hslogger           0.1.0.1-16           0.1.0.1-18
                 haskell-descriptive             0.9.5-95             0.9.5-96
                         haskell-dns             4.0.1-10             4.0.1-11
                haskell-doctemplates             0.8.1-12             0.8.1-13
              haskell-email-validate          2.3.2.12-21          2.3.2.12-22
                   haskell-esqueleto              3.3.2-2              3.3.2-3
                  haskell-fdo-notify            0.3.1-269            0.3.1-271
                        haskell-feed            1.3.0.1-1            1.3.0.1-2
                          haskell-gi             0.23.0-7             0.23.0-8
                     haskell-githash           0.1.3.3-82           0.1.3.3-83
            haskell-hackage-security           0.6.0.0-55           0.6.0.0-56
             haskell-haddock-library             1.8.0-41             1.8.0-42
                      haskell-hakyll          4.13.2.0-32          4.13.2.0-33
                       haskell-hasql              1.4.2-2              1.4.2-3
                  haskell-hasql-pool             0.5.1-76             0.5.1-77
           haskell-hasql-transaction            1.0.0.1-6            1.0.0.1-7
                haskell-hjsonpointer             1.5.0-79             1.5.0-80
                 haskell-hledger-lib             1.17.1-2             1.17.1-3
                    haskell-hopenpgp             2.9.4-46             2.9.4-47
                       haskell-hpack            0.33.0-95            0.33.0-96
                   haskell-hspec-wai            0.10.1-10            0.10.1-11
              haskell-hspec-wai-json            0.10.1-10            0.10.1-11
                haskell-hsyaml-aeson           0.2.0.0-25           0.2.0.0-26
                haskell-html-conduit           1.3.2.1-54           1.3.2.1-55
                        haskell-http        4000.3.14-153        4000.3.14-155
               haskell-http-api-data           0.4.1.1-23           0.4.1.1-24
                 haskell-http-client           0.6.4.1-22           0.6.4.1-24
             haskell-http-client-tls          0.3.5.3-207          0.3.5.3-208
                haskell-http-conduit           2.3.7.3-99          2.3.7.3-100
                   haskell-http-date             0.0.8-57             0.0.8-58
               haskell-http-download           0.2.0.0-22           0.2.0.0-23
                haskell-http-streams           0.8.7.1-66           0.8.7.1-68
                       haskell-http2             2.0.3-64             2.0.3-65
                  haskell-httpd-shed           0.4.1.1-82           0.4.1.1-84
                         haskell-hxt          9.3.1.18-49          9.3.1.18-50
          haskell-incremental-parser            0.4.0.1-6            0.4.0.1-7
                         haskell-ini             0.4.1-48             0.4.1-49
   haskell-insert-ordered-containers             0.2.3-19             0.2.3-20
                  haskell-io-streams           1.5.1.0-51           1.5.1.0-52
          haskell-io-streams-haproxy           1.0.1.0-51           1.0.1.0-52
                       haskell-ipynb              0.1-162              0.1-163
                        haskell-jose           0.8.2.0-68           0.8.2.0-69
                   haskell-js-jquery            3.3.1-392            3.3.1-394
                  haskell-lens-aeson               1.1-19               1.1-20
                      haskell-libmpd           0.9.1.0-13           0.9.1.0-14
             haskell-microlens-aeson           2.3.0.4-45           2.3.0.4-46
                 haskell-microstache          1.0.1.1-140          1.0.1.1-141
                haskell-monad-logger            0.3.32-12            0.3.32-13
                    haskell-mustache             2.3.1-70             2.3.1-71
                  haskell-network-ip           0.3.0.3-25           0.3.0.3-26
                 haskell-network-uri           2.6.3.0-49           2.6.3.0-51
          haskell-openpgp-asciiarmor             0.1.2-27             0.1.2-28
             haskell-openssl-streams           1.2.2.0-53           1.2.2.0-54
             haskell-optparse-simple          0.1.1.2-159          0.1.1.2-160
                haskell-pandoc-types              1.20-26              1.20-27
                      haskell-pantry           0.4.0.1-11           0.4.0.1-12
                     haskell-parsers           0.12.10-38           0.12.10-39
                        haskell-path              0.7.0-4              0.7.0-5
                     haskell-path-io             1.6.0-12             1.6.0-13
                  haskell-persistent          2.10.5.2-11          2.10.5.2-12
               haskell-persistent-qq           2.9.1.1-58           2.9.1.1-59
           haskell-persistent-sqlite          2.10.6.2-35          2.10.6.2-36
         haskell-persistent-template           2.8.2.3-13           2.8.2.3-14
             haskell-persistent-test            2.0.3.1-7            2.0.3.1-8
                  haskell-pipes-http            1.0.6-119            1.0.6-120
           haskell-postgresql-binary            0.12.2-32            0.12.2-33
            haskell-project-template          0.2.0.1-217          0.2.0.1-218
                 haskell-rio-orphans           0.1.1.0-93           0.1.1.0-94
             haskell-rio-prettyprint           0.1.0.0-45           0.1.0.0-46
                         haskell-sbv               8.6-51               8.6-52
                   haskell-serialise            0.2.2.0-7            0.2.2.0-8
                     haskell-servant              0.17-14              0.17-15
              haskell-servant-server              0.17-14              0.17-15
             haskell-servant-swagger             1.1.8-15             1.1.8-16
                       haskell-shake            0.18.5-59            0.18.5-60
                 haskell-shakespeare            2.0.24-17            2.0.24-18
             haskell-simple-sendfile            0.2.30-46            0.2.30-47
                 haskell-skylighting           0.8.3.2-47           0.8.3.2-48
            haskell-skylighting-core           0.8.3.2-47           0.8.3.2-48
                   haskell-snap-core           1.0.4.1-60           1.0.4.1-61
                 haskell-snap-server          1.1.1.1-173          1.1.1.1-174
                   haskell-sourcemap            0.1.6-171            0.1.6-172
                  haskell-statistics          0.15.2.0-10          0.15.2.0-11
                    haskell-swagger2                2.5-2                2.5-3
           haskell-tagstream-conduit          0.5.5.3-343          0.5.5.3-344
         haskell-tamarin-prover-term             1.4.1-53             1.4.1-54
       haskell-tamarin-prover-theory             1.4.1-73             1.4.1-74
                 haskell-tar-conduit             0.3.2-64             0.3.2-65
                     haskell-texmath          0.12.0.1-40          0.12.0.1-41
                   haskell-tree-diff               0.1-73               0.1-74
                    haskell-trifecta               2.1-30               2.1-31
              haskell-uri-bytestring           0.3.2.2-40           0.3.2.2-41
                  haskell-uri-encode           1.5.0.5-60           1.5.0.5-61
              haskell-wai-app-static           3.1.7.1-61           3.1.7.1-62
                    haskell-wai-cors             0.2.7-38             0.2.7-39
                   haskell-wai-extra          3.0.29.1-29          3.0.29.1-30
          haskell-wai-handler-launch           3.0.3.1-30           3.0.3.1-31
                  haskell-wai-logger             2.3.6-58             2.3.6-59
              haskell-wai-websockets          3.0.1.2-128          3.0.1.2-129
                        haskell-warp             3.3.9-12             3.3.9-14
                    haskell-warp-tls            3.2.11-49            3.2.11-50
                  haskell-websockets          0.12.7.0-17          0.12.7.0-18
                        haskell-wreq          0.5.3.2-170          0.5.3.2-171
                      haskell-xcffib             0.9.0-22             0.9.0-23
                 haskell-xml-conduit            1.9.0.0-4            1.9.0.0-5
                  haskell-xml-hamlet           0.5.0.1-67           0.5.0.1-68
                haskell-xss-sanitize             0.3.6-97             0.3.6-98
                        haskell-yaml           0.11.3.0-8           0.11.3.0-9
                       haskell-yesod           1.6.0.1-65           1.6.0.1-66
                  haskell-yesod-auth             1.6.10-3             1.6.10-4
                  haskell-yesod-core          1.6.17.3-23          1.6.17.3-24
               haskell-yesod-default            1.2.0-706            1.2.0-707
                  haskell-yesod-form            1.6.7-144            1.6.7-145
            haskell-yesod-persistent           1.6.0.4-89           1.6.0.4-90
                haskell-yesod-static          1.6.0.1-346          1.6.0.1-347
                  haskell-yesod-test            1.6.9-105            1.6.9-106
                             hledger           1.17.1.1-3           1.17.1.1-4
                          hledger-ui           1.17.1.1-5           1.17.1.1-6
                         hledger-web             1.17.1-8             1.17.1-9
                               hlint            2.2.11-32            2.2.11-33
                              hoogle         5.0.17.15-20         5.0.17.15-21
                      hopenpgp-tools             0.23.1-6             0.23.1-7
                               idris            1.3.2-107            1.3.2-108
                            impacket             0.9.20-1             0.9.21-1
     intellij-idea-community-edition         2:2019.3.2-1         2:2019.3.4-1
                   java-commons-lang                3.9-5               3.10-1
                               kitty             0.17.1-1             0.17.2-1
                      kitty-terminfo             0.17.1-1             0.17.2-1
                   krita-plugin-gmic              2.8.4-2              2.9.0-1
                            lollypop             1.2.30-1             1.2.32-1
                         lsp-plugins             1.1.14-1             1.1.15-1
             mkinitcpio-systemd-tool                 25-1                 27-1
                              pandoc             2.9.2-75             2.9.2-76
                     pandoc-citeproc              0.17-56              0.17-57
                     pandoc-crossref           0.3.6.2-53           0.3.6.2-54
                          perl-mouse              2.5.9-1             2.5.10-1
                    perl-ppix-regexp              0.070-1              0.071-1
                           postgrest            6.0.2-109            6.0.2-110
                      python-alembic              1.4.1-1              1.4.2-1
                      python-etesync             0.10.0-1             0.11.1-1
                  python-lark-parser              0.8.2-1              0.8.3-1
                 python-openstacksdk             0.44.0-1             0.45.0-1
               python-prompt_toolkit              3.0.4-1              3.0.5-1
                  python-pysol_cards              0.8.8-1              0.8.9-1
                    python-softlayer              5.8.6-1              5.8.7-1
                        python-sybil              1.2.2-1              1.3.0-1
                         python-tqdm             4.43.0-1             4.44.0-1
                        python-ujson              2.0.2-1              2.0.3-1
             python-virtualenv-clone              0.5.3-3              0.5.4-1
                         python-yaml                5.3-1              5.3.1-1
                     python2-alembic              1.4.1-1              1.4.2-1
                       python2-ujson              2.0.2-1              2.0.3-1
                        python2-yaml                5.3-1              5.3.1-1
                            qtractor             0.9.12-1             0.9.13-1
                          shellcheck            0.7.0-202            0.7.0-203
                                sssd              2.2.3-2              2.2.3-5
                               stack    2.1.3.20200310-31    2.1.3.20200310-32
                     stylish-haskell          0.11.0.0-12          0.11.0.0-13
                      tamarin-prover            1.4.1-310            1.4.1-311
                             taskell           1.9.2.0-64           1.9.2.0-65
      thunderbird-extension-enigmail              2.1.5-1              2.1.6-1
                     ttf-inconsolata            1:3.000-1            1:3.000-2
                           uglify-js              3.8.0-1              3.8.1-1
                             uranium              4.4.0-4              4.5.0-1
                                 waf             2.0.19-1             2.0.20-1
         wingpanel-indicator-network              2.2.2-1              2.2.3-1
                              xmobar              0.33-20              0.33-22
                             xtrlock               2.12-1               2.13-1
                                zart              2.8.4-2              2.9.0-1
                             dua-cli                    -              2.3.9-2
                    espeak-ng-espeak                    -               1.50-2
                              flterm                    -                2.4-1
              haskell-base-noprelude                    -           4.13.0.0-1
                   lm32-elf-binutils                    -               2.34-2
                        lm32-elf-gcc                    -              9.3.0-1
                        lm32-elf-gdb                    -                9.1-1
                     lm32-elf-newlib                    -              3.3.0-1
                   or1k-elf-binutils                    -               2.34-1
                        or1k-elf-gcc                    -              9.3.0-1
                        or1k-elf-gdb                    -                9.1-1
                     or1k-elf-newlib                    -              3.3.0-1
                ppc64le-elf-binutils                    -               2.34-1
                     ppc64le-elf-gdb                    -                9.1-1
                          prjtrellis                    -                1.0-1
                       prjtrellis-db                    -       r115.717478b-3
                          prjxray-db                    -       r225.1a4ee7c-1
                     python-intelhex                    -              2.2.1-2
                    python-jsonmerge                    -              1.7.0-1
                python-nmigen-boards                    -       r100.18315d8-1
                riscv32-elf-binutils                    -               2.34-2
                     riscv32-elf-gcc                    -              9.3.0-1
                     riscv32-elf-gdb                    -                9.1-1
                  riscv32-elf-newlib                    -              3.3.0-2
                riscv64-elf-binutils                    -               2.34-1
                     riscv64-elf-gcc                    -              9.3.0-1
                     riscv64-elf-gdb                    -                9.1-1
                  riscv64-elf-newlib                    -              3.3.0-1
                    sh2-elf-binutils                    -               2.34-1
                         sh2-elf-gdb                    -                9.1-1
                    sh4-elf-binutils                    -               2.34-1
                            tinyprog                    -             1.0.23-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-27           2020-03-29
-------------------------------------------------------------------------------
                             systemd              245.2-1              245.3-1
                        systemd-libs              245.2-1              245.3-1
                  systemd-resolvconf              245.2-1              245.3-1
                  systemd-sysvcompat              245.2-1              245.3-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-27           2020-03-29
-------------------------------------------------------------------------------
                                krb5             1.17.1-1               1.18-1
                            xfsprogs              5.4.0-1              5.5.0-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-27           2020-03-29
-------------------------------------------------------------------------------
                           boxit-arm              2.1.3-2              2.1.3-3


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-27           2020-03-29
-------------------------------------------------------------------------------
                                 eog             3.36.0-1             3.36.1-1
                         file-roller             3.36.0-1             3.36.1-1
                        five-or-more             3.32.1-1             3.32.2-1
                                 gjs           2:1.64.0-1           2:1.64.1-1
          gnome-getting-started-docs             3.36.0-1             3.36.1-1
                          gnome-maps             3.36.0-1             3.36.1-1
                         gnome-music           1:3.36.0-1           1:3.36.1-1
                      gnome-terminal             3.36.1-2           3.36.1.1-1
                     gnome-user-docs             3.36.0-1             3.36.1-1
                          gst-python             1.16.2-1             1.16.2-2
                         gst-python2             1.16.2-1                    -
                         imagemagick           7.0.10.2-2           7.0.10.3-1
                     imagemagick-doc           7.0.10.2-2           7.0.10.3-1
                            kdiagram              2.6.1-2              2.6.2-1
                                 ldb            1:1.5.6-2            1:2.0.7-2
                              libdca              0.0.6-1              0.0.7-1
                          libmagick6           6.9.11.2-1           6.9.11.3-1
                             librsvg           2:2.48.0-1           2:2.48.1-1
                            libwacom                1.2-1                1.3-1
                         libwbclient            4.10.10-2             4.11.3-3
                        link-grammar              5.7.0-2              5.8.0-1
                             perl-tk            804.034-4            804.035-1
                               samba            4.10.10-2             4.11.3-3
                           smbclient            4.10.10-2             4.11.3-3
                                tali             3.36.0-1             3.36.1-1
                                 tdb             1.3.18-4              1.4.3-2
                              tevent           1:0.9.39-4           1:0.10.1-2
                   xfce4-screensaver              0.1.9-2              0.1.9-3
                       xfce4-session             4.14.1-1             4.14.2-1
                        xscreensaver               5.43-1               5.44-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-27           2020-03-29
-------------------------------------------------------------------------------
                       lib32-systemd              245.2-1              245.3-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-03-27           2020-03-29
-------------------------------------------------------------------------------
               lib32-glib-networking             2.64.0-1             2.64.1-1
                          lib32-gtk3            3.24.14-1            3.24.16-1
                          lib32-krb5             1.17.1-1               1.18-1
                       lib32-librsvg             2.48.0-1             2.48.1-1
                                wine                5.4-1                5.5-1
                        wine-staging                5.4-1                5.5-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

9 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Older issues

HP Device Manager


Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:
https://gitlab.manjaro.org/applications/pamac/issues/757

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.


Weird font glitches (see screenshots below).

If you have weird glitches like below...

Screenshots

Screenshot%20from%202020-01-16%2023-59-49
string3
strings%20mismatch
post%20transaction%20hooks

... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.


Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in

/usr/lib/python3.7/site-packages/

To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.


System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.


xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.


Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.


Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

@philm, @oberon I'm using 5.6 kernel because I have some systemd warnings with kernel 5.5.
It's works like a charm on my gnome desktop, could you build please linux5.6-virtualbox-host-modules?

Edit: As I can see 5.6 is stable now. :wink:

1 Like

virtualbox needs time, zfs was corrected almost instantly :stuck_out_tongue:

Everything seems OK, wine 5.5 staging seem to have memory leaks with some games though (silent hunter 4 on steam), but this is probably an upstream problem.

If you would have tried it yourself, you would have seen that there are builderrors when built against Kernel 5.6 :wink: It needs an update from Oracle first.

2 Likes

@philm it seems like there is a regression on 5.6 already.

--> https://www.phoronix.com/scan.php?page=news_item&px=Linux-5.6-Broken-Intel-IWLWIFI

It will be fixed in Linux 5.6.1.

They know that, can't find it now (I'm a lazy human) but they said that already

Just use Ethernet :grin:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by