[Testing Update] 2020-04-01 - Plasma 5.18.4.1, Breath2, Haskell, Python

I can only suspect a cache issue ... The icons you show got no touch-ups at all, no change whatsoever. Sometimes i notice that my Telegram icon has different icons, randomly from time to time, when i first click on it, but all comes back to normal after a couple of minutes. I found no explanation for it, reason why i did not mentioned.

Talking about the devil, as i just did a reboot.

image
muahahaha

2 Likes

Mayday! Mayday! @philm

There's a problem with linux56 and newer, config.x86_64 has a new setting CONFIG_EFI_DISABLE_PCI_DMA set to Y, I've checked already, maybe it's a good thing but it causes this:

exit_boot() failed!
efi_main() failed!

Like described here on Arch forums. Can you set it to no if possible? I'm yet to understand whether it's necessary or not but its negative impact I've already experienced -- my system is unable to boot with with linux56. Thanks dog I have linux54 installed.

I have to describe my case if you cannot reproduce the above for some reason: I have no Grub, only systemd-boot and EFISTUB is used for booting, hence this thing affects me. It happens upon kernel loading and nothing could be done except Ctrl+Alt+Delete, which is, as one famous guy says, sad.

1 Like

Try with efi=no_disable_early_pci_dma set allows you normally to boot your system.

1 Like

That is fixed now ...

3 Likes

smbclient with SMB1 stopped working in Dolphin (KDE) network tab.

I have an old Iomega NAS that can only do SMB1, in the process of being decomissened, and the new one with up to date samba, so I had smb.conf with client max protocol = NT1 and I could see both the old and the new NAS, but it seems something went wrong after samba 4.11.3-3, from 4.11.6-1 on it stopped working.

Changing smb.conf to client max protocol = SMB3 makes the new NAS appear again.

I can still manually mount the old NAS using vers=1.0 in either mount command or in /etc/fstab.

SMB1 is kinda old and unsecure. However, there are reports after switching from 4.10.x to 4.11.x or 4.12.x SMB1 kinda doesn't work anymore.

https://bugs.archlinux.org/task/64537
https://bugs.archlinux.org/task/62521

Now vbox works with kernel 5.6 :wink:

1 Like

KInfoCenter reports my Plasma version as 5.18.4. Pamac reports that I have 5.18.4.1 installed.

It was a snafu upstream that caused this. Jonathon Riddell forgot to change the version number in the source code. He then re-rolled the tars as 5.18.4.1 instead. What you see is fine, there's no issue with out-dated packages.

I was running Kernel 5.5 and after the update this morning I performed a reboot. But I couldn't get into the desktop with an error:

[FAILED] Failed to start Load Kernel Modules

I needed to use tty2 to move to the stable branch and perform a pacman -Syyuu to get to the desktop.

I was then able to successfully move back to the testing branch and make this update.

I have got some missing icons on notification dropdowns (both for third party apps and system), but other than that it's working really well.

image

What about broadcom-wl on linux56? The kernel version is 5.6.1 and I still can't use Wi-Fi :slightly_frowning_face:

python2-keybinder needs pygtk to be installed, and it was not in the repository, so it was installed via AUR.

Yeah, I've already tried that and it worked.

Is the same on the git version: plasma-desktop-git-5.18.80.r7522.g4b2639e58-1 and KInfoCenter only shows 5.18.80
I don't think is an issue tho :slight_smile:

blame broadcom. They need to make their driver compatible with the new kernel.

3 Likes

The needed patch just went in.

1 Like

compiled this today with makepkg -s

i have found no problems so far

uname -a
Linux Horizen 5.4.29-1-MANJARO #1 SMP PREEMPT Wed Apr 1 13:28:47 UTC 2020 x86_64 GNU/Linux

journalctl -p err -b
-- Logs begin at Fri 2019-12-20 16:01:09 CET, end at Thu 2020-04-02 14:14:03 CEST. --
Apr 02 14:12:00 Horizen kernel: audit: kauditd hold queue overflow
Apr 02 14:12:00 Horizen kernel: audit: kauditd hold queue overflow
Apr 02 14:12:00 Horizen kernel: audit: kauditd hold queue overflow

Whats that?!
.
GRUB.cfg
linux /boot/vmlinuz-5.4-x86_64 root=UUID=xxxx....xxxx rw quiet udev.log_priority=3 apparmor=1 security=apparmor audit=1 amd_iommu=on iommu=pt
+++++++++++++++++++++++++++++
(using kernel 5.4 and 4.19)
reinstalled kernel 4.19 --> then problem has gone. Why! How?

Hi
With Kernel 5.6.1 and 5.6.2 my soundcard isn't working correctly anymore (did still work with 5.6.0).
Journald shows the following error multiple times:
kernel: snd_ice1724 0000:04:00.0: control 2:0:0:Analog Capture Source:0: access overflow
There is still sound coming out, but I have to raise the volume from previously 25% (Plasma Volume Applet) to around 80% to get the same volume.
Also when i try to select the hardware-card in alsamixer, it crashes.
The kernel changelog shows no direct changes to the ice1724 driver - did you change something at compile time @philm ?

Hi.
No usb tethering and no android file transfer through usb with kernel 5.6

$ journalctl -b1 -p3 |grep "usb"
mars 05 02:13:58 steph-Tour kernel: usb 4-2: device descriptor read/all, error -62
mars 05 03:46:40 steph-Tour kernel: usb usb1-port5: disabled by hub (EMI?), re-enabling...

Works fine with kernel 5.4.

Forum kindly sponsored by