[Testing Update] 2020-04-05 - Pamac 9.4.1, x265, Foomatic-DB, Calamares-Git, Haskell, Python

Hello community,

here is another Testing Update for you:


i3 image for the PinebookPro has just been updated to 20.04, providing our global mirror-update OOTB and fixing the terminal lag of the previous release.

Some feature-updates:

  • Pamac 9.4 got it's first point-release
  • x265 rebuilds of several packages
  • foomatic-db got updated
  • Calamares-git got some updates
  • The usual upstream updates including Haskell and Python

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 19.0.2 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.82
  • linux44 4.4.218
  • linux49 4.9.218
  • linux414 4.14.175
  • linux419 4.19.114
  • linux54 5.4.30
  • linux55 5.5.15
  • linux56 5.6.2
  • linux419-rt 4.19.106_rt45
  • linux54-rt 5.4.28_rt19

Package Changes (Sun Apr 5 22:39:01 CEST 2020)

  • testing community x86_64: 140 new and 135 removed package(s)
  • testing core x86_64: 3 new and 3 removed package(s)
  • testing extra x86_64: 54 new and 53 removed package(s)
  • testing multilib x86_64: 2 new and 2 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-04-04           2020-04-05
-------------------------------------------------------------------------------
                     ledger-live-bin             1.20.0-1              2.1.0-1
         manjaro-gnome-settings-19.0           20200331-1           20200404-2
                    rebuild-detector              4.1.2-1              4.1.3-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-04-04           2020-04-05
-------------------------------------------------------------------------------
                             aws-cli            1.18.26-1            1.18.36-1
                       brightnessctl              0.5.1-1              0.5.1-2
                       budgie-extras             0.10.1-2              1.0.0-1
                             buildah             1.14.5-1             1.14.6-1
                          cloud-init               19.3-1               19.3-2
                              conmon           1:2.0.14-1           1:2.0.15-1
                             cryptol             2.8.0-96             2.8.0-97
                             dua-cli              2.3.9-2              2.5.0-1
                           duplicity             0.8.11-1             0.8.12-1
                                eric              20.03-1              20.04-1
                         eric-common              20.03-1              20.04-1
                           fatresize              1.0.4-4              1.1.0-1
                              faudio              20.03-1              20.04-1
                              fcitx5     0.0.0.20200403-1     0.0.0.20200405-1
                        fcitx5-anthy     0.0.0.20200403-1     0.0.0.20200404-1
               fcitx5-chinese-addons     0.0.0.20200403-1     0.0.0.20200404-1
                           fcitx5-qt     0.0.0.20200403-1     0.0.0.20200404-1
                       fcitx5-unikey     0.0.0.20200325-1     0.0.0.20200404-1
                                fish              3.1.0-2              3.1.0-3
                                 fzf           0.21.0.1-1             0.21.1-1
                                gala 3.2.0.r73.c49189b8-1              3.3.0-1
                           git-annex         8.20200330-5         8.20200330-6
                              glider              0.9.2-2              0.9.3-1
                    gnuradio-osmosdr              0.2.0-2              0.2.0-3
                  haskell-aeson-diff           1.1.0.8-86           1.1.0.8-87
               haskell-binary-tagged               0.2-53               0.2-54
                        haskell-dbus             1.2.12-5             1.2.13-1
               haskell-dbus-hslogger           0.1.0.1-22           0.1.0.1-23
                  haskell-fdo-notify            0.3.1-275            0.3.1-276
                haskell-generics-sop            0.5.0.0-5            0.5.1.0-1
           haskell-ghc-lib-parser-ex            8.8.5.8-3            8.8.6.0-1
                     haskell-githash           0.1.3.3-90            0.1.4.0-1
                      haskell-hakyll          4.13.2.0-43          4.13.2.0-45
                       haskell-ipynb              0.1-168              0.1-169
             haskell-optparse-simple          0.1.1.2-167          0.1.1.2-168
                         haskell-sbv               8.6-57               8.6-58
             haskell-servant-swagger             1.1.8-23             1.1.8-24
                 haskell-skylighting           0.8.3.2-55            0.8.3.4-1
            haskell-skylighting-core           0.8.3.2-55            0.8.3.4-1
                       haskell-store             0.7.2-24              0.7.4-1
                    haskell-swagger2                2.5-8                2.5-9
                haskell-th-utilities           0.2.3.1-22            0.2.4.0-1
                          helm-synth              0.9.0-8              0.9.0-9
                               hlint            2.2.11-38            2.2.11-39
                                 k9s             0.18.1-1             0.19.1-1
                              kanshi              1.0.0-2              1.1.0-1
                               khard             0.15.1-1             0.16.0-1
                        languagetool                4.8-1                4.9-1
                 libretro-beetle-psx               2277-1               2280-1
              libretro-beetle-psx-hw               2277-1               2280-1
                      libretro-bsnes             1:1196-1             1:1198-1
                    libretro-flycast               4114-1               4122-1
               libretro-parallel-n64               5143-1               5145-1
                       libretro-play               5549-1               5552-1
                     libretro-ppsspp              26779-1              26808-1
              libretro-shaders-slang                725-1                729-1
                             libvirt             5.10.0-2             5.10.0-3
                           limesuite            20.01.0-2            20.01.0-3
                            lollypop             1.2.32-1             1.2.33-1
                         lsp-plugins             1.1.15-1             1.1.17-1
                                mame              0.219-1              0.220-1
                          metasploit             5.0.81-1             5.0.83-1
                              mopidy              3.0.1-2              3.0.2-1
                              murmur              1.3.0-6              1.3.0-7
                              neovim              0.4.3-2              0.4.3-3
                                 nim              1.0.6-1              1.2.0-1
                              pandoc            2.9.2.1-8           2.9.2.1-10
                     pandoc-citeproc              0.17-67              0.17-69
                     pandoc-crossref           0.3.6.2-64           0.3.6.2-66
                 pantheon-calculator              1.5.4-1              1.5.5-1
                   pantheon-calendar              5.0.3-2              5.0.4-1
                      pantheon-files              4.4.1-1              4.4.2-1
           pantheon-shortcut-overlay              1.1.0-1              1.1.1-1
                 perl-ppix-quotelike              0.010-1              0.011-1
                            pgadmin4               4.19-1               4.20-1
                                pocl                1.4-3                1.5-1
                           postgrest            6.0.2-119              7.0.0-1
                           pulseview              0.4.1-4              0.4.2-1
                  python-aiobotocore             0.12.0-1              1.0.1-1
                        python-boto3            1.12.26-1            1.12.36-1
                     python-botocore            1.15.26-1            1.15.36-1
                      python-cytoolz             0.10.1-2             0.10.1-3
                        python-flask              1.1.1-3              1.1.2-1
                    python-fonttools              4.6.0-2              4.7.0-1
                 python-graphql-core              2.3.1-1              3.1.0-1
                        python-i3ipc              2.1.1-2              2.2.1-1
                       python-pg8000             1.14.1-1             1.15.1-1
                       python-sphinx              2.4.4-1              3.0.0-1
                     python-werkzeug              1.0.0-2              1.0.1-1
                     python-zeroconf             0.24.5-1             0.25.0-1
                       python2-flask              1.1.1-3              1.1.2-1
                    python2-werkzeug              1.0.0-2              1.0.1-1
                      radare2-cutter           1:1.10.2-2           1:1.10.2-3
              rapid-photo-downloader             0.9.20-1             0.9.20-2
                              raylib              2.6.0-1              3.0.0-1
                              remind              3.3.0-1              3.3.1-1
                             remmina            1:1.4.1-1            1:1.4.1-2
                            rsibreak            0.12.12-1            0.12.13-1
                            rx_tools              1.0.3-3              1.0.3-4
                          shellcheck            0.7.0-213            0.7.0-215
                         soapyairspy              0.1.2-1              0.1.2-2
                          soapyaudio              0.1.1-1              0.1.1-2
                        soapybladerf              0.4.1-2              0.4.1-3
                         soapyhackrf              0.3.3-1              0.3.3-2
                         soapynetsdr              0.1.0-1              0.2.0-1
                           soapyosmo              0.2.5-5              0.2.5-6
                       soapyplutosdr              0.2.0-2              0.2.0-3
                         soapyremote              0.5.0-1              0.5.1-1
                         soapyrtlsdr              0.3.0-1              0.3.0-2
                            soapysdr              0.7.1-4              0.7.2-1
                            soapyuhd              0.3.4-7              0.3.6-1
                              srslte              19.12-1              19.12-2
                         srslte-avx2              19.12-1              19.12-2
                               stack    2.1.3.20200310-43    2.1.3.20200310-44
           switchboard-plug-datetime              2.1.6-1              2.1.7-1
           switchboard-plug-printers              2.1.7-1              2.1.8-1
              switchboard-plug-sound              2.2.2-1              2.2.3-1
                          teamspeak3              3.5.1-1              3.5.2-1
                   teamspeak3-server             3.12.0-1             3.12.1-1
                  ukui-power-manager              2.0.1-1              2.0.2-1
         v2ray-domain-list-community       202004012315-1       202004041314-1
                               vault              1.3.3-1              1.3.4-1
                        vim-nerdtree              6.4.4-1              6.4.5-1
                      weechat-matrix              0.1.0-2              0.2.0-1
           wingpanel-indicator-power              2.1.4-1              2.1.5-1
           wingpanel-indicator-sound              2.1.4-1              2.1.5-1
                           wordpress              5.3.2-1                5.4-1
                              xmobar              0.33-29              0.33-30
                                xpra              3.0.7-1              3.0.7-2
                                 yad                5.0-1                6.0-1
             zsh-theme-powerlevel10k              1.4.0-2              1.4.0-3
              zsh-theme-powerlevel9k              0.6.7-2              0.6.7-3
                             cargo-c                    -              0.6.2-1
               fcitx5-material-color                    -     0.0.0.20200405-1
                      fuse-overlayfs                    -              0.7.8-2
                                helm                    -              3.1.2-3
               python-sphinx-autoapi                    -              1.2.1-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-04-04           2020-04-05
-------------------------------------------------------------------------------
                               bison              3.5.3-1              3.5.4-1
                            iproute2              5.5.0-1              5.6.0-1
                            libnftnl              1.1.5-1              1.1.6-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-04-04           2020-04-05
-------------------------------------------------------------------------------
               calamares-git 3.2.22.r7605.76f29dcdd-1 3.2.22.r7624.e3816fa13-1
                           pamac-cli              9.4.0-7              9.4.1-1
                       pamac-cli-dev              9.4.0-7              9.4.1-1
                        pamac-common              9.4.0-7              9.4.1-1
                    pamac-common-dev              9.4.0-7              9.4.1-1
                pamac-flatpak-plugin              9.4.0-7              9.4.1-1
            pamac-flatpak-plugin-dev              9.4.0-7              9.4.1-1
         pamac-gnome-integration-dev              9.4.0-7              9.4.1-1
                           pamac-gtk              9.4.0-7              9.4.1-1
                       pamac-gtk-dev              9.4.0-7              9.4.1-1
                   pamac-snap-plugin              9.4.0-7              9.4.1-1
               pamac-snap-plugin-dev              9.4.0-7              9.4.1-1
             pamac-tray-appindicator              9.4.0-7              9.4.1-1
         pamac-tray-appindicator-dev              9.4.0-7              9.4.1-1
                 linux56-ndiswrapper                    -               1.62-3


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-04-04           2020-04-05
-------------------------------------------------------------------------------
                        avidemux-cli              2.7.4-3              2.7.4-4
                         avidemux-qt              2.7.4-3              2.7.4-4
                            cbindgen             0.13.2-1             0.14.0-1
                             digikam              6.4.0-7              6.4.0-8
                                 ell               0.28-1               0.30-1
                              falkon              3.1.0-9             3.1.0-10
                              ffmpeg            1:4.2.2-4            1:4.2.2-5
                         foomatic-db         3:20200220-1         3:20200404-1
                 foomatic-db-nonfree         3:20200220-1         3:20200404-1
            foomatic-db-nonfree-ppds         3:20200220-1         3:20200404-1
                    foomatic-db-ppds         3:20200220-1         3:20200404-1
               gobject-introspection             1.64.0-1             1.64.1-1
       gobject-introspection-runtime             1.64.0-1             1.64.1-1
                     gst-plugins-bad             1.16.2-5             1.16.2-6
                gst-plugins-bad-libs             1.16.2-5             1.16.2-6
               gtk-update-icon-cache     1:3.24.17-2 1:3.24.17+4+g8c97702a07-2
                                gtk3     1:3.24.17-2 1:3.24.17+4+g8c97702a07-2
                                gvim           8.2.0343-1           8.2.0510-1
                               hwloc              2.1.0-2              2.2.0-1
                         imagemagick           7.0.10.3-1           7.0.10.4-1
                     imagemagick-doc           7.0.10.3-1           7.0.10.4-1
                             libheif              1.6.2-1              1.6.2-2
                          libmagick6           6.9.11.3-1           6.9.11.4-1
                              libwps             0.4.10-1             0.4.11-1
                              maxima             5.43.2-2             5.43.2-3
                           mercurial              5.3.1-1              5.3.2-1
                      mkvtoolnix-cli             44.0.0-1             45.0.0-1
                      mkvtoolnix-gui             44.0.0-1             45.0.0-1
                            nftables            1:0.9.3-1            1:0.9.4-1
                        python-pyqt5             5.14.1-2             5.14.2-1
                          python-xdg               0.26-4                    -
                       python2-pyqt5             5.14.1-2             5.14.2-1
                         python2-xdg               0.26-4                    -
                                sbcl              2.0.1-1              2.0.3-1
                                 vim           8.2.0343-1           8.2.0510-1
                         vim-runtime           8.2.0343-1           8.2.0510-1
                                 vlc             3.0.8-11             3.0.8-12
                                x265              3.2.1-1                3.3-1
                xfce4-clipman-plugin              1.6.0-1              1.6.1-1
                        python-pyxdg                    -               0.26-6
                       python2-pyxdg                    -               0.26-6


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-04-04           2020-04-05
-------------------------------------------------------------------------------
                        lib32-faudio              20.03-1              20.04-1
                          lib32-gtk3            3.24.16-1            3.24.17-1


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

8 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Older issues

HP Device Manager


Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:
https://gitlab.manjaro.org/applications/pamac/issues/757

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.


Weird font glitches (see screenshots below).

If you have weird glitches like below...

Screenshots

Screenshot%20from%202020-01-16%2023-59-49
string3
strings%20mismatch
post%20transaction%20hooks

... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.


Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in

/usr/lib/python3.7/site-packages/

To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.


System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.


xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.


Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.


Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

i got a conflict with fmpeg-compat-57
but fixed it by removing it

update
[sudo] password for zany130:
:: Synchronizing package databases...
 chaotic-aur is up to date
 mesa-git is up to date
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
warning: glibc: ignoring package upgrade (2.30-3 => 2.31-2)
warning: lib32-glibc: ignoring package upgrade (2.30-3 => 2.31-2)
:: Replace python-xdg with extra/python-pyxdg? [Y/n] y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing x265 (3.3-1) breaks dependency 'libx265.so=179-64' required by ffmpeg-compat-57
Error installing repo packages
1 Like

13 posts were split to a new topic: What to do when AUR package blocks an update

You likely installed fmpeg-compat-57 as a optional dependency to play local music files on spotify however it was build based on an older version of libx265.so.

To update you need to uninstall it first, update x265 (and everything else) then rebuild fmpeg-compat-57 (clean build) so that it uses the newer libx265.so.

3 Likes

gtk3 fixed the initialization of surfaces, Wofi and Waybar now works as expected.
Proceed

so uninstalling kernel 5.5 after 5.6 is not possible

linux55
linux55-r8168
linux55-nvidia-435xx

Starting
checking dependencies...
:: removing linux55 breaks dependency 'linux55' required by linux-latest
:: removing linux55-nvidia-435xx breaks dependency 'linux55-nvidia-435xx' required by linux-latest-nvidia-435xx
:: removing linux55-r8168 breaks dependency 'linux55-r8168' required by linux-latest-r8168


Hecho.

We did not update the Linux latest packages. Either remove them or wait until we updated them.

The latest version of gnome-terminal (3.36.1.1-1) sometimes crashes when I use xdotool (3.20160805.1-2) to manipulate terminal windows. Problem is worse with the 5.6.2 kernel. Also depends on whether other programs are running. Perhaps it's a timing- or memory-related issue. I filed a bug report upstream here.

seems Kernel 5.6.2 doesnot like systemd245....
Timing or memory-related issue seems likely.

x265 breaks dependencies
For example, this is the output of mpv:
mpv: error while loading shared libraries: libx265.so.179: cannot open shared object file: No such file or directory
The library is unexistent. Linking lib265.so to lib265.so.179 doesn't work either:
mpv: symbol lookup error: /usr/lib/libavcodec.so.58: undefined symbol: x265_api_get_179

Cannot reproduce. mpv open just fine here. Where did your mpv come from?

version 1:0.32.0-2, from Manjaro stable-testing repos.

What provides your /usr/lib/libavcodec.so.58?

$ pacman -Qo /usr/lib/libavcodec.so.58
/usr/lib/libavcodec.so.58 is owned by ffmpeg 1:4.2.2-5
ffmpeg-full-git 4.3.r97081.gddbd77da90-1

Problem solved, I just updated it. Thanks

Lots of icons in indicator become Prohibition signs
2020-04-08 00-08-56 的螢幕擷圖 2020-04-08 00-08-58 的螢幕擷圖 2020-04-08 00-09-03 的螢幕擷圖

I noticed that as well, not sure what's causing it.

Try another theme guys, something more fast to response to upstream changes, like Materia-git or Yaru-git.

I'm using the Adwaita-maia-dark theme with Papirus-Dark-Maia icons on GNOME. I've tried the default Adwaita theme / icons, Qogir, Matcha & Vimix.

is linux latest = kernel 5.6?

also I want to remove kernel 5.5 but it doesnt allow me, I need the hard drive space

Forum kindly sponsored by