[Testing Update] 2020-04-07 - KDE-Git, Nvidia 440.82, Firefox 75.0, Haskell, Python

Hello community,

here is another Testing Update for you:


We are working on a new 11" UltraBook ...

Some feature-updates:

  • We added Gnome-Integration to Pamac
  • KDE-git packages got updated
  • Nvidia got updated to 440.82
  • Firefox got renewed to 75.0
  • The usual upstream updates including Haskell and Python

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our current 19.0.2 ISOs and give us the needed feedback. You might also want to give our latest spin with NX-Desktop a try ...

As always we appreciate your input and feedback for the updates.


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.82
  • linux44 4.4.218
  • linux49 4.9.218
  • linux414 4.14.175
  • linux419 4.19.114
  • linux54 5.4.30
  • linux55 5.5.15
  • linux56 5.6.2
  • linux419-rt 4.19.106_rt45
  • linux54-rt 5.4.28_rt19

Package Changes (Tue Apr 7 18:58:38 CEST 2020)

  • testing community x86_64: 264 new and 260 removed package(s)
  • testing core x86_64: 2 new and 2 removed package(s)
  • testing extra x86_64: 159 new and 157 removed package(s)
  • testing multilib x86_64: 8 new and 8 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-04-05           2020-04-07
-------------------------------------------------------------------------------
                          attica-git5.69.0.r748.gd2e5e5b-15.69.0.r749.gc7fdfb7-1
                           baloo-git5.69.0.r2742.g74c17af6-15.69.0.r2749.gd4494ee4-1
                        bluez-qt-git5.69.0.r589.g09ae2c2-15.69.0.r590.gd84fee7-1
                          breeze-git5.18.80.r1977.g885c7783-15.18.80.r1979.ga1e1a53f-1
                    breeze-icons-git5.69.0.r1530.g4cdcd11c-15.69.0.r1538.gb8b972a5-1
             extra-cmake-modules-git5.69.0.r3143.g6136a97-15.69.0.r3144.g907d46e-1
            frameworkintegration-git5.69.0.r513.g5db6722-15.69.0.r514.g6d7f83e-1
                     kactivities-git5.69.0.r1281.g63be46e5-15.69.0.r1282.g998ae955-1
               kactivities-stats-git5.69.0.r275.g21445ba-15.69.0.r276.g710eb44-1
                        karchive-git5.69.0.r416.g0474bae-15.69.0.r417.gfa78327-1
                           kauth-git5.69.0.r350.g420c607-15.69.0.r351.g4903e94-1
                      kbookmarks-git5.69.0.r325.gd49b079-15.69.0.r326.g8f5ef69-1
                        kcmutils-git5.69.0.r379.gfc639ac-15.69.0.r381.gd16f10e-1
                         kcodecs-git5.69.0.r301.g2536577-15.69.0.r302.g66e4d1c-1
                     kcompletion-git5.69.0.r355.ga636f5f-15.69.0.r356.gd903a98-1
                         kconfig-git5.69.0.r678.g066c2bd-15.69.0.r679.g0d113fb-1
                  kconfigwidgets-git5.69.0.r450.gb8d79ca-15.69.0.r451.gfe8a5de-1
                     kcoreaddons-git5.69.0.r964.g0ee6512-15.69.0.r965.g13ecffa-1
                          kcrash-git5.69.0.r298.g4297a0a-15.69.0.r299.g29c23f2-1
                     kdbusaddons-git5.69.0.r304.g7f8d778-15.69.0.r305.gfc4b9b7-1
                    kdeclarative-git5.69.0.r761.gcb18820-15.69.0.r762.ga09398e-1
                            kded-git5.69.0.r305.ge72c85b-15.69.0.r306.gfb9fd81-1
                 kdelibs4support-git5.69.0.r928.gfc7fa518-15.69.0.r929.g1e8ce683-1
                kdeplasma-addons-git5.18.80.r8327.gdaf8142d5-15.18.80.r8328.g02c3233d8-1
                 kdesignerplugin-git5.69.0.r275.g5494006-15.69.0.r276.g86892eb-1
                           kdesu-git5.69.0.r392.g6c56e93-15.69.0.r393.g9e8b424-1
                       kdewebkit-git5.69.0.r225.g0f0b4bf-15.69.0.r226.gb9c6c29-1
                          kdnssd-git5.69.0.r252.gca62329-15.69.0.r253.g24f4fa5-1
                       kdoctools-git5.69.0.r534.gc2e0be3-15.69.0.r535.gc975990-1
                      kemoticons-git5.69.0.r313.gcf9cfe8-15.69.0.r314.g0791ec5-1
                   kfilemetadata-git5.69.0.r686.g78b95b2-15.69.0.r687.g0b64697-1
                    kglobalaccel-git5.69.0.r354.gc14934d-15.69.0.r355.g2e5f278-1
                      kguiaddons-git5.69.0.r271.gb764f9c-15.69.0.r272.gd4d0d3b-1
                       kholidays-git5.69.0.r851.g3e51a0d-15.69.0.r852.g44a33a9-1
                        khotkeys-git5.18.80.r1984.g8b502fe-15.18.80.r1986.g0000a8a-1
                           khtml-git5.69.0.r491.gba10e1e-15.69.0.r492.g6d94b42-1
                           ki18n-git5.69.0.r389.g1097127-15.69.0.r390.g8c97058-1
                     kiconthemes-git5.69.0.r417.gd9cb221-15.69.0.r418.g931cd93-1
                       kidletime-git5.69.0.r244.gabb8f91-15.69.0.r245.gee6b119-1
                   kimageformats-git5.57.0.r266.g551e7d4-15.57.0.r267.gf089e86-1
                           kinit-git5.69.0.r338.g0cccf02-15.69.0.r339.g965fd09-1
                             kio-git5.69.0.r3873.ga624e074-15.69.0.r3884.gd025ed9b-1
                       kirigami2-git5.69.0.r2135.g1d777eef-15.69.0.r2139.g4c7780ea-1
                     kitemmodels-git5.69.0.r421.g8696ae5-15.69.0.r422.gbe17828-1
                      kitemviews-git5.69.0.r264.ge0f581e-15.69.0.r265.g9a19456-1
                     kjobwidgets-git5.69.0.r289.g2f14890-15.69.0.r290.g6959d16-1
                             kjs-git5.69.0.r277.gec8003d-15.69.0.r278.g0b565a9-1
                        kjsembed-git5.69.0.r239.g97aa443-15.69.0.r240.g9985484-1
                    kmediaplayer-git5.69.0.r233.geee919f-15.69.0.r234.g61eb03f-1
                      knetattach-git5.18.80.r7528.gd7213a192-15.18.80.r7532.g1f0cf38db-1
                       knewstuff-git5.69.0.r796.gd63e8bf4-15.69.0.r802.g37452d02-1
                  knotifications-git5.69.0.r518.g3dafde9-15.69.0.r519.g420344f-1
                   knotifyconfig-git5.69.0.r277.g8e0f19f-15.69.0.r278.ge693e20-1
                        kpackage-git5.69.0.r570.g3bd2dab-15.69.0.r571.gebe8855-1
                          kparts-git5.69.0.r392.gc56b490-15.69.0.r394.gd0b5675-1
                         kpeople-git5.69.0.r1248.gaea6d71-15.69.0.r1249.g3a9c80b-1
                       kplotting-git5.69.0.r228.g7d2d543-15.69.0.r229.g0660c6b-1
                            kpty-git5.69.0.r252.g705decf-15.69.0.r253.g107800d-1
                           kross-git5.69.0.r275.ge79889c-15.69.0.r276.g5931dda-1
                        kservice-git5.69.0.r754.gce83ae5-15.69.0.r757.g0ba6476-1
                    ktextwidgets-git5.69.0.r305.ga9f219c-15.69.0.r307.gd7ec040-1
                 kunitconversion-git5.69.0.r300.gb7bab9d-15.69.0.r301.g3f0bbf2-1
                         kwallet-git5.69.0.r952.g1a22e6b-15.69.0.r953.gbc9713e-1
                        kwayland-git5.69.0.r990.gff9cadf-15.69.0.r1000.g51870cb-2
                  kwidgetsaddons-git5.69.0.r647.g8262488-15.69.0.r649.g0c94871-1
                            kwin-git5.18.80.r17827.gbb04ab390-15.18.80.r17866.g6dc938907-2
                   kwindowsystem-git5.69.0.r506.gd3bc79d-15.69.0.r507.ge94116d-1
                         kxmlgui-git5.69.0.r610.g9404efe-15.69.0.r612.g8968101-1
                   kxmlrpcclient-git5.69.0.r389.g9bb8a54ad-15.69.0.r390.ga14270903-1
                    matcha-gtk-theme           20200330-1           20200403-1
                 modemmanager-qt-git5.69.0.r452.g4ad1209-15.69.0.r453.gadc7f1b-1
               networkmanager-qt-git5.69.0.r1041.gdcf88d7-15.69.0.r1042.gf5fa7ae-1
                    oxygen-icons-git5.69.0.r221.g90bab0d-15.69.0.r222.gc0471f0-1
                oxygen-icons-svg-git5.69.0.r221.g90bab0d-15.69.0.r222.gc0471f0-1
      plasma-browser-integration-git5.18.80.r1021.g928f320d-15.18.80.r1023.gb26ddbe9-1
                  plasma-desktop-git5.18.80.r7528.gd7213a192-15.18.80.r7532.g1f0cf38db-1
                plasma-framework-git5.69.0.r15397.g26eb57c53-15.69.0.r15407.gd6f3a52d8-1
                       plasma-nm-git5.18.80.r2841.gd72ff6e1-15.18.80.r2842.g285b5593-1
          plasma-wayland-session-git5.18.80.r8864.g6dc04ef0a-15.18.80.r8871.g96ad51cde-1
                plasma-workspace-git5.18.80.r8864.g6dc04ef0a-15.18.80.r8871.g96ad51cde-1
                          prison-git5.69.0.r250.ge0dec83-15.69.0.r251.ge06242c-1
                         purpose-git5.69.0.r750.g00e456f-15.69.0.r751.g0b07034-1
              qqc2-desktop-style-git5.69.0.r346.gd2f44e4-15.69.0.r347.gb25d915-1
                           solid-git5.69.0.r551.ge468daf-15.69.0.r552.g2ce25d2-1
                          sonnet-git5.69.0.r524.g2ce07be-15.69.0.r525.ga359393-1
                     syndication-git5.69.0.r760.g1cd8312-15.69.0.r761.g3697545-1
             syntax-highlighting-git5.69.0.r1100.g213d4bb-15.69.0.r1101.gdd7ac18-1
                    threadweaver-git5.69.0.r438.g5274821-15.69.0.r439.g9bf422c-1
                      gnome-firmware                    - 3.34.0+36+g4147a76-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-04-05           2020-04-07
-------------------------------------------------------------------------------
                                agda             2.6.1-20             2.6.1-21
                auto-multiple-choice              1.4.0-6              1.4.0-7
                            autopep8              1:1.5-1            1:1.5.1-1
                             aws-cli            1.18.36-1            1.18.37-1
                                axel             2.17.7-1             2.17.8-1
                           bandwhich             0.12.0-1             0.13.0-1
                       cabal-install           3.0.0.0-72           3.0.0.0-73
                               cacti             1.2.10-1             1.2.11-1
                          cargo-edit              0.5.0-2              0.6.0-1
                             chezmoi             1.7.18-1             1.7.19-1
                             cockpit                216-1                216-3
                   cockpit-dashboard                216-1                216-3
                         cockpit-pcp                216-1                216-3
                         coin-or-cbc             2.10.5-2             2.10.5-3
                                croc              8.0.2-1              8.0.5-1
                                cuda            10.2.89-3            10.2.89-5
                               darcs           2.14.2-207           2.14.2-208
                             dbeaver              7.0.1-1              7.0.2-1
                               dhall             1.31.1-2             1.31.1-3
                          dhall-bash             1.0.29-6             1.0.29-7
                          dhall-json              1.6.3-6              1.6.3-7
                          diffoscope                138-1                139-1
                      dnscrypt-proxy             2.0.42-1             2.0.42-2
                              drupal              8.8.4-1              8.8.5-1
                           dvdauthor              0.7.2-7              0.7.2-8
                           dvdbackup              0.4.2-5              0.4.2-6
                            earlyoom                1.5-1                1.5-2
                            electron              8.2.0-3              8.2.1-1
               firefox-ublock-origin             1.25.2-1             1.26.0-1
               freepats-general-midi           20200216-1           20200405-1
                    gimp-plugin-gmic              2.9.0-1              2.9.0-2
                           git-annex         8.20200330-6         8.20200330-7
                          git-repair        1.20200102-63        1.20200102-64
                                gmic              2.9.0-1              2.9.0-2
                             haproxy              2.1.3-1              2.1.4-1
                haskell-authenticate             1.3.5-94             1.3.5-95
          haskell-authenticate-oauth           1.6.0.1-73           1.6.0.1-74
                         haskell-aws              0.22-26              0.22-27
                 haskell-casa-client             0.0.1-15             0.0.1-16
                  haskell-cheapskate           0.1.1.2-63           0.1.1.2-64
                   haskell-criterion           1.5.6.2-28           1.5.6.2-29
                         haskell-dav             1.3.4-75             1.3.4-76
                haskell-generic-data            0.8.2.0-5            0.8.3.0-1
                     haskell-githash            0.1.4.0-1            0.1.4.0-2
            haskell-hackage-security           0.6.0.0-62           0.6.0.0-63
                      haskell-hakyll          4.13.2.0-45          4.13.2.0-46
                    haskell-hopenpgp             2.9.4-54             2.9.4-56
                       haskell-hpack           0.33.0-103           0.33.0-104
                   haskell-hspec-wai            0.10.1-17            0.10.1-18
              haskell-hspec-wai-json            0.10.1-18            0.10.1-19
                        haskell-http        4000.3.14-162        4000.3.14-163
                 haskell-http-client           0.6.4.1-31           0.6.4.1-32
             haskell-http-client-tls          0.3.5.3-214          0.3.5.3-215
                haskell-http-conduit          2.3.7.3-106          2.3.7.3-107
               haskell-http-download           0.2.0.0-30           0.2.0.0-31
                haskell-http-streams           0.8.7.1-77           0.8.7.1-78
                  haskell-httpd-shed           0.4.1.1-91           0.4.1.1-92
                         haskell-hxt          9.3.1.18-56          9.3.1.18-57
                 haskell-ixset-typed                0.5-8                0.5-9
                        haskell-jose           0.8.2.0-75           0.8.2.0-76
                   haskell-js-jquery            3.3.1-401            3.3.1-402
                    haskell-mustache             2.3.1-78             2.3.1-79
                 haskell-network-uri           2.6.3.0-58           2.6.3.0-59
             haskell-optparse-simple          0.1.1.2-168          0.1.1.2-169
                      haskell-pantry           0.4.0.1-21           0.4.0.1-22
                  haskell-pipes-http            1.0.6-126            1.0.6-127
                    haskell-safecopy            0.10.2-34            0.10.2-35
                     haskell-servant              0.17-21              0.17-22
              haskell-servant-server              0.17-22              0.17-23
             haskell-servant-swagger             1.1.8-24             1.1.8-25
                       haskell-shake            0.18.5-66            0.18.5-67
                 haskell-skylighting            0.8.3.4-1            0.8.3.4-2
            haskell-skylighting-core            0.8.3.4-1            0.8.3.4-2
                   haskell-snap-core           1.0.4.1-67           1.0.4.1-68
                 haskell-snap-server          1.1.1.1-184          1.1.1.1-186
                     haskell-texmath          0.12.0.1-47          0.12.0.1-48
                  haskell-uri-encode           1.5.0.5-67           1.5.0.5-68
                       haskell-vault           0.3.1.3-24            0.3.1.4-1
                         haskell-wai           3.2.2.1-47           3.2.2.1-49
              haskell-wai-app-static           3.1.7.1-69           3.1.7.1-70
                 haskell-wai-conduit          3.0.0.4-193          3.0.0.4-194
                    haskell-wai-cors             0.2.7-42             0.2.7-43
                   haskell-wai-extra          3.0.29.1-36          3.0.29.1-37
          haskell-wai-handler-launch           3.0.3.1-37           3.0.3.1-38
                  haskell-wai-logger             2.3.6-65             2.3.6-66
       haskell-wai-middleware-static             0.8.3-27             0.8.3-28
              haskell-wai-websockets          3.0.1.2-132          3.0.1.2-133
                        haskell-warp             3.3.9-21             3.3.9-22
                    haskell-warp-tls            3.2.11-56            3.2.11-57
                        haskell-wreq          0.5.3.2-178          0.5.3.2-179
                haskell-xss-sanitize            0.3.6-104            0.3.6-105
                       haskell-yesod           1.6.0.1-74           1.6.0.1-75
                  haskell-yesod-auth            1.6.10-12            1.6.10-13
                  haskell-yesod-core             1.6.18-5             1.6.18-6
               haskell-yesod-default            1.2.0-715            1.2.0-716
                  haskell-yesod-form            1.6.7-153            1.6.7-154
            haskell-yesod-persistent           1.6.0.4-98           1.6.0.4-99
                haskell-yesod-static          1.6.0.1-355          1.6.0.1-356
                  haskell-yesod-test            1.6.9-114            1.6.9-115
                         hledger-web            1.17.1-17            1.17.1-18
                              hoogle         5.0.17.15-28         5.0.17.15-29
                      hopenpgp-tools            0.23.1-14            0.23.1-16
                               idris            1.3.2-115            1.3.2-116
                         jami-daemon           20190813-3           20190813-4
                          jupyterlab              2.0.1-2              2.1.0-1
                   krita-plugin-gmic              2.9.0-1              2.9.0-2
                         libopenshot              0.2.5-1              0.2.5-2
                            librsync            1:2.2.1-1            1:2.3.0-1
                               lsdvd               0.17-3               0.17-4
                           lttng-ust             2.11.0-3             2.11.1-1
                        matterbridge             1.16.5-2             1.17.1-1
                          monero-gui           0.15.0.4-1           0.15.0.5-1
                                 mpv           1:0.32.0-2           1:0.32.0-3
                             netdata             1.20.0-4             1.21.0-1
                              nomacs             3.14.2-1             3.14.2-2
                          obs-studio             25.0.3-1             25.0.4-1
                            ogmtools                1.5-8                1.5-9
                             opendht           1:1.10.1-4           1:1.10.1-5
                              pandoc           2.9.2.1-10           2.9.2.1-11
                     pandoc-citeproc              0.17-69              0.17-70
                     pandoc-crossref           0.3.6.2-66           0.3.6.2-67
                  papirus-icon-theme           20200301-1           20200405-1
                            paraview              5.8.0-1              5.8.0-2
                               peony              2.1.1-1              2.1.2-1
                          performous               1.1-23               1.1-24
                            polymake             4.0.r1-1             4.0.r1-3
                           postgrest              7.0.0-1              7.0.0-2
                            prettier              2.0.2-1              2.0.4-1
                               pynac             0.7.26-2             0.7.26-3
                  python-aiobotocore              1.0.1-1              1.0.2-1
                python-aiohttp-socks              0.3.6-1              0.3.7-1
                        python-boto3            1.12.36-1            1.12.37-1
                     python-botocore            1.15.36-1            1.15.37-1
                         python-cmd2              1.0.1-1              1.0.2-1
                   python-deprecated              1.2.7-2              1.2.8-1
                         python-dkim              1.0.3-1              1.0.4-1
                 python-jsbeautifier             1.10.3-1             1.11.0-1
                     python-lttngust             2.11.0-3             2.11.1-1
                      python-pytorch              1.4.1-1              1.4.1-2
                 python-pytorch-cuda              1.4.1-1              1.4.1-2
                  python-pytorch-opt              1.4.1-1              1.4.1-2
             python-pytorch-opt-cuda              1.4.1-1              1.4.1-2
               python-sphinx-autoapi              1.2.1-1              1.3.0-1
                    python2-autopep8              1:1.5-1            1:1.5.1-1
                 python2-qpid-proton             0.30.0-1             0.30.0-2
                         qbittorrent              4.2.2-1              4.2.3-1
                     qbittorrent-nox              4.2.2-1              4.2.3-1
                         qpid-proton             0.30.0-1             0.30.0-2
                      rime-cantonese     0.0.0.20200331-2     0.0.0.20200406-1
                            sagemath               9.0-12               9.0-13
                    sagemath-jupyter               9.0-12               9.0-13
                          shellcheck            0.7.0-215            0.7.0-216
                            singular           4.1.2.p5-3              4.1.3-1
                            sonic-pi              3.2.1-2              3.2.2-1
                               stack    2.1.3.20200310-44    2.1.3.20200310-45
                              stella                6.1-1              6.1.1-1
                              sysdig             0.26.6-1             0.26.6-2
                      tamarin-prover            1.4.1-319            1.4.1-320
                             taskell           1.9.2.0-72           1.9.2.0-73
                           transcode             1.1.7-32             1.1.7-33
                             ts-node              8.8.1-1              8.8.2-1
                 ukui-control-center              2.0.2-1              2.0.3-1
                          ukui-media              2.0.2-1              2.0.3-1
                          ukui-panel              2.0.4-1              2.0.5-1
                        ukui-sidebar              1.1.1-1              1.1.2-1
         v2ray-domain-list-community       202004041314-1       202004061300-1
                               vamps            0.99.2-13            0.99.2-14
                                 vtk              8.2.0-9             8.2.0-10
                              waybar              0.9.1-1              0.9.1-3
                              xmobar              0.33-30              0.33-31
                                zart              2.9.0-1              2.9.0-2
                       zita-ajbridge              0.8.2-1              0.8.4-1
                      cockpit-docker                    -                216-3
                    cockpit-machines                    -                216-3
                        libvirt-dbus                    -              1.3.0-2


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-04-05           2020-04-07
-------------------------------------------------------------------------------
                   mhwd-nvidia-440xx             440.64-1             440.82-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-04-05           2020-04-07
-------------------------------------------------------------------------------
                         btrfs-progs              5.4.1-1                5.6-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-04-05           2020-04-07
-------------------------------------------------------------------------------
               calamares-git 3.2.22.r7624.e3816fa13-1 3.2.22.r7648.8b6d605d5-1
               linux316-nvidia-440xx             440.64-1             440.82-1
               linux414-nvidia-440xx             440.64-4             440.82-1
               linux419-nvidia-440xx             440.64-8             440.82-1
                linux44-nvidia-440xx             440.64-5             440.82-1
                linux49-nvidia-440xx             440.64-5             440.82-1
                linux54-nvidia-440xx             440.64-9             440.82-1
                linux55-nvidia-440xx            440.64-11             440.82-1
                linux56-nvidia-440xx             440.64-3             440.82-1
              manjaro-tools-base-git      r2887.dee5a38-1      r2895.3806b31-1
               manjaro-tools-iso-git      r2887.dee5a38-1      r2895.3806b31-1
               manjaro-tools-pkg-git      r2887.dee5a38-1      r2895.3806b31-1
              manjaro-tools-yaml-git      r2887.dee5a38-1      r2895.3806b31-1
                  nvidia-440xx-utils             440.64-1             440.82-1
                 opencl-nvidia-440xx             440.64-1             440.82-1
                           pamac-cli              9.4.1-1              9.4.1-3
                       pamac-cli-dev              9.4.1-1              9.4.1-2
                        pamac-common              9.4.1-1              9.4.1-3
                    pamac-common-dev              9.4.1-1              9.4.1-2
                pamac-flatpak-plugin              9.4.1-1              9.4.1-3
            pamac-flatpak-plugin-dev              9.4.1-1              9.4.1-2
         pamac-gnome-integration-dev              9.4.1-1              9.4.1-2
                           pamac-gtk              9.4.1-1              9.4.1-3
                       pamac-gtk-dev              9.4.1-1              9.4.1-2
                   pamac-snap-plugin              9.4.1-1              9.4.1-3
               pamac-snap-plugin-dev              9.4.1-1              9.4.1-2
             pamac-tray-appindicator              9.4.1-1              9.4.1-3
         pamac-tray-appindicator-dev              9.4.1-1              9.4.1-2
             pamac-gnome-integration                    -              9.4.1-3


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-04-05           2020-04-07
-------------------------------------------------------------------------------
                           audacious             3.10.1-2              4.0.1-1
                   audacious-plugins             3.10.1-4              4.0.1-1
                            cbindgen             0.14.0-1             0.14.0-2
                               cmake             3.17.0-1             3.17.0-2
                             digikam              6.4.0-8              6.4.0-9
                             firefox             74.0.1-1               75.0-1
                    firefox-i18n-ach             74.0.1-1               75.0-1
                     firefox-i18n-af             74.0.1-1               75.0-1
                     firefox-i18n-an             74.0.1-1               75.0-1
                     firefox-i18n-ar             74.0.1-1               75.0-1
                    firefox-i18n-ast             74.0.1-1               75.0-1
                     firefox-i18n-az             74.0.1-1               75.0-1
                     firefox-i18n-be             74.0.1-1               75.0-1
                     firefox-i18n-bg             74.0.1-1               75.0-1
                     firefox-i18n-bn             74.0.1-1               75.0-1
                     firefox-i18n-br             74.0.1-1               75.0-1
                     firefox-i18n-bs             74.0.1-1               75.0-1
                     firefox-i18n-ca             74.0.1-1               75.0-1
            firefox-i18n-ca-valencia             74.0.1-1               75.0-1
                    firefox-i18n-cak             74.0.1-1               75.0-1
                     firefox-i18n-cs             74.0.1-1               75.0-1
                     firefox-i18n-cy             74.0.1-1               75.0-1
                     firefox-i18n-da             74.0.1-1               75.0-1
                     firefox-i18n-de             74.0.1-1               75.0-1
                    firefox-i18n-dsb             74.0.1-1               75.0-1
                     firefox-i18n-el             74.0.1-1               75.0-1
                  firefox-i18n-en-ca             74.0.1-1               75.0-1
                  firefox-i18n-en-gb             74.0.1-1               75.0-1
                  firefox-i18n-en-us             74.0.1-1               75.0-1
                     firefox-i18n-eo             74.0.1-1               75.0-1
                  firefox-i18n-es-ar             74.0.1-1               75.0-1
                  firefox-i18n-es-cl             74.0.1-1               75.0-1
                  firefox-i18n-es-es             74.0.1-1               75.0-1
                  firefox-i18n-es-mx             74.0.1-1               75.0-1
                     firefox-i18n-et             74.0.1-1               75.0-1
                     firefox-i18n-eu             74.0.1-1               75.0-1
                     firefox-i18n-fa             74.0.1-1               75.0-1
                     firefox-i18n-ff             74.0.1-1               75.0-1
                     firefox-i18n-fi             74.0.1-1               75.0-1
                     firefox-i18n-fr             74.0.1-1               75.0-1
                  firefox-i18n-fy-nl             74.0.1-1               75.0-1
                  firefox-i18n-ga-ie             74.0.1-1               75.0-1
                     firefox-i18n-gd             74.0.1-1               75.0-1
                     firefox-i18n-gl             74.0.1-1               75.0-1
                     firefox-i18n-gn             74.0.1-1               75.0-1
                  firefox-i18n-gu-in             74.0.1-1               75.0-1
                     firefox-i18n-he             74.0.1-1               75.0-1
                  firefox-i18n-hi-in             74.0.1-1               75.0-1
                     firefox-i18n-hr             74.0.1-1               75.0-1
                    firefox-i18n-hsb             74.0.1-1               75.0-1
                     firefox-i18n-hu             74.0.1-1               75.0-1
                  firefox-i18n-hy-am             74.0.1-1               75.0-1
                     firefox-i18n-ia             74.0.1-1               75.0-1
                     firefox-i18n-id             74.0.1-1               75.0-1
                     firefox-i18n-is             74.0.1-1               75.0-1
                     firefox-i18n-it             74.0.1-1               75.0-1
                     firefox-i18n-ja             74.0.1-1               75.0-1
                     firefox-i18n-ka             74.0.1-1               75.0-1
                    firefox-i18n-kab             74.0.1-1               75.0-1
                     firefox-i18n-kk             74.0.1-1               75.0-1
                     firefox-i18n-km             74.0.1-1               75.0-1
                     firefox-i18n-kn             74.0.1-1               75.0-1
                     firefox-i18n-ko             74.0.1-1               75.0-1
                    firefox-i18n-lij             74.0.1-1               75.0-1
                     firefox-i18n-lt             74.0.1-1               75.0-1
                     firefox-i18n-lv             74.0.1-1               75.0-1
                     firefox-i18n-mk             74.0.1-1               75.0-1
                     firefox-i18n-mr             74.0.1-1               75.0-1
                     firefox-i18n-ms             74.0.1-1               75.0-1
                     firefox-i18n-my             74.0.1-1               75.0-1
                  firefox-i18n-nb-no             74.0.1-1               75.0-1
                  firefox-i18n-ne-np             74.0.1-1               75.0-1
                     firefox-i18n-nl             74.0.1-1               75.0-1
                  firefox-i18n-nn-no             74.0.1-1               75.0-1
                     firefox-i18n-oc             74.0.1-1               75.0-1
                  firefox-i18n-pa-in             74.0.1-1               75.0-1
                     firefox-i18n-pl             74.0.1-1               75.0-1
                  firefox-i18n-pt-br             74.0.1-1               75.0-1
                  firefox-i18n-pt-pt             74.0.1-1               75.0-1
                     firefox-i18n-rm             74.0.1-1               75.0-1
                     firefox-i18n-ro             74.0.1-1               75.0-1
                     firefox-i18n-ru             74.0.1-1               75.0-1
                     firefox-i18n-si             74.0.1-1               75.0-1
                     firefox-i18n-sk             74.0.1-1               75.0-1
                     firefox-i18n-sl             74.0.1-1               75.0-1
                    firefox-i18n-son             74.0.1-1               75.0-1
                     firefox-i18n-sq             74.0.1-1               75.0-1
                     firefox-i18n-sr             74.0.1-1               75.0-1
                  firefox-i18n-sv-se             74.0.1-1               75.0-1
                     firefox-i18n-ta             74.0.1-1               75.0-1
                     firefox-i18n-te             74.0.1-1               75.0-1
                     firefox-i18n-th             74.0.1-1               75.0-1
                     firefox-i18n-tl             74.0.1-1               75.0-1
                     firefox-i18n-tr             74.0.1-1               75.0-1
                    firefox-i18n-trs             74.0.1-1               75.0-1
                     firefox-i18n-uk             74.0.1-1               75.0-1
                     firefox-i18n-ur             74.0.1-1               75.0-1
                     firefox-i18n-uz             74.0.1-1               75.0-1
                     firefox-i18n-vi             74.0.1-1               75.0-1
                     firefox-i18n-xh             74.0.1-1               75.0-1
                  firefox-i18n-zh-cn             74.0.1-1               75.0-1
                  firefox-i18n-zh-tw             74.0.1-1               75.0-1
                          fluidsynth              2.1.1-1              2.1.2-1
                  gnome-disk-utility             3.36.1-1             3.36.1-2
                       gnome-weather             3.34.1-1             3.36.0-1
                     gst-plugins-bad             1.16.2-6             1.16.2-7
                gst-plugins-bad-libs             1.16.2-6             1.16.2-7
                    gst-plugins-ugly             1.16.2-2             1.16.2-3
    gtk-update-icon-cache 1:3.24.17+4+g8c97702a07-2 1:3.24.17+18+gcdd4349bfe-1
                     gtk3 1:3.24.17+4+g8c97702a07-2 1:3.24.17+18+gcdd4349bfe-1
                         imagemagick           7.0.10.4-1           7.0.10.6-1
                     imagemagick-doc           7.0.10.4-1           7.0.10.6-1
                             jsoncpp              1.9.1-1              1.9.2-1
                         jsoncpp-doc              1.9.1-1              1.9.2-1
                                 k3b          1:19.12.3-1          1:19.12.3-2
                           libdvdnav              6.1.0-1              6.1.0-2
                          libdvdread              6.1.0-1              6.1.1-1
                        libinstpatch              1.1.3-1              1.1.4-1
                            mencoder              38157-1              38157-2
                                 mlt             6.20.0-2             6.20.0-3
                             mplayer              38157-1              38157-2
                              opencv              4.2.0-2              4.3.0-1
                      opencv-samples              4.2.0-2              4.3.0-1
                    python-pyparsing              2.4.6-1              2.4.7-1
                   python2-pyparsing              2.4.6-1              2.4.7-1
                               rtkit               0.12-1               0.13-1
                                vala             0.48.2-1             0.48.3-1
                                 vlc             3.0.8-12             3.0.8-13
                            xine-lib             1.2.10-2             1.2.10-3
                               rav1e                    -              0.3.1-4


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-04-05           2020-04-07
-------------------------------------------------------------------------------
            lib32-nvidia-440xx-utils             440.64-1             440.82-1
           lib32-opencl-nvidia-440xx             440.64-1             440.82-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-04-05           2020-04-07
-------------------------------------------------------------------------------
                    lib32-fluidsynth              2.1.1-1              2.1.2-1
                          lib32-jack            0.125.0-2            0.125.0-3
                         lib32-jack2             1.9.14-1             1.9.14-2
                  lib32-libinstpatch              1.1.3-1              1.1.4-1
                 lib32-libsamplerate              0.1.9-2              0.1.9-3
                     lib32-portaudio    190600_20161030-2           1:19.6.0-4

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

7 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Older issues

HP Device Manager


Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:
https://gitlab.manjaro.org/applications/pamac/issues/757

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.


Weird font glitches (see screenshots below).

If you have weird glitches like below...

Screenshots

Screenshot%20from%202020-01-16%2023-59-49
string3
strings%20mismatch
post%20transaction%20hooks

... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.


Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in

/usr/lib/python3.7/site-packages/

To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.


System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.


xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.


Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.


Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

I just attempted to install today's updates and no matter how I attempt to do them I get the below.

error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-440xx-utils (440.82-1) breaks dependency 'nvidia-utils=440.64' required by linux54-rt-nvidia-440

I've attempted with the below and not works.

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu
sudo pacman-mirrors -f && sudo pacman -Syyu

And using Pamac itself.

you have to update that as well.

it should of been offered like they always are. Is there a way to do it manually first, then the rest of the updates? Thanks

seems so, or try with pacman -S

It's been a long time since I had a problem after an update - but now it's my turn.
Since this update polybar don't start anymore under i3 for me. When I try to start it manually I get the following error message

polybar: error while loading shared libraries: libjsoncpp.so.21: cannot open shared object file: No such file or directory

jsoncpp is installed. The stranged thing is, as far as I can see none of the involved packages got updated under the last two rounds.

has to be rebuilt. Install from AUR, problem gone :stuck_out_tongue:

1 Like

You are 100% right.

OK all updates in except the below 4.

nVidia

It is simple. Realtime kernel extramodules for Nvidia are not updated yet. @oberon

I missed that. Pushed now.

2 Likes

The latest KDE -git packages have fixed my previous problem:

Only me who got this problem after update on gnome https://github.com/qbittorrent/qBittorrent/issues/12441, https://github.com/qbittorrent/qBittorrent/pull/12273 and I solved it by downgrading it to qbittorrent 4.2.2.

It looks fine on GNOME. :man_shrugging:

this is how my problem looks on gnome

issue with polybar

polybar: error while loading shared libraries: libjsoncpp.so.XX: cannot open shared object file: No such file or directory

I had to build polybar from source by myself

Thanks for the Nvidia driver update. No more fake warnings in journal log.

These updates work fine, as does chromium-81.0.4044.92-1 from unstable, sourced as a standalone manual download from the Unstable repository mirror in Austria.

I noticed the Qt transition on audacious. Not my cup of tea atm. "Use software volume control" is enabled regardless if that checkbox is ticked or not (which is good bug -- every other media player acts like that) but the volume control seems jittery to me on the ported "winamp-like" skins. (I was a very hardcore winamp user back in the day.) Also, the "global hotkey" plugin seems to have disappeared entirely. This is a big deal-breaker to me because I use control keys all the time while gaming and my keyboard doesn't exactly have "media keys" to control items like volume, tracks (next, previous), etc. I'll probably downgrade for now as the issue seems to have been known for some time...or else I'll use the depreciated gtk version.

inxi -A (device 3 default)
Audio:
  Device-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel 
  Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel 
  Device-3: GYROCOM C&C DigiHug USB Audio type: USB 
  driver: hid-generic,snd-usb-audio,usbhid 
  Sound Server: ALSA v: k5.6.2-1-MANJARO

Forum kindly sponsored by