[Testing Update] 2020-04-18 - Kernels, Systemd v245.5, Browsers, VirtualBox, LibreOffice. KDE-Frameworks

Hello community,

After a long week of development we fast-tracked all packages to testing branch. With this, we have some interesting updates for you!


With the Tuxedo Control Center you get the most out of your InfinityBook

  • Most of our kernels got updated. Realtime-Kernel 4.19 got removed. You get upgraded to 5.4 series automatically
  • systemd got updated to 245.5
  • KDE-git packages got partly renewed
  • The universal package manager bauh got updated to 0.9.0
  • Some Webbrowsers got renewed
  • VirtualBox is now at 6.1.6
  • KDE Frameworks got updated to 5.69.0
  • LibreOffice is now at 6.4.3
  • Some fixes for php got added with 7.4.5

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our second release-candidate of Manjaro Lysia 20.0! XFCE, KDE and Gnome


Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.82
  • linux44 4.4.218
  • linux49 4.9.218
  • linux414 4.14.175
  • linux419 4.19.114
  • linux54 5.4.31
  • linux55 5.5.16
  • linux56 5.6.3
  • linux57 5.7-rc0
  • linux419-rt 4.19.106_rt45
  • linux54-rt 5.4.28_rt19

Package Changes (Sat Apr 18 14:18:39 CEST 2020)

  • testing community x86_64: 1025 new and 999 removed package(s)
  • testing core x86_64: 38 new and 38 removed package(s)
  • testing extra x86_64: 538 new and 535 removed package(s)
  • testing multilib x86_64: 18 new and 18 removed package(s)

A detailed list of all package updates can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

8 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

Older issues

HP Device Manager


Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:
https://gitlab.manjaro.org/applications/pamac/issues/757

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.


Weird font glitches (see screenshots below).

If you have weird glitches like below...

Screenshots

Screenshot%20from%202020-01-16%2023-59-49
string3
strings%20mismatch
post%20transaction%20hooks

... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.


Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in

/usr/lib/python3.7/site-packages/

To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.


System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.


xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.


Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.


Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


gnome-shell-extension-desktop-icons

the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

1 Like

Thanks for this one.. no problem with thunderbird here.

Summary

[manjaro@manjaro-pc ~]$ inxi -Fxxxz
System:
Host: manjaro-pc Kernel: 5.6.5-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: KDE Plasma 5.18.4 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM
Distro: Manjaro Linux
Machine:
Type: Laptop System: Dell product: Inspiron 5459 v: N/A serial: Chassis:
type: 9 serial:
Mobo: Dell model: 0TNRDT v: A00 serial: UEFI [Legacy]: Dell v: 1.2.5
date: 10/06/2016
Battery:
ID-1: BAT0 charge: 28.8 Wh condition: 28.8/41.4 Wh (70%) volts: 16.8/14.8
model: Panasonic DELL 78V9D6A type: Li-ion serial: status: Full
CPU:
Topology: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP
arch: Skylake rev: 3 L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19204
Speed: 700 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 687 2: 694 3: 698
4: 684
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:1916
Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting
alternate: fbdev,vesa compositor: kwin_x11 tty: N/A
OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.0.4
direct render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel
v: kernel bus ID: 00:1f.3 chip ID: 8086:9d70
Sound Server: ALSA v: k5.6.5-1-MANJARO
Network:
Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel port: f040
bus ID: 01:00.0 chip ID: 8086:08b3
IF: wlp1s0 state: up mac:
Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169
v: kernel port: e000 bus ID: 02:00.0 chip ID: 10ec:8136
IF: enp2s0 state: down mac:
Drives:
Local Storage: total: 447.13 GiB used: 211.88 GiB (47.4%)
ID-1: /dev/sda vendor: SanDisk model: Ultra II 480GB size: 447.13 GiB
speed: 6.0 Gb/s serial: rev: 20RL scheme: GPT
Partition:
ID-1: / size: 438.62 GiB used: 211.88 GiB (48.3%) fs: ext4 dev: /dev/sda2
Sensors:
System Temperatures: cpu: 50.0 C mobo: 38.0 C sodimm: 37.0 C
Fan Speeds (RPM): cpu: 0
Info:
Processes: 201 Uptime: 1h 17m Memory: 3.55 GiB used: 1.40 GiB (39.3%)
Init: systemd v: 245 Compilers: gcc: 9.3.0 clang: 9.0.1 Shell: bash v: 5.0.16
running in: konsole inxi: 3.0.37

not sure if you saw the shutdown hang report: [Testing Update] 2020-04-10 - Thunderbird 68.7.0, OnlyOffice 5.5, Gnome, GTK

3 Likes

No issues with thunderbird. In fact, I was finally able to update thunderbird-appmenu-bin from AUR because the newest version needed new libs which came with this update.

So far all is working nicely.
My usual test after bigger update is to switch to different GPU mode with optimus-manager and launch Steam to see if everything works as intended. In the past some updates did break it, but those were on unstable branch and issues were usually trivial (like: 32-lib came later).

Actually, this updated finally fixed the pamac update icon on Plasma! Now one-click and update is checking, just as it was in the past! I believe that knotify.conf update was the fix.

2 Likes

this bug is not affecting my system so far.. rechecked twice, it dooesn't hang out at rebooting or shutting down.

Getting this hang on shutdown now, also.
Yelling "Don't leave me hanging, kernel!" at my machine had no effect. Thinking @BS86's provided patch may be a better bet.

All else is the usual Manjaro coolness.

1 Like

I use Budgie edition.

The Alt+Tab behavior has changed. It has got a preview of window which is not problem but it is unable to switch between applications and shows only one of them (which one is started first and the other programs are ignored). I was able to fix this by (re)setting the Shortcut for Switch Window to Alt+Tab before. However this solution is ineffective this time and the faulty switcher with preview remains. I have set the Switch Window Shortcut to Super+Tab instead of Alt+Tab and this way I can use the previous switcher.

Also I have to terminate "previews_creator" because of high CPU usage.

Using pamac-manager, it suggests 96 packages to upgrade, but the entire upgrade never succeeds.
The upgrade of nss poses a problem because of existing files.

Error messages are:

..
nss: /usr/lib/p11-kit-trust.so existiert bereits im Dateisystem
lib32-nss: /usr/lib32/p11-kit-trust.so existiert bereits im Dateisystem

2 Likes

Thanks, that does the trick.
However it looks like one cannot do the upgrade using pamac-manager then.

Indeed, you have to use the terminal with pacman or pamac.
Right now pamac from GUI does not support the overwrite option, maybe it will be supported in the future, it could be useful if implemented in a sane way.

2 Likes

In that case, you need to use the nuclear option. Threaten it with Soft Cushions, & ultimately, The Comfy Chair, whilst screaming Confess.

3 Likes

i got ==> Fixing file conflicts for 'lib32-nss' update for you ... and lib32-nss installed beforehand, with normal pacman -Syyu. So no manual intervention needed here ^^
Everything else seems ok on first glance (amd/kde/5.6)

1 Like

Manjaro, the Nanny distro. :stuck_out_tongue_winking_eye:

3 Likes

The shutdown/reboot hang occurs on 2 of my machines as well.

journalctl -p err -b - output =
gdm-password][1212]: gkr-pam: unable to locate daemon control file

has gone after restarting (once is enough) with this selection in GRUB-menu:
menuentry 'Manjaro Linux (Kernel: 5.4.33-1-MANJARO x64 - fallback initramfs

Are you guys talking about first shutdown after update or a permanent occurrence? Sure, I had a shutdown delay after the update, but this is nothing unusual after kernel updates. Later on, all works normally, no shutdown delays.

guys, please READ before posting. The bug affects only systems using amdgpu. From your profiles, you don't have affected systems ...

4 Likes

Hi,

do you think that the Manjaro 20.0 (codename : Lysia) final version will be release the next week ?

Thanks.

Forum kindly sponsored by