[Testing Update] 2020-04-18 - Kernels, Systemd v245.5, Browsers, VirtualBox, LibreOffice. KDE-Frameworks

could this be a problem?

Warning: p11-kit wird vor seiner Abhängigkeit systemd installiert werden

Vorbereitung...
Synchronisiere Paketdatenbanken...
Abhängigkeiten werden aufgelöst...
Interne Konflikte werden überprüft...
Warnung: Abhängigkeits-Zyklus entdeckt:
Warnung: p11-kit wird vor seiner Abhängigkeit systemd installiert werden

EDIT: Yes, normally it is not a problem but when systemd is highlighted, i am sensitive (;

No. Those warnings pretty self-explanatory (and common). As long as the update finishes completely all will be fine.

I cannot update because of

In Konflikt stehende Dateien:
nss: /usr/lib/p11-kit-trust.so existiert bereits im Dateisystem
lib32-nss: /usr/lib32/p11-kit-trust.so existiert bereits im Dateisystem

grafik

Please do a little more reading/research, that one was covered multiple times:

1 Like

Would seriously doubt it since we haven't even got testing versions yet.

Hey all you amdgpu users, @jonathon has compiled kernels with AMD's patch for your rebooting/shutdown pleasure.

4 Likes

On KDE Plasma, the telegram-desktop icon has reverted to the old blue one instead of the monochrome breeze one that was introduced recently.

Pretty sure it depends on what theme you're using. I'm using Amore global theme and mine is the blue with the white paper plane on it.

Same thing on my machine since the previous Unstable update. Miraculously disappeared with the last one.

Had a strange regression on 5.6.5 kernel related to EC:

Kernel log
[    0.408629] ACPI: EC: GPE=0xa
[    0.408629] ACPI: \_SB_.PCI0.LPCB.EC0_: Boot ECDT EC initialization complete
[    0.408629] ACPI: \_SB_.PCI0.LPCB.EC0_: EC: Used to handle transactions and events
[    0.408629] ACPI: EC: EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.408629] ACPI: EC: GPE=0xa
[    0.408629] ACPI: \_SB_.PCI0.LPCB.EC0_: Boot ECDT EC initialization complete
[    0.408629] ACPI: \_SB_.PCI0.LPCB.EC0_: EC: Used to handle transactions and events
[    0.408629] ------------[ cut here ]------------
[    0.408629] Could not request EC data io port 0x62
[    0.408629] WARNING: CPU: 1 PID: 1 at drivers/acpi/ec.c:1677 acpi_ec_add.cold+0xcf/0x105
[    0.408629] Modules linked in:
[    0.408629] CPU: 1 PID: 1 Comm: swapper/0 Not tainted 5.6.5-1-MANJARO #1
[    0.408629] Hardware name: ASUSTeK COMPUTER INC. X555LN/X555LN, BIOS X555LN.313 04/19/2019
[    0.408629] RIP: 0010:acpi_ec_add.cold+0xcf/0x105
[    0.408629] Code: 74 2c 45 84 ed 74 09 48 8b 7d 00 e8 a0 8f ff ff 0f 1f 44 00 00 e9 4a fc ff ff 48 8b 75 18 48 c7 c7 40 9c d8 bb e8 f8 98 b1 ff <0f> 0b eb b0 48 8b 75 10 48 c7 c7 68 9c d8 bb e8 e4 98 b1 ff 0f 0b
[    0.408629] RSP: 0000:ffff96eb00047cf8 EFLAGS: 00010282
[    0.408629] RAX: 0000000000000000 RBX: ffff8fd2e5643800 RCX: 0000000000000000
[    0.408629] RDX: 0000000000000001 RSI: ffffffffbc7052c6 RDI: 0000000000000246
[    0.408629] RBP: ffff8fd2e510a100 R08: 00000000185b3052 R09: 0000000000000026
[    0.408629] R10: 000000000000000f R11: ffffffffbc7052c6 R12: 0000000000000000
[    0.408629] R13: 0000000000000000 R14: 0000000000000000 R15: 0000000000000000
[    0.408629] FS:  0000000000000000(0000) GS:ffff8fd2e6e80000(0000) knlGS:0000000000000000
[    0.408629] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    0.408629] CR2: 0000000000000000 CR3: 000000016180a001 CR4: 00000000001606e0
[    0.408629] Call Trace:
[    0.408629]  acpi_device_probe+0x47/0x1d0
[    0.408629]  really_probe+0x147/0x3c0
[    0.408629]  driver_probe_device+0xb6/0x100
[    0.408629]  ? driver_allows_async_probing+0x50/0x50
[    0.408629]  bus_for_each_drv+0x8f/0xd0
[    0.408629]  __device_attach+0xf0/0x170
[    0.408629]  ? acpi_sleep_proc_init+0x24/0x24
[    0.408629]  acpi_bus_register_early_device+0x4a/0x70
[    0.408629]  acpi_ec_init+0x17c/0x1a8
[    0.408629]  acpi_init+0x2d4/0x33a
[    0.408629]  do_one_initcall+0x59/0x240
[    0.408629]  kernel_init_freeable+0x1b2/0x214
[    0.408629]  ? rest_init+0xbf/0xbf
[    0.408629]  kernel_init+0xa/0x101
[    0.408629]  ret_from_fork+0x35/0x40
[    0.408629] ---[ end trace 8b6a700cfed9a9c6 ]---
[    0.408629] ------------[ cut here ]------------
[    0.408629] Could not request EC cmd io port 0x66
[    0.408629] WARNING: CPU: 1 PID: 1 at drivers/acpi/ec.c:1679 acpi_ec_add.cold+0xe3/0x105
[    0.408629] Modules linked in:
[    0.408629] CPU: 1 PID: 1 Comm: swapper/0 Tainted: G        W         5.6.5-1-MANJARO #1
[    0.408629] Hardware name: ASUSTeK COMPUTER INC. X555LN/X555LN, BIOS X555LN.313 04/19/2019
[    0.408629] RIP: 0010:acpi_ec_add.cold+0xe3/0x105
[    0.408629] Code: 00 e9 4a fc ff ff 48 8b 75 18 48 c7 c7 40 9c d8 bb e8 f8 98 b1 ff 0f 0b eb b0 48 8b 75 10 48 c7 c7 68 9c d8 bb e8 e4 98 b1 ff <0f> 0b eb c0 48 8b 75 00 48 c7 c2 7d a0 d8 bb 48 c7 c7 18 ad 14 bc
[    0.408629] RSP: 0000:ffff96eb00047cf8 EFLAGS: 00010282
[    0.408629] RAX: 0000000000000000 RBX: ffff8fd2e5643800 RCX: 0000000000000000
[    0.408629] RDX: 0000000000000001 RSI: ffffffffbc7052c5 RDI: 0000000000000246
[    0.408629] RBP: ffff8fd2e510a100 R08: 00000000185b3052 R09: 0000000000000025
[    0.408629] R10: 000000000000000f R11: ffffffffbc7052c5 R12: 0000000000000000
[    0.408629] R13: 0000000000000000 R14: 0000000000000000 R15: 0000000000000000
[    0.408629] FS:  0000000000000000(0000) GS:ffff8fd2e6e80000(0000) knlGS:0000000000000000
[    0.408629] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    0.408629] CR2: 0000000000000000 CR3: 000000016180a001 CR4: 00000000001606e0
[    0.408629] Call Trace:
[    0.408629]  acpi_device_probe+0x47/0x1d0
[    0.408629]  really_probe+0x147/0x3c0
[    0.408629]  driver_probe_device+0xb6/0x100
[    0.408629]  ? driver_allows_async_probing+0x50/0x50
[    0.408629]  bus_for_each_drv+0x8f/0xd0
[    0.408629]  __device_attach+0xf0/0x170
[    0.408629]  ? acpi_sleep_proc_init+0x24/0x24
[    0.408629]  acpi_bus_register_early_device+0x4a/0x70
[    0.408629]  acpi_ec_init+0x17c/0x1a8
[    0.408629]  acpi_init+0x2d4/0x33a
[    0.408629]  do_one_initcall+0x59/0x240
[    0.408629]  kernel_init_freeable+0x1b2/0x214
[    0.408629]  ? rest_init+0xbf/0xbf
[    0.408629]  kernel_init+0xa/0x101
[    0.408629]  ret_from_fork+0x35/0x40
[    0.408629] ---[ end trace 8b6a700cfed9a9c7 ]---

I'm not the only one, and that's the kernel issue: https://www.spinics.net/lists/kernel/msg3480332.html

But the system still does boot and everything is working (I guess).

I'm using the default breeze which should have a new monochrome icon. Not sure why it's using the icon that telegram-desktop provides.

i can confirm, not sure if i like the monochrome better or the "normal" one xD

@philm The image isn't loading for the topic.

@philm

would you mind pushing us this godly software called Wine version 5.6, as I mentioned last week ? Thank you very much for your coolness and dedication. :innocent:

I'll take the normal.

If you are a Firefox user the setting 'Enhanced Tracking Protection - Strict' blocks pictures hosted on twimage. The images from other hosts are working

1 Like

Ahh, I see. I'm using waterfox-current so there are probably a slew of disabled functions.

Dell Studio 1749 with 4.19.114-1. There was indeed the message with the conflict in pamac but next it went ok, untill next restart.... Eth0 and wifi gone, no idea which package caused it. So I have reverted with timeshift (this tool is fantastic) and perhaps will do update after some time.
BR/Jarek

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by