[Testing Update] 2020-05-01 - Kernels, Mesa 20.0.6, Gnome 3.36.2, Pamac 9.5beta, AMDVLK 20.Q2.2

this works but the icon in menu/settings still missed

ok, then you seem to have another problem as well.
I can see the firewall settings in my (xfce)-settings. - Maybe try rebooting?gufw

Haven't tried yet cause still in the middle of today's updates, but if you have a entry now in the start-panel try rightclicking the start-panel and selecting edit applications and edit GUFW there.

I'm with plasma

already rebooted twice

no chance to load the icon, not available

Plasma here as well. Give me a a few mins to try here.

There's even more missing. I'll try to find and upload from my Manjaro Cinnamon stable and try out and give you the files.
It's only a quick-fix. - The next gufw update will fix it eventually anyway.

OK Got it. Download the .desktop file, rightclick it, select your icon, move or copy it to /usr/share/applications and it will retain it's icon in both the applications folder and on the start-panel.


Should add I downloaded a fresh icon.

If there is more missing you might want to create a seprate thread.

No, it's okay I guess. I have the firewall-settings in xfce-settings manager, as well as my rofi.
I'm not sure anymore if it was in my awesome/xfce-panel /-menu anyway.

Update on Manjaro awesome: Update went fine, no breakages, everything is working, except gufw.desktop still missing, fixed it myself until an updates fixes it permanently (see above).

Todays updates installed, rebooted and so far all seems good. Nice job again.

Everything seems to be working, also getting from login to desktop seems fater on KDE. Thanks for the update.

6 posts were split to a new topic: Using debtap to install gufw

Downgraded to the GUFW version from stable on stable-staging

After locking the screen, I was experiencing graphical corruption in a Plasma Xorg session. I tried to take a screenshot, but it appeared normal. The glitches stopped after I followed the instructions (posted below) from the KDE forum to disable and restart the compositor. I believe it is a regression due to this update because it never happened before.

How to disable and restart the compositor in Plasma Xorg session:

qdbus org.kde.KWin /Compositor suspend
qdbus org.kde.KWin /Compositor resume

EDIT: inxi -Fxxxz

System:    Host: bens-laptop Kernel: 5.6.8-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           Desktop: KDE Plasma 5.18.4 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Laptop 17-by1xxx v: Type1ProductConfigId serial: <filter> 
           Chassis: type: 10 serial: <filter> 
           Mobo: HP model: 8530 v: 17.21 serial: <filter> UEFI: Insyde v: F.53 date: 12/13/2019 
Battery:   ID-1: BAT0 charge: 36.6 Wh condition: 36.6/36.6 Wh (100%) volts: 13.1/11.6 
           model: Hewlett-Packard Primary type: Li-ion serial: <filter> status: Full 
CPU:       Topology: Dual Core model: Intel Core i3-8145U bits: 64 type: MT MCP arch: Kaby Lake rev: C 
           L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 18406 
           Speed: 1909 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 2642 2: 2714 3: 2716 4: 2851 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:3ea0 
           Display: x11 server: X.Org 1.20.8 driver: modesetting alternate: fbdev,intel,vesa 
           compositor: kwin_x11 resolution: 1600x900~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.0.6 direct render: Yes 
Audio:     Device-1: Intel Cannon Point-LP High Definition Audio vendor: Hewlett-Packard 
           driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9dc8 
           Sound Server: ALSA v: k5.6.8-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard 
           driver: r8169 v: kernel port: 4000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: eno1 state: down mac: <filter> 
           Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard 
           driver: rtl8821ce v: N/A port: 3000 bus ID: 03:00.0 chip ID: 10ec:c821 
           IF: wlo1 state: up mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 931.51 GiB used: 275.15 GiB (29.5%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-60Z10T0 size: 931.51 GiB speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: <filter> rev: 1A04 scheme: GPT 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 5060
           bus ID: 00:17.0 chip ID: 8086.282a rev: 30 
Partition: ID-1: / size: 823.24 GiB used: 275.08 GiB (33.4%) fs: btrfs dev: /dev/sda6 
           ID-2: /home size: 823.24 GiB used: 275.08 GiB (33.4%) fs: btrfs dev: /dev/sda6 
           ID-3: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 43.0 C mobo: 0.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 210 Uptime: 1h 52m Memory: 7.67 GiB used: 2.61 GiB (34.0%) Init: systemd v: 245 
           Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 running in: konsole inxi: 3.0.37

I tried this as well, unfortunately, it did not work. For me still the only option is to downgrade the manjaro-kde-settings package.

update went smooth

I don't experience any issues with lockscreen (maybe it's only on intel? ), but to suspend and resume the compositor, you can also use alt+shift+f12 :slight_smile:

1 Like

The corruption first happened on the lock screen, but it continued after unlocking, until I suspended and resumed the compositor.

I just checked the list of updates. The manjaro-kde-settings was not even included in this update

Maybe it was pushed in between? According to the package name "manjaro-kde-settings-20200430-1" it was not pushed with the update from the 29th April. I got it with this update, even if it is not listed as part of it. Package which is working for me is from 20200424.

Try to downgrade it on your machine and you will see if it is the culprit or not.

Forum kindly sponsored by