[Testing Update] 2020-05-10 - KDE-Git, Thunderbird 68.8.0, Pamac 9.5

Hello community,

Another testing branch update with some interesting updates for you!

Redeem your free standard delivery of all Manjaro Merch. Ends today! #stayhome, #staysave, #stayhealthy

  • KDE-git packages got updated
  • Thunderbird is at 68.8.0
  • Pamac 9.5 got its released. Find out more
  • The usual upstream updates

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latst release candidates of Manjaro Lysia 20.0.1! XFCE, KDE and Gnome

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux316 3.16.83
  • linux44 4.4.222
  • linux49 4.9.222
  • linux414 4.14.179
  • linux419 4.19.121
  • linux54 5.4.39
  • linux55 5.5.19 EOL
  • linux56 5.6.11
  • linux57 5.7-rc4
  • linux54-rt 5.4.28_rt19
  • linux56-rt 5.6.10_rt5

Package Changes (Sun May 10 10:41:45 CEST 2020)

  • testing community x86_64: 96 new and 92 removed package(s)
  • testing extra x86_64: 32 new and 32 removed package(s)
:: Different overlay package(s) in repository community x86_64

                             PACKAGE           2020-05-09           2020-05-10
                            libcpuid 0.4.1.r35.g9d22c61-1 0.4.1.r50.g21e4b1f-1
              linux56-rt-ndiswrapper               1.62-3               1.63-1
                    matcha-gtk-theme           20200505-1           20200509-1
              linux54-rt-ndiswrapper                    -               1.63-1
                      qgnomeplatform                    -   0.6.0+8+gd4277c9-1

:: Different sync package(s) in repository community x86_64

                             PACKAGE           2020-05-09           2020-05-10
               aarch64-linux-gnu-gcc              9.3.0-1             10.1.0-1
                               acorn            1:7.1.1-1            1:7.2.0-1
                          aliyun-cli             3.0.37-2             3.0.42-1
                                anki             2.1.23-1             2.1.26-1
                        ansible-lint              4.2.0-1              4.2.0-3
                         baidupcs-go              3.6.2-1              3.6.2-2
                                croc              8.0.9-1             8.0.10-1
                      dns-over-https              2.2.1-2              2.2.1-3
                                dune              2.5.0-1              2.5.1-1
                              erlang             22.2.7-1               22.3-1
                         erlang-docs               22.2-1               22.3-1
                          erlang-nox             22.2.7-1               22.3-1
                     erlang-unixodbc             22.2.7-1               22.3-1
                                fish              3.1.1-1              3.1.2-1
               freepats-general-midi           20200405-1           20200508-1
                              glider             0.10.0-1             0.10.0-2
                           gocryptfs              1.7.1-2              1.8.0-1
                               gsoap            2.8.101-1            2.8.102-1
                                helm              3.2.0-1              3.2.1-1
                             libvips              8.9.1-1              8.9.2-1
                             liteide               36.3-2               37.1-1
                         lua51-bitop              1.0.2-8              1.0.2-9
                         lua52-bitop              1.0.2-8              1.0.2-9
                                 lxd              4.0.1-1                4.1-1
                   massif-visualizer              0.7.0-2              0.7.0-3
                      matrix-synapse             1.11.0-1             1.12.4-1
                                mcqd              1.0.0-1              1.0.0-2
                          metasploit             5.0.86-1             5.0.88-1
                             mimetic              0.9.8-1              0.9.8-2
             nextcloud-app-bookmarks            1:3.0.0-1            1:3.0.4-1
                  nextcloud-app-mail              1.3.3-1              1.3.4-1
                 nextcloud-app-notes              3.2.0-1              3.3.0-1
                                opam              2.0.6-2              2.0.7-1
                           pam_mount               2.16-4               2.16-5
                               pbpst              1.4.1-1              1.4.1-2
                                  pd             0.50.2-2             0.50.2-3
              perl-scalar-list-utils               1.54-1               1.55-1
                                po4a               0.57-1               0.58-1
                            powertop               2.11-1               2.12-1
                       python-bleach              3.1.3-1              3.1.5-1
                       python-pyglet              1.5.4-2              1.5.5-1
                python-pytest-pylint             0.15.1-1             0.16.0-1
                       python-yaspin             0.16.0-1             0.17.0-1
                                qmmp              1.3.7-1              1.4.0-1
                            qrupdate              1.1.2-3              1.1.2-4
                               qvkbd        git20170102-1        git20170102-2
              rapid-photo-downloader             0.9.23-1             0.9.24-1
                              rclone             1.51.0-3             1.51.0-4
                             ripgrep             12.0.1-1             12.1.0-1
              sage-data-polytopes_db           20170220-1           20170220-2
                                  sd              0.7.4-1              0.7.5-1
                           syncthing              1.4.2-1              1.5.0-1
                  syncthing-relaysrv              1.4.2-1              1.5.0-1
                    telegram-desktop              2.1.3-1              2.1.4-1
                             tellico              3.2.3-1                3.3-1
                          testssl.sh              3.0.1-1              3.0.2-1
                               tilda              1.5.1-1              1.5.2-1
                               v2ray             4.23.1-1             4.23.1-2
         v2ray-domain-list-community       202005061230-1       202005092152-1
                        vim-nerdtree              6.6.0-1              6.6.1-1
                              global                    -              6.6.4-1
                         staticcheck                    -           2020.1.3-1

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE           2020-05-09           2020-05-10
                linux316-ndiswrapper              1.62-17               1.63-1
                linux414-ndiswrapper              1.62-46               1.63-1
                linux419-ndiswrapper              1.62-60               1.63-1
                 linux44-ndiswrapper              1.62-35               1.63-1
                 linux49-ndiswrapper              1.62-37               1.63-1
                 linux54-ndiswrapper              1.62-45               1.63-1
                 linux55-ndiswrapper              1.62-23               1.63-1
                 linux56-ndiswrapper              1.62-15               1.63-1
                 linux57-ndiswrapper             1.62-0.7             1.63-0.1
                           pamac-cli            9.5.0rc-1              9.5.0-1
                       pamac-cli-dev            9.5.0rc-1              9.5.0-1
                        pamac-common            9.5.0rc-1              9.5.0-1
                    pamac-common-dev            9.5.0rc-1              9.5.0-1
                pamac-flatpak-plugin            9.5.0rc-1              9.5.0-1
            pamac-flatpak-plugin-dev            9.5.0rc-1              9.5.0-1
             pamac-gnome-integration            9.5.0rc-1              9.5.0-1
         pamac-gnome-integration-dev            9.5.0rc-1              9.5.0-1
                           pamac-gtk            9.5.0rc-1              9.5.0-1
                       pamac-gtk-dev            9.5.0rc-1              9.5.0-1
                   pamac-snap-plugin            9.5.0rc-1              9.5.0-1
               pamac-snap-plugin-dev            9.5.0rc-1              9.5.0-1
             pamac-tray-appindicator            9.5.0rc-1              9.5.0-1
         pamac-tray-appindicator-dev            9.5.0rc-1              9.5.0-1

:: Different sync package(s) in repository extra x86_64

                             PACKAGE           2020-05-09           2020-05-10
                          libmm-glib             1.12.8-1            1.12.10-1
                              libqmi            1.24.10-1            1.24.12-1
                        modemmanager             1.12.8-1            1.12.10-1
                         thunderbird             68.7.0-2             68.8.0-1
                        wxgtk-common              3.0.5-1  
                              wxgtk2              3.0.5-1  
                              wxgtk3              3.0.5-1       
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

1 Like

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Gnome-shell-extension-pop-shell is currently incompatible with wayland

... and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Older issues

Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

HP Device Manager

Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in


To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

I don't know in which update this issue arose, because I hadn't used the program for about 2 weeks.
When I start mediathekview I get the following error-message

Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.UnsupportedClassVersionError: mediathek/Main has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:757)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:468)
at java.net.URLClassLoader.access$100(URLClassLoader.java:74)
at java.net.URLClassLoader$1.run(URLClassLoader.java:369)
at java.net.URLClassLoader$1.run(URLClassLoader.java:363)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:362)
at java.lang.ClassLoader.loadClass(ClassLoader.java:419)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:352)
at java.lang.ClassLoader.loadClass(ClassLoader.java:352)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:495)

Maybe a simple rebuild of the package is solving this.

Check which java you're currently using:

$ archlinux-java status

mediathek requires java-runtime>=11.

1 Like

Available Java environments:
java-8-openjdk (default)

You need to switch to newer version for mediathekview to work:

$ archlinux-java set java-11-openjdk
1 Like

Thank you very much! :ok_hand:
Now I only wonder, why I had to do this manually.

You probably installed Java 8 before 11, so 8 was always the default. :wink:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by