[Testing Update] 2020-05-21 - Kernels, Toolchain, Mesa, KDE Apps, Cinnamon, Browser

Hello community,

Another testing branch update with some interesting updates for you!

PreOrder our new AMD-Laptop! Philip talks a little about this Laptop at LUP #stayhome, #staysave, #stayhealthy

  • All our Kernels got renewed or rebuilt against the new GCC10
  • KDE-git packages got updated
  • KDE Apps are now at 20.04.1
  • Mesa got another point-release
  • Cinnamon got updated to 4.6.0
  • Regular updates to some of our Browsers
  • The usual upstream updates and massrebuilds by Arch

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest release Manjaro Lysia 20.0.1! XFCE, KDE and Gnome

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux44 4.4.224
  • linux49 4.9.224
  • linux414 4.14.181
  • linux419 4.19.124
  • linux54 5.4.42
  • linux56 5.6.14
  • linux57 5.7-rc6
  • linux54-rt 5.4.39_rt23
  • linux56-rt 5.6.10_rt5

Package Changes (Thu May 21 08:41:56 CEST 2020)

  • testing community x86_64: 1382 new and 1480 removed package(s)
  • testing core x86_64: 40 new and 43 removed package(s)
  • testing extra x86_64: 1548 new and 1610 removed package(s)
  • testing multilib x86_64: 19 new and 19 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Gnome-shell-extension-pop-shell is currently incompatible with wayland

... and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Older issues

Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

HP Device Manager

Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in


To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

still present the icons missing bug in kinfocenter. everything else seems ok

@notageek can you link me to that bug?

Is it https://bugs.kde.org/show_bug.cgi?id=421830 (or a duplicate of that one)?

It seems the issue is not present in KDE Plasma git version, but also the layout is different.


I still don't get it. What exactly is missing?

i guess the missing entries (haven't updated today yet, though)

Yes, the missing entries.... When expanding the arrow the sub-tree is displayed, but not the branch icon.

I'm an idiot, but not as big of an idiot as I could have been.

I applied the mostly empty /etc/shadow.pacnew and that (obviously) prevented me logging in after rebooting, so I couldn't even fix it with the copy I made beforehand (less of an idiot).

Long story short: found out it's possible to write bootable usb-sticks from some android phones, and I fixed it from the live environment.

Cleanup of the Manjaro repos "demoted" xdg-su to the AUR (explanation on Unstable thread)

$ pacman -Qm       
xdg-su 1.2.3-1

And new orphans:

$ pacman -Qdt            
lib32-libdbusmenu-gtk2 16.04.0-4
lib32-libindicator-gtk2 12.10.1-8

I was able to remove them (sudo pacman -Rsn and re-boot) without any immediate breakage.

Launch from terminal it would complain at relevant .so files

Is this what you mean?

$ kinfocenter
Couldn't load plugin "kcms/kcm_about_distro" : "The shared library was not found."  -- falling back to old-style loading from desktop file

Everything went fine on my KDE box just some missing entries on kinfocenter but i don't really care tbh @philm


Arch Wiki wrote:

Warning: Arch Linux defaults of the files are created as .pacnew files by new releases of the filesystem package. Unless Pacman outputs related messages for action, these .pacnew files can, and should, be disregarded/removed. New required default users and groups are added or re-added as needed by systemd-sysusers(8) or the package install script.


sorry for late, I'm not always on pc...

$ kinfocenter
Couldn't load plugin "kcms/kcm_about_distro" : "La libreria dinamica non è stata trovata."  -- falling back to old-style loading from desktop file

same as pointed out @mparillo

still present also after today update in unstable

Latest optimus-manager deprecated the set-startup argument so I had to create a new optimus-manager.conf at /etc/optimus-manager/ to set the startup_mode key.

Ditto, but I would like to have the missing Icons back in Info Center. Side note 522 updates and after reboot the icons in Info Center seem to be the only issue.

1 Like

With 472 packages, this was quite a big update. But after reboot everything seems to work as expected. :+1:

Forum kindly sponsored by