[Testing Update] 2020-05-26 - Browser, LibreOffice, Cinnamon, Deepin, Haskell, OpenJDK

Hello community,

Another testing branch update with some interesting updates for you!

We are happy to present our 1.1 kg light-weight 14" laptop by Tuxedo. Find out more! First Video-Review here. #stayhome, #staysafe, #stayhealthy

  • KDE-git packages got updated
  • More updates to Cinnamon and Deepin
  • openjdk got updated to 11 series
  • LibreOffice is now at 6.4.4
  • Regular Haskell, Python and Browser updates
  • The usual upstream updates and massrebuilds by Arch

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest release Manjaro Lysia 20.0.1! XFCE, KDE and Gnome

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux44 4.4.224
  • linux49 4.9.224
  • linux414 4.14.181
  • linux419 4.19.124
  • linux54 5.4.42
  • linux56 5.6.14
  • linux57 5.7-rc7
  • linux54-rt 5.4.39_rt23
  • linux56-rt 5.6.10_rt5

Package Changes (Tue May 26 19:19:08 CEST 2020)

  • testing community x86_64: 1063 new and 1059 removed package(s)
  • testing core x86_64: 35 new and 33 removed package(s)
  • testing extra x86_64: 216 new and 218 removed package(s)
  • testing multilib x86_64: 24 new and 24 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Gnome-shell-extension-pop-shell is currently incompatible with wayland

... and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Older issues

Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

HP Device Manager

Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in


To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

1 Like

Please do this from now on instead of embedding the list in the post. It causes Google Chrome on my OnePlus 7 Pro to freeze while loading it.

...the culprit is usually resource-intensive websites



My OneplusOne with LineageOS has no problem with that either on Firefox or Chrome. Good old tech :wink:

Chrome on my Android sometimes freezes also when viewing a long list of updates embedded in the announcement.

Everything went smoothly. Thanks for another huge update :slight_smile:

Mozilla-common was orphaned?

$ pacman -Qdt
mozilla-common 1.4-6

I did not remember removing firefox, but since I do not have it now, I must have removed it months ago. Longer than my history, I guess:

$ history | grep firefox
  503  history | grep firefox

Firefox no longer uses mozilla-common. The only programs that depend on it are bluegriffon and seamonkey.

1 Like

...and tor-browser too..

the fraction scaling version - works.
But artifacts at every second or third reboot before entering desktop (Gnome).

$ pacman -Qdt
khotkeys 5.18.5-1
mozilla-common 1.4-6
sndio 20180120-1

should i remove them?

Might want to mark this as explicitly installed - it's needed for some hotkey definition:

1 Like

So I updated in a tty and I noticed I got an error with something about PAM user account control after that error I noticed I could no longer athenticate sudo commands so I thought my system just needed a reboot so I rebooted and now the system can't authenticate my user account.

Exact error messages are important, try to copy it next time.

Yeah I'm restoring from a timeshift backup and then I'll do the update again and log it to a file

Ok NVM I just restored and did the update again and this time it worked. I think it might be be because I used pacui the first time around. I know there are controversies around it so I guess this was a false alarm and can be ignored

Why not just use pamac or pacman?

It looks like mozilla-common is required by Thunderbird in my setup.

Are you sure?

$ pacman -Qi thunderbird
Name            : thunderbird
Version         : 68.8.1-1
Depends On      : gtk3  libxt  startup-notification  mime-types  dbus-glib  alsa-lib  nss  hunspell  sqlite  ttf-font  icu
Optional Deps   : libcanberra: sound support [installed]

German language is broken in xfce. Menu entries, apps, settings all english. locale.conf and locale.gen looks fine.

Edit: A timeshift restore, new update and a reboot fixed it.

Forum kindly sponsored by