[Testing Update] 2020-06-16 - Kernel, Browser, KDE, Cinnamon, Deepin, Haskell, Mesa, Virtualbox

Hello community,

Another testing branch update with some interesting updates for you!

3 days left to gain 15% discount on our #Merch! Check it out now #stayhome, #staysafe, #stayhealthy

  • Most of the Kernels got updated
  • Some Cinnamon and Deepin updates
  • KDE Frameworks and Plasma5 for git-releases got updated
  • Plasma5 got updated to 5.19.1
  • KDE Frameworks is now at 5.71.0
  • KDE Apps got renewed to 20.04.1
  • Wine is renewed to 5.10
  • Brave browser has new versions in standard and beta
  • Virtualbox is now at 6.1.10
  • Mesa got updated to 20.1.1
  • PHP is now at 7.4.7
  • The usual upstream updates including Haskell and Python by Arch

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest release Manjaro Lysia 20.0.3! XFCE, KDE and Gnome

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux44 4.4.227
  • linux49 4.9.227
  • linux414 4.14.184
  • linux419 4.19.128
  • linux54 5.4.46
  • linux56 5.6.18
  • linux57 5.7.2
  • linux54-rt 5.4.44_rt27
  • linux56-rt 5.6.17_rt9

Package Changes (Tue Jun 16 19:29:31 CEST 2020)

  • testing community x86_64: 1258 new and 1233 removed package(s)
  • testing core x86_64: 35 new and 33 removed package(s)
  • testing extra x86_64: 666 new and 653 removed package(s)
  • testing multilib x86_64: 20 new and 19 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Gnome-shell-extension-pop-shell is currently incompatible with wayland

... and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Older issues

Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

HP Device Manager

Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in


To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here


Great job, updates in, rebooted, all looks good here. Thanks

1 Like

I received the below error message when I was trying to update:

error: failed to commit transaction (conflicting files)
ventoy: /opt/ventoy/tool/ENROLL_THIS_KEY_IN_MOKMANAGER.cer exists in filesystem
ventoy: /opt/ventoy/tool/VentoyWorker.sh exists in filesystem
ventoy: /opt/ventoy/tool/hexdump exists in filesystem
ventoy: /opt/ventoy/tool/mkexfatfs_32 exists in filesystem
ventoy: /opt/ventoy/tool/mkexfatfs_64 exists in filesystem
ventoy: /opt/ventoy/tool/vtoy_gen_uuid exists in filesystem
ventoy: /opt/ventoy/tool/vtoyfat_32 exists in filesystem
ventoy: /opt/ventoy/tool/vtoyfat_64 exists in filesystem
Errors occurred, no packages were upgraded.

I removed ventoy and updated again without any further issues.

A couple of days after the thread for Ventoy was created here I got that, thought it was about Ventoy not updating itself. I removed Ventoy and downloaded the build files and have been updating Ventoy that way since.

Wallpaper got reset to default wallpaper on my KDE virtual machine. Not a big deal for me, I just set it back to what I used before.

This comment is kind of out of context but wanted to know the possible fate of plasmafox? what are the plans of manjaro team regarding it? Seems very nice project, will it be ever get into stable branch?

1 Like

I can't login to Plasma anymore after this update. The loading screen shows and there a popup that kde5 has requested to open the wallet 'kdewallet'. Wether I do anything in this popup is irrelevant, the screen just freezes and stays that way indefinitely.
Any suggestions?

A "popup"? That means the desktop has loaded but plasmashell hasn't? Can you run krunner or anything?

Taking long time after downloading all packages. I have to wait until more than 15 minutes, then they go continue uppgrade packages.

Only the splashcreen loads and then freezes. Sometimes there are popups that ask for passwords, i.e. for my wifi connection. When I use systemctl restart sddm from TTY I get back to the SDDM login screen.

Edit: org.kde.notifications: WaitForName: Service was not registered within timeout appears in journalctl after the freeze. Then nothing.

Takes a long time to start Plasma and the cpu load is about 30% without opening any programs.

Rebooted Plasma and everything working fine here. The only thing I noticed was that restoring the session did not preserve the virtual desktops the windows were on.

Updated without any problems. The new fontconfig packages solve the problem with xfsettingsd outlined here.

On GNOME I use Krusader.
Since this update, Krusader does not start as root.
SOLVED: replace kde-cli-tools by kde-cli-tools-git
EDIT: in the meantime "kde-cli-tools" work again. Earlier, re-installing did not work.
Maybe: i resetted my GNOME-settings today because of an amok app - so there was an error
in gsettings prior this...

Hi!! On my VM the update has done well, except for the systray applet: all icons have gone away despite I mark as "always show", only appears the MSM.

I've deleted the cache folder, the plasma-org.kde.plasma.desktop-appletsrc file, the default panel and added a new one and, also, I have tried with Breath2 and Breeze global themes. No success. Rebooting the VM neither fix nothing.

Weird... :thinking:

You have the -icon Pakets for those themes installed?

Yes, they are the default one's of KDE and Manjaro.

rebuild mime-cache?

Nope, I don't know how to do that. However, this should be done by the system itself when updating, isn't it? :thinking:

Forum kindly sponsored by