[Testing Update] 2020-06-25 - Kernel, Plasma 5.19.2, Perl, Calamares, AMDVLK, Cinnamon, Deepin

Hello community,

Another testing branch update with some interesting updates for you!

If you need a new Office Suite compatible to MS-Office, maybe Softmaker 2021 is your thing! 50% discount now! #stayhome, #staysafe, #stayhealthy

  • Some of the Kernels got updated
  • Some Cinnamon and Deepin updates
  • Plasma5 got updated some more fixes for 5.19.2
  • The usual upstream updates including Perl rebuilds/updates by Arch

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest release Manjaro Lysia 20.0.3! XFCE, KDE and Gnome

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux44 4.4.228
  • linux49 4.9.228
  • linux414 4.14.185
  • linux419 4.19.129
  • linux54 5.4.49
  • linux56 5.6.19
  • linux57 5.7.6
  • linux54-rt 5.4.44_rt27
  • linux56-rt 5.6.17_rt9

Package Changes (Thu Jun 25 09:08:32 CEST 2020)

  • testing community x86_64: 594 new and 595 removed package(s)
  • testing core x86_64: 12 new and 12 removed package(s)
  • testing extra x86_64: 304 new and 305 removed package(s)
  • testing multilib x86_64: 6 new and 6 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

System takes a long time to boot

If you've got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here

I think I've some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

... and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Older issues

Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

HP Device Manager

Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in


To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

the Bug that I have posted in [Testing Update] 2020-06-23 - Kernel, KDE-git, Cinnamon, Firefox, Pamac, Plasma, Deepin
exist also on the latest systemd:

It's a bug in systemd: https://github.com/Nefelim4ag/systemd-swap/issues/135

-- Logs begin at Wed 2020-06-24 22:51:32 CEST, end at Thu 2020-06-25 10:32:36 CEST. --
Jun 25 10:20:55 Workstation systemd[1]: /run/systemd/system/var-lib-systemd\x2dswap-swapfc-1.swap:11: Sorry, swap priorities smaller than -1 may only be assigned by the kernel itself, ignoring: -2
Jun 25 10:20:56 Workstation systemd[1]: Failed to activate swap Swap File.

Also linux56 is installed instead of the upgrade to linux57 with linux-latest
do I need to remove linux56 manually?

Update: I set the priority to 100 and the problem is gone.
:confused: It repeats, try downgrade of systemd version from stable

[ALPM-SCRIPTLET] WARNING: '/usr/lib/perl5/5.30' contains data from at least 1 packages which will NOT be used by the installed perl interpreter.

pacman -Qqo '/usr/lib/perl5/5.30' -->> output was: alien_package_converter (AUR)
since I do not use this any longer, I uninstalled this.

Two systems updated and rebooted, no issues that I can see so far.

In my case, I already moved into kernel 57 using the mhwd app tool in kde>preferences.. it all went good and safe in my testing Kde.

Yes in my case I use the meta - package linux-latest which points to the latest kernel if the previous reached eol.
On this update linux56 is EOL but stayes installed instead linux57 is installed.

Normally it should uninstall the previous Kernel

I think this is a bug in the meta-package

Sorry, now I can see what you meant clearly. Possibly it is a bug in that meta-package-linux-latest. I have never used that meta before. Maybe I will give it a try some time.
Keep safe and be @ home.

1 Like

All good :wink:

you too

All seems ok, but I received this message:
WARNING: '/usr/lib/perl5/5.30' contains data from at least 1 packages which will NOT be used by the installed perl interpreter.
-> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/5.30'
after running the command:
~ >>> pacman -Qqo '/usr/lib/perl5/5.30'
Should I do something?

You'll need to rebuild any affected AUR packages.

We only remove an EOL kernel with linux-latest when we also remove it from our repos. This will be done in a couple of weeks. Also the kernel is still listed on kernel.org.

1 Like

Ok, thank you

So, I discovered an issue a few hours after update: my bluetooth headphones would connect and play, but only with very, very ...but very low volume. First time I face quite an issue and I don't have any idea how to debug it,
What I can say is the following:

  • No issue detected yesterday (before the update)
  • Same behaviour with every Kernel (so it's not kernel related)
  • My other bluetooth device (no headphone, but sound amplifier) is working as it should
    That's it. Meanwhile I use my headphone with a jack. Any idea ?
    And.... I am on KDE edition.

Oh I didn’t know this. Good to know thanks, stay home and take care :wink:

You'll need to rebuild any affected AUR packages.

In case of alien_package_converter (AUR) this does not help :innocent:
(Does not matter, as I do not need the converter - not tried other apps)

I need it87 from AUR for my hardware.
Building it87 I got:

---> Install DKMS modules
==> dkms install --no-depmod -m it87 -v 148.40bec4b -k 5.7.6-1-MANJARO
==> dkms install --no-depmod -m it87 -v 148.40bec4b -k 4.19.130-1-MANJARO
==> dkms install --no-depmod -m it87 -v 148.40bec4b -k 5.4.49-1-MANJARO
==> depmod 5.7.6-1-MANJARO
==> depmod 4.19.130-1-MANJARO
==> depmod 5.4.49-1-MANJARO
==> Unable to install module it87/148.40bec4b for kernel 4.19.120-1-MANJARO: Missing kernel modules tree.
Vorgang erfolgreich abgeschlossen.
does anyone know whom to ask

Are all header packages installed?

Yes, philm, header packages I install as standard.
Presumed reason:
there were still the remains of an uninstalled kernel (4.19) in / usr / lib / modules
Deleting those, at next uninstall / install of it87 the "error" has gone.
Thank You [solved].

Forum kindly sponsored by