[Testing Update] 2020-07-04 - Firefox, Jade, Deepin, LibreOffice, Curl

Hello community,

Another testing branch update with some interesting updates for you!

Say Hi to our latest Ryzen Laptop. Ready to be ordered! #stayhome, #staysafe, #stayhealthy

  • Deepin packages got mostly renewed
  • Some more fixes to our Jade desktop
  • Firefox is now at 78.0.1
  • LibreOffice got renewed to 6.4.5
  • The usual upstream updates rebuilds/updates including curl by Arch

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest preview of Manjaro Mikah 20.1! XFCE, KDE and Gnome

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux44 4.4.229
  • linux49 4.9.229
  • linux414 4.14.187
  • linux419 4.19.131
  • linux54 5.4.50
  • linux56 5.6.19 [EOL]
  • linux57 5.7.7
  • linux54-rt 5.4.44_rt27
  • linux56-rt 5.6.17_rt9

Package Changes (Sat Jul 4 21:54:29 CEST 2020)

  • testing community x86_64: 352 new and 348 removed package(s)
  • testing core x86_64: 5 new and 6 removed package(s)
  • testing extra x86_64: 262 new and 356 removed package(s)
  • testing multilib x86_64: 8 new and 8 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

System takes a long time to boot

If you've got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here

I think I've some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

... and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Older issues

Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

HP Device Manager

Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in


To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

Linux-firmware update solved Kernel issue with ath9k drivers... with chipset Qualcomm Atheros AR9271 802.11n. My TLP usb stick model AR9271 is working good once again. Thanks for this update. (@mu3r73 had this same issue as well.)


I can confirm there are more people on the stable branch whining about not having the latest packages than are on the testing branch. :rofl:

I guess switching branches is too scary for them. :ghost:


Oh. No!

It has nothing to do with firmware. We reverted a commit which broke the driver inside the kernels. That's it.


It is scary as hell. And the best thing is, you never can switch back to stable, when you're on testing :kissing_smiling_eyes: - too addicted ...


I hesitated to go to testing for a while, because i didn't want to have to tinker too much with my main system....but i must say, for now (about a year), i haven't had any major issues :+1:
I'd say manjaro testing is more stable than some other stable branches :joy:


What would the pleebs do on openSuse Tumbleweed since it's more cutting edge than Manjaro Unstable? Pee themselves while having a complete mental nreakdown?

1 Like

Updated today, no issues but python2-pillow seems like it landed in AUR but its needed by Calibre and Kodi.

No issues: XFCE + BTRFS + Linux57
Hold packages back: systemd-swap to 4.0.1-2

Something seems wrong with the pamac menu from the panel on KDE Plasma.
1.) The icon looks blurry
2.) the right click menu has weird spacing now

Pretty sure yesterday before the update the pamac icon was sharp as the others and the menu didn't have this weird spacing (space on the left and under "Schließen", now it looks like there would be a third menu entry but there isn't, it's just useless space)


I made testing updates without problem. I wanted to switch to wayland but I will stay on xorg/X11 for a long time because I can't use some programs under wayland (example:qtvkbd) and the virtual keyboard doesn't work under wayland. Also, I can't do some things on wayland (open easily a system folder as root in GUI).

I made a test install on a spare SSD with Manjaro Gnome 20.0.3...
The menu with the nine points does not show all entries when I select "all",
only some, less than in "frequently".

And then, we publish some "garbage" and they complained that we do not test packages enough and that it should have stayed in Testing for a longer time.



Same "glitch" here

Pillow dropped Python 2 support. You can replace calibre with calibre-python3 and perhaps use kodi-git from the AUR.

1 Like

Switching to testing made me unstable. :crazy_face:


xorg-fonts-alias is still missing from the repos. According to this Arch-Forum thread it should have been fixed and just been a mistake. Is that not applicable to manjaro? I would have thought the next update shoud re-sync the repos?

It was fixed and all the relevant packages are in the testing branch. See here for the recent changes.

1 Like

Forum kindly sponsored by