[Testing Update] 2020-07-08 - Kernel, Deepin, Gnome, Gambas, Plasma 5.19.3

Hello community,

Another testing branch update with some interesting updates for you!

Get 15% off on our Merch. Ready to be ordered! #stayhome, #staysafe, #stayhealthy

  • Deepin and Gnome packages got mostly renewed
  • linux is now at 5.8-rc4
  • Plasma got another point-release: 5.19.3
  • The development IDE Gambas is now at 3.15.0
  • A lot of KDE-git package updates to showcase the latest features of KDE software
  • The usual upstream updates rebuilds/updates including python by Arch

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest preview of Manjaro Mikah 20.1! XFCE, KDE and Gnome

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux44 4.4.229
  • linux49 4.9.229
  • linux414 4.14.187
  • linux419 4.19.131
  • linux54 5.4.50
  • linux56 5.6.19 [EOL]
  • linux57 5.7.7
  • linux58 5.8-rc4
  • linux54-rt 5.4.44_rt27
  • linux56-rt 5.6.17_rt9

Package Changes ( Wed Jul 8 23:25:13 CEST 2020 )

  • testing community x86_64: 560 new and 549 removed package(s)
  • testing core x86_64: 11 new and 11 removed package(s)
  • testing extra x86_64: 128 new and 134 removed package(s)
  • testing multilib x86_64: 10 new and 10 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

System takes a long time to boot

If you've got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here

I think I've some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

... and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Older issues

Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

HP Device Manager

Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in


To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

Thank you Manjaro for such an amazing distro, don't know where I would be without you! Somehow the testing branch of a "unstable" distro has been the most stable OS I have ever used.


Updated successfully, changed to kernel 5.8, everything working so far..
According to Linus Torvalds, this is a huge kernel release.. Thanks Manjaro team for giving us the opportunity to test it so soon.
Great work as always!!


11 posts were split to a new topic: Off-topic comments about stable and unstable

Updated and everything is running great! Adwaita theme on GNOME no longer having the odd font issues.

No problem with these updates.
And for me, for Dejavu fonts :

bruno  ~  fc-match Sans
DejaVuSans.ttf: "DejaVu Sans" "Book"

 bruno  ~  fc-match Serif
DejaVuSerif.ttf: "DejaVu Serif" "Book"

 bruno  ~  fc-match Mono
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"

No issues on my machine: XFCE + BTRFS + Linux57
Hold back package: systemd-swap to the version in stable
Fix was merged, resolved the Btrfs_path issue but the swap file repeats fail to activate.

I have a problem with Dash-to-Panel (the version distributed with Manjaro and from gnome extensions) just since now after updateing.
If I hit super - or in some other way (hot top left corner) get to the "overview" I am stuck there - windows will just not come back to be active and only thing to resolve was to relog - Alt+F2 - open browser, deactivate "Dash to Panel"

I see icons for aplications quickly faded in and out behind the floating window overview- but cant access the aplications as I am stuck in overview (applications start and terminate though correctly)

PS: switching workspaces does not work as well - windows shown in overview move out of frame (as normal) but neither the right side workspace switcher animates nor does one get to a working desktop

Stuck at overview: Bildschirmfoto von 2020-07-09 08-46-34

Overview without extension enabled
Bildschirmfoto von 2020-07-09 08-46-12

If working as expected both screenshots should be same except the dash being a panel - but workspace switcher showing and all.

There is a new problem in Kde edition. It can't download plasma theme from Kde settings.

journalctl -xe

-- The job identifier is 315.
Jul 09 12:56:02 Horizen systemd[951]: gnome-launched-gnome-terminal-2248.scope: Succeeded.
-- Subject: Unit succeeded
-- Defined-By: systemd
-- Support: https://archived.forum.manjaro.org/c/technical-issues-and-assistance
-- The unit UNIT has successfully entered the 'dead' state.
Jul 09 08:58:51 Horizen gnome-shell[1014]: setup_framebuffers: assertion 'width > 0' failed
Jul 09 08:58:51 Horizen gnome-shell[1014]: setup_framebuffers: assertion 'width > 0' failed
Jul 09 08:58:51 Horizen gnome-shell[1014]: setup_framebuffers: assertion 'width > 0' failed

I will see what for is this good?!
journalctl -p err -b
-- Logs begin at Fri 2020-06-19 17:39:31 CEST, end at Thu 2020-07-09 08:58:51 CEST. --
-- No entries --
(GNOME with Wayland)
EDIT: seems to be xorg doesnot start, because its a wayland-session???????

I had the same issue. I deleted dash to panel from extensions, reinstalled it from github and the issue solved:


Alright - so neither the version in the ropositories, nor from extension.gnome.org does work, but the latest git (installed via the AUR package) fixes the issue and works!

Edit: @ kouros17 thanks - cam to the same solution =D

1 Like

I have the same error, I guess it has nothing to do with Plasma itself, let's hope someone on Stable will check it.

Same here

Manjaro KDE, something wrong with Telegram window. Also, pamac-tray-appindicator don't start.


No problem for me with Telegram Desktop. I use the version from the Official Repositories (2.1.18pre-0.1 at the moment). Check this one if you use another build.

There is no issue with Telegram. They changed the framework to use a more Windows10 style for the Window frames. Regarding Pamac-tray, use mouse middle-click to open it. Else use the right mouse and the menu to access Pamac.

This is fixed with todays update:

:: Different overlay package(s) in repository community x86_64

                             PACKAGE           2020-07-08           2020-07-09
                         edid-decode       r438.becb0ef-1       r439.4d94efe-1
 gnome-shell-extension-dash-to-panel    v37+38+gef3120c-1    v37+70+geff0322-1

:: Different sync package(s) in repository community x86_64

                             PACKAGE           2020-07-08           2020-07-09
                           bsd-games              2.17-18                3.0-1
                              cython            0.29.20-1            0.29.21-1
                             cython2            0.29.20-1            0.29.21-1
                       fontobene-qt5              0.1.0-1              0.1.0-2
                              rustup             1.22.0-1             1.22.1-1
                           seamonkey             2.53.2-1             2.53.3-1

:: Different sync package(s) in repository extra x86_64

                             PACKAGE           2020-07-08           2020-07-09
                   libva-mesa-driver             20.1.2-1             20.1.3-1
                                mesa             20.1.2-1             20.1.3-1
                          mesa-vdpau             20.1.2-1             20.1.3-1
                         opencl-mesa             20.1.2-1             20.1.3-1
                      vulkan-headers          1:1.2.145-1          1:1.2.146-1
                    vulkan-html-docs          1:1.2.145-1          1:1.2.146-1
                        vulkan-intel             20.1.2-1             20.1.3-1
                  vulkan-mesa-layers             20.1.2-1             20.1.3-1
                       vulkan-radeon             20.1.2-1             20.1.3-1

:: Different sync package(s) in repository multilib x86_64

                             PACKAGE           2020-07-08           2020-07-09
             lib32-libva-mesa-driver             20.1.2-1             20.1.3-1
                          lib32-mesa             20.1.2-1             20.1.3-1
                    lib32-mesa-vdpau             20.1.2-1             20.1.3-1
                   lib32-opencl-mesa             20.1.2-1             20.1.3-1
                  lib32-vulkan-intel             20.1.2-1             20.1.3-1
            lib32-vulkan-mesa-layers             20.1.2-1             20.1.3-1
                 lib32-vulkan-radeon             20.1.2-1             20.1.3-1

Thanks, I fixed Telegram window.

Forum kindly sponsored by