[Testing Update] 2020-07-08 - Kernel, Deepin, Gnome, Gambas, Plasma 5.19.3

There is no issue with Telegram. They changed the framework to use a more Windows10 style for the Window frames. Regarding Pamac-tray, use mouse middle-click to open it. Else use the right mouse and the menu to access Pamac.

This is fixed with todays update:

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-07-08           2020-07-09
-------------------------------------------------------------------------------
                         edid-decode       r438.becb0ef-1       r439.4d94efe-1
 gnome-shell-extension-dash-to-panel    v37+38+gef3120c-1    v37+70+geff0322-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-07-08           2020-07-09
-------------------------------------------------------------------------------
                           bsd-games              2.17-18                3.0-1
                              cython            0.29.20-1            0.29.21-1
                             cython2            0.29.20-1            0.29.21-1
                       fontobene-qt5              0.1.0-1              0.1.0-2
                                gnac            0.2.4.1-8            0.2.4.1-9
                              rustup             1.22.0-1             1.22.1-1
                           seamonkey             2.53.2-1             2.53.3-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-07-08           2020-07-09
-------------------------------------------------------------------------------
                   libva-mesa-driver             20.1.2-1             20.1.3-1
                                mesa             20.1.2-1             20.1.3-1
                          mesa-vdpau             20.1.2-1             20.1.3-1
                         opencl-mesa             20.1.2-1             20.1.3-1
                      vulkan-headers          1:1.2.145-1          1:1.2.146-1
                    vulkan-html-docs          1:1.2.145-1          1:1.2.146-1
                        vulkan-intel             20.1.2-1             20.1.3-1
                  vulkan-mesa-layers             20.1.2-1             20.1.3-1
                       vulkan-radeon             20.1.2-1             20.1.3-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2020-07-08           2020-07-09
-------------------------------------------------------------------------------
             lib32-libva-mesa-driver             20.1.2-1             20.1.3-1
                          lib32-mesa             20.1.2-1             20.1.3-1
                    lib32-mesa-vdpau             20.1.2-1             20.1.3-1
                   lib32-opencl-mesa             20.1.2-1             20.1.3-1
                  lib32-vulkan-intel             20.1.2-1             20.1.3-1
            lib32-vulkan-mesa-layers             20.1.2-1             20.1.3-1
                 lib32-vulkan-radeon             20.1.2-1             20.1.3-1
4 Likes

Thanks, I fixed Telegram window.

Same problem.

and @Jonty_Shaw, @fratac, @ahepas

tested in stable same issue, something must be offline

Summary

Screenshot_20200709_151404

@philm
can we also check this
https://git.kernel.org/pub/scm/linux/kernel/git/stable/stable-queue.git/diff/releases/5.7.7/efi-libstub-fix-path-separator-regression.patch?id=6392191d249cac00300106a39995b78ec5eb436f
( only in version kernel 5.7.7 actually )

there some topic that we can't restore Grub in EFI


Am I the only one that have a black icon for Pamac in Manjaro KDE when using the Breath2 theme? It is supposed to be white.

black-pamac

How you fixed telegram? Now it doesn't follow colours of other windows and buttons are on the opposite side of where they should be

Telegram > Settings > Advanced > System Integration > Use system window frame
image

2 Likes

Thank you! I just casually discovered that and I was coming to edit my message :sweat_smile:
I even tried to download a package called telegram-qt but I'm not sure what it was, I'm so a newbie even after 5 years of Linux

You're welcome. Being a "newbie" is very relative, as all of us always have something to discover, learn and improve.

All good on first glance here on KDE/AMD

Due to the ongoing boottime issue / nsswitch.conf workaround i reverted my system to a working state with timeshift (10.6.2020) and updated from there - unfortunately the issue came back, so definitely not a configuration issue.

same problem here with pamac icon on breath2 themepamac

Hey @Frog and @eavy - There is a report on the pamac tray icon and i think was acknowledged


I'm sure will be addressed and fixed. Hopefully is not a big deal breaker for you :slight_smile:

Still having problems with the system tray on KDE Plasma.
1.) Pamac icon is still blurry
grafik
2) Pamac tray menu still has weird space
grafik
3) Telegram tray menu doesn't work anymore
-> on stable when I right click the Telegram icon, it opens a menu. On testing nothing happens but this small box looking like a graphical glitch appears:
Screenshot_20200709_200347

All of these 3 are no problem on stable branch. I also tried switching the theme (tried with Materia, Breeze and Breath2) but it doesn't make any difference, tray is just broken on testing.

However, everything else is running fine and pretty stable :slight_smile:

Edit: for problem 2 with the menu: It seems to be a problem with autostart. When I just log in and pamac tray auto started, it has this weird space. But when I kill it and restart it myself, the space is gone, just how it should be.
Peek 2020-07-09 20-26

Also the problem with the telegram tray menu not coming up seems to have the same cause. I have Telegram in Autostart and if autostarted, the tray menu doesn't work. But when I start Telegram by hand some seconds after the session is started, the menu works.

So autostart triggers some tray bugs. Weird, doesn't happen with Plasma 5.18 on stable.

i updated today -- still same issue with ion pamac -- it is not a big deal it is just a cosmetic issue
all other things are working well

Does this update have Gnome 3.36.4? 3.36.4 has some major performance fixes.

Search for gnome-desktop :wink:

3 Likes

Telegram > Settings > Advanced > System integration > Use system window frame

Do you have re2 1:20200706-1 installed? Sounds like a partial upgrade happened somehow. Make sure your mirrors are up to date.

Forum kindly sponsored by