[Testing Update] 2020-07-10 - Kernels, Deepin, KDE Apps 20.04.3, Firefox 78.0.2

Hello community,

Another testing branch update with some interesting updates for you!

We are getting closer to our next release: Mikah. Ready to be tested! #stayhome, #staysafe, #stayhealthy

  • Most of our Kernels got renewed
  • KDE Apps got another point-release: 20.04.3
  • More Deepin updates
  • Firefox is now at 78.0.2 providing new security fixes
  • The usual upstream updates rebuilds/updates including python by Arch

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest preview of Manjaro Mikah 20.1! XFCE, KDE and Gnome

Upstream notice

Arch updated their default compression to zstd. We adopted to the same standard. More and more packages will have the zst extension from now on. If you get for what ever reason an error with ZSTD not supported as archive format you can do this:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux44 4.4.230
  • linux49 4.9.230
  • linux414 4.14.188
  • linux419 4.19.132
  • linux54 5.4.51
  • linux56 5.6.19 [EOL]
  • linux57 5.7.8
  • linux58 5.8-rc4
  • linux54-rt 5.4.44_rt27
  • linux56-rt 5.6.17_rt9

Package Changes (Fri Jul 10 09:48:35 CEST 2020)

  • testing community x86_64: 1177 new and 1172 removed package(s)
  • testing core x86_64: 15 new and 15 removed package(s)
  • testing extra x86_64: 433 new and 436 removed package(s)
  • testing multilib x86_64: 2 new and 2 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

System takes a long time to boot

If you've got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here

I think I've some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

... and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Older issues

Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

HP Device Manager

Pamac stuck at "Preparing..."

Users have reported issues with the recent release candidate of Pamac 9.4.0 when initiating transactions, being stuck at "Preparing..." without being able to cancel the transaction and quit Pamac normally.

For now, it is recommended to use pacman to do package management until this issue is solved and Pamac become usable again. Please test out upcoming updates for Pamac to see if the issue becomes solved or not.

If you are stuck in "Preparing...", you will have to manually kill the pamac-managerprocess.

Reported on Gitlab:

Upgrading firewalld package to 0.8.1-2 requires manual intervention

Please read this announcement if you have file conflicts when trying to upgrade firewalld package to 0.8.1-2.

Firewalld requires manual intervention

khotkeys identified as an orphaned package

You can remove that package, but might loose some functionality with your key-bindings. We made it now optional to be installed.

Weird font glitches (see screenshots below).

If you have weird glitches like below...



... have you tried turning it off and on again?

More seriously, so far, people that reported to have such issue noticed that the problem goes away at next boot.

Installing xorgproto (2019.2-2) breaks dependency of a package

If you run into an issue because of xorgproto please DON'T follow the Arch suggestion as Manjaro uses the xorgproto-transfer package to make this automatic. If you have an issue, please report and wait for an update from us!

AUR Rebuilds required after updating python 3.7 to 3.8

Packages that depend on python from the AUR will need to be rebuilt after everything else has been updated. You can rebuild some of them with the following:

sudo pacman -S --needed --noconfirm expac yay
yay -S --rebuildtree $(pacman -Qmq $(expac %N python))

You can find other packages that need to be rebuilt by looking at the folders/files in


To find out what package owns a folder/file in that, you can use the following:

pacman -Qo folder_or_filename

If no package owns a file, it can probably be ignored.

System Settings and kinfocenter crash when entering Night Color settings randomly

Remove entire [NightColor] section of ~/.config/kwinrc
No solution yet ─ please edit as soon as a workaround is found.

xfce4-power-manager does not open / upower fails

Install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with upower 0.99.11-1 on kernels 4.4 and 4.9.

xfce4-terminal / guake / gnome-terminal does not open

Update to vte3 0.58.2-1 or install kernel 4.14 or higher (4.14, 4.19, 5.2 [EOL], 5.3)

There is an issue with vte3 0.58.1-1 on kernels 4.4 and 4.9.

Replace linux52 with community/linux-latest ?

linux52 is EOL and has been removed from the repositories. It will be replaced by a metapackage which will from now on keep you on a maintained kernel.

If you want to keep the old kernel and modules then include them in your pacman.conf's IgnorePkg.

Pamac-Qt is not compatible to 9.0 API of Pamac

Pamac Qt 0.3 pre-RC: Towards the release, needs help in testing


the pkgver 19.10.1 ship with an hook to remove the capability from gnome-shell. A message is present during install but essentially you need to reboot the system to show correctly the icons in the desktop. More info here

1 Like

Updated via TTY and everything good so far XFCE, Kernel 5.7, nouveau Thank you

linux57-5.7.8-1-x86_64: 172,5 MiB

That's quite large...

Since this update today, flatpaks don't start anymore.

~ >>> flatpak run com.microsoft.Teams                                                                                                                                                         
bwrap: Can't bind mount /bindfilevKs0Yf on /newroot/etc/group: Invalid argument
~ >>> flatpak run com.discordapp.Discord                                                                                                                                                      
bwrap: Can't bind mount /bindfilezq5k8i on /newroot/etc/group: Invalid argument

Update 1: There are more issues. I now get some weird messages on boot, will try to get a picture later. This one is a real 'killer update'.

Also what I noticed since yesterdays KDE Plasma 5.19.3 update: My desktop on my main monitor doesn't load on startup correctly. The background is black instead of showing my background wallpaper and I can't right click on the desktop. After restarting the plasmashell process it works again, but it is broken directly after startup.

Also, all the issues with system tray menus I posted yesterday are still there.

Update 2: I installed Kernel 5.4, just to test. Flatpaks start now again. So the flatpak issue seems to be only with the new kernel 5.7.8. It worked yesterday with 5.7.7.

Update 3: Here is a picture of the new error I now get on every boot since this update:
Note: my system is LVM on LUKS. Seems to be some new bug with LVM.

Another thing that changed is: I now see the grub menu on boot, but I never saw it on this machine before. Now I have two Manjaros to choose from, but there is only one installed.

The first one boots, but show the LVM errors.
If I try to boot the third entry, this happens:
When I press a key, the system just freezes.

So this is really not ready for stable in this state.

Seems fine on KDE/AMD here :slight_smile:

Failed to start Network Manager Wait Online. Issue persists with Kernel 5.8 though

I am having a problem getting to the desktop (Plasma) with Kernel 5.7.8

sddm starts fine. When I enter my password, I get a black screen with a mouse cursor (the one I have set for the desktop theme) and nothing further happens. No disk activity. No keyboard input is recognized. I can switch to other consoles and have tried to startx after stopping sddm.service. Xorg complains about not being able to start:

Error log from ~/.local/share/xorg/ here.

It works as expected under Kernel 5.4.51

I tried restoring from backup and re-installing just in case of a bad or missing download. Same.

Help? :crying_cat_face:

Seems something is afoot with 5.7.8 … but every day in every way, it's getting better and better.

I'm now missing my qBittorrent systrayicon along with another systray icon and I cannot get qBittorrent. Terminal output.

[agentx@Secret-Cpmputer ~]$ qbittorrent
Icon theme "Papirus" not found.
Icon theme "Numix" not found.

I have some problem

# pacman -S downgrade
resolving dependencies...
looking for conflicting packages...

Packages (1) downgrade-8.0.0-1

Total Download Size:   0.02 MiB
Total Installed Size:  0.05 MiB

:: Proceed with installation? [Y/n] 
error: could not open file: /etc/mtab: No such file or directory
error: could not determine filesystem mount points
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.


# uname -a
Linux  5.7.8-1-MANJARO #1 SMP PREEMPT Thu Jul 9 09:14:09 UTC 2020 x86_64 GNU/Linux

On 5.4 kernel everything is fine

After the update, kernel 5.7.8 is showing message "buggy seq_file .next function m_next did not updated position index" every 2 secs... other than that didn't see any other adverse effects except for this nasty flooding on my kernel log... kernel 5.4 doesn't show that behavior.

1 Like

Linux 5,8 is ok.
5.7 is broken now.

p.s. fix released :star_struck:

Yepp, same here since 5.7.8:

[   43.905012] buggy seq_file .next function m_next did not updated position index
[   43.905258] buggy seq_file .next function m_next did not updated position index
[   43.905479] buggy seq_file .next function m_next did not updated position index
[   56.876082] buggy seq_file .next function m_next did not updated position index
[   56.876389] buggy seq_file .next function m_next did not updated position index
[   56.876590] buggy seq_file .next function m_next did not updated position index

As another user reported, since updating Flatpaks no longer start

Feel like editing your post and elaborating ? Thanks


Thanks for that helped me narrow down my issue after this update.

That was one doozy of an upgrade. After updating as I reported before flatpaks no longer worked and after reboot I had multiple Manjaro Linux selections in the GRUB menu. Attempted to install an older kernel in the Manjaro Settings Manager and got stuck on the 3rd step, updating GRUB. Other applications became slow to boot. Luckily I have automatic daily timeshift back-ups so I restored my back-up from yesterday and everything is not working as it should. Although Manjaro Settings Manager still reports running kernel 5.7.8-1, pacman -Q | grep linux shows 5.7.7-1 as I intended.

Well, after some little research I found the message "buggy seq_file .next function m_next did not updated position index" is annoying but just informative, looking for kernel code to see differences between 5.7.8 and 5.4.51 shows that... (I apologize to those non-programmers):

5.4.51 version:

	/* they want more? let's try to get some more */
	while (1) {
		size_t offs = m->count;
		loff_t pos = m->index;

		p = m->op->next(m, p, &m->index);
		if (pos == m->index)
			/* Buggy ->next function */
		if (!p || IS_ERR(p)) {
			err = PTR_ERR(p);
		if (m->count >= size)
		err = m->op->show(m, p);
		if (seq_has_overflowed(m) || err) {
			m->count = offs;
			if (likely(err <= 0))

5.7.8 version:

	/* they want more? let's try to get some more */
	while (1) {
		size_t offs = m->count;
		loff_t pos = m->index;

		p = m->op->next(m, p, &m->index);
		if (pos == m->index) {
			pr_info_ratelimited("buggy seq_file .next function %ps "
				"did not updated position index\n",
		if (!p || IS_ERR(p)) {
			err = PTR_ERR(p);
		if (m->count >= size)
		err = m->op->show(m, p);
		if (seq_has_overflowed(m) || err) {
			m->count = offs;
			if (likely(err <= 0))
1 Like

Also have some problem with locales after update.

2020 M07 10... why here is M07? It must be month name

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "ru_RU.UTF-8",
        LC_NAME = "ru_RU.UTF-8",
        LC_MONETARY = "cv_RU.UTF-8",
        LC_PAPER = "ru_RU.UTF-8",
        LC_IDENTIFICATION = "ru_RU.UTF-8",
        LC_TELEPHONE = "ru_RU.UTF-8",
        LC_MEASUREMENT = "cv_RU.UTF-8",
        LC_TIME = "cv_RU.UTF-8",
        LC_NUMERIC = "cv_RU.UTF-8",
        LANG = "cv_RU.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C")

cv_RU instead of ru_RU?

Selected manually ru_RU and everything is ok now. (KDE)

So, I'm just waiting for fixes to 5.7.8 kernel :blush:
Now, switched to 5.4

p.s. fix released :star_struck:


I see some people as @Bleuzen , @Othoric and maybe more have issues with Flatpak. I am on KDE edition, and my Flatpak are working as they should after the update: Bitwarden, Signal desktop and Zoom.

Which kernel are you using? Because later in my first post I pointed out that this is a problem with the new 5.7.8 kernel. It works on 5.4.

Forum kindly sponsored by